You are not logged in.

#1 2013-03-01 11:34:07

VeXe
Member
Registered: 2013-02-13
Posts: 27

Not able to install some QT-dependant packages after upgrading to QT5

I ran an updated today, it was a major update, there was a lot of stuff that I got prompted to replace, I said yes of course. One of those was qt, which was a dependancy to some of my apps, like Skype and edb-debugger. So I just, removed those apps, and proceeded with the update, it went alright. After that, I wanted to reinstall those two apps:

resolving dependencies...
warning: cannot resolve "lib32-qt", a dependency of "skype"
:: The following package cannot be upgraded due to unresolvable dependencies:
      skype

Do you want to skip the above package for this upgrade? [y/N]

if I give that a yes:

looking for inter-conflicts...
 there is nothing to do
 

No:

error: failed to prepare transaction (unexpected error)
 

For edb, from yaourt:

 
error: target not found: qt>=4.5

It states that it wants a version of qt which is higher than 4.5 right? I already have qt5! so what's up?

I looked into my /var/cache/pacman/pkg for qt so that I could downgrade, I didn't find that 'literal' package, I found some qt-related stuff.

sudo pacman -U qt-4.8.4-3-x86_64.pkg.tar.xz 
loading packages...
resolving dependencies...
looking for inter-conflicts...
:: qt and qt4 are in conflict. Remove qt4? [y/N] y
:: qt and qt5-base are in conflict. Remove qt5-base? [y/N] y
:: qt and qt5-declarative are in conflict. Remove qt5-declarative? [y/N] y
:: qt and qt5-imageformats are in conflict. Remove qt5-imageformats? [y/N] y
:: qt and qt5-multimedia are in conflict. Remove qt5-multimedia? [y/N] y
:: qt and qt5-quick1 are in conflict. Remove qt5-quick1? [y/N] y
:: qt and qt5-script are in conflict. Remove qt5-script? [y/N] y
:: qt and qt5-svg are in conflict. Remove qt5-svg? [y/N] y
:: qt and qt5-tools are in conflict. Remove qt5-tools? [y/N] y
:: qt and qt5-translations are in conflict. Remove qt5-translations? [y/N] y
:: qt and qt5-xmlpatterns are in conflict. Remove qt5-xmlpatterns? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: attica: requires qt4
:: grantlee: requires qt4
:: lib32-qt4: requires qt4
:: libdbusmenu-qt: requires qt4
:: libqzeitgeist: requires qt4
:: phonon: requires qt4
:: polkit-qt: requires qt4
:: poppler-qt: requires qt4
:: prison: requires qt4
:: q4wine: requires qt4
:: qca: requires qt4
:: qimageblitz: requires qt4
:: qjson: requires qt4
:: qt5-graphicaleffects: requires qt5-declarative
:: qt5-jsbackend: requires qt5-base
:: qt5-webkit: requires qt5-declarative
:: qtwebkit: requires qt4
:: soprano: requires qt4
:: strigi: requires qt4
:: unetbootin: requires qt4
:: vlc: requires qt4
:: winestuff: requires qt4

Are you freckin kiddin me? I'm NOT gonna go over this again, hell no!

I downloaded skype from its site, did a pacman -U on it:

error: missing package metadata in skype-4.1.0.20.tar.bz2
error: 'skype-4.1.0.20.tar.bz2': invalid or corrupted package

How can I get around this, install Skype and the stuff that I want? anyhelp please?

Thanks!

Last edited by VeXe (2013-03-01 11:36:00)

Offline

#2 2013-03-01 12:06:18

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: Not able to install some QT-dependant packages after upgrading to QT5

error: target not found: qt>=4.5

You have to install lib32-qt4 in order to run Skype.

VeXe wrote:

I downloaded skype from its site, did a pacman -U on it:

error: missing package metadata in skype-4.1.0.20.tar.bz2
error: 'skype-4.1.0.20.tar.bz2': invalid or corrupted package

Oh well... An archive (like any archive) doesn't have to be an Arch package... I think you should spend some time reading Wiki and Forums to grasp the basics of Arch packaging.

Last edited by bohoomil (2013-03-01 12:11:06)


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#3 2013-03-01 12:14:41

Raynman
Member
Registered: 2011-10-22
Posts: 1,154

Re: Not able to install some QT-dependant packages after upgrading to QT5

VeXe wrote:
resolving dependencies...
warning: cannot resolve "lib32-qt", a dependency of "skype"
:: The following package cannot be upgraded due to unresolvable dependencies:
      skype

Do you want to skip the above package for this upgrade? [y/N]

Here you are trying to install skype from multilib, right? Then your mirror is not fully up to date or you need another -Sy. skype in the repos has been updated to depend on (lib32-)qt4 instead of (lib32-)qt.

edb-debugger in AUR hasn't caught up with this change, you should at least edit the PGKBUILD, changing qt in debs to qt4.

You can't just downgrade qt to the 4.x branch if you have apps depending on the qt5-* packages.

Offline

#4 2013-03-01 12:27:47

VeXe
Member
Registered: 2013-02-13
Posts: 27

Re: Not able to install some QT-dependant packages after upgrading to QT5

@Raynman: Thanks! What you told me about Skype worked very well, I did a:

reflector -l 6 --sort rate --save /etc/pacman.d/mirrorlist

But I'm still having trouble with edb, I edited the depnds to:

depends=('qt4')

But it didn't work out, it gave me:

Project ERROR: edb requires Qt version 4.5 or greater

But now I have both qt4 and 5, so ... ? sad

Last edited by VeXe (2013-03-01 12:28:38)

Offline

#5 2013-03-01 12:31:05

ilpianista
Fellow developer
From: Lecce, Italy
Registered: 2007-10-06
Posts: 568
Website

Re: Not able to install some QT-dependant packages after upgrading to QT5

VeXe wrote:

But it didn't work out, it gave me:

Project ERROR: edb requires Qt version 4.5 or greater

But now I have both qt4 and 5, so ... ? sad

Replace also qmake with qmake-qt4 in the PKGBUILD to explicitly use Qt 4.x

Offline

#6 2013-03-01 12:44:36

VeXe
Member
Registered: 2013-02-13
Posts: 27

Re: Not able to install some QT-dependant packages after upgrading to QT5

@ascarpino: YOU ROCK! \m/ --> th@nX

I guess it's [solved] now.

Offline

#7 2013-03-02 12:12:30

DonVla
Member
From: Bonn, Germany
Registered: 2007-06-07
Posts: 997

Re: Not able to install some QT-dependant packages after upgrading to QT5

"qmake-qt4" doesn't seem to be in the repos.

Offline

#8 2013-03-02 13:03:46

Radioactiveman
Member
From: Germany
Registered: 2010-05-13
Posts: 377

Re: Not able to install some QT-dependant packages after upgrading to QT5

$ LANG=C pacman -Qo /usr/bin/qmake-qt4
/usr/bin/qmake-qt4 is owned by qt4 4.8.4-13

Offline

Board footer

Powered by FluxBB