You are not logged in.

#1 2012-12-16 19:04:18

slavik262
Member
From: WA, USA
Registered: 2012-07-12
Posts: 46
Website

Hiding wireless messages on boot [Solved]

After clearing the systemd startup sequence on my laptop, the system displays several messages regarding what I can only assume to be the kernel's wireless drivers, such as

[   <some value, perhaps a timestamp?>] ieee80211 phy0: brcmsmac: brcms_ops_bss_info_changed: associated
[   <some value, perhaps a timestamp?>] ieee80211 phy0: brcms_ops_bss_info_changed: arp filtering: enable true, count 0 (implment)

They also show up as I go in and out of hibernate and sleep. These would be fine, except they often get printed in the middle of my login prompt. Is there any way to disable these messages or route them elsewhere, such as to a log?

I'm using NetworkManager, for what it's worth.

Last edited by slavik262 (2013-03-05 17:05:33)

Offline

#2 2012-12-18 18:09:53

slavik262
Member
From: WA, USA
Registered: 2012-07-12
Posts: 46
Website

Re: Hiding wireless messages on boot [Solved]

It seems that these are just from dmesg. Is there any way to lower the level dmesg prints (probably through dmesg -n) during startup?

Offline

#3 2012-12-18 23:04:33

illusionist
Member
From: localhost
Registered: 2012-04-03
Posts: 498

Re: Hiding wireless messages on boot [Solved]

"loglevel=1" in your kernel line.


  Never argue with stupid people,They will drag you down to their level and then beat you with experience.--Mark Twain
@github

Offline

#4 2012-12-19 02:08:54

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: Hiding wireless messages on boot [Solved]

illusionist's suggestion will work, but I think it will actually effect the output for everything.  You can get much more control in /etc/systemd/journald.conf.  There are different log level options for the syslog, kmsg, and console, as well as log level to actually store.

Offline

#5 2012-12-29 18:06:33

slavik262
Member
From: WA, USA
Registered: 2012-07-12
Posts: 46
Website

Re: Hiding wireless messages on boot [Solved]

WonderWoofy wrote:

illusionist's suggestion will work, but I think it will actually effect the output for everything.  You can get much more control in /etc/systemd/journald.conf.  There are different log level options for the syslog, kmsg, and console, as well as log level to actually store.

I've set

MaxLevelConsole=err

in /etc/systemd/journald.conf, but the wireless config messages are still being printed. I'm sorry, what options should I be setting? The man page hasn't really helped.

Offline

#6 2013-03-05 15:40:48

slavik262
Member
From: WA, USA
Registered: 2012-07-12
Posts: 46
Website

Re: Hiding wireless messages on boot [Solved]

I edited multiple options in /etc/systed/journald.conf, including uncommenting ForwardToConsole=no and uninstalled syslog-ng (since the wiki advised that it is no longer necessary given systemd's journald service), but these messages still persist. I could globally set the log level of the kernel as illusionist suggested (and as is noted in this thread), but it seems like quite the brute force solution.

Is there nothing else I can do to suppress these messages?

Last edited by slavik262 (2013-03-05 16:00:19)

Offline

#7 2013-03-05 15:56:59

sevensage
Member
Registered: 2012-12-10
Posts: 11

Re: Hiding wireless messages on boot [Solved]

try mephs solution
Try putting this in your /etc/rc.local and rebooting:

dmesg -n 3

dig +short txt archlinux.wp.dg.cx

Offline

#8 2013-03-05 16:02:01

slavik262
Member
From: WA, USA
Registered: 2012-07-12
Posts: 46
Website

Re: Hiding wireless messages on boot [Solved]

Seeing as we're all on systemd now, that wouldn't help. Is there a way to execute the same command on startup using systemd?

Offline

#9 2013-03-05 16:11:34

sevensage
Member
Registered: 2012-12-10
Posts: 11

Re: Hiding wireless messages on boot [Solved]

from the wiki

If you continuously get some verbose and annoying messages during the boot, With systemd write your own service file in /etc/systemd/system/brcms_verbosity_supression.service

[Unit]
Description=brcms_verbosity_supression
[Service]
Type=oneshot
ExecStart=****
[Install]
WantedBy=multi-user.target

Where **** is a path to a shell script executing

dmesg -n 3

dig +short txt archlinux.wp.dg.cx

Offline

#10 2013-03-05 16:25:51

slavik262
Member
From: WA, USA
Registered: 2012-07-12
Posts: 46
Website

Re: Hiding wireless messages on boot [Solved]

Thanks! That should do the trick.

Last edited by slavik262 (2013-03-05 16:26:05)

Offline

#11 2013-03-05 16:28:45

sevensage
Member
Registered: 2012-12-10
Posts: 11

Re: Hiding wireless messages on boot [Solved]

your welcome, mark it as solved if your all done.


dig +short txt archlinux.wp.dg.cx

Offline

Board footer

Powered by FluxBB