You are not logged in.

#1 2013-03-19 02:11:37

dambros
Member
Registered: 2013-03-16
Posts: 16

Videos not running smooth at all

Hi,

I've been in a battle with Arch for the couple of days and I'm about to give up because I'm running out of options here to make it work. Any video that I play (from an avi/mp4 file) is not smooth at all. Even tough it is watchable it is clearly perceivable the "unsmoothness", it is like I have fps issues.

My hardware is a ATI HD 5850 and I have tried all the proprietary drivers on pacman and the beta ones in AUR without success. Maybe I am just dumb and missing something, so here I am hoping someone can point me what I am missing. Also I tried with both VLC and MPlayer.

Since I am a beginner, please be specific on recommendations, otherwise I won't know how to do it.

Thanks in advance.

Last edited by dambros (2013-03-19 02:12:17)

Offline

#2 2013-03-19 04:09:29

anonymous_user
Member
Registered: 2009-08-28
Posts: 3,058

Re: Videos not running smooth at all

When you tried mplayer, do you install mplayer-vaapi and use vaapi as the renderer?

https://wiki.archlinux.org/index.php/VA-API

I think VLC has an option for hardware acceleration too.

Offline

#3 2013-03-19 21:42:00

dambros
Member
Registered: 2013-03-16
Posts: 16

Re: Videos not running smooth at all

anonymous_user wrote:

When you tried mplayer, do you install mplayer-vaapi and use vaapi as the renderer?

https://wiki.archlinux.org/index.php/VA-API

I think VLC has an option for hardware acceleration too.

I didnt know about that so I gave it a shot on both MPlayer (reinstalled with vaapi) and VLC (it was already set to use hardware acceleration) and it is still laggy as hell. Funny thing: I removed all video drivers on the computer and before restarting I gave the videos a shot and they worked perfect... after teh restart X didnt go up as expected so I reinstalled the drivers and the shitty display returned.

Please I need more ideas...

Offline

#4 2013-03-19 23:24:19

Max-P
Member
Registered: 2011-06-11
Posts: 164

Re: Videos not running smooth at all

Are you sure the graphic driver is being used?

Is it only the videos that lags as hell, or does any 2D/3D task does?

Try

glxinfo | grep rendering

and

glxgears

to see if you have direct rendering and if 3D works smoothly, that might help identify where the issue is (depending if you do have 3D acceleration or not, that changes everything).

Offline

#5 2013-03-19 23:31:35

dambros
Member
Registered: 2013-03-16
Posts: 16

Re: Videos not running smooth at all

Max-P wrote:

Are you sure the graphic driver is being used?

Is it only the videos that lags as hell, or does any 2D/3D task does?

Try

glxinfo | grep rendering

and

glxgears

to see if you have direct rendering and if 3D works smoothly, that might help identify where the issue is (depending if you do have 3D acceleration or not, that changes everything).

I don´t know how to test the 3D, since I dont have anything installed that can make use of it

glxinfo | grep rendering

Returns

direct rendering: Yes

Glxgears ran perfectly, with the following outputs:

302 frames in 5.0 seconds = 60.296 FPS
300 frames in 5.0 seconds = 59.931 FPS

The videos themselves are watchable, but you clearly realize there is something wrong. It looks like when you are playing a game with low fps.

Maybe it is something codec related? Im wild guessing here, since on Windows when there isnt codecs the video wont even start...

Last edited by dambros (2013-03-19 23:33:16)

Offline

#6 2013-03-19 23:34:11

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 5,243

Re: Videos not running smooth at all

Are you using compositing? If so, disable it when watching a video.


Sakura:-
Mobo: ASUS P8Z77-V PRO // Processor: Intel Core i7-3770K 3.4GHz // GFX: nVidia GeForce GTX 970 Ti // RAM: 32GB (4x 8GB) Corsair DDR3 (@ 2133MHz) // Storage: 1x 3TB Seagate SATAII 5x 1TB Samsung SATAII, 2x 120GB Corsair SSD

Offline

#7 2013-03-19 23:36:58

dambros
Member
Registered: 2013-03-16
Posts: 16

Re: Videos not running smooth at all

WorMzy wrote:

Are you using compositing? If so, disable it when watching a video.

Total noob here, what do you mean by ``compositing``? How can I disable it please?

Would it be editing xorg.conf and changing  this?

  Option             "Composite" "Disable"

Last edited by dambros (2013-03-19 23:38:37)

Offline

#8 2013-03-19 23:42:23

Max-P
Member
Registered: 2011-06-11
Posts: 164

Re: Videos not running smooth at all

Ok, next step

Which -vo did you try with mplayer?

Does any of these helps?

mplayer -vo x11 somevideo.mkv
mplayer -vo xv somevideo.mkv
mplayer -vo gl somevideo.mkv
mplayer -vo sdl somevideo.mkv
mplayer -vo vdpau somevideo.mkv

Also, compositing is a window manager extension that allows transparency, animations and a lot of eyecandy. If you are using Gnome Shell or KDE, you are really likely be using it. You can't disable it on Gnome, but you can in the KDE settings. XFCE has it too, but it's disabled by default. If you are using any other desktop environment, you likely know if your WM does compositing or not. What DE are you using?

Offline

#9 2013-03-19 23:45:16

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 5,243

Re: Videos not running smooth at all

dambros wrote:
WorMzy wrote:

Are you using compositing? If so, disable it when watching a video.

Total noob here, what do you mean by ``compositing``? How can I disable it please?

Would it be editing xorg.conf and changing  this?

  Option             "Composite" "Disable"

That's kind of a heavy-handed way of disabling it, but yes, that should work. The only problem is that you'll need to restart X every time you want to toggle it using that method.

EDIT: you apparently need to do that in the extensions section: https://wiki.archlinux.org/index.php/Xo … _extension

Last edited by WorMzy (2013-03-19 23:50:44)


Sakura:-
Mobo: ASUS P8Z77-V PRO // Processor: Intel Core i7-3770K 3.4GHz // GFX: nVidia GeForce GTX 970 Ti // RAM: 32GB (4x 8GB) Corsair DDR3 (@ 2133MHz) // Storage: 1x 3TB Seagate SATAII 5x 1TB Samsung SATAII, 2x 120GB Corsair SSD

Offline

#10 2013-03-19 23:49:34

dambros
Member
Registered: 2013-03-16
Posts: 16

Re: Videos not running smooth at all

Max-P wrote:

Ok, next step

Which -vo did you try with mplayer?

Does any of these helps?

mplayer -vo x11 somevideo.mkv
mplayer -vo xv somevideo.mkv
mplayer -vo gl somevideo.mkv
mplayer -vo sdl somevideo.mkv
mplayer -vo vdpau somevideo.mkv

Also, compositing is a window manager extension that allows transparency, animations and a lot of eyecandy. If you are using Gnome Shell or KDE, you are really likely be using it. You can't disable it on Gnome, but you can in the KDE settings. XFCE has it too, but it's disabled by default. If you are using any other desktop environment, you likely know if your WM does compositing or not. What DE are you using?

mplayer -vo x11 somevideo.mkv

A little better than usual

mplayer -vo xv somevideo.mkv

Pretty decent, way better than before

mplayer -vo gl somevideo.mkv

Terrible!

mplayer -vo sdl somevideo.mkv

Same as X11

mplayer -vo vdpau somevideo.mkv

Could hear the sound, but no video O.o

I am running KDE here.

WorMzy wrote:
dambros wrote:
WorMzy wrote:

Are you using compositing? If so, disable it when watching a video.

Total noob here, what do you mean by ``compositing``? How can I disable it please?

Would it be editing xorg.conf and changing  this?

  Option             "Composite" "Disable"

That's kind of a heavy-handed way of disabling it, but yes, that should work. The only problem is that you'll need to restart X every time you want to toggle it using that method.

I looked into xorg.conf and couldnt find that line. Looking at Desktop Effects on KDE there isnt really an option to disable it. I can change between OpenGL and Xrender but that is it...
I found that line looking into the wiki previously hmm

Last edited by dambros (2013-03-19 23:54:11)

Offline

#11 2013-03-19 23:54:22

Max-P
Member
Registered: 2011-06-11
Posts: 164

Re: Videos not running smooth at all

dambros wrote:

I am running KDE here.

Try disabling desktop effects in the KDE settings, I think it's in Window Manager then advanced tab or something. I don't know exactly, I'm using XFCE.

Quick Googling might give you the answer, KDE's compositing is pretty damn slow even on beefy hardware, so it's discussed everywhere. There's tips and tricks about it in the Arch wiki too.

(Another option is to disable vsync and keep desktop effects, but it never fixed anything for me back when I last tried KDE)

EDIT: I think Shift+Alt+F12 is the default shortcut for Compositing on/off

EDIT2: You can also try another window manager just for the test, like openbox or xfwm4.

Last edited by Max-P (2013-03-19 23:56:37)

Offline

#12 2013-03-20 00:00:48

dambros
Member
Registered: 2013-03-16
Posts: 16

Re: Videos not running smooth at all

Max-P wrote:
dambros wrote:

I am running KDE here.

Try disabling desktop effects in the KDE settings, I think it's in Window Manager then advanced tab or something. I don't know exactly, I'm using XFCE.

Quick Googling might give you the answer, KDE's compositing is pretty damn slow even on beefy hardware, so it's discussed everywhere. There's tips and tricks about it in the Arch wiki too.

(Another option is to disable vsync and keep desktop effects, but it never fixed anything for me back when I last tried KDE)

EDIT: I think Shift+Alt+F12 is the default shortcut for Compositing on/off

EDIT2: You can also try another window manager just for the test, like openbox or xfwm4.


One thing I can say for sure, disabling it made my things open 10x faster... wth! The bad thing is there is a huge black square where my cairo dock is supposed to be hmm

Videowise it didnt change much, I can see about the same as I did using xv vo on MPlayer.

Downloading and trying Openbox.

Last edited by dambros (2013-03-20 00:02:25)

Offline

#13 2013-03-20 00:05:56

Max-P
Member
Registered: 2011-06-11
Posts: 164

Re: Videos not running smooth at all

Openbox is a different WM, and is on its own package. There's a wiki page about it too. But openbox doesn't support compositing itself, you will need xcompmgr too with it, which I never used.

You may also want to retry all the vo options of mplayer since some are highly affected by this (especially -vo gl, which uses OpenGL and is highly affected by compositing).

Openbox can be ran pretty quickly, just install the package and run

openbox --replace

. It should come with some defaults, but for testing sake, it should just work good enough to see if it helps or not.

Offline

#14 2013-03-20 00:15:01

dambros
Member
Registered: 2013-03-16
Posts: 16

Re: Videos not running smooth at all

Max-P wrote:

Openbox is a different WM, and is on its own package. There's a wiki page about it too. But openbox doesn't support compositing itself, you will need xcompmgr too with it, which I never used.

You may also want to retry all the vo options of mplayer since some are highly affected by this (especially -vo gl, which uses OpenGL and is highly affected by compositing).

Openbox can be ran pretty quickly, just install the package and run

openbox --replace

. It should come with some defaults, but for testing sake, it should just work good enough to see if it helps or not.

Ok, same old thing with openbox.

So far the best thing was vo xv, which made them watchable, but if you pay attention you still see the lags there. Maybe Im just being too picky and since Im having this issue for the past days and it is driving me nuts I may be seeing thing. I guess I will ask my gf to take a look tomorrow and see if the lags now are not pre-assumptions.

Offline

#15 2013-03-20 00:17:52

Max-P
Member
Registered: 2011-06-11
Posts: 164

Re: Videos not running smooth at all

dambros wrote:

Maybe Im just being too picky and since Im having this issue for the past days and it is driving me nuts I may be seeing thing. I guess I will ask my gf to take a look tomorrow and see if the lags now are not pre-assumptions.

That's fairly possible. Videos are encoded at either 25 FPS or 29.997 FPS for most of them, while monitors are 60FPS+. If you look really closely, they all lag somehow once you notice, but they don't, they play at full speed wink Take a break from it, come back later and use the best vo option, probably will be fine.

Offline

#16 2013-03-20 00:29:51

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 5,243

Re: Videos not running smooth at all

Another thing worth noting is that scaling takes up a lot of processing power, so if you're trying to play a 1920x1080 video on a 1280x800 monitor, it'll be noticeably laggier than if you were watching a 1280x720 version of the video. You can use something like handbrake to scale down videos prior to watching them, but this is a slow process too.

Last edited by WorMzy (2013-03-20 00:31:06)


Sakura:-
Mobo: ASUS P8Z77-V PRO // Processor: Intel Core i7-3770K 3.4GHz // GFX: nVidia GeForce GTX 970 Ti // RAM: 32GB (4x 8GB) Corsair DDR3 (@ 2133MHz) // Storage: 1x 3TB Seagate SATAII 5x 1TB Samsung SATAII, 2x 120GB Corsair SSD

Offline

#17 2013-03-20 00:31:35

dambros
Member
Registered: 2013-03-16
Posts: 16

Re: Videos not running smooth at all

Well I am not crazy, I just sat back fired up a serie and it definitly lags as hell after 2-3mins in...

My setup runs on 1920x1080, but the default video size is not anywhere near it. The thing is I never had similar problems before on another OS hmm

Offline

#18 2013-03-20 00:40:18

anonymous_user
Member
Registered: 2009-08-28
Posts: 3,058

Re: Videos not running smooth at all

By another OS, do you mean Windows or a different Linux distro? If you boot a Linux live CD, is it able to play your videos without lag?

Offline

#19 2013-03-20 00:45:09

Gusar
Member
Registered: 2009-08-25
Posts: 3,447

Re: Videos not running smooth at all

WorMzy wrote:

Another thing worth noting is that scaling takes up a lot of processing power, so if you're trying to play a 1920x1080 video on a 1280x800 monitor, it'll be noticeably laggier than if you were watching a 1280x720 version of the video.

That would be true if software scaling was used. But it's usually not, the point of xv is to do hardware scaling. So video resolution makes no difference.

There are two stages of video playback - decoding and presentation. Presentation is pretty much always done in hardware provided the graphics driver is installed properly, xv and gl being the usual methods. Decoding can also be done in hardware, using vaapi, vdpau or xvba. I'm talking about dedicated video players here, I mention this because there's also Flash, which is a totally different thing.

@dambros: "glxinfo | grep OpenGL" is the command to use to check if hardware acceleration is active. Then, your player needs to be configured for either xv or gl. If you're using mplayer, it gives you a lot of info, so you can easily see which video output method it is using.

Offline

#20 2013-03-20 01:00:19

dambros
Member
Registered: 2013-03-16
Posts: 16

Re: Videos not running smooth at all

anonymous_user wrote:

By another OS, do you mean Windows or a different Linux distro? If you boot a Linux live CD, is it able to play your videos without lag?

I meant Win7. I dont have a Live CD right now, but I will get one for tomorrow and check!


Gusar wrote:
WorMzy wrote:

Another thing worth noting is that scaling takes up a lot of processing power, so if you're trying to play a 1920x1080 video on a 1280x800 monitor, it'll be noticeably laggier than if you were watching a 1280x720 version of the video.

That would be true if software scaling was used. But it's usually not, the point of xv is to do hardware scaling. So video resolution makes no difference.

There are two stages of video playback - decoding and presentation. Presentation is pretty much always done in hardware provided the graphics driver is installed properly, xv and gl being the usual methods. Decoding can also be done in hardware, using vaapi, vdpau or xvba. I'm talking about dedicated video players here, I mention this because there's also Flash, which is a totally different thing.

@dambros: "glxinfo | grep OpenGL" is the command to use to check if hardware acceleration is active. Then, your player needs to be configured for either xv or gl. If you're using mplayer, it gives you a lot of info, so you can easily see which video output method it is using.

"glxinfo | grep OpenGL" returns:

OpenGL vendor string: Advanced Micro Devices, Inc.                              
OpenGL renderer string: ATI Radeon HD 5800 Series                               
OpenGL core profile version string: 4.2.12002 Core Profile Context 9.012        
OpenGL core profile shading language version string: 4.20                       
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 4.2.12002 Compatibility Profile Context 9.012
OpenGL shading language version string: 4.20
OpenGL context flags: (none)
OpenGL profile mask: compatibility profile
OpenGL extensions:

After rebooting I went in again and gave the same movie as before a try running on MPlayer this time (-vo xv). It seems OK, so I assume the issue is with VLC now. I will keep watching for a bit longer and see if the problem doesnt come back to haunt me. The previous scene where I had the issue pasted by ok on MPlayer this time.

Offline

#21 2013-03-20 10:55:04

David Batson
Member
Registered: 2011-10-13
Posts: 640

Re: Videos not running smooth at all

I also boot Mageia 2 KDE.  I've found if you go to Desktop Effects > Advanced tab and use the following settings, video tearing is eliminated.

Compositing type: OpenGL
Keep window thumbnails: Only for Shown Windows
Scale method: Accurate
unchecked - Suspend desktop effects for fullscreen windows
unchecked - Use OpenGL 2 Shaders
checked - Use VSync

Offline

#22 2013-03-21 00:39:22

dambros
Member
Registered: 2013-03-16
Posts: 16

Re: Videos not running smooth at all

OK, this is back to haunt me... Im beggining to think Linux simply can't handle the GPU correctly. I've removed KDE, installed XCFE and yet I can't even use MPlayer anymore

Offline

#23 2013-03-21 08:09:37

David Batson
Member
Registered: 2011-10-13
Posts: 640

Re: Videos not running smooth at all

For Arch XFCE I installed Compiz and enabled VSync in Compiz.  No tearing with this setup.
FTR, I have a Intel i5 Sandybridge CPU.

Offline

Board footer

Powered by FluxBB