You are not logged in.

#1 2013-03-23 22:21:59

husainaloos
Member
Registered: 2013-03-23
Posts: 26

[Solved]Trackpad is Extremely Sensitive

Hello,

I installed Arch finally. But the trackpad is very sensitive: with the minimum pressure, it interprets it as a click. The wiki suggested touchpad synaptics. Even though it is for touchpads, I tried it (FingerHigh, FingerPress), but that does not work either. Could anybody helps me?

I have an Asus Eee PC netbook. This is my file:

$ cat /etc/X11/xorg.conf.d/50-synaptics.conf 
# Example xorg.conf.d snippet that assigns the touchpad driver
# to all touchpads. See xorg.conf.d(5) for more information on
# InputClass.
# DO NOT EDIT THIS FILE, your distribution will likely overwrite
# it when updating. Copy (and rename) this file into
# /etc/X11/xorg.conf.d first.
# Additional options may be added in the form of
#   Option "OptionName" "value"
#
Section "InputClass"
        Identifier "touchpad catchall"
        Driver "synaptics"
        MatchIsTouchpad "on"
        Option "TapButton1" "1"
        Option "TapButton2" "2"
        Option "TapButton3" "3"
	Option "FingerHigh" "18"
	Option "FingerPress" "18"
# This option is recommend on all Linux systems using evdev, but cannot be
# enabled by default. See the following link for details:
# [url]http://who-t.blogspot.com/2010/11/how-to-ignore-configuration-errors.html[/url]
        MatchDevicePath "/dev/input/event*"
EndSection

Section "InputClass"
        Identifier "touchpad ignore duplicates"
        MatchIsTouchpad "on"
        MatchOS "Linux"
        MatchDevicePath "/dev/input/mouse*"
        Option "Ignore" "on"
	Option "FingerHigh" "18"
	Option "FingerPress" "18"
EndSection

# This option enables the bottom right corner to be a right button on
# non-synaptics clickpads.
# This option is only interpreted by clickpads.
Section "InputClass"
        Identifier "Default clickpad buttons"
        MatchDriver "synaptics"
        Option "SoftButtonAreas" "50% 0 82% 0 0 0 0 0"
	Option "FingerHigh" "18"
	Option "FingerPress" "18"
#       To disable the bottom edge area so the buttons only work as buttons,
#       not for movement, set the AreaBottomEdge
#       Option "AreaBottomEdge" "82%"
EndSection

# This option disables software buttons on Apple touchpads.
# This option is only interpreted by clickpads.
Section "InputClass"
        Identifier "Disable clickpad buttons on Apple touchpads"
        MatchProduct "Apple|bcm5974"
        MatchDriver "synaptics"
        Option "SoftButtonAreas" "0 0 0 0 0 0 0 0"
	Option "FingerHigh" "18"
EndSection

Last edited by husainaloos (2013-03-24 04:47:19)

Offline

#2 2013-03-23 23:16:09

cookies
Member
Registered: 2013-01-17
Posts: 253

Re: [Solved]Trackpad is Extremely Sensitive

husainaloos wrote:

I installed Arch finally. But the trackpad is very sensitive: with the minimum pressure, it interprets it as a click. The wiki suggested touchpad synaptics. Even though it is for touchpads, I tried it (FingerHigh, FingerPress), but that does not work either. Could anybody helps me?

You could disable it completely with

Option "TapButton1" "0"
Option "TapButton2" "0"
Option "TapButton3" "0"

That's what I did with my Eee PC since that tapping feature was annoying me.

But follow the advice given in the config file (or you might loose it with the next X update):

# Example xorg.conf.d snippet that assigns the touchpad driver
# to all touchpads. See xorg.conf.d(5) for more information on
# InputClass.
# DO NOT EDIT THIS FILE, your distribution will likely overwrite
# it when updating. Copy (and rename) this file into
# /etc/X11/xorg.conf.d first.

If you don't want to disalbe tapping, you can find more details at http://www.x.org/wiki/

And please use code tags when posting config files. (see https://bbs.archlinux.org/help.php).

Offline

#3 2013-03-23 23:50:49

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [Solved]Trackpad is Extremely Sensitive

I want to reiterate the "Please use code tags" in the above post.  It makes the post easier to read.

That said, I f*cking hate tap-to-click.  So I typically disable it also as described above.  If you want to know all the configuration options for your touchpad, see the synaptics man page.  It is long, but if you read through it, you can become the touchpad configuration master you always wanted to be!

Also, instead of loading and reloading via changes to your xorg.conf.d/10-synaptics.conf file, simply use synclient to change settings on the fly.  There is a synaptics wiki page as well, that might help you out.  It has clickpad specific instructions on how to make something like 60% of the touchpad bottom a left click and the rest a right click.

Offline

#4 2013-03-24 02:08:59

veneratio
Member
Registered: 2011-08-05
Posts: 11

Re: [Solved]Trackpad is Extremely Sensitive

I'm not well versed in in the particulars of Synaptics settings, but one problem I've had is my window manager overriding my settings in the conf file for Synaptics.  You might want to try running

 synclient -l 

This will give you a listing of your current settings, so you can tell if the correct settings are loading.  I once tried changing settings in the file twenty times before realizing my wm was causing the trouble.

Offline

#5 2013-03-24 02:14:15

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [Solved]Trackpad is Extremely Sensitive

vereratio brings up a good point.  Are you using something like Gnome?  I believe that the settings are overridden by gconf in that particular case.  I am not sure what others might or might not do this, but I know that there are some settings daemons that conflict (or rather simply ignore) the settings put in place in the traditional conf files.

Offline

#6 2013-03-24 04:50:05

husainaloos
Member
Registered: 2013-03-23
Posts: 26

Re: [Solved]Trackpad is Extremely Sensitive

Thank you...

I actually was not able to figure out how to change the sensitivity at all. But cookies's code works for me. I personally realized that the trackpad is annoying anyway. Just changed the configuration file, and restarted it.

I could not change the sensitivity. It did not work for some reason, but it does not matter anymore.

Thanks again...

Offline

#7 2013-03-24 05:07:08

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [Solved]Trackpad is Extremely Sensitive

You should really read the synaptics man page.  It has every configuration available to you.  I think it is better to learn about what you are doing rather than just blindly copy/pasting configurations from other people.  Otherwise, why did you choose a DIY distribution?

Just know that the variables in the synaptics man page can either be set using the configuration you already know about, or by passing them as arguments to synclient.  So for example

$ synclient TouchpadOff=1

will turn the touchpad off.

$ synclient TapButton1=0 TapButton2=0 TapButton3=0

will do the same as what you are achieving with the configuration file.

I tell you this because it makes it so much easier to try different settings if you don't have to restart X everytime you make a change.

Offline

Board footer

Powered by FluxBB