You are not logged in.

#1 2013-04-23 06:38:00

mangatmodi
Member
Registered: 2012-11-16
Posts: 18

[SOLVED] Trouble installing Xmonad and Xmonad-contrib

I am new to Arch Linux. After using awesome for a month I decided to shift to xmonad.I installed xmonad and xmonad-contrib from official arch repositories by using

pacman -S xmonad xmonad-contrib

and then installed GHC. I was able to start session using

 exec xmonad 

in my ~/.xsession file. I copied the default xmonad.hs template to my home.

 cp /usr/share/xmonad-0.11/man/xmonad.hs ~/.xmonad/xmonad.hs 

. However while recompiling I am getting this error -

xmonad.hs:14:18:
    Could not find module `XMonad.StackSet'
    Use -v to see a list of the files searched for.

So I checked the modules in my ghc

[mangat@Noahas_Arch ~]$ ghc-pkg list
/usr/lib/ghc-7.6.2/package.conf.d
   Cabal-1.16.0
   array-0.4.0.1
   base-4.6.0.1
   bin-package-db-0.0.0.0
   binary-0.5.1.1
   bytestring-0.10.0.2
   containers-0.5.0.0
   deepseq-1.3.0.1
   directory-1.2.0.1
   filepath-1.3.0.1
   ghc-7.6.2
   ghc-prim-0.3.0.0
   haskell2010-1.1.1.0
   haskell98-2.0.0.2
   hoopl-3.9.0.0
   hpc-0.6.0.0
   integer-gmp-0.5.0.0
   old-locale-1.0.0.5
   old-time-1.1.0.1
   pretty-1.1.1.0
   process-1.1.0.2
   rts-1.0
   template-haskell-2.8.0.0
   time-1.4.0.1
   unix-2.6.0.1

I am now missing xmonad and xmonad-contrib modules, so I tried to reinstall it but I am now getting following error messages :-

[mangat@Noahas_Arch ~]$ su -c "pacman -Sv xmonad xmonad-contrib"
Password: 
Root      : /
Conf File : /etc/pacman.conf
DB Path   : /var/lib/pacman/
Cache Dirs: /var/cache/pacman/pkg/  
Lock File : /var/lib/pacman/db.lck
Log File  : /var/log/pacman.log
GPG Dir   : /etc/pacman.d/gnupg/
Targets   : xmonad  xmonad-contrib
warning: xmonad-0.11-5 is up to date -- reinstalling
warning: xmonad-contrib-0.11-6 is up to date -- reinstalling
resolving dependencies...
looking for inter-conflicts...

Packages (2): xmonad-0.11-5  xmonad-contrib-0.11-6

Total Installed Size:   34.13 MiB
Net Upgrade Size:       0.00 MiB

:: Proceed with installation? [Y/n] Y
(2/2) checking keys in keyring                                                                       [###########################################################] 100%
(2/2) checking package integrity                                                                     [###########################################################] 100%
(2/2) loading package files                                                                          [###########################################################] 100%
(2/2) checking for file conflicts                                                                    [###########################################################] 100%
(2/2) checking available disk space                                                                  [###########################################################] 100%
ghc-pkg: cannot find package xmonad-0.11
error: command failed to execute correctly
(1/2) reinstalling xmonad                                                                            [###########################################################] 100%
Reading package info from stdin ... done.
xmonad-0.11: Warning: haddock-interfaces: /usr/share/doc/xmonad-0.11/html/xmonad.haddock doesn't exist or isn't a file
xmonad-0.11: Warning: haddock-html: /usr/share/doc/xmonad-0.11/html doesn't exist or isn't a directory
xmonad-0.11: dependency "X11-1.6.1.1-1d285f3adf4105d51aa29a4bb5b0c634" doesn't exist (use --force to override)
xmonad-0.11: dependency "extensible-exceptions-0.1.1.4-757e1af929bd59fccfe8430149f55bc2" doesn't exist (use --force to override)
xmonad-0.11: dependency "mtl-2.1.2-36ff22533b21e2182d8d4647bfd2b3e7" doesn't exist (use --force to override)
xmonad-0.11: dependency "utf8-string-0.3.7-89a3d8cf53390a43809e108bcfba69ef" doesn't exist (use --force to override)
error: command failed to execute correctly
ghc-pkg: cannot find package xmonad-contrib-0.11
error: command failed to execute correctly
(2/2) reinstalling xmonad-contrib                                                                    [###########################################################] 100%
Reading package info from stdin ... done.
xmonad-contrib-0.11: Warning: haddock-interfaces: /usr/share/doc/xmonad-contrib-0.11/html/xmonad-contrib.haddock doesn't exist or isn't a file
xmonad-contrib-0.11: Warning: haddock-html: /usr/share/doc/xmonad-contrib-0.11/html doesn't exist or isn't a directory
xmonad-contrib-0.11: dependency "X11-1.6.1.1-1d285f3adf4105d51aa29a4bb5b0c634" doesn't exist (use --force to override)
xmonad-contrib-0.11: dependency "X11-xft-0.3.1-af5f924091c4d4d0e7fd0f1ef1e3e1c5" doesn't exist (use --force to override)
xmonad-contrib-0.11: dependency "extensible-exceptions-0.1.1.4-757e1af929bd59fccfe8430149f55bc2" doesn't exist (use --force to override)
xmonad-contrib-0.11: dependency "mtl-2.1.2-36ff22533b21e2182d8d4647bfd2b3e7" doesn't exist (use --force to override)
xmonad-contrib-0.11: dependency "random-1.0.1.1-048316c239de82db6e182c94b6cf4e19" doesn't exist (use --force to override)
xmonad-contrib-0.11: dependency "utf8-string-0.3.7-89a3d8cf53390a43809e108bcfba69ef" doesn't exist (use --force to override)
xmonad-contrib-0.11: dependency "xmonad-0.11-b1caf0967c016228684d4fbe995fb8d7" doesn't exist (use --force to override)
error: command failed to execute correctly

Any Idea why pacman is unable to resolve the dependency. Are they availiable in AUR?

PS: I have just updated by installation and I am not using AUR right now.

Last edited by mangatmodi (2013-04-23 09:26:14)

Offline

#2 2013-04-23 08:42:28

Raynman
Member
Registered: 2011-10-22
Posts: 1,113

Re: [SOLVED] Trouble installing Xmonad and Xmonad-contrib

It's not pacman that is unable to resolve dependencies, it's Cabal (Haskell installation framework that comes with ghc). Apparently, as far as pacman knows, those haskell packages have been installed, but ghc disagrees.

mangatmodi wrote:

I installed xmonad and xmonad-contrib from official arch repositories by using

pacman -S xmonad xmonad-contrib

and then installed GHC.

This (bold part) is strange. GHC is a dependency of xmonad, so pacman should have pulled that in before installing xmonad. This, combined with the dependency errors, makes it seem like you manually installed ghc afterwards, perhaps overwriting files containing registered modules (because the modules in your list are probably just the ones that come with ghc). I'm guessing here -- so what exactly did you do?

If your ghc installation seems to be fine (i.e. you didn't do anything crazy), I would reinstall xmonad and all its dependencies. The simplest way may be:

# pacman -Rs xmonad xmonad-contrib
# pacman -S xmonad xmonad-contrib

Offline

#3 2013-04-23 09:13:57

mangatmodi
Member
Registered: 2012-11-16
Posts: 18

Re: [SOLVED] Trouble installing Xmonad and Xmonad-contrib

@Raynman

My pacman.conf was really in a very bad shape at the time of installation of Xmonad. I think I must be careless to notice and removed dependency check.
When I compiled my xmonad.hs I found errors related to GHC. I was too surprised, however installed it further. Now since GHC was installed later, it missed some modules which were previously installed.

I tried reinstalling xmonad, xmonad-contrib before but there was no use. However recursively removing and installing, as suggested by you, seems to have fixed have problem. I am now getting following modules in GHC.

/usr/lib/ghc-7.6.2/package.conf.d
   Cabal-1.16.0
   X11-1.6.1.1
   X11-xft-0.3.1
   array-0.4.0.1
   base-4.6.0.1
   bin-package-db-0.0.0.0
   binary-0.5.1.1
   bytestring-0.10.0.2
   containers-0.5.0.0
   data-default-0.5.1
   deepseq-1.3.0.1
   directory-1.2.0.1
   dlist-0.5
   extensible-exceptions-0.1.1.4
   filepath-1.3.0.1
   ghc-7.6.2
   ghc-prim-0.3.0.0
   haskell2010-1.1.1.0
   haskell98-2.0.0.2
   hoopl-3.9.0.0
   hpc-0.6.0.0
   integer-gmp-0.5.0.0
   mtl-2.1.2
   old-locale-1.0.0.5
   old-time-1.1.0.1
   pretty-1.1.1.0
   process-1.1.0.2
   random-1.0.1.1
   rts-1.0
   template-haskell-2.8.0.0
   time-1.4.0.1
   transformers-0.3.0.0
   unix-2.6.0.1
   utf8-string-0.3.7
   xmonad-0.11
   xmonad-contrib-0.11

I will test my system and mark the thread solved. Thank you for the help

Offline

Board footer

Powered by FluxBB