You are not logged in.

#1 2013-04-09 14:54:46

R09UE-RAVEN
Member
Registered: 2012-04-08
Posts: 19

Laptop will not stay suspended

So I've been having a laptop problem for a while now that after a while of running in a single boot session (roughly 1 day), the suspend capability of my laptop fails. Here's some things to note:

  • Laptop: Lenovo Thinkpad T530

  • Laptop has suspend/sleep implemented at the hardware level (doesn't help)

  • I've tried giving Systemd control over suspend via logind.conf.

  • I'm not using any power management tools. Systemd and my laptop's hardware handles everything.

  • Could be a BIOS setting?

Whenever I suspend my laptop, it suspends, and then immediately wakes back up. This happens regardless of whether I'm closing the lid of the laptop or issuing systemd the suspend command. I've checked my log files trying to find out what's keeping it from staying asleep, but it was of little help. If I reboot my system, suspend works again, but it soon fails again after a couple of successful suspends. This issue seem to occur quite randomly and with no clear cause. I originally thought some kernel modules weren't unloading during suspend. Then I thought systemd didn't know that a closed lid meant "let the computer suspend". Then I suspected bluetooth. It seems independent of any application I'm running when I tell it to suspend. If I remove all procs that I started since booting my computer, it still won't suspend. I've even had cases where it fails to suspend immediately after a fresh reboot.

# /etc/systemd/logind.conf

[Login]
#NAutoVTs=6
#ReserveVT=6
#KillUserProcesses=no
#KillOnlyUsers=
#KillExcludeUsers=root
#Controllers=
#ResetControllers=cpu
#InhibitDelayMaxSec=5
HandlePowerKey=poweroff
HandleSuspendKey=suspend
HandleHibernateKey=hibernate
HandleLidSwitch=suspend
PowerKeyIgnoreInhibited=yes
SuspendKeyIgnoreInhibited=yes
HibernateKeyIgnoreInhibited=yes
LidSwitchIgnoreInhibited=yes
#IdleAction=ignore
#IdleActionSec=30min

I'll try to post a fresh instance of it happening in the log files if that's needed.

Offline

#2 2013-04-09 17:06:50

TheFlyingFrenchman
Member
Registered: 2013-02-23
Posts: 9

Re: Laptop will not stay suspended

Hi,
I am certainly not skilled enough to help you through a full troubleshoot of your problem, but here are a couple things to look at which could help investigate a little more:

- Do you have acpid installed and actually loaded ? if that is the case check your /etc/acpi config files for any conflict with acpid trying to handle the suspend process (wiki is your friend), starting with handler.sh ;
- These lines in your logind.conf:

PowerKeyIgnoreInhibited=yes
SuspendKeyIgnoreInhibited=yes
HibernateKeyIgnoreInhibited=yes
LidSwitchIgnoreInhibited=yes

are only useful if you use Gnome or KDE as a DE, according to our wiki friend. Do you have one of these two installed? If it is the case, your settings make them inhibit systemd and handle the suspend function themselves, so the problem should not come from systemd but from the DE. If you do not have such a DE, try commenting these lines, because they are of no use.
Hope this helps. Good luck !

Offline

#3 2013-04-24 14:23:10

R09UE-RAVEN
Member
Registered: 2012-04-08
Posts: 19

Re: Laptop will not stay suspended

The above post hasn't helped as I posted my properly logind.conf and I'm not using acpid as I would like to use the suspend cababilities native to my hardware and systemd. I would post my log files, but I don't know what log information to filter for - I don't want to just post the output of a journalctl -b. Any suggestions are extremely welcome.

Offline

#4 2013-04-25 00:21:00

R09UE-RAVEN
Member
Registered: 2012-04-08
Posts: 19

Re: Laptop will not stay suspended

Well scratch the above post, I misread your response and have edited my logind.conf appropriately. I don't have a DE.

I think my problem is acpid - or the fact that it's absent from my system. I've been under the impression that it was unnecessary and that systemd could handle everything itself. Is this wrong? The wiki never explicitly says this:

On systems which run no graphical setup or only a simple window manager like i3 or awesome, this may replace the acpid daemon which is usually used to react to these ACPI events.

I use a simple window manager, so this statement should apply to me. For this reason, I assumed that I could just use systemd and avoid acpid all together. I'm going to post some information just in case it's helpful. Here's the status for my suspend service after a failure to stay suspended:

systemd-suspend.service - Suspend
   Loaded: loaded (/usr/lib/systemd/system/systemd-suspend.service; static)
   Active: inactive (dead) since Wed 2013-04-24 20:09:26 EDT; 52s ago
     Docs: man:systemd-suspend.service(8)
  Process: 12193 ExecStart=/usr/lib/systemd/systemd-sleep suspend (code=exited, status=0/SUCCESS)

Apr 24 20:09:23 anansi systemd[1]: Starting Suspend...
Apr 24 20:09:23 anansi systemd-sleep[12193]: Suspending system...
Apr 24 20:09:26 anansi systemd-sleep[12193]: System resumed.
Apr 24 20:09:26 anansi systemd[1]: Started Suspend.

Here are some log entries following my system's failure to suspend:

Apr 24 20:09:23 anansi sudo[12190]: michael : TTY=pts/4 ; PWD=/etc/systemd ; USER=root ; COMMAND=/usr/bin/systemctl suspend
Apr 24 20:09:23 anansi sudo[12190]: pam_unix(sudo:session): session opened for user root by (uid=0)
Apr 24 20:09:23 anansi systemd[1]: Starting Sleep.
Apr 24 20:09:23 anansi systemd[1]: Reached target Sleep.
Apr 24 20:09:23 anansi systemd[1]: Starting Suspend...
Apr 24 20:09:23 anansi systemd-sleep[12193]: Suspending system...
Apr 24 20:09:23 anansi kernel: PM: Syncing filesystems ... done.
Apr 24 20:09:23 anansi kernel: PM: Preparing system for mem sleep
Apr 24 20:09:26 anansi kernel: Freezing user space processes ... (elapsed 0.01 seconds) done.
Apr 24 20:09:26 anansi systemd[1]: Time has been changed
Apr 24 20:09:26 anansi bluetoothd[365]: bluetoothd[365]: Adapter /org/bluez/365/hci0 has been disabled
Apr 24 20:09:26 anansi bluetoothd[365]: bluetoothd[365]: Unregister path: /org/bluez/365/hci0
Apr 24 20:09:26 anansi bluetoothd[365]: Adapter /org/bluez/365/hci0 has been disabled
Apr 24 20:09:26 anansi dhcpcd[2801]: enp0s25: carrier lost
Apr 24 20:09:26 anansi bluetoothd[365]: Unregister path: /org/bluez/365/hci0
Apr 24 20:09:26 anansi dhcpcd[3085]: enp0s25: carrier lost
Apr 24 20:09:26 anansi kernel: Freezing remaining freezable tasks ... (elapsed 0.01 seconds) done.
Apr 24 20:09:26 anansi systemd[1]: Service bluetooth.target is not needed anymore. Stopping.
Apr 24 20:09:26 anansi systemd[1]: Stopping Bluetooth.
Apr 24 20:09:26 anansi systemd[1]: Stopped target Bluetooth.
Apr 24 20:09:26 anansi systemd[1]: Starting Bluetooth.
Apr 24 20:09:26 anansi systemd[1]: Reached target Bluetooth.
Apr 24 20:09:26 anansi systemd-sleep[12193]: System resumed.
Apr 24 20:09:26 anansi kernel: PM: Entering mem sleep
Apr 24 20:09:26 anansi kernel: Suspending console(s) (use no_console_suspend to debug)
Apr 24 20:09:26 anansi kernel: sd 0:0:0:0: [sda] Synchronizing SCSI cache
Apr 24 20:09:26 anansi kernel: sd 0:0:0:0: [sda] Stopping disk
Apr 24 20:09:26 anansi kernel: e1000e 0000:00:19.0: System wakeup enabled by ACPI
Apr 24 20:09:26 anansi kernel: i915 0000:00:02.0: power state changed by ACPI to D3hot
Apr 24 20:09:26 anansi kernel: PM: suspend of devices complete after 749.300 msecs
Apr 24 20:09:26 anansi kernel: PM: late suspend of devices complete after 0.432 msecs
Apr 24 20:09:26 anansi kernel: ehci-pci 0000:00:1d.0: System wakeup enabled by ACPI
Apr 24 20:09:26 anansi kernel: ehci-pci 0000:00:1d.0: power state changed by ACPI to D3hot
Apr 24 20:09:26 anansi kernel: ehci-pci 0000:00:1a.0: System wakeup enabled by ACPI
Apr 24 20:09:26 anansi kernel: ehci-pci 0000:00:1a.0: power state changed by ACPI to D3hot
Apr 24 20:09:26 anansi kernel: xhci_hcd 0000:00:14.0: System wakeup enabled by ACPI
Apr 24 20:09:26 anansi kernel: xhci_hcd 0000:00:14.0: power state changed by ACPI to D3hot
Apr 24 20:09:26 anansi kernel: PM: noirq suspend of devices complete after 66.228 msecs
Apr 24 20:09:26 anansi kernel: ACPI: Preparing to enter system sleep state S3
Apr 24 20:09:26 anansi kernel: PM: Saving platform NVS memory
Apr 24 20:09:26 anansi kernel: Disabling non-boot CPUs ...
Apr 24 20:09:26 anansi kernel: smpboot: CPU 1 is now offline
Apr 24 20:09:26 anansi kernel: smpboot: CPU 2 is now offline
Apr 24 20:09:26 anansi kernel: smpboot: CPU 3 is now offline
Apr 24 20:09:26 anansi kernel: smpboot: CPU 4 is now offline
Apr 24 20:09:26 anansi kernel: smpboot: CPU 5 is now offline
Apr 24 20:09:26 anansi kernel: smpboot: CPU 6 is now offline
Apr 24 20:09:26 anansi systemd[1]: Started Suspend.
Apr 24 20:09:26 anansi systemd[1]: Requested transaction contradicts existing jobs: File exists
Apr 24 20:09:26 anansi systemd[1]: Service sleep.target is not needed anymore. Stopping.
Apr 24 20:09:26 anansi systemd[1]: Stopping Sleep.
Apr 24 20:09:26 anansi systemd[1]: Stopped target Sleep.
Apr 24 20:09:26 anansi systemd[1]: Reached target Suspend.
Apr 24 20:09:26 anansi sudo[12190]: pam_unix(sudo:session): session closed for user root
Apr 24 20:09:26 anansi kernel: smpboot: CPU 7 is now offline
Apr 24 20:09:26 anansi kernel: Extended CMOS year: 2000
Apr 24 20:09:26 anansi kernel: ACPI: Low-level resume complete
Apr 24 20:09:26 anansi kernel: PM: Restoring platform NVS memory
Apr 24 20:09:26 anansi kernel: Extended CMOS year: 2000
Apr 24 20:09:26 anansi kernel: Enabling non-boot CPUs ...
Apr 24 20:09:26 anansi kernel: smpboot: Booting Node 0 Processor 1 APIC 0x1
Apr 24 20:09:26 anansi kernel: CPU1 is up
Apr 24 20:09:26 anansi kernel: smpboot: Booting Node 0 Processor 2 APIC 0x2
Apr 24 20:09:26 anansi kernel: CPU2 is up
Apr 24 20:09:26 anansi kernel: smpboot: Booting Node 0 Processor 3 APIC 0x3
Apr 24 20:09:26 anansi kernel: CPU3 is up
Apr 24 20:09:26 anansi kernel: smpboot: Booting Node 0 Processor 4 APIC 0x4
Apr 24 20:09:26 anansi kernel: CPU4 is up
Apr 24 20:09:26 anansi kernel: smpboot: Booting Node 0 Processor 5 APIC 0x5
Apr 24 20:09:26 anansi kernel: CPU5 is up
Apr 24 20:09:26 anansi kernel: smpboot: Booting Node 0 Processor 6 APIC 0x6
Apr 24 20:09:26 anansi kernel: CPU6 is up
Apr 24 20:09:26 anansi kernel: smpboot: Booting Node 0 Processor 7 APIC 0x7
Apr 24 20:09:26 anansi kernel: CPU7 is up
Apr 24 20:09:26 anansi kernel: ACPI: Waking up from system sleep state S3
Apr 24 20:09:26 anansi kernel: i915 0000:00:02.0: power state changed by ACPI to D0
Apr 24 20:09:26 anansi kernel: xhci_hcd 0000:00:14.0: power state changed by ACPI to D0
Apr 24 20:09:26 anansi kernel: xhci_hcd 0000:00:14.0: System wakeup disabled by ACPI
Apr 24 20:09:26 anansi kernel: ehci-pci 0000:00:1a.0: power state changed by ACPI to D0
Apr 24 20:09:26 anansi kernel: ehci-pci 0000:00:1a.0: System wakeup disabled by ACPI
Apr 24 20:09:26 anansi kernel: ehci-pci 0000:00:1d.0: power state changed by ACPI to D0
Apr 24 20:09:26 anansi kernel: ehci-pci 0000:00:1d.0: System wakeup disabled by ACPI
Apr 24 20:09:26 anansi kernel: sdhci-pci 0000:02:00.0: MMC controller base frequency changed to 50Mhz.
Apr 24 20:09:26 anansi kernel: PM: noirq resume of devices complete after 161.174 msecs
Apr 24 20:09:26 anansi kernel: PM: early resume of devices complete after 0.279 msecs
Apr 24 20:09:26 anansi kernel: i915 0000:00:02.0: setting latency timer to 64
Apr 24 20:09:26 anansi kernel: xhci_hcd 0000:00:14.0: setting latency timer to 64
Apr 24 20:09:26 anansi kernel: e1000e 0000:00:19.0: System wakeup disabled by ACPI
Apr 24 20:09:26 anansi bluetoothd[365]: bluetoothd[365]: Adapter /org/bluez/365/hci0 has been enabled
Apr 24 20:09:26 anansi bluetoothd[365]: Adapter /org/bluez/365/hci0 has been enabled
Apr 24 20:09:26 anansi kernel: ehci-pci 0000:00:1a.0: setting latency timer to 64
Apr 24 20:09:26 anansi kernel: ehci-pci 0000:00:1d.0: setting latency timer to 64
Apr 24 20:09:26 anansi kernel: mei 0000:00:16.0: irq 44 for MSI/MSI-X
Apr 24 20:09:26 anansi kernel: ahci 0000:00:1f.2: setting latency timer to 64
Apr 24 20:09:26 anansi kernel: snd_hda_intel 0000:00:1b.0: irq 47 for MSI/MSI-X
Apr 24 20:09:26 anansi kernel: e1000e 0000:00:19.0: irq 48 for MSI/MSI-X
Apr 24 20:09:26 anansi kernel: tpm_tis 00:09: TPM is disabled/deactivated (0x6)
Apr 24 20:09:26 anansi kernel: Extended CMOS year: 2000
Apr 24 20:09:26 anansi kernel: usb 3-1.4: reset full-speed USB device number 4 using ehci-pci
Apr 24 20:09:26 anansi kernel: btusb 3-1.4:1.0: no reset_resume for driver btusb?
Apr 24 20:09:26 anansi kernel: btusb 3-1.4:1.1: no reset_resume for driver btusb?
Apr 24 20:09:26 anansi kernel: ata2: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
Apr 24 20:09:26 anansi kernel: ata2.00: ACPI cmd e3/00:1f:00:00:00:a0 (IDLE) succeeded
Apr 24 20:09:26 anansi kernel: ata2.00: ACPI cmd e3/00:02:00:00:00:a0 (IDLE) succeeded
Apr 24 20:09:26 anansi kernel: ata2.00: ACPI cmd ef/10:03:00:00:00:a0 (SET FEATURES) filtered out
Apr 24 20:09:26 anansi kernel: ata5: SATA link down (SStatus 0 SControl 300)
Apr 24 20:09:26 anansi kernel: ata2.00: ACPI cmd e3/00:1f:00:00:00:a0 (IDLE) succeeded
Apr 24 20:09:26 anansi kernel: ata2.00: ACPI cmd e3/00:02:00:00:00:a0 (IDLE) succeeded
Apr 24 20:09:26 anansi kernel: ata2.00: ACPI cmd ef/10:03:00:00:00:a0 (SET FEATURES) filtered out
Apr 24 20:09:26 anansi kernel: ata2.00: configured for UDMA/33
Apr 24 20:09:26 anansi kernel: usb 3-1.6: reset high-speed USB device number 5 using ehci-pci
Apr 24 20:09:26 anansi kernel: firewire_core 0000:02:00.3: rediscovered device fw0
Apr 24 20:09:26 anansi kernel: ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
Apr 24 20:09:26 anansi kernel: ata1.00: ACPI cmd ef/02:00:00:00:00:a0 (SET FEATURES) succeeded
Apr 24 20:09:26 anansi kernel: ata1.00: ACPI cmd f5/00:00:00:00:00:a0 (SECURITY FREEZE LOCK) filtered out
Apr 24 20:09:26 anansi kernel: ata1.00: ACPI cmd ef/10:03:00:00:00:a0 (SET FEATURES) filtered out
Apr 24 20:09:26 anansi kernel: ata1.00: ACPI cmd ef/02:00:00:00:00:a0 (SET FEATURES) succeeded
Apr 24 20:09:26 anansi kernel: ata1.00: ACPI cmd f5/00:00:00:00:00:a0 (SECURITY FREEZE LOCK) filtered out
Apr 24 20:09:26 anansi kernel: ata1.00: ACPI cmd ef/10:03:00:00:00:a0 (SET FEATURES) filtered out
Apr 24 20:09:26 anansi kernel: ata1.00: configured for UDMA/100
Apr 24 20:09:26 anansi kernel: sd 0:0:0:0: [sda] Starting disk
Apr 24 20:09:26 anansi kernel: iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
Apr 24 20:09:26 anansi kernel: iwlwifi 0000:03:00.0: Radio type=0x1-0x2-0x0
Apr 24 20:09:26 anansi kernel: PM: resume of devices complete after 1085.032 msecs
Apr 24 20:09:26 anansi kernel: PM: Finishing wakeup.
Apr 24 20:09:26 anansi kernel: Restarting tasks ... done.
Apr 24 20:09:26 anansi kernel: video LNXVIDEO:00: Restoring backlight state

Hope this helps.

Offline

#5 2013-04-25 01:37:26

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,661

Re: Laptop will not stay suspended

TheFlyingFrenchman wrote:

Hi,
I am certainly not skilled enough to help you through a full troubleshoot of your problem, but here are a couple things to look at which could help investigate a little more:

- Do you have acpid installed and actually loaded ? if that is the case check your /etc/acpi config files for any conflict with acpid trying to handle the suspend process (wiki is your friend), starting with handler.sh ;
- These lines in your logind.conf:

PowerKeyIgnoreInhibited=yes
SuspendKeyIgnoreInhibited=yes
HibernateKeyIgnoreInhibited=yes
LidSwitchIgnoreInhibited=yes

are only useful if you use Gnome or KDE as a DE, according to our wiki friend. Do you have one of these two installed? If it is the case, your settings make them inhibit systemd and handle the suspend function themselves, so the problem should not come from systemd but from the DE. If you do not have such a DE, try commenting these lines, because they are of no use.
Hope this helps. Good luck !

It is the other way around. These setting will make systemd ignore DE Inhibitors which prevent systemd handling these events. Setting these to no tells sytemd to respect blocks placed by DEs wanting to handle these events.

@OP,
I would try to simplify everything as much as possible and then get the logs. For example, disable bluetooth (in BIOS if necessary) and whatever else you can. Make sure the relevant systemd targets/services are not enabled and are stopped. See if it suspends then. If not, the log will contain fewer distractions. If so, you can add things back one at a time until you identify the problem.

I think that systemd's ability to take over these functions is currently pretty limited although I  think it should handle suspend OK.

I'm not sure what the hardware handling is doing. Are you sure that's not conflicting somehow?

Last edited by cfr (2013-04-25 01:41:52)


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#6 2013-04-25 04:11:51

R09UE-RAVEN
Member
Registered: 2012-04-08
Posts: 19

Re: Laptop will not stay suspended

I've fiddled around with the BIOS settings in case the hardware was the cause, but it's had no effect. What's frustrating about this is that I've done more or less what you said, but with surprisingly little results. When my laptop first started to fail its suspension, I started removing the complexity of my system - basically undoing everything I had done since the last reboot. I would think that any issue with my configs or the hardware would result in my computer failing to suspend every time, which it doesn't after a fresh reboot. I would also think that if it stopped suspending properly after some usage that I would be able to backtrack to the culprit, but that hasn't worked either.

I'll investigate further and report any findings I might make.

Offline

#7 2013-04-29 06:59:37

virtualeyes
Member
Registered: 2013-02-24
Posts: 17

Re: Laptop will not stay suspended

Same deal here, but on Fedora 18 with Dell Precision M4700 laptop and i3 WM.

Logs reveal nothing, just suspend log entries followed immediately by resume, without any indication of why the system is waking up, frustrating.

Fortunately the machine boots in @6 seconds and I have running applications set to start on boot, but it's a major hassle still, suspend/resume is quite handy!

Will post back here if I find any clue as to what is going on.

Offline

#8 2013-04-29 23:37:38

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,661

Re: Laptop will not stay suspended

Have you tried other methods to suspend? I know you don't want to use acpi or whatever but it would be interesting to know if a non-systemd method would work or not.


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#9 2013-05-03 12:49:33

nspeirs1
Member
Registered: 2011-06-02
Posts: 7

Re: Laptop will not stay suspended

I'm having the exact same problem.  Since I updated  my computer, the laptop will only suspend erratically.  I've tried suspending with pm-suspend, systemctl suspend, and using the suspend button on XFCE.

Offline

#10 2013-05-03 23:31:11

nspeirs1
Member
Registered: 2011-06-02
Posts: 7

Re: Laptop will not stay suspended

Another thing:  Oddly, my left and right arrow keys have stopped working.

Offline

#11 2013-05-07 08:50:58

virtualeyes
Member
Registered: 2013-02-24
Posts: 17

Re: Laptop will not stay suspended

Continues here, get 3 or 4 suspends in after a reboot and then, presto, sleep-immediate-wakeup.

Haven't had time to really dig around; not sure if a recent system update (yum in Fedora) has caused this, or something hardware related on my end (would be odd if the latter, 3 of us in this thread all having hardware issue affecting sleep functionality)

Last edited by virtualeyes (2013-05-07 08:51:38)

Offline

#12 2013-05-17 06:38:16

virtualeyes
Member
Registered: 2013-02-24
Posts: 17

Re: Laptop will not stay suspended

Believe I found the cause of the problem on my end.

When attaching a mountable USB device to the laptop, if I dismount the device, subsequent suspend attempts fail, machine wakes right back up.

Not sure what is going on as mount shows the USB device as not mounted.

Anyway, am able to sleep reliably again

Offline

#13 2013-07-11 16:11:59

cullum
Member
Registered: 2013-02-06
Posts: 3

Re: Laptop will not stay suspended

Just wanted to chime in here to confirm the same issue on my T530. Running latest kernel and everything, systemd power management disabled, suspending with KDE's power management. I've had the issue since I bought the laptop. Every 24 hours or so, I have to reboot the machine to get it to suspend.

I've tried uninstalling the desktop environments and suspending with systemd, same thing happens. I've tried unloading all the usb modules before suspending as well. Logs show nothing that causes the wakeups other than the unhelpful line "Waking Up."

Incidentally, it seems to be related to suspending via hardware events only. If I suspend with the suspend button or by closing the lid, I'll get the dreaded wakeup. But, if I call pm-suspend at the command line, it will a stay asleep, even if the lid-closing method isn't working and I haven't rebooted yet.

Last edited by cullum (2013-07-11 16:16:24)

Offline

#14 2013-07-11 21:10:00

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,661

Re: Laptop will not stay suspended

Have you considered disabling KDE's handling and using something like acpi to run pm-suspend on lid close or whatever?


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#15 2014-11-12 17:01:37

openprivacy
Member
From: Pittsburgh, PA
Registered: 2014-11-12
Posts: 5

Re: Laptop will not stay suspended

I have T530, too, and just switched from Xubuntu to Arch w/ Xmonad. Used to have this issue regularly with Xubuntu, have not seen it with Arch -- until just now. sad See also: http://unix.stackexchange.com/questions … nt-suspend

Fortunately, a reboot takes only about 20 seconds...

Offline

Board footer

Powered by FluxBB