You are not logged in.

#1 2013-04-25 23:10:44

oconnor663
Member
Registered: 2012-12-16
Posts: 45

[SOLVED]Backlight and Ctrl-Alt-F* aren't working on T420s/nvidia/Gnome

I'm running Gnome on a Lenovo T420s with the proprietary nvidia driver (nouveau isn't able to drive my large external monitor -- the laptop becomes unresponsive when I try to plug it in, maybe expected but saving that for a separate post).

1) My backlight controls (Fn + Home/End) work in that Gnome shows the brightness meter, and the bar moves left and right, but the actual brightness of the screen doesn't change. When I first boot the screen is always at 100% brightness, but when I wake from sleep the brightness is very low, and in both cases I'm not able to change it. If I `systemctl stop gdm` and go back to console mode, the brightness keys work fine again. I'd consider using console mode as a workaround, but that has me running into problem #2.

I've tried installing the nvidiabl driver from the AUR. That modprobes successfully, but it doesn't seem to affect the situation inside Gnome. I've also tried different combinations of the acpi_backlight kernel param with and without that driver, but those didn't seem to affect anything either. I'd love suggestions for other configurations to try. One thing the nvidiabl driver DID do is add some new entries under /sys/class/backlight/nvidia_backlight (previously there was only acpi_video0). The following may be totally unrelated to my problem, but I notice that `cat max_brightness` in there returns 127, but `cat brightness` returns 15000 something. Trying to set echo > brightness to anything above 127 fails -- makes sense -- but setting it to 127 results in the screen becoming very dim. It's then impossible to get back to high brightness, though I can adjust successfully between extremely dim and very dim. If anyone recognizes that problem, please let me know.

I can confirm that if I switch back to the nouveau drivers, the Gnome brightness problem is fixed. Problem #2 remains though:

2) Switching to console mode no longer works while Gnome is running. The Ctrl+Alt+F2 etc. combinations don't have any effect. They work fine if I `systemctl stop gdm` to get back to text mode, but not while I'm looking at the Gnome desktop. I've read a few posts that suggest this is simply a bug with the NVidia drivers, but I wanted to ask if anyone knew a workaround.

Apologies if I should've made a second post about this one, but since it's hurting my ability to solve #1 I thought I might add it. Thanks again to anyone with thoughts.

Last edited by oconnor663 (2013-05-01 22:35:32)

Offline

#2 2013-05-01 22:38:14

oconnor663
Member
Registered: 2012-12-16
Posts: 45

Re: [SOLVED]Backlight and Ctrl-Alt-F* aren't working on T420s/nvidia/Gnome

Fixing the backlight required adding an X11 config file: /usr/share/X11/xorg.conf.d/10-nvidia-brightness.conf

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "Quadro K1000M"
    Option         "RegistryDwords" "EnableBrightnessControl=1"
EndSection

I found the answer here: http://askubuntu.com/questions/76081/br … dia-driver

Offline

#3 2013-05-01 23:07:51

oconnor663
Member
Registered: 2012-12-16
Posts: 45

Re: [SOLVED]Backlight and Ctrl-Alt-F* aren't working on T420s/nvidia/Gnome

This turned out to be documented on the wiki, but I missed it: https://wiki.archlinux.org/index.php/NV … ss_Control

Offline

Board footer

Powered by FluxBB