You are not logged in.

#1 2013-05-07 03:03:48

piratebill
Member
From: Sol System
Registered: 2011-10-20
Posts: 78

[Solved] Vlc seg faults after latest upgrade

When updating vlc I now get this message  from pacman

/tmp/alpm_LHUeqA/.INSTALL: line 1:  1809 Segmentation fault      (core dumped) usr/lib/vlc/vlc-cache-gen -f /usr/lib/vlc/plugins

Running vlc outputs

VLC media player 2.0.6 Twoflower (revision 2.0.6-0-gbe9623c)
Segmentation fault (core dumped)

running dmesg gives

segfault at 7fcfb5413e8b ip 00007fcfba60c206 sp 00007ffff597e588 error 4 in libc-2.17.so[7fcfba58c000+1a3000]

I've tried manually running vlc-cache-gen as well, but I get the same output as above.  Downgrading vlc also resulted in the same error.  I am using the nvidia closed source driver if that makes a difference.  Any one have any ideas on whats going on here?

Last edited by piratebill (2013-05-15 18:52:50)

Offline

#2 2013-05-07 14:56:48

piratebill
Member
From: Sol System
Registered: 2011-10-20
Posts: 78

Re: [Solved] Vlc seg faults after latest upgrade

running vlc -v gets me

$ vlc -v
VLC media player 2.0.6 Twoflower (revision 2.0.6-0-gbe9623c)
[0xd5e138] main libvlc warning: cannot read /usr/lib/vlc/plugins/plugins.dat (No such file or directory)
[0xd5e138] main libvlc warning: cannot load module `/usr/lib/vlc/plugins/codec/libtwolame_plugin.so' (libtwolame.so.0: cannot open shared object file: No such file or directory)
[0xd5e138] main libvlc warning: cannot load module `/usr/lib/vlc/plugins/notify/libxosd_plugin.so' (libxosd.so.2: cannot open shared object file: No such file or directory)
Segmentation fault (core dumped)

I have 2 arch systems, one upgraded fine.  I've also tried downgrading glib2 in hopes it would fix the issue (as suggested here: https://bbs.archlinux.org/viewtopic.php?id=162388).  it did not help.

Last edited by piratebill (2013-05-07 14:57:08)

Offline

#3 2013-05-07 15:00:36

flipper T
Member
Registered: 2012-09-14
Posts: 419

Re: [Solved] Vlc seg faults after latest upgrade

Hi, try reinstalling it.  (edit.."it" being vlc)

This solved the issue for me.

Last edited by flipper T (2013-05-07 15:02:18)


If I'm curt with you it's because time is a factor. I think fast, I talk fast and I need you guys to act fast if you wanna get out of this. So, pretty please... with sugar on top. Clean the [censored] car. -The Wolf

Offline

#4 2013-05-07 17:58:34

piratebill
Member
From: Sol System
Registered: 2011-10-20
Posts: 78

Re: [Solved] Vlc seg faults after latest upgrade

flipper T wrote:

Hi, try reinstalling it.  (edit.."it" being vlc)

This solved the issue for me.


I've tried that a few times yesterday.  I'll try it again when I get home in case something new got pushed.

Last edited by piratebill (2013-05-07 18:39:53)

Offline

#5 2013-05-07 20:05:51

piratebill
Member
From: Sol System
Registered: 2011-10-20
Posts: 78

Re: [Solved] Vlc seg faults after latest upgrade

flipper T wrote:

Hi, try reinstalling it.  (edit.."it" being vlc)

This solved the issue for me.


Nope, nothing changed

Offline

#6 2013-05-07 20:35:37

pilotkeller
Member
From: Canada
Registered: 2011-12-22
Posts: 513
Website

Re: [Solved] Vlc seg faults after latest upgrade

I hate to be 'that guy' but trying out mplayer2 is another option.
I moved away form VLC over a year ago and haven't looked back.

It's your call but I have VLC on Windows and the new versions seem to brick itself.
Could be that it's old configs are breaking the new version.

Offline

#7 2013-05-07 20:45:04

LeCrayonVert
Member
Registered: 2010-09-01
Posts: 133

Re: [Solved] Vlc seg faults after latest upgrade

flipper T wrote:

Hi, try reinstalling it.  (edit.."it" being vlc)

This solved the issue for me.

Me too...


I believe in a world I can and do understand. A rational universe, explained through rational means.

Offline

#8 2013-05-07 21:02:25

piratebill
Member
From: Sol System
Registered: 2011-10-20
Posts: 78

Re: [Solved] Vlc seg faults after latest upgrade

pilotkeller wrote:

I hate to be 'that guy' but trying out mplayer2 is another option.
I moved away form VLC over a year ago and haven't looked back.

It's your call but I have VLC on Windows and the new versions seem to brick itself.
Could be that it's old configs are breaking the new version.

I'm not married to VLC, so noted.


On the trying to repair it front, I found a german guy with the same issue:

https://bbs.archlinux.de/viewtopic.php?pid=304355

While google translate does try, I cant really tell what he did to fix it.  Thoughts?

Offline

#9 2013-05-07 21:03:00

piratebill
Member
From: Sol System
Registered: 2011-10-20
Posts: 78

Re: [Solved] Vlc seg faults after latest upgrade

LeCrayonVert wrote:
flipper T wrote:

Hi, try reinstalling it.  (edit.."it" being vlc)

This solved the issue for me.

Me too...


Its also possible my mirror is out of date.  I'll try to switch mirrors when I get home

Offline

#10 2013-05-08 22:15:43

stfn
Member
Registered: 2010-02-28
Posts: 32

Re: [Solved] Vlc seg faults after latest upgrade

piratebill wrote:
pilotkeller wrote:

I hate to be 'that guy' but trying out mplayer2 is another option.
I moved away form VLC over a year ago and haven't looked back.

It's your call but I have VLC on Windows and the new versions seem to brick itself.
Could be that it's old configs are breaking the new version.

I'm not married to VLC, so noted.


On the trying to repair it front, I found a german guy with the same issue:

https://bbs.archlinux.de/viewtopic.php?pid=304355

While google translate does try, I cant really tell what he did to fix it.  Thoughts?

What he did was restore a system backup from a few days ago, then first a `pacman -Sy` to update the package list and after that a single `pacman -S vlc` so that only vlc gets updated, and then finally the system upgrade `pacman -Su`. Seems like that worked for him.

Unfortunately I'm having the same problem and don't have the option to restore a recent system backup.

Offline

#11 2013-05-09 12:10:25

theodore
Member
From: Aalborg / Denmark
Registered: 2008-09-09
Posts: 68

Re: [Solved] Vlc seg faults after latest upgrade

same problem here, reinstalling didn't solve the problem...

Offline

#12 2013-05-09 12:28:30

BasT
Member
Registered: 2010-08-28
Posts: 78

Re: [Solved] Vlc seg faults after latest upgrade

Offline

#13 2013-05-09 19:30:46

stfn
Member
Registered: 2010-02-28
Posts: 32

Re: [Solved] Vlc seg faults after latest upgrade

Yeah fluidsynth seems to be causing the problem. After a `pacman -R fluidsynth` VLC is working again for me.

Last edited by stfn (2013-05-09 19:31:16)

Offline

#14 2013-05-12 06:53:12

szym
Member
Registered: 2007-11-16
Posts: 14

Re: [Solved] Vlc seg faults after latest upgrade

Same issue with vlc-2.0.6-2
Removing fluidsynth-1.1.6-1 fixed the issue.

Offline

#15 2013-05-12 16:29:16

akurei
Member
From: Bochum, NRW, Germany
Registered: 2009-05-25
Posts: 152
Website

Re: [Solved] Vlc seg faults after latest upgrade

Same Problem. Removing libfluidsynth fixed the issue.

Offline

#16 2013-05-15 18:52:33

piratebill
Member
From: Sol System
Registered: 2011-10-20
Posts: 78

Re: [Solved] Vlc seg faults after latest upgrade

Brilliant! Thank you for finding this. marking as solved.

Offline

Board footer

Powered by FluxBB