You are not logged in.

#1 2013-05-09 08:37:03

gauthma
Member
Registered: 2010-02-16
Posts: 186
Website

[Solved] KDE without reboot / shutdown buttons

I've just installed Arch with KDE, but I don't use KDM: I log in to the shell, and then startx my way into KDE. I have systemd-sysvcompat installed, and my non root user is in the power group (and is able, in the command line, without root privileges, to reboot/shutdown the machine). Nevertheless, KDE refuses to show me those buttons.

What might I be missing? My .xinitrc is below:

#!/bin/sh
#
# ~/.xinitrc
#
# Executed by startx (run your window manager from here)

if [ -d /etc/X11/xinit/xinitrc.d ]; then
  for f in /etc/X11/xinit/xinitrc.d/*; do
    [ -x "$f" ] && . "$f"
  done
  unset f
fi

# exec gnome-session
exec startkde
# exec startxfce4
# ...or the Window Manager of your choice

Last edited by gauthma (2013-05-14 17:25:02)

Offline

#2 2013-05-09 09:41:23

henk
Member
From: Weert, Netherlands
Registered: 2013-01-01
Posts: 330

Re: [Solved] KDE without reboot / shutdown buttons

Hello,

did you try the this from:
http://ubuntuforums.org/showthread.php?t=1860008 or
http://forum.kde.org/viewtopic.php?f=66&t=89710

Go to System Settings → Startup and Shutdown → Session Management and check the “Offer shutdown options” checkbox.

Offline

#3 2013-05-09 09:56:05

gauthma
Member
Registered: 2010-02-16
Posts: 186
Website

Re: [Solved] KDE without reboot / shutdown buttons

The checkbox "Offer shutdown options" was always selected, as well as the shutdown in the Loggin Manager, which is set to everybody -- problem still happens. However, on the ubuntuforums link, one reads: "It appears to be related to KDM. Unless you are using KDM (not GDM) for your login screen, then KDE does not support a shut-down option. ". As I mentioned above, I am not using KDM, instead starting X manually. I'll set up KDM, and see if that solves the problem...

Offline

#4 2013-05-09 18:07:30

miniclip22
Member
From: London, England, UK
Registered: 2013-05-08
Posts: 18

Re: [Solved] KDE without reboot / shutdown buttons

gauthma wrote:

The checkbox "Offer shutdown options" was always selected, as well as the shutdown in the Loggin Manager, which is set to everybody -- problem still happens. However, on the ubuntuforums link, one reads: "It appears to be related to KDM. Unless you are using KDM (not GDM) for your login screen, then KDE does not support a shut-down option. ". As I mentioned above, I am not using KDM, instead starting X manually. I'll set up KDM, and see if that solves the problem...

I have the same exact problem... On KDM I can't boot into cinnamon... On LXDM I can't shut down and reboot on KDE... Someone please help us, thanks!


Ac/dc Rocks!!!!!!

Offline

#5 2013-05-09 19:10:54

chord
Member
Registered: 2012-11-07
Posts: 121

Re: [Solved] KDE without reboot / shutdown buttons

gauthma wrote:

I log in to the shell, and then startx my way into KDE. I have systemd-sysvcompat installed, and my non root user is in the power group (and is able, in the command line, without root privileges, to reboot/shutdown the machine). Nevertheless, KDE refuses to show me those buttons.

KDE started from CLI by startx command has no Reboot and Shutdown buttons. Logout only. It is default behavior.
Enable KDM to manage your desktop if you want these buttons appeared.

Last edited by chord (2013-05-09 19:13:03)

Offline

#6 2013-05-10 11:20:41

ubunchu
Member
Registered: 2012-05-01
Posts: 175

Re: [Solved] KDE without reboot / shutdown buttons

I vaguely remember something about launching sessions with dbus and/or ck-launck-session.
I think that consolekit or something managing permissions to shutdown and similar, need to be enabled before you start a session (such as kde).
Though I repeat, I'm uncertain of this.
You could also figure out what command KDM launches when starting KDE and use that instead.

Good luck.


Don't forget to mark as [SOLVED].

Offline

#7 2013-05-10 11:45:50

gurnaik
Member
From: Smethwick
Registered: 2011-09-07
Posts: 11

Re: [Solved] KDE without reboot / shutdown buttons

ubunchu wrote:

I vaguely remember something about launching sessions with dbus and/or ck-launck-session.
I think that consolekit or something managing permissions to shutdown and similar, need to be enabled before you start a session (such as kde).
Though I repeat, I'm uncertain of this.
You could also figure out what command KDM launches when starting KDE and use that instead.

Good luck.

With the advent of systemd, consolekit has been removed. The only way I found was to enable KDM.

Offline

#8 2013-05-11 09:51:10

Solvialle
Member
Registered: 2012-04-07
Posts: 19

Re: [Solved] KDE without reboot / shutdown buttons

This is a known bug and a patch is available. https://bugs.archlinux.org/task/32371

Offline

#9 2013-05-14 17:24:36

gauthma
Member
Registered: 2010-02-16
Posts: 186
Website

Re: [Solved] KDE without reboot / shutdown buttons

Thank you all for the feedback. ubunchu I was aware of the consolekit issue, but given the fact that the fact that there no longer is a consolekit, it didn't help me much... Anyway, my question is answered, even if not in the way I expected.

Offline

Board footer

Powered by FluxBB