You are not logged in.

#1 2013-06-09 18:22:01

ffcitatos
Member
Registered: 2012-10-28
Posts: 16

I don't want programs restored after a reboot

Hello,

After updating to systemd, doing a restart reloads all the stuff that was open beforehand. How to get rid of that behavior? Please point me in the right direction, as I cannot find any relevant info (am I using wrong keywords?). I am using xfce.

Thanks a ton!

Offline

#2 2013-06-09 18:35:36

the_shiver
Member
From: Fortress Europe
Registered: 2013-03-27
Posts: 127

Re: I don't want programs restored after a reboot

Offline

#3 2013-06-09 18:35:41

msthev
Member
Registered: 2012-04-05
Posts: 177

Re: I don't want programs restored after a reboot

You'll need to be more specific, otherwise no one can really help you. What "stuff"? What keywords are you using? How are you starting XFCE? If you mention something, provide as much detail as possible.


Edit:
OK, I see someone who knows XFCE responded, please ignore my post if the previous one solves your issue. (Although still, it's always good to provide details.)

Last edited by msthev (2013-06-09 18:37:24)

Offline

#4 2013-06-09 18:35:45

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 12,392

Re: I don't want programs restored after a reboot

From your settings manager, select the 'Session and Starup'.  On the 'General' tab, uncheck 'Automatically save session on logout'.  Then, on the 'Application Autostart' tab, ensure only those things you want to start are checked.


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Like you, I have no idea what you are doing, but I am pretty sure it is wrong...Jasonwryan
----
How to Ask Questions the Smart Way

Offline

#5 2013-06-09 18:54:50

ffcitatos
Member
Registered: 2012-10-28
Posts: 16

Re: I don't want programs restored after a reboot

First of all, thanks for all the suggestions!

However, my 'Automatically save session on logout' is unchecked. In the 'application autostart', there is only screensaver and xfsettingsd.

By 'stuff', I mean programs like xterm and firefox.

Which files should I include to get a better answer? I am sorry for being clueless, but I don't know what is relevant for this.

Last edited by ffcitatos (2013-06-09 18:55:11)

Offline

#6 2013-06-09 19:02:00

Lennox
Member
Registered: 2012-07-16
Posts: 11

Re: I don't want programs restored after a reboot

Interesting. I have the same "issue". My applications are saved as well but my "Automatically save ..." box is unchecked. I never noticed that before because I like it that way.
Try "Session and Startup" -> "Session" -> "Clear saved sessions". Perhaps that'll work


Nothing in this world that's worth having comes easy

Offline

#7 2013-06-09 19:07:50

ffcitatos
Member
Registered: 2012-10-28
Posts: 16

Re: I don't want programs restored after a reboot

Lennox wrote:

Interesting. I have the same "issue". My applications are saved as well but my "Automatically save ..." box is unchecked. I never noticed that before because I like it that way.
Try "Session and Startup" -> "Session" -> "Clear saved sessions". Perhaps that'll work

Unfortunately, this does not work.

Offline

#8 2013-06-09 19:34:46

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 12,392

Re: I don't want programs restored after a reboot

Also, purge all of the files in ~/.config/xfce4-session/.

Edit:  And how do you start xfce4?

Last edited by ewaller (2013-06-09 19:35:35)


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Like you, I have no idea what you are doing, but I am pretty sure it is wrong...Jasonwryan
----
How to Ask Questions the Smart Way

Offline

#9 2013-06-09 19:35:47

youngian
Member
Registered: 2012-08-06
Posts: 22

Re: I don't want programs restored after a reboot

I have exactly the same problem! It first manifested about a couple weeks ago and has been happening since. I made no real changes to my system before it happened, other than perhaps routine package updates. It acts like I have enabled the "save session" option, but I have not. Terminal windows, Thunar, Firefox, gpodder - all sorts of things will reopen on boot.

Offline

#10 2013-06-09 19:41:41

youngian
Member
Registered: 2012-08-06
Posts: 22

Re: I don't want programs restored after a reboot

ewaller wrote:

Also, purge all of the files in ~/.config/xfce4-session/.

Edit:  And how do you start xfce4?

I start xfce4 with this in my ~/.xinitrc:

exec startxfce4

Purging the config files seems to have worked for this reboot. I'll see if the problem reoccurs on future reboots.

Offline

#11 2013-06-09 19:48:10

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 12,392

Re: I don't want programs restored after a reboot

youngian wrote:

start xfce4 with this in my ~/.xinitrc:

exec startxfce4

That is what I was fishing for.  I assume, then, you are not starting any of the offending applications in there.

Purging the config files seems to have worked for this reboot. I'll see if the problem reoccurs on future reboots.

Cool; standing by...


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Like you, I have no idea what you are doing, but I am pretty sure it is wrong...Jasonwryan
----
How to Ask Questions the Smart Way

Offline

#12 2013-06-09 20:32:39

ffcitatos
Member
Registered: 2012-10-28
Posts: 16

Re: I don't want programs restored after a reboot

ewaller wrote:
youngian wrote:

start xfce4 with this in my ~/.xinitrc:

exec startxfce4

That is what I was fishing for.  I assume, then, you are not starting any of the offending applications in there.

Purging the config files seems to have worked for this reboot. I'll see if the problem reoccurs on future reboots.

Cool; standing by...

Still does not work for me. I even did a link

xfce4-session -> /dev/null

in .config - nothing! The way xfce is started is exactly the same in my case. Could it be important that I use the LXDM as my display manager?

Offline

#13 2013-06-13 04:01:47

youngian
Member
Registered: 2012-08-06
Posts: 22

Re: I don't want programs restored after a reboot

Unfortunately, the problem reoccurs on reboots if I don't purge the config files again each time.

Offline

#14 2013-07-02 16:44:50

youngian
Member
Registered: 2012-08-06
Posts: 22

Re: I don't want programs restored after a reboot

Anyone have more thougts on this? It's still happening with me. I can't determine exactly the pattern for things being restored - it's not everything, and it's not the exact last shutdown state - it's like some state gets saved prior to that and hangs around through multiple boots. For a while Liferea (RSS reader) was starting up on every boot, even though I closed it each time. Now, even stranger, I get two instances each of gPodder and Pidgin starting up on boot, as if they have somehow been saved to the session twice (as you might guess, I have never started up two instances at the same time by my own volition).

Offline

#15 2013-07-02 16:51:37

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 13,491
Website

Re: I don't want programs restored after a reboot

I've never really used xfce, but if all else is failing, I'd go for a brute-force approach: find some program that is a common problem (likely to be restarted on the next restart) and grep -r through some folders for that program name.  For example, if firefox is common:

grep -r firefox ~/.cache ~/.config ~/.local

EDIT: also, unless I missed it, there's a lot of talk of looking in ~/.config, but xfce's session cache is stored (appropriately so) in ~/.cache

Last edited by Trilby (2013-07-02 16:52:50)


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#16 2013-07-02 17:02:19

henk
Member
From: Weert, Netherlands
Registered: 2013-01-01
Posts: 330

Re: I don't want programs restored after a reboot

You could also check ~/.config/autostart and /etc/xdg/autostart and see what's in there.

Offline

#17 2013-07-02 18:45:33

Radioactiveman
Member
From: Germany
Registered: 2010-05-13
Posts: 376

Re: I don't want programs restored after a reboot

https://bbs.archlinux.org/viewtopic.php?id=164354

Workaround is in the last post, works fine for me now.

Offline

#18 2013-07-02 19:12:56

jrussell
Member
From: Cape Town, South Africa
Registered: 2012-08-16
Posts: 510

Re: I don't want programs restored after a reboot

Radioactiveman wrote:

https://bbs.archlinux.org/viewtopic.php?id=164354

Workaround is in the last post, works fine for me now.

You can get the link to a post from the date above the specific post
https://bbs.archlinux.org/viewtopic.php … 5#p1285385

Also, people with this problem, try and make a new clean user and see if the problem persists (this seems to be my advice for so many threads now)


bitcoin: 1G62YGRFkMDwhGr5T5YGovfsxLx44eZo7U

Offline

#19 2013-07-05 07:51:18

youngian
Member
Registered: 2012-08-06
Posts: 22

Re: I don't want programs restored after a reboot

Trilby wrote:

EDIT: also, unless I missed it, there's a lot of talk of looking in ~/.config, but xfce's session cache is stored (appropriately so) in ~/.cache

I tried trashing everything in ~/.cache/sessions, still no luck.

GVim has now also decided to show up on boot, which is new as of today.

Checked ~/.config/autostart and /etc/xdg/autostart, and it looks like what's in there is what I would expect to be in there - programs I've actually requested to have autostart.

Offline

#20 2013-07-05 07:57:31

jrussell
Member
From: Cape Town, South Africa
Registered: 2012-08-16
Posts: 510

Re: I don't want programs restored after a reboot

See if it happens with a different user


bitcoin: 1G62YGRFkMDwhGr5T5YGovfsxLx44eZo7U

Offline

#21 2013-07-06 03:42:33

youngian
Member
Registered: 2012-08-06
Posts: 22

Re: I don't want programs restored after a reboot

jrussell wrote:

See if it happens with a different user

It does indeed. I just created a completely fresh user. The only thing I copied over was my .xinitrc:

#!/bin/sh

# Source scripts in /etc/X11/xinit/xinitrc.d/
if [ -d /etc/X11/xinit/xinitrc.d ]; then
    for f in /etc/X11/xinit/xinitrc.d/*; do
        [ -x "$f" ] && . "$f"
    done
    unset f
fi

setxkbmap -option compose:rwin

exec startxfce4

Opened Thunar, Terminal, and Firefox as the new user, and all three of them showed up again after a reboot.

Last edited by youngian (2013-07-06 03:43:18)

Offline

#22 2013-07-06 11:09:29

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 13,491
Website

Re: I don't want programs restored after a reboot

With that new user you have freedom to experiment.

First just to triple check what should definitely be true:

rm -rf /home/newuser/*
rm -rf /home/newuser/.*
cp /home/normaluser/.xinitrc /home/newuser/.xinitrc

Then restart x, thunar terminal and firefox should definitely not be there anymore.  Reopen them(1), restart X, they probably will be.  Then

find /home/newuser/

and you have your suspect list.

You could probably make this even a little more precise with inotify, but the results of that find command should be quite a short list anyhow, and the problematic file will definitely be in the list.

1) I'd suggest just reopening terminal and not the others.  Both thunar and firefox can each create a boatload of config and cache files on their first run in a fresh user.  Terminal will create some, but far fewer.

Last edited by Trilby (2013-07-06 11:12:10)


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#23 2013-07-06 12:38:26

Radioactiveman
Member
From: Germany
Registered: 2010-05-13
Posts: 376

Re: I don't want programs restored after a reboot

youngian wrote:
Trilby wrote:

EDIT: also, unless I missed it, there's a lot of talk of looking in ~/.config, but xfce's session cache is stored (appropriately so) in ~/.cache

I tried trashing everything in ~/.cache/sessions, still no luck.

You have to make this directory readonly (chmod 444), otherwise it gets filled with session files again and again.
Nevertheless if you remove them or not.

https://bbs.archlinux.org/viewtopic.php … 7#p1295407

Offline

#24 2013-07-11 06:13:59

youngian
Member
Registered: 2012-08-06
Posts: 22

Re: I don't want programs restored after a reboot

Trilby wrote:

With that new user you have freedom to experiment.

First just to triple check what should definitely be true:

rm -rf /home/newuser/*
rm -rf /home/newuser/.*
cp /home/normaluser/.xinitrc /home/newuser/.xinitrc

Then restart x, thunar terminal and firefox should definitely not be there anymore.  Reopen them(1), restart X, they probably will be.  Then

find /home/newuser/

and you have your suspect list.

You could probably make this even a little more precise with inotify, but the results of that find command should be quite a short list anyhow, and the problematic file will definitely be in the list.

1) I'd suggest just reopening terminal and not the others.  Both thunar and firefox can each create a boatload of config and cache files on their first run in a fresh user.  Terminal will create some, but far fewer.

Thanks for all your helpful suggestions. As it turns out, I was wrong. When testing with the new user, I accidentally left the checkbox checked when logging out and so my session was saved intentionally. So I cannot reproduce the problem with a new user.

I'm happy to try some more stuff - maybe I could copy over some files from my existing user to the new one? I'm just not sure where to start looking.

Radioactiveman wrote:

You have to make this directory readonly (chmod 444), otherwise it gets filled with session files again and again.
Nevertheless if you remove them or not.

https://bbs.archlinux.org/viewtopic.php … 7#p1295407

Thanks for the tip, but I'd rather figure out what's causing this than treat a symptom. Making that directory read-only strikes me as a very hacky workaround.

Last edited by youngian (2013-07-11 06:15:30)

Offline

Board footer

Powered by FluxBB