You are not logged in.

#1 2013-08-02 07:14:38

MutantJohn
Member
Registered: 2012-12-17
Posts: 95

[SOLVED]gcc-libs-multilib conflict with most current pacman -Syu

Hello All,

I installed the gcc-libs-multilib so I could use the netflix-desktop package from the AUR. But now, when I try to do my normal updates, it wants to replace it with gcc-libs with defeats the purpose of me getting the multilib version in the first place.

Any way to solve this besides just doing constant replacing?

Last edited by MutantJohn (2013-08-04 08:26:16)

Offline

#2 2013-08-02 12:59:13

msthev
Member
Registered: 2012-04-05
Posts: 177

Re: [SOLVED]gcc-libs-multilib conflict with most current pacman -Syu

It's now in multilib-testing and should be pushed do multilib soon. You can just wait with the update — it's a minor one, so it *shouldn't* break anything.

Offline

#3 2013-08-02 13:09:54

Allan
Developer
From: Brisbane, AU
Registered: 2007-06-09
Posts: 10,396
Website

Re: [SOLVED]gcc-libs-multilib conflict with most current pacman -Syu

You should install the multilib version of all other gcc packages you have installed and you will never see this again.

Offline

#4 2013-08-02 13:12:20

karol
Archivist
Registered: 2009-05-06
Posts: 25,427

Re: [SOLVED]gcc-libs-multilib conflict with most current pacman -Syu

Do you have gcc-multilib installed?

Offline

#5 2013-08-02 18:24:45

MutantJohn
Member
Registered: 2012-12-17
Posts: 95

Re: [SOLVED]gcc-libs-multilib conflict with most current pacman -Syu

karol wrote:

Do you have gcc-multilib installed?

Lol yeah, I do.

But one of the above posters mentioned that whatever update will be out of the multilib testing soon. If not that I don't know what to do because every time pacman asks me to swap and I say no, it doesn't even let me see which package is requiring the gcc-libs over the multilibs.

Offline

#6 2013-08-03 09:31:33

derhamster
Member
Registered: 2012-07-08
Posts: 86

Re: [SOLVED]gcc-libs-multilib conflict with most current pacman -Syu

Make sure that every installed gcc package is the multilib version. I had gcc-fortran installed instead of gcc-fortran-multilib and ran into the same problem.

Offline

#7 2013-08-04 06:16:54

MutantJohn
Member
Registered: 2012-12-17
Posts: 95

Re: [SOLVED]gcc-libs-multilib conflict with most current pacman -Syu

Lol how do I check if every gcc package is the multilib version? How do I even check which packages I have that are gcc affiliate?

Offline

#8 2013-08-04 06:35:19

karol
Archivist
Registered: 2009-05-06
Posts: 25,427

Re: [SOLVED]gcc-libs-multilib conflict with most current pacman -Syu

Start with 'pacman -Qqs gcc | grep gcc'.

Offline

#9 2013-08-04 08:25:48

MutantJohn
Member
Registered: 2012-12-17
Posts: 95

Re: [SOLVED]gcc-libs-multilib conflict with most current pacman -Syu

Thank you all so much. Upgrading the gcc-fortran to gcc-fortran-multilib solved my upgrade issue. Thanks!

Offline

Board footer

Powered by FluxBB