You are not logged in.

#1 2014-01-25 13:47:26

Marvix
Member
Registered: 2013-10-08
Posts: 51

[Solved] Syslinux boots but not loads completely

Since my last update, 2 weeks ago, syslinux in my root partition doesn't completely loads. I've tried to mount the root partition and reinstall and edit again the syslinux but it didn't work. I don't know what to else to do to repair it.

Last edited by Marvix (2014-02-02 09:34:11)

Offline

#2 2014-01-25 13:54:48

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 13,683
Website

Re: [Solved] Syslinux boots but not loads completely

Please provide much more detail.

How far does it get in booting?  Do you see the syslinux menu, or does it not get that far?  Are there any error messages or output?  If so, post them.

What do you mean you've mounted the root partition and editted "the syslinux"?  I assume you booted a live medium to do maintainance, but what did you reinstall (`pacman -S syslinux`, or `syslinux-install_update -i -a -m`?)  Did you also mount your boot partition when you were doing this maintainance?

Also, if you can check your logs to see what you updated two weeks ago, that may help.  But if you only update every few weeks, it will likely be just about everything updated.

Last edited by Trilby (2014-01-25 13:55:39)


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#3 2014-01-25 13:54:59

nomorewindows
Member
Registered: 2010-04-03
Posts: 2,973

Re: [Solved] Syslinux boots but not loads completely

Tried syslinux-install_update -iam?

Last edited by nomorewindows (2014-01-25 14:19:39)


I may have to CONSOLE you about your usage of ridiculously easy graphical interfaces...
Look ma, no mouse.

Offline

#4 2014-01-25 14:11:30

Marvix
Member
Registered: 2013-10-08
Posts: 51

Re: [Solved] Syslinux boots but not loads completely

@Triby

It shows the syslinux menu and I have it the

Yes I tried with the live medium to reinstall it, with pacman and syslinux-install_update -i -a -m. Also I've looked to /boot/syslinux/syslinux.cfg. My boot partition is the root partition and yes I mounted for the maintenance.

My laptop uses UEFI but I choose to use the legacy mode. I checked again for my bios not to use UEFI.

I have and a third parttion for my Windows 7 and I have it in syslinux's menu to choose it, which it loads fine, but not Arch.

How do I check the log

Offline

#5 2014-01-25 14:21:40

nomorewindows
Member
Registered: 2010-04-03
Posts: 2,973

Re: [Solved] Syslinux boots but not loads completely

Seems like syslinux is fussier if boot is root.


I may have to CONSOLE you about your usage of ridiculously easy graphical interfaces...
Look ma, no mouse.

Offline

#6 2014-01-25 16:10:57

Marvix
Member
Registered: 2013-10-08
Posts: 51

Re: [Solved] Syslinux boots but not loads completely

Well I had to reinstall Arch, since I messing up with GParted I lost the home partition.

Offline

#7 2014-01-26 00:25:16

nomorewindows
Member
Registered: 2010-04-03
Posts: 2,973

Re: [Solved] Syslinux boots but not loads completely

Marvix wrote:

Well I had to reinstall Arch, since I messing up with GParted I lost the home partition.

Messing with the /home partition doesn't destroy your Arch installation by itself, unless you moved everything else on the disk and it did destroy your Arch installation.


I may have to CONSOLE you about your usage of ridiculously easy graphical interfaces...
Look ma, no mouse.

Offline

Board footer

Powered by FluxBB