You are not logged in.

#1 2014-07-12 17:34:33

Agkel0s
Member
From: Portugal
Registered: 2011-12-26
Posts: 13

[SOLVED] XFCE - Incorrect windows placement

Hi,

I'm currently having a issue with XFCE's window placement. In the settings panel, under Window Manager Tweaks > Placement, window placement is set to Center for all windows, but this option has no effect. I tried changing it to place windows under the mouse, but it also has no effect on the windows placement. Windows keep opening on the screen corners.

I checked the forums for similar problems, and found some results, but none of the solutions worked for me. Also, those are quite old topics.

This is not a big problem, but I'm kind of picky, so if anyone knows a solution to this problem, please share it.

Best Regards,
Agkel0s

Last edited by Agkel0s (2014-07-14 21:37:54)

Offline

#2 2014-07-13 00:39:25

0strodamus
Member
Registered: 2014-01-22
Posts: 66

Re: [SOLVED] XFCE - Incorrect windows placement

Try adjusting the "Minimum size of windows to trigger smart placement:" slider.


archlinux - Xfce - TOMOYO Linux - OpenRC
ACLU - EFF - FFRF - Riseup - Tor - Black/Thrash Metal

Offline

#3 2014-07-14 17:36:57

Agkel0s
Member
From: Portugal
Registered: 2011-12-26
Posts: 13

Re: [SOLVED] XFCE - Incorrect windows placement

Ostradamus, thanks for the answer, but unfortunately I've already tried that and it did not work.
Currently the slider is on the minimum value, and windows of all sizes should open centered on screen.

Best regards,
Agkel0s

Offline

#4 2014-07-14 18:06:14

jjacky
Member
Registered: 2011-11-09
Posts: 321
Website

Re: [SOLVED] XFCE - Incorrect windows placement

Agkel0s wrote:

Currently the slider is on the minimum value, and windows of all sizes should open centered on screen.

Shouldn't you actually have it on the maximum value?

I believe the way this works is that the size (or ratio, the option is actually called placement_ratio IIRC and is a ratio of window size vs screen size) you specify here is the minimum to trigger "smart placement." If the window isn't (at least) of that size, then the default (i.e. center or under mouse pointer, as defined below) will be used. So if you want every window to use the default placement, you should set the minimum size for smart placement to be as large as possible. (In fact, I believe with a ratio set to 100 (i.e. slider to the max) it should always use the default placement, regardless of window size, which is want you're after if I'm not wrong.)

If even with the slider to the max you get new windows placed using smart placement, then it sounds like a bug I'd say.

(Also, just as FYI and though you might simply want all windows to be centered, I wasn't happy with xfwm's smart placement myself, you can see this topic for a (IMO) better alternative.)

Offline

#5 2014-07-14 21:35:50

Agkel0s
Member
From: Portugal
Registered: 2011-12-26
Posts: 13

Re: [SOLVED] XFCE - Incorrect windows placement

Thanks jjacky and 0strodamus, you we're both right...

To center all the windows the slider must be set on the maximum value. It was indeed a lapse of mine. However, there seems to be overlapping settings, since on the windows manager settings there are also options to "Align windows to corners" and "with other windows", and maybe when I previously tested the center placement, those option were checked.

jjacku, I'll also check your suggestion for a better window placement...

Problem solved :-)

Best regards,
Agkel0s

Offline

Board footer

Powered by FluxBB