You are not logged in.

#1 2016-01-18 08:09:43

makh
Member
Registered: 2011-10-10
Posts: 37

TLP Settings for Governor Control

Hello

I previously installed some package to force the TLP to fix the i3 core to lowest frequency 0.8GHz. Now at times I want the processor to run at full ie 1.9GHz, but it remains down.

setting /etc/default/tlp:
CPU_SCALING_GOVERNOR_ON_BAT=ondemand

doesnt help.

Kindly inform how to use the ondemand feature again.

Thanks in advance.


OS:  Arch  &  Debian
System: HP Probook 440 G2
WM: Openbox

Offline

#2 2016-01-18 20:35:03

snakeroot
Member
Registered: 2012-10-06
Posts: 104

Re: TLP Settings for Governor Control

I believe that the HP Probook uses the 4th gen "Haswell" processor. That results in use of the intel_pstate driver. The only available settings for that driver are powerstate and performance and the speed at which the processor runs is determined by internal logic in the processor rather than by the driver.

You can disable the pstate driver from the kernel command line, but then you lose the benefit of the more advanced power management.

Please see the Wiki article and the kernel documentation

Offline

#3 2016-01-25 06:48:07

makh
Member
Registered: 2011-10-10
Posts: 37

Re: TLP Settings for Governor Control

Infact I dont have cpupower installed. I installed some other package and did some setting, which I am unable to resolve to get back the on-demand option working.

Thankyou


OS:  Arch  &  Debian
System: HP Probook 440 G2
WM: Openbox

Offline

Board footer

Powered by FluxBB