You are not logged in.

#1 2016-08-30 14:30:39

From: Iran
Registered: 2015-08-20
Posts: 2

Atheros R9285 wireless card unstable and weak reception

So I finally installed the arch,
Everythings going well except for the wifi, which disconnects every minutes now and then. It disconnects whenever I try to a download a package it will give a timeout because of low speed.

I have read some topics on forums and it turned up my wifi card is under 'ath9k' drivers. I saw this post which leads to a bug fix, but that kernel version is way before my kernel version which is 4.4.19-1. I have also tried to install backports-patched from AUR but I came up with errors.

Another thing good to notice is that when I run 'netrunner rolling' (arch distro I've installed) live iso wifi works great!

Here are some output:

iwlist scan:

enp38s0   Interface doesn't support scanning.

wlo1      Scan completed :
          Cell 01 - Address: EC:22:80:C4:C4:65
                    Frequency:2.442 GHz (Channel 7)
                    Quality=21/70  Signal level=-89 dBm  
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 9 Mb/s
                              18 Mb/s; 36 Mb/s; 54 Mb/s
                    Bit Rates:6 Mb/s; 12 Mb/s; 24 Mb/s; 48 Mb/s
                    Extra: Last beacon: 25963ms ago
                    IE: Unknown: 00094D454E54414C495354
                    IE: Unknown: 010882848B961224486C
                    IE: Unknown: 030107
                    IE: Unknown: 2A0104
                    IE: Unknown: 32040C183060
                    IE: Unknown: 2D1A6E1116FF000000010000000000000000000000000C0000000000
                    IE: Unknown: 3D1607000600000000000000000000000000000000000000
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK
                    IE: Unknown: DD180050F2020101000003A4000027A4000042435E0062322F00
                    IE: Unknown: 4A0E14000A002C01C800140005001900
                    IE: Unknown: 7F0400000001
                    IE: Unknown: DD07000C4304000000
                    IE: Unknown: 0706545700010B10
                    IE: Unknown: DD970050F204104A0001101044000102103B00010310470010BC329E001DD811B28601EC2280C4C46510210013442D4C696E6B20436F72706F726174696F6E2E1023001C442D4C696E6B20576972656C6573732041636365737320506F696E74102400065254323836301042000831323334353637381054000800060050F204000110110008442D4C696E6B4150100800020084103C000101
          Cell 02 - Address: 48:EE:0C:C7:65:50
                    Frequency:2.417 GHz (Channel 2)
                    Quality=29/70  Signal level=-81 dBm  
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s
                    Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
                    Extra: Last beacon: 25740ms ago
                    IE: Unknown: 000F53484154454C2D54656C2D31353235
                    IE: Unknown: 010882848B960C121824
                    IE: Unknown: 030102
                    IE: Unknown: 2A0100
                    IE: Unknown: 32043048606C
                    IE: Unknown: 2D1A2C181FFFFF000000000000000000000000000000000000000000
                    IE: Unknown: 3D1602000000000000000000000000000000000000000000
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK
                    IE: Unknown: DD180050F2020101800003A4000027A4000042435E0062322F00
                    IE: Unknown: DD1E00904C332C181FFFFF000000000000000000000000000000000000000000
                    IE: Unknown: DD1A00904C3402000000000000000000000000000000000000000000
                    IE: Unknown: DD0600E04C020160
                    IE: Unknown: DDA50050F204104A0001101044000102103B000103104700106304125310192006122848EE0CC765501021001B5265616C74656B2053656D69636F6E647563746F7220436F72702E1023000752544C383637311024000D45562D323030362D30372D32371042000F3132333435363738393031323334371054000800060050F2040001101100104144534C20536F486F20526F757465721008000220081049000600372A000120

lo        Interface doesn't support scanning.

ip link:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: enp38s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN mode DEFAULT group default qlen 1000
    link/ether e4:11:5b:5c:75:f1 brd ff:ff:ff:ff:ff:ff
3: wlo1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP mode DORMANT group default qlen 1000
    link/ether 44:6d:57:1a:1b:fa brd ff:ff:ff:ff:ff:ff


enp38s0   no wireless extensions.

wlo1      IEEE 802.11bgn  ESSID:"MENTALIST"  
          Mode:Managed  Frequency:2.442 GHz  Access Point: EC:22:80:C4:C4:65   
          Bit Rate=6.5 Mb/s   Tx-Power=17 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=16/70  Signal level=-94 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:24  Invalid misc:79   Missed beacon:0

lo        no wireless extensions.

lspci -nn | grep Atheros

25:00.0 Network controller [0280]: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) [168c:002b] (rev 01)

If you guys need any other info, just let me know,

Last edited by the.farbod (2016-08-30 14:32:45)


#2 2016-08-31 12:51:40

From: Iran
Registered: 2015-08-20
Posts: 2

Re: Atheros R9285 wireless card unstable and weak reception

As I said before in live iso I have no problem. I tought this might be network manager tool. So I installed Wicd, it shows better reception (only 'shows' apparently), but connection gets disconnected.
Also when I installed Netrunner Rolling setup said that there were no device driver found for my wifi card(or something like that).
And another thing I tried was dmesg | grep firmware and that gives nothing back, which I suppose mean that there's no need to install firmware(?).

BTW: would installing 'backports' solve my problem?

Still waiting for some response,

Last edited by the.farbod (2016-08-31 14:16:52)


Board footer

Powered by FluxBB