You are not logged in.

#1 2021-06-07 12:02:11

Hori
Member
From: Romania
Registered: 2017-01-12
Posts: 7
Website

Camera not working (/dev/video0 missing)

Hello,

I have an old Canyon CNR-WCAM413G web camera that I want to use on my desktop, but is apparently not working.

Relevant outputs:

lsusb:

Bus 001 Device 008: ID 0ac8:3450 Z-Star Microelectronics Corp. Vimicro USB Camera (Altair)

dmesg:

[ 1654.718819] usb 1-6: new high-speed USB device number 8 using xhci_hcd
[ 1654.882068] usb 1-6: New USB device found, idVendor=0ac8, idProduct=3450, bcdDevice= 9.00
[ 1654.882073] usb 1-6: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 1654.882075] usb 1-6: Product: Vimicro USB Camera (Altair)
[ 1654.882076] usb 1-6: Manufacturer: Vimicro
[ 1654.896056] usb 1-6: Found UVC 1.00 device Vimicro USB Camera (Altair) (0ac8:3450)
[ 1654.896063] usb 1-6: No streaming interface found for terminal 3.
[ 1654.896176] input: Vimicro USB Camera (Altair): Vi as /devices/pci0000:00/0000:00:01.2/0000:01:00.0/usb1/1-6/1-6:1.0/input/input44

The uvcvideo module is indeed loaded. I also tried loading stk1160 (I found someone in an old thread saying it handles this specific device) but still no luck.

I do not have other cameras to test with but I did try droidcam (which uses an Android phone's camera) and that one works just fine.

I did try searching the web and the wiki for a while to see if I can find anything, but so far I was unsuccessful.

I also tried it on my laptop (which also runs Arch Linux) and it has the same problem there as well. This camera is not working, but the built-in one does.

If anyone has any suggestion or if I need to provide any more info, please let me know.

PS: I think my problem is the same as in this thread (https://bbs.archlinux.org/viewtopic.php?id=202012) but there is no solution there, unfortunately - and it is also very old, so I cannot "resurrect" it.

Last edited by Hori (2021-06-07 12:04:34)

Offline

Board footer

Powered by FluxBB