You are not logged in.

#1 Yesterday 00:32:12

shoelesshunter
Member
Registered: 2014-05-18
Posts: 162

[solved]update fails. invalid or corrupted package

I am updating a machine I haven't used in months. over 1,500 packages. I was using aria2 as my Xfer command. all went well, until pacman told me an error had occurred. the error was do to the "external downloader" (I can't recall specific error).

I changed my pacman.conf to use the default method. I ran

 pacman -Syu 

again. I was then asked to import new keys. I did this, and pacman proceeded to fetch the remaining packages.

before the changes were committed, I was told a number of packages in the cache were corrupted, and would I like to remove them. I said, yes, to all.

at the end, I still get this error:

:: File /var/cache/pacman/pkg/wavemon-0.9.4-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: failed to commit transaction (invalid or corrupted package)
Errors occurred, no packages were upgraded.

Last edited by shoelesshunter (Yesterday 03:18:07)

Offline

#2 Yesterday 00:38:10

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 26,155
Website

Re: [solved]update fails. invalid or corrupted package


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#3 Yesterday 02:47:47

shoelesshunter
Member
Registered: 2014-05-18
Posts: 162

Re: [solved]update fails. invalid or corrupted package

I deleted all .part files with find. I also ran

pacman -Scc

I still get

error: runc: signature from "Frederik Schwan <frederik.schwan@linux.com>" is unknown trust
:: File /var/cache/pacman/pkg/runc-1.0.3-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] 

Offline

#4 Yesterday 03:16:31

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 29,811
Website

Re: [solved]update fails. invalid or corrupted package

shoelesshunter wrote:
Do you want to delete it? [Y/n] 

And?


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

#5 Yesterday 03:17:43

shoelesshunter
Member
Registered: 2014-05-18
Posts: 162

Re: [solved]update fails. invalid or corrupted package

I set

Siglevel = Never

in my pacman.conf

then I successfully updated. I did this when updating the 151 keys in the keyring hanged.

this is not ideal, but it works enough for now.

Offline

#6 Yesterday 03:18:55

shoelesshunter
Member
Registered: 2014-05-18
Posts: 162

Re: [solved]update fails. invalid or corrupted package

jasonwryan wrote:
shoelesshunter wrote:
Do you want to delete it? [Y/n] 

And?

Yes, I deleted them, then it failed.

Offline

#7 Yesterday 04:47:49

imnotpathetic
Member
Registered: 2021-10-29
Posts: 7

Re: [solved]update fails. invalid or corrupted package

Did you try going into live-iso and reinstalling or updating the keyring?

Offline

#8 Today 07:27:02

shoelesshunter
Member
Registered: 2014-05-18
Posts: 162

Re: [solved]update fails. invalid or corrupted package

right now thats not an option. I am in a rehab (tbh), and just got the laptop shipped here. I have no idea how long before I can buy a USB drive to make installation media.

Offline

Board footer

Powered by FluxBB