You are not logged in.

#1 2022-09-22 23:40:15

MrEvilBreakfast
Member
From: Abbotsford, BC
Registered: 2011-11-03
Posts: 29

[SOLVED] Screen colours on boot after update

So I did a bad thing and performed a massive system update on my old laptop with an Nvidia card (that needs the 340xx driver) and silly me didn't set the kernel to be ignored. Silly me also forgot to read ahead before building the driver packages, and did all of that in one go.

Now on boot up, when the kernel would be initializing the driver and setting dkms, the system acts normally but the screen just cycles through colors. Full screen red, then full screen green, blue, white, black, repeat, and I can't see or do anything with the system.

I tried booting off a brand new image, but even off the install ISO it does this. Aside from tracking down an older snapshot and booting off that, is there anything I can do?

Thanks

Last edited by MrEvilBreakfast (Yesterday 08:05:43)

Offline

#2 2022-09-22 23:50:28

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 17,018

Re: [SOLVED] Screen colours on boot after update

The latest version of the 340xx driver supports the latest stable kernel, make sure your https://aur.archlinux.org/packages/nvidia-340xx-dkms is actually up to date.

If the artifacts are actually due to issues with nouveau, try whether you get a non blinking setup with the nomodeset kernel parameter. If that doesn't work either, chances are your graphics card is actually toast.

FWIW when the screen is blinking can you switch VTs? are you using lightdm? It has some issues in the current version with non default (non GTK) greeters.

Last edited by V1del (2022-09-22 23:53:04)

Offline

#3 Yesterday 01:31:37

MrEvilBreakfast
Member
From: Abbotsford, BC
Registered: 2011-11-03
Posts: 29

Re: [SOLVED] Screen colours on boot after update

Hmmm nomodeset kernel parameter. I'll give that a try when I get home tonight. Thanks!

Offline

#4 Yesterday 06:51:48

MrEvilBreakfast
Member
From: Abbotsford, BC
Registered: 2011-11-03
Posts: 29

Re: [SOLVED] Screen colours on boot after update

Sorry for the mostly duplicate answer. I kinda messed that up. I got home and tried the nomodeset parameter and that worked. I got the proper dkms package installed and the terminal now works fine.

I still have a lot of work ahead of me to get xorg working though. But at least I can do that.

Thank you!

Offline

#5 Yesterday 07:38:33

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 17,018

Re: [SOLVED] Screen colours on boot after update

nomodeset is an emergency option, you shouldn't need it anymore if you've properly updated the nvidia driver package. If that works so far and the topic is answered in gneral, please mark as [SOLVED] by editing the title in your first post.

Offline

Board footer

Powered by FluxBB