You are not logged in.

#1 Yesterday 07:42:16

the_mungler
Member
Registered: Yesterday
Posts: 3

mkvtoolnix-cli and mkvtoolnix-gui packages seem to be missing [Solved]

Trying to install the named packages above. I checked and made sure everything is up to date, that isn't the issue. It's odd, I just get a lot of 404 errors from all the mirrors. everything else can install fine. the output is full of error messages for every mirror pacman attempts to download the package from.

command output (truncated for brevity, I'm just getting the same message for every mirror attempted):

pacman -S mkvtoolnix-gui
resolving dependencies...
looking for conflicting packages...

Packages (8) cmark-0.30.2-1  fmt-9.1.0-1  libebml-1.4.2-2  libmatroska-1.6.3-2  mkvtoolnix-cli-70.0.0-1  pugixml-1.12.1-1  qt6-multimedia-6.3.2-1
             mkvtoolnix-gui-70.0.0-1

Total Download Size:   12.19 MiB
Total Installed Size:  41.05 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
 libmatroska-1.6.3-2-x86_64                                        128.0 KiB   128 KiB/s 00:01 [########################################################] 100%
 qt6-multimedia-6.3.2-1-x86_64                                     488.7 KiB   395 KiB/s 00:01 [########################################################] 100%
 fmt-9.1.0-1-x86_64                                                449.2 KiB   361 KiB/s 00:01 [########################################################] 100%
 cmark-0.30.2-1-x86_64                                             111.0 KiB   793 KiB/s 00:00 [########################################################] 100%
 pugixml-1.12.1-1-x86_64                                           100.0 KiB   526 KiB/s 00:00 [########################################################] 100%
 libebml-1.4.2-2-x86_64                                             68.1 KiB   400 KiB/s 00:00 [########################################################] 100%
 mkvtoolnix-gui-70.0.0-1-x86_64                                      0.0   B  0.00   B/s 00:00 [########################################################] 100%
 mkvtoolnix-cli-70.0.0-1-x86_64                                      0.0   B  0.00   B/s 00:00 [########################################################] 100%
 mkvtoolnix-gui-70.0.0-1-x86_64.pkg.tar.zst failed to download
 Total (8/8)                                                                12.2 MiB   195 KiB/s 01:04 [#############################################################] 100%
error: failed retrieving file 'mkvtoolnix-gui-70.0.0-1-x86_64.pkg.tar.zst' from mirror.ette.biz : The requested URL returned error: 404
error: failed retrieving file 'mkvtoolnix-cli-70.0.0-1-x86_64.pkg.tar.zst' from mirror.ette.biz : The requested URL returned error: 404
error: failed retrieving file 'mkvtoolnix-cli-70.0.0-1-x86_64.pkg.tar.zst' from mnvoip.mm.fcix.net : The requested URL returned error: 404
error: failed retrieving file 'mkvtoolnix-gui-70.0.0-1-x86_64.pkg.tar.zst' from mnvoip.mm.fcix.net : The requested URL returned error: 404
...
...
error: failed to commit transaction (failed to retrieve some files)
Errors occurred, no packages were upgraded.

I don't think I'm doing anything wrong, is it possible there is something wrong with this package?

Last edited by the_mungler (Yesterday 08:24:42)

Offline

#2 Yesterday 07:50:10

loqs
Member
Registered: 2014-03-06
Posts: 15,320

Re: mkvtoolnix-cli and mkvtoolnix-gui packages seem to be missing [Solved]

See Pacman#Packages_cannot_be_retrieved_on_installation your system's package database is out of date.

Offline

#3 Yesterday 08:08:21

the_mungler
Member
Registered: Yesterday
Posts: 3

Re: mkvtoolnix-cli and mkvtoolnix-gui packages seem to be missing [Solved]

odd, I ran pacman -Syu before attempting this, but you're right, the version pacman is trying to get is 70.0.0-1, but it should be 70.0.0-2. just now I attempted to update the database but pacman tells me there is nothing to do...

pacman -Syu
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
:: Starting full system upgrade...
 there is nothing to do

for some reason my pacman command is doing nothing?

Offline

#4 Yesterday 08:16:20

seth
Member
Registered: 2012-09-03
Posts: 31,824

Re: mkvtoolnix-cli and mkvtoolnix-gui packages seem to be missing [Solved]

Out of sync mirror?
https://archlinux.org/packages/community/any/reflector/

Edit: no, they're not.

Last edited by seth (Yesterday 08:19:55)

Offline

#5 Yesterday 08:16:32

loqs
Member
Registered: 2014-03-06
Posts: 15,320

Re: mkvtoolnix-cli and mkvtoolnix-gui packages seem to be missing [Solved]

I am assuming your system's primary mirror (the first mirror in the mirrorlist) is mirror.ette.biz which is out of sync according to https://archlinux.org/mirrors/status/ so change that mirror and the issue should be resolved.

Offline

#6 Yesterday 08:23:43

the_mungler
Member
Registered: Yesterday
Posts: 3

Re: mkvtoolnix-cli and mkvtoolnix-gui packages seem to be missing [Solved]

ah, yup, that appears to be the case.

Offline

Board footer

Powered by FluxBB