You are not logged in.

#1 2022-11-15 03:15:07

Registered: 2022-11-14
Posts: 1

Stuck after trying to fix some missing glibc libraries

After some time (months) without using a laptop with Arch on it, I tried installing Openssh, but the installation wasn't completely succesful, as many messages of files with discrepancies appeared (not only on the attempt to install that one package, but in some others too).

Anyway, after installation, I tried using ssh, which lead to the error:

version GLIBC_2.34 not found (required by ssh)

That code led me to this thread . I followed the steps indicated, basically, follow the pacman wiki ("Pacman crashes during an upgrade" troubleshooting section) but on the 4th step, instead, use:

pacman --root /mnt --cache /mnt/var/cache/pacman/pkg -Syu

From the output, the update seemed to work fine (even though running 'find /mnt/usr/lib -size 0' showed a huge list of occurencies, which might indicate that there are still broken packages), but after removing the USB and attempting to boot from the Arch installed on my laptop to check the results, the screen just displays:

Starting version 248.3-2-arch
/dev/sda2: clean, 187632/30523392 files, 4642693/122063622 blocks

I can access to shell with Ctrl+Alt+F2, but I'm pretty lost at this point, to be honest...

Last edited by RichtofenFromCODzombies (2022-11-15 03:17:44)


#2 2022-11-15 04:05:31

From: Cymru
Registered: 2011-11-27
Posts: 6,853

Re: Stuck after trying to fix some missing glibc libraries

Post /var/log/pacman.log and the system journal. (Link below to wiki instructions on how to do this from the command line.)

CLI Paste | How To Ask Questions

Arch Linux | x86_64 | GPT | EFI boot | refind | stub loader | systemd | LVM2 on LUKS
Lenovo x270 | Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz | Intel Wireless 8265/8275 | US keyboard w/ Euro | 512G NVMe INTEL SSDPEKKF512G7L


Board footer

Powered by FluxBB