You are not logged in.

#1 2024-04-01 06:01:25

heyimnyl
Member
Registered: 2024-02-06
Posts: 11

[Solved] System entering wrong suspend mem sleep mode

Hello,

I have this problem of sometimes the automatic sleep does work correctly, sometimes it tries to enter a deeper mode(?) as in it wants to shut off or rather it does for a short time power cycle the psu and then instantly comes back.
I noticed this because fan speeds of a connected usb fan controller are spinning faster in the morning than when I left for the night.

What I'm trying to say is: It's nice that it wants to automatically sleep but its sometimes entering the wrong sleep mode, the one it should be in is suspend to ram and usually thats fine.

https://pastebin.com/raw/QhPKwAuc
^ journalctl entries from 1 cycle, this just repeats every time the system wants to sleep over and over until now.

https://pastebin.com/raw/pYLSUCJM
^ this is from me pressing sleep in start menue

It's almost like it's mistaking hibernate for sleep but hibernate is the same and I don't hibernate and never set it up to go hibernate as far as I remember.
Just to try this and see what happens I pressed hibernate but it just goes back to login screen after showing tty for a bit. I don't hibernate so not sure if relevant but here is the log from that:
https://pastebin.com/raw/JpZ1dJA4


If I go and press sleep in system menue now or in the login screen it also tries to enter deeper sleep mode which is wrong. Usually I fix this by just rebooting but it's rather annoying and I would like to know why or what causes this.


Thank you!

Last edited by heyimnyl (2024-04-04 16:42:57)

Offline

#2 2024-04-01 16:11:20

seth
Member
Registered: 2012-09-03
Posts: 51,132

Re: [Solved] System entering wrong suspend mem sleep mode

https://pastebin.com/raw/QhPKwAuc simply shows the system entering S3 and then returning ~8s later, there's nothing about "deeper" or hiberanting.
If the problem is that the system automatically wakes up from S3, see https://wiki.archlinux.org/title/Power_ … om_suspend and also check cat /proc/acpi/wakeup

There's some noise around

Apr 01 04:09:46 nyArch kernel: usb 5-1.2: new full-speed USB device number 35 using xhci_hcd
Apr 01 04:09:46 nyArch kernel: usb 5-1.2: device descriptor read/64, error -32
Apr 01 04:09:46 nyArch kernel: usb 5-1.2: device descriptor read/64, error -32
Apr 01 04:09:47 nyArch kernel: usb 5-1.2: new full-speed USB device number 36 using xhci_hcd
Apr 01 04:09:47 nyArch kernel: usb 5-1.2: device descriptor read/64, error -32
Apr 01 04:09:47 nyArch kernel: usb 5-1.2: device descriptor read/64, error -32
Apr 01 04:09:47 nyArch kernel: usb 5-1-port2: attempt power cycle

so if you have sub in the wakeup triggers and depending on what that device is, it might be the cause.

Offline

#3 2024-04-03 07:35:27

heyimnyl
Member
Registered: 2024-02-06
Posts: 11

Re: [Solved] System entering wrong suspend mem sleep mode

Sorry for potentially mixing up technical terms about sleep states

seth wrote:

https://pastebin.com/raw/QhPKwAuc simply shows the system entering S3 and then returning ~8s later, there's nothing about "deeper" or hiberanting.

Yes I think that's the problem. I didn't wake it up and normally a log looks like this: https://pastebin.com/raw/zJTrLhEC
Which is not S3 if I'm reading this correct and thats totally fine, I like not S3 - it works big_smile

I tried to look in Suspend and Hibernate Wiki 7.4 but my devices are ??
cat /sys/bus/i2c/devices/i2c-
i2c-0/ i2c-1/ i2c-2/ i2c-3/ i2c-4/ i2c-5/ i2c-6/ i2c-7/ i2c-8/

So I'm a bit stuck on the names.

The only thing enabled in acpi/wakeup is this
XHC0      S4    *enabled   pci:0000:10:00.3

the rest is all disabled.
until now I have not had the problem again of system entering wrong mode so I could not check what would have been enabled in the case if it's in wake-up loop again.

Also I added
options pcie_port_pm=off
options pcie_pme=nomsi

to my boot conf after not being able to have the system go to idle when I set everything up and came across a thread here on the forums, that basically solved it but sometimes it still tries to to do this exact thing of entering and just waking up.
I think it's a different idle mode.. What I can see from the good journal is s2idle and its all fine, I can just power it off when I go away for longer but it's rather weird and I don't know how to fix these other occurrences when it doesn't go to s2idle.

Last edited by heyimnyl (2024-04-03 07:43:36)

Offline

#4 2024-04-03 08:22:13

seth
Member
Registered: 2012-09-03
Posts: 51,132

Re: [Solved] System entering wrong suspend mem sleep mode

Apr 03 09:12:30 nyArch kernel: PM: suspend entry (deep)
Apr 03 09:12:52 nyArch kernel: PM: suspend entry (s2idle)
cat /sys/power/mem_sleep

You can control the behavior w/ eg.

echo s2idle | sudo tee /sys/power/mem_sleep

https://wiki.archlinux.org/title/Power_ … end_method

Offline

#5 2024-04-04 16:42:16

heyimnyl
Member
Registered: 2024-02-06
Posts: 11

Re: [Solved] System entering wrong suspend mem sleep mode

Thank you!
I set s2idle as kernel parameter after noticing it defaults back to deep.
would be nice if this fixes the wrong sleep occurrences (it probably will), marking as solved.

Offline

Board footer

Powered by FluxBB