You are not logged in.

#1 2007-05-07 11:23:19

gerryAU
Member
From: Australia
Registered: 2007-04-08
Posts: 37

[solved] k3b locale

Howdy, getting a weird locale error when starting k3b ver 1.0.1 (new pc install, pacman -Syu latest packages)

have set locales (en_us en_gb & en_au ) & have run local-gen ,but makes no difference sad

screenie ;

snapshot11ii0.th.png

thanks.

Last edited by gerryAU (2007-05-18 14:06:02)

Offline

#2 2007-05-07 11:58:10

SiD
Member
From: Germany
Registered: 2006-09-21
Posts: 729

Re: [solved] k3b locale

Have you set your locale in /etc/rc.conf ?

Offline

#3 2007-05-07 12:28:27

gerryAU
Member
From: Australia
Registered: 2007-04-08
Posts: 37

Re: [solved] k3b locale

I have "LOCALE="en_US.utf8"" in rc.conf & have uncommented
en_GB.UTF-8
en_GB    ISO-8859-1
en_US    ISO-8859-1
en_US.UTF-8    UTF-8
en_AU.UTF-8    UTF-8
en_AU    ISO-8859-1

in locale.gen

cheers

Offline

#4 2007-05-07 13:42:04

AndyRTR
Developer
From: Magdeburg/Germany
Registered: 2005-10-07
Posts: 1,638

Re: [solved] k3b locale

check your /etc/profile for the right export LC= variable wink

Offline

#5 2007-05-08 09:04:37

gerryAU
Member
From: Australia
Registered: 2007-04-08
Posts: 37

Re: [solved] k3b locale

Thanks Andy, checked my /etc/profile it has;

export LC_COLLATE="C"

Is that correct or should it be something else ? Note that my /etc/profile is identical to the Arch build on another pc I have & K3b doesn`t  complain about it.

Offline

#6 2007-05-08 09:06:04

gerryAU
Member
From: Australia
Registered: 2007-04-08
Posts: 37

Re: [solved] k3b locale

my full /etc/profile for reference;

#
# /etc/profile
#

export PATH="/bin:/usr/bin:/sbin:/usr/sbin:/usr/X11R6/bin:/opt/bin"

export MANPATH="/usr/man:/usr/X11R6/man"
export LESSCHARSET="latin1"
export INPUTRC="/etc/inputrc"
export LESS="-R"

export LC_COLLATE="C"

export COLUMNS LINES

export PS1='[\u@\h \W]\$ '
export PS2='> '

umask 022

if [ "$TERM" = "xterm" -o "$TERM" = "xterm-color" -o "$TERM" = "rxvt" -o "$TERM" = "xterm-xfree86" ]; then
  PROMPT_COMMAND='echo -ne "\033]0;${USER}@${HOSTNAME%%.*}:${PWD/$HOME/~}\007"'
fi

# load profiles from /etc/profile.d
#  (to disable a profile, just remove execute permission on it)
if [ `ls -A1 /etc/profile.d/ | wc -l` -gt 0 ]; then
  for profile in /etc/profile.d/*.sh; do
    if [ -x $profile ]; then
      . $profile
    fi
  done
  unset profile
fi
# End of file

Offline

#7 2007-05-18 11:08:51

evilcoder
Member
Registered: 2007-05-18
Posts: 4

Re: [solved] k3b locale

hi, i'm new to arch linux and i was having the same problem until today.
heres the solution:
- edit /opt/kde/share/config/kdm/kdmrc
- put this line into the [General] section (usually at the top of the file): ExportList=LANG,LC_ALL
- the above assumes you have set LANG and LC_ALL in /etc/profile
- save it, and restart X (mybe restart your computer, if /etc/profile needs to be re-sourced)

cheers,
ecx

Offline

#8 2007-05-18 14:08:50

gerryAU
Member
From: Australia
Registered: 2007-04-08
Posts: 37

Re: [solved] k3b locale

Thanks evil for the tip, but it didn`t work for me , but this did (removed /etc/locale.gen before reinstalling glibc, then re-edited  /etc/locale.gen  with my locales & then re-run locale-gen)

http://bbs.archlinux.org/viewtopic.php?id=32770

thanks all smile

Last edited by gerryAU (2007-05-18 14:13:05)

Offline

Board footer

Powered by FluxBB