You are not logged in.

#1 2009-12-20 15:21:59

Nixxx
Member
From: Poland
Registered: 2009-08-01
Posts: 85

[SOLVED]KDM auto-login issue

Hi All. After I've configured VSFTPD server with PAM authorization method (virtual users), I'm unable  to set auto-login option. I have enabled auto-login checkbox as usually but KDM always asks me for login and password after every reboot. Can someone know how to fix this problem? Thanks.

Last edited by Nixxx (2009-12-21 17:00:55)

Offline

#2 2009-12-20 17:07:58

mkkot
Member
From: Poland
Registered: 2009-12-20
Posts: 198
Website

Re: [SOLVED]KDM auto-login issue

Hello for the first time!

I have also autologin issue but I would say my KDM is configured rather "normally", so I'm using it on my private computer to enter into kde without any typing or pressing enter. Although I haven't changed any settings, autologin stopped working today(?) - now I see KDM's screen and need to type password or press enter instead of being directly logged in.

I use up-to-date Arch 64 bit with KDE 4.3.4 from official repo. There is nothing interesting in logs and here comes my /usr/share/config/kdm/kdmrc:

[General]
ConfigVersion=2.4
ConsoleTTYs=tty1,tty2,tty3,tty4,tty5,tty6
PidFile=/var/run/kdm.pid
ReserveServers=:1,:2,:3
ServerVTs=-7
StaticServers=:0

[Shutdown]
BootManager=Grub
HaltCmd=/sbin/halt
RebootCmd=/sbin/reboot

[X-*-Core]
AllowNullPasswd=false
AllowRootLogin=false
AllowShutdown=None
AutoReLogin=false
ClientLogFile=.xsession-errors-%d
Reset=/usr/share/config/kdm/Xreset
Session=/usr/share/config/kdm/Xsession
SessionsDirs=/usr/share/config/kdm/sessions,/usr/share/apps/kdm/sessions
Setup=/usr/share/config/kdm/Xsetup
Startup=/usr/share/config/kdm/Xstartup

[X-*-Greeter]
AntiAliasing=false
ColorScheme=
FaceSource=AdminOnly
FailFont=Sans Serif,10,-1,5,75,0,0,0,0,0
ForgingSeed=1259447680
GUIStyle=
GreetFont=Serif,20,-1,5,50,0,0,0,0,0
GreetString=Witamy na komputerze %s w %n
GreeterPos=50,50
HiddenUsers=
Language=pl
LogoArea=Logo
LogoPixmap=/usr/share/apps/kdm/pics/kdelogo.png
MaxShowUID=65000
MinShowUID=500
Preloader=/usr/bin/preloadkde
SelectedUsers=
ShowUsers=NotHidden
SortUsers=true
StdFont=Sans Serif,10,-1,5,50,0,0,0,0,0
Theme=/usr/share/apps/kdm/themes/arch # yeah, it also doesn't work with default one
UseBackground=true
UseTheme=true
UserCompletion=false
UserList=true

[X-:*-Core]
AllowNullPasswd=true
AllowShutdown=All
NoPassEnable=true
NoPassUsers=mk
ServerArgsLocal=-nolisten tcp
ServerCmd=/usr/bin/X

[X-:*-Greeter]
AllowClose=false
DefaultUser=mk
FocusPasswd=true
LoginMode=DefaultLocal
PreselectUser=Default

[X-:0-Core]
AutoLoginEnable=true
AutoLoginLocked=false
AutoLoginUser=mk
ClientLogFile=.xsession-errors

[Xdmcp]
Enable=false
Willing=/usr/share/config/kdm/Xwilling

killall X also returns KDM's login screen.
killall kdm causes immediate direct logging into KDE (as it should).

Last edited by mkkot (2009-12-20 17:17:23)

Offline

#3 2009-12-20 18:38:17

Nixxx
Member
From: Poland
Registered: 2009-08-01
Posts: 85

Re: [SOLVED]KDM auto-login issue

Hi. Thanks for reply. So probably it seems to be not connected with PAM but it happend after todays update. First I've updated the system then without rebooting I started to configuring ftp server so that's why I thought that it's connected with PAM authorisation. What a coincidence.  My kdmrc file looks the same as yours so it looks like a bug.

Last edited by Nixxx (2009-12-20 19:01:47)

Offline

#4 2009-12-20 21:08:44

mkkot
Member
From: Poland
Registered: 2009-12-20
Posts: 198
Website

Re: [SOLVED]KDM auto-login issue

The thing is that last KDE update was performed on my PC [2009-12-04 17:40]. Maybe it's related with some other package, here is pacman's log from last 2 days:

[2009-12-18 14:50] upgraded boost (1.41.0-1.1 -> 1.41.0-2)
[2009-12-18 14:50] upgraded lib32-glibc (2.11-1 -> 2.11.1-1)
[2009-12-18 14:50] upgraded lib32-expat (2.0.1-2 -> 2.0.1-4)
[2009-12-18 14:50] upgraded lib32-gcc-libs (4.4.2-3 -> 4.4.2-4)
[2009-12-18 14:50] upgraded lib32-glib2 (2.22.2-1 -> 2.22.3-1)
[2009-12-18 14:50] upgraded lib32-sqlite3 (3.6.20-1 -> 3.6.21-1)
[2009-12-18 14:50] upgraded raptor (1.4.19-1 -> 1.4.20-1)
[2009-12-18 19:06] synchronizing package lists
[2009-12-18 19:06] starting full system upgrade
[2009-12-19 22:40] synchronizing package lists
[2009-12-19 22:41] starting full system upgrade
[2009-12-19 22:57] synchronizing package lists
[2009-12-19 22:57] starting full system upgrade
[2009-12-19 23:00] installed libmtp (0.3.7-1.1)
[2009-12-19 23:00] installed mutagen (1.18-1)
[2009-12-19 23:00] installed sg3_utils (1.28-1)
[2009-12-19 23:00] installed libgpod (0.7.2-1)
[2009-12-19 23:00] installed qtscriptgenerator (0.1.0-1)
[2009-12-19 23:00] installed taglib-extras (1.0.1-1)
[2009-12-19 23:00] installed liblastfm (0.3.0-4)
[2009-12-19 23:00] installed loudmouth (1.4.3-1)
[2009-12-19 23:00] installed amarok (2.2.1-2)
[2009-12-20 13:29] synchronizing package lists
[2009-12-20 13:29] starting full system upgrade
[2009-12-20 13:31] upgraded firefox-i18n (3.5.5-1 -> 3.5.6-1)
[2009-12-20 13:31] upgraded hal-info (0.20090716-2 -> 0.20091130-1)
[2009-12-20 13:31] upgraded hal (0.5.13-3 -> 0.5.14-1)
[2009-12-20 13:31] upgraded libdrm (2.4.15-1 -> 2.4.16-1)
[2009-12-20 13:31] upgraded xcb-proto (1.5-1 -> 1.6-1)
[2009-12-20 13:31] upgraded libxcb (1.4-1 -> 1.5-1)
[2009-12-20 13:31] upgraded xorg-xkb-utils (7.5-1 -> 7.5-2)
[2009-12-20 17:50] synchronizing package lists

BTW it's funny when two Polishes need to talk English cool

Offline

#5 2009-12-20 21:50:05

Diaz
Member
From: Lisbon, Portugal
Registered: 2008-04-16
Posts: 361
Website

Re: [SOLVED]KDM auto-login issue

my kdm doesn't autologin too, it appears it tries to login, but then it comes back to the login screen where i have to type the password.


Owner of Asus 1215B :: User of Xfce :: Vasco Dias @blog

Offline

#6 2009-12-20 22:38:25

Nixxx
Member
From: Poland
Registered: 2009-08-01
Posts: 85

Re: [SOLVED]KDM auto-login issue

I have reported a bug FS#17564 - KDE auto-login failed - http://bugs.archlinux.org/task/17564?pr … &sort=desc

Offline

#7 2009-12-20 23:17:51

areisp
Member
From: Russia
Registered: 2009-12-20
Posts: 1

Re: [SOLVED]KDM auto-login issue

It seems hal issue. Downgrading that to 0.5.13-3 sovles problem.

Offline

#8 2009-12-21 09:06:59

Nixxx
Member
From: Poland
Registered: 2009-08-01
Posts: 85

Re: [SOLVED]KDM auto-login issue

I've changed the method of running KDM from deamon to inittab and it works fine now.

Last edited by Nixxx (2009-12-21 09:16:18)

Offline

#9 2009-12-21 12:34:04

mkkot
Member
From: Poland
Registered: 2009-12-20
Posts: 198
Website

Re: [SOLVED]KDM auto-login issue

I have this method since installation and it doesn't work!

id:5:initdefault:

rc::sysinit:/etc/rc.sysinit
rs:S1:wait:/etc/rc.single
rm:2345:wait:/etc/rc.multi
rh:06:wait:/etc/rc.shutdown
su:S:wait:/sbin/sulogin -p
c1:2345:respawn:/sbin/agetty -8 38400 tty1 linux
c2:2345:respawn:/sbin/agetty -8 38400 tty2 linux
c3:2345:respawn:/sbin/agetty -8 38400 tty3 linux
c4:2345:respawn:/sbin/agetty -8 38400 tty4 linux
c5:2345:respawn:/sbin/agetty -8 38400 tty5 linux
c6:2345:respawn:/sbin/agetty -8 38400 tty6 linux

ca::ctrlaltdel:/sbin/shutdown -t3 -r now
x:5:respawn:/usr/bin/kdm -nodaemon
DAEMONS=(syslog-ng network !netfs dbus hal crond alsa cpufreq)

More info: http://wiki.archlinux.org/index.php/Add … on_startup

Okay, it started to work properly after consolekit update (probably, who knows).

Last edited by mkkot (2009-12-21 12:47:59)

Offline

#10 2009-12-21 17:00:38

Nixxx
Member
From: Poland
Registered: 2009-08-01
Posts: 85

Re: [SOLVED]KDM auto-login issue

After update consolekit to 0.4.1-2 problem was solved. Checked with both methods (demon and inittab).

Last edited by Nixxx (2009-12-22 14:44:50)

Offline

#11 2009-12-22 02:42:38

Diaz
Member
From: Lisbon, Portugal
Registered: 2008-04-16
Posts: 361
Website

Re: [SOLVED]KDM auto-login issue

yeah, i just updated and saw something about consolekit beeing updated again, and now it autologins fine again.


Owner of Asus 1215B :: User of Xfce :: Vasco Dias @blog

Offline

Board footer

Powered by FluxBB