You are not logged in.

#26 2010-02-12 07:55:21

syre
Member
From: Denmark
Registered: 2009-08-04
Posts: 99

Re: Wicd | "Connection Failed: Unable to get IP address"

same bug for me, i use wicd (wicd-curses) and i lose the connection/fail to connect to encrypted networks.
got an Acer Aspire One

Offline

#27 2010-02-12 20:25:32

silversnakeeyes
Member
From: Seattle, WA
Registered: 2009-11-14
Posts: 31
Website

Re: Wicd | "Connection Failed: Unable to get IP address"

Try just switching to the NetworkManager (sudo pacman -S NetworkManager) package, then switching back after a day or two. (Alternatively, just stick with network manager) For some reason, this fixes it.

Last edited by silversnakeeyes (2010-02-12 20:26:13)

Offline

#28 2010-03-22 16:59:52

perrazo
Member
Registered: 2010-03-22
Posts: 1

Re: Wicd | "Connection Failed: Unable to get IP address"

jvalecillos wrote:
mcsaba77 wrote:

I have the same problem, 100% reproducible. Wicd connects on startup, if I disconnect and then try to connect again, I get the Connection Failed error.

I have exactly the same problem, and if i do:

modprobe -r ath5k

and

modprobe ath5k

Then Wicd connects, the problem persists on kernel 2.6.32.4. I don't think that this is a wicd problem because i've installed a bzr version of "AUR" and i  have not updated in a while. The wicd 1.7.0 and current bzr version presents the problem too, but as i said before i think that is a kernel's problem (or his modules).

It seems to be the same bug here http://bbs.archlinux.org/viewtopic.php?pid=694349

Hi,

I've made a little bash script to be used by Wicd at preconnection after your idea. The script reads which interface has been selected in Preferences, unloading and loading the proper driver accordingly. Very useful when you use more than one connection interface, like when you have a wireless USB adapter to plug in addition to your internal wireless adapter. I hope you find it handy while developers debug where the problem is.

Simply, copy& paste the code to create a bash script and place it in /etc/wicd/scripts/preconnect. Don't forget to give your user sudo privileges with no password so the script won't ask for your password and stall there forever. I guess there are more secure/easier ways to implement the idea, but it works for me this way. Feel free to modify it as you may please.

 #!/bin/bash

WICDFIELD="`sudo cat /etc/wicd/manager-settings.conf | grep "wireless_interface"`"

WLINTERFACE="${WICDFIELD##*= }"

if [ -e "/sys/class/net/$WLINTERFACE/device/driver" ]
then
    WLDRIVER="`ls -l "/sys/class/net/$WLINTERFACE/device/driver" | sed 's/^.*\/\([a-zA-Z0-9_-]*\)$/\1/'`"
    
else
    WLDRIVER=""
fi

if [ "$WLDRIVER" != "" ]
then
    sudo modprobe -r $WLDRIVER
    sudo modprobe $WLDRIVER   
fi

PS: This is my first post, so not very familiar with forum rules. I'm sorry for any inconvenience I may cause if I have broken any forum rules.

Last edited by perrazo (2010-03-22 17:24:51)

Offline

#29 2010-04-04 20:58:50

alesscor
Member
From: Costa Rica
Registered: 2010-04-02
Posts: 4

Re: Wicd | "Connection Failed: Unable to get IP address"

perrazo. After adding your script in the indicated place, wicd stopped failing. The sudo call is not required in this script cause wicd daemon permissions are enough. Before this, wicd never worked completely (always failed at getting ip address when no startup) this week long on my acer one netbook (the first week archlinux runs on it). Thanks!!!


Arch i686 w XFCE on Acer Aspire One

Offline

#30 2010-04-29 01:35:46

cha0s6983
Member
Registered: 2009-09-15
Posts: 5

Re: Wicd | "Connection Failed: Unable to get IP address"

Workaround works great here, but it doesn't feel clean... hehe

Thank you though. ^^

Offline

#31 2010-05-04 02:48:44

timdor
Member
Registered: 2009-03-16
Posts: 2

Re: Wicd | "Connection Failed: Unable to get IP address"

For what it's worth, I think I have found an easy workaround.  A few days ago I installed archone on my Aspire One.  Wicd could not give me an IP address.  After trying jvalecillos suggestion regarding modprobe, I added "!ath5k" to the modules section in /etc/rc.conf.  Then I added "sudo modprobe ath5k" to the startup programs in openbox.  Have had no problems connecting since doing this.

Last edited by timdor (2010-05-04 02:56:16)

Offline

#32 2010-05-04 14:29:15

TheSaint
Member
From: my computer
Registered: 2007-08-19
Posts: 1,380

Re: Wicd | "Connection Failed: Unable to get IP address"

I'm thinking if it is related only with ath5k module....

F


do it good first, it will be faster than do it twice the saint wink

Offline

#33 2010-06-15 11:29:52

rztka
Member
From: Czech Republic
Registered: 2006-03-10
Posts: 37

Re: Wicd | "Connection Failed: Unable to get IP address"

TheSaint wrote:

I'm thinking if it is related only with ath5k module....

F

i guess it's not. since a recent major update of my archlinux i'm experiencing the same problem with ipw2200. unloading and loading the module helps and wicd will connect to encrypted network (testing the solution with wicd preconnect script now). but i'm still getting frequent disconnections (every 3-5 minutes).

EDIT: here is one of the disconnections as logged in everything.log:

Jun 15 13:49:08 kamarad dhcpcd[22039]: eth1: carrier lost
Jun 15 13:49:08 kamarad dhcpcd[22735]: sending signal 1 to pid 22039
Jun 15 13:49:08 kamarad dhcpcd[22039]: received SIGHUP, releasing
Jun 15 13:49:08 kamarad dhcpcd[22039]: eth1: removing interface
Jun 15 13:49:08 kamarad dhcpcd[22735]: waiting for pid 22039 to exit
Jun 15 13:49:08 kamarad ntpd[22048]: Terminating
Jun 15 13:49:08 kamarad dhcpcd[22753]: dhcpcd not running

what does the 'carrier lost' message means exactly?

Last edited by rztka (2010-06-15 12:02:41)

Offline

Board footer

Powered by FluxBB