You are not logged in.

#1 2010-10-02 12:30:52

STM
Member
Registered: 2010-04-21
Posts: 13

GPU running at high temperature at idle

Hi all - I have a strange problem. Under Arch, my gnome-system-monitor records a temp of 63 degrees Celsius for my GPU at idle. As a result the fan is left on permanently. I've tried running Oblivion under Wine for a while, and it rises the temperature to ~73 degrees Celsius.

I would have put this down to a cooling issue on the laptop (it's a high performance Clevo M57RU with an 8800M GTX, so I was all set to put this down to inefficient cooling. However, if I boot to a Ubuntu Live CD, the fan drops at idle without issue. I haven't yet checked the exact temperature under Ubuntu (will do that now and edit), but it must be lower for the fan to drop speed.

I installed lm_sensors, but it can't detect my GPU fan, so I can't directly manipulate it. Is there a way I can check how Ubuntu controls it and is there any way for me to monitor traffic going to my GPU that could be causing excessive usage (and thus heat)?

Last edited by STM (2010-10-02 12:32:01)


New account: tjbp

Offline

#2 2010-10-02 13:16:24

hokasch
Member
Registered: 2007-09-23
Posts: 1,461

Re: GPU running at high temperature at idle

Different video drivers maybe - are you using nouveau? The proprietary Nvidia drivers have a "gpufreq" powersaving options (eventually check if it is activated), AFAIK nouveau currently still lags good powersaving.

Offline

#3 2010-10-02 13:51:43

STM
Member
Registered: 2010-04-21
Posts: 13

Re: GPU running at high temperature at idle

I'm using version 256.53 of the nvidia drivers. Was unable to get an actual temperature readout from an Ubuntu Live CD (ran into bugs with gnome-panel and other crap) - but after booting back into Arch and loading Gnome I was able to watch the GPU temp creep up from 55 degrees to 63 again.

nvidia-settings has a 'PowerMizer' section - it's currently in Adaptive mode. There are 4 performance levels, and it's on the highest while idling. A driver bug perhaps?

Last edited by STM (2010-10-02 13:54:04)


New account: tjbp

Offline

#4 2010-10-02 14:01:11

litemotiv
Forum Fellow
Registered: 2008-08-01
Posts: 5,026

Re: GPU running at high temperature at idle

You can issue:

$ nvidia-smi -a

To get a temperature reading from console (shipped with the binary Nvidia driver).

Your PowerMizer in Arch is on level 3? Are you running cpufreq as well, to avoid heating the video chip with the cpu?


ᶘ ᵒᴥᵒᶅ

Offline

#5 2010-10-02 14:29:21

STM
Member
Registered: 2010-04-21
Posts: 13

Re: GPU running at high temperature at idle

Whoops, didn't even know about cpufreq. Have installed and configured, which is helping with the fan noise, but it hasn't really affected the GPU temp.


New account: tjbp

Offline

#6 2010-10-03 06:15:38

DStein
Member
From: Buffalo, NY USA
Registered: 2009-11-27
Posts: 60

Re: GPU running at high temperature at idle

I've had the same problem with my 360M.  My guess is that this is an Nvidia driver bug.  I just installed Nvidia beta from AUR and will see if it's any better, but it has been an ongoing issue for me since before the current release driver version.  The only thing that absolutely solves it for me is to disable compositing.  Being closed source drivers there's only so much one can do.

Offline

#7 2010-10-03 11:02:23

STM
Member
Registered: 2010-04-21
Posts: 13

Re: GPU running at high temperature at idle

Nice to know I'm not the only one - though I still have a feeling that part of the problem is user error (this is the same installation I've used since first trying Arch, so some of the configs and software selections are very messy). I actually don't have any compositing - just vanilla GNOME.

Can anyone shed any light on whether we can monitor GPU usage? Even to a specific process perhaps? When I have time I'll install a fresh Debian or similar and run the same nvidia drivers to see if the effects are the same.


New account: tjbp

Offline

#8 2010-10-03 11:11:05

hokasch
Member
Registered: 2007-09-23
Posts: 1,461

Re: GPU running at high temperature at idle

The one monitoring I know of is the PowerMizer section in NVIDIA X Server settings, it only shows general GPU/Memory clock though. Mine is showing "performance mode" as "maximum perf.", despite adaptive being selected and obviously working (altough it scales up quite often because of compiz).

P.S: If you are stuck on the highest performance level, maybe these tips to force the setting could help:
http://wiki.archlinux.org/index.php/NVI … wer_saving

Last edited by hokasch (2010-10-03 11:15:01)

Offline

#9 2010-10-03 13:01:30

STM
Member
Registered: 2010-04-21
Posts: 13

Re: GPU running at high temperature at idle

Unfortunately the power saving still won't work with that setting - but I did enable overclocking, and underclocked the card myself using the interface. Dropped my temp to 56 using that - which I suppose will work as an interim. Though the nvidia drivers don't seem to consider that low enough to notch down my fan speed sad


New account: tjbp

Offline

#10 2010-10-03 13:56:41

skunktrader
Member
From: Brisbane, Australia
Registered: 2010-02-14
Posts: 1,321

Re: GPU running at high temperature at idle

Have you tried nvclock?  You can control the fanspeed using the flag --fanspeed.  The --info flag will display the temperatures of all the sensors on the card.

Offline

#11 2010-10-04 02:00:56

STM
Member
Registered: 2010-04-21
Posts: 13

Re: GPU running at high temperature at idle

$ sudo nvclock --fanspeed 100
Error: adjustment of the fanspeed isn't supported on your type of videocard!

Nope, but thanks for the suggestion. It also says my GPU temp is -372. tongue


New account: tjbp

Offline

Board footer

Powered by FluxBB