You are not logged in.

#1 2011-01-29 09:52:00

aurelieng
Member
Registered: 2010-02-02
Posts: 80

Problem after suspend to RAM: randomly freezing for 2-3 seconds...

Hi all,

Since a few months, KDE often freezes randomly for 2-3 secondes. It seems to occur when moving the mouse, either to move/resize a window, or to move the pointer from one window to another. It often happen when I play around with with Dophin, Okular, Gwenview, OpenOffice, or the 3D molecular viewer UCSF Chimera which extensively uses OpenGL. I initially attributed this annoying behavior to the NVIDIA driver 256.44 [https://bbs.archlinux.org/viewtopic.php?id=102202]. Unfortunately, it was still here with the 256.53, and is still not solved with 260.19.29 or 260.19.36. Nothing in dmesg, /var/log/message, /var/log/Xorg.0.log, or ~/.xsession.errors. I noticed that the System Load Viewer plasmoid I embedded in the task bar reports a very high load on one core when this problem occurs. I tried to monitor further the activity of the machine with top and iotop, but the output of both is frozen as well.

After hibernation, playing with nvidia-settings/powermizer seems to help. These freezes mainly occur with the packaged binary driver, but also, less frequently, with the official binary driver. This is however probably subjective.

Hardware details : Dell M6400 w/
- nVidia Corporation G94M [Quadro FX 2700M]
- Intel(R) Core(TM)2 Extreme CPU Q9300

Software details: Arch Linx x86_64 (I update it daily):
- KDE 4.6.00
- lib32-nvidia-utils 260.19.29-2
- nvidia 260.19.36-1
- nvidia-utils 260.19.36-1
- kernel26 2.6.36.3-2
- xorg-server 1.9.2-2

I already asked for help in the nvnews forum (http://www.nvnews.net/vbulletin/showthread.php?t=158248) but nobody seems to care about it sad

What else would be needed in order to help identifying the problem ?

Thanks for your help,

A.

Offline

#2 2011-01-29 12:59:41

augegr
Member
Registered: 2007-10-03
Posts: 36

Re: Problem after suspend to RAM: randomly freezing for 2-3 seconds...

Yeah same problem here. I really wish to help but I don't get any errors on any log files that I look into.

Maybe someone with more knowledge can help us out to, at least, debug the thing?

Offline

#3 2011-02-03 03:54:32

aurelieng
Member
Registered: 2010-02-02
Posts: 80

Re: Problem after suspend to RAM: randomly freezing for 2-3 seconds...

Offline

#4 2011-03-01 08:03:23

aurelieng
Member
Registered: 2010-02-02
Posts: 80

Re: Problem after suspend to RAM: randomly freezing for 2-3 seconds...

Hi all,

It seems that most freezes are gone with:
- 270.29 beta driver
- MTRR enabled by appending enable_mtrr_cleanup mtrr_spare_reg_nr=1 to the list of kernel options (see http://www.nvnews.net/vbulletin/showpos … tcount=39)

I didn't investigate further to  know if both the driver and the MTRR trick are required.

Thanks a lot,

Aurel.

Offline

Board footer

Powered by FluxBB