You are not logged in.

#1 2010-04-16 11:05:55

TomMan81
Member
Registered: 2009-10-15
Posts: 8

Plymouth Boot Splash only Text Mode

Hi,

I recently installed Plymouth, following the instructions on the wiki page about Plymouth, but when I try and boot I only get a text boot with a blue progress bar at the bottom. I have an intel graphics card and KMS is definitely on and I added it to /etc/mkinitcpio.conf.

Offline

#2 2010-04-16 11:21:37

hokasch
Member
Registered: 2007-09-23
Posts: 1,461

Re: Plymouth Boot Splash only Text Mode

Have you set a theme?

Offline

#3 2010-04-16 11:28:02

TomMan81
Member
Registered: 2009-10-15
Posts: 8

Re: Plymouth Boot Splash only Text Mode

Yeah, I did (as root):

plymouth-set-default-theme fade-in
mkinitcpio -p kernel26

Offline

#4 2010-04-16 12:28:29

hokasch
Member
Registered: 2007-09-23
Posts: 1,461

Re: Plymouth Boot Splash only Text Mode

Hmm, no idea really...
I think it normally falls back in text mode either because "splash" is not set in grub's kernel line, or it has some beef with KMS. Maybe you can find something in the logs?

Offline

#5 2010-04-16 12:43:46

davvil
Member
Registered: 2008-05-06
Posts: 165

Re: Plymouth Boot Splash only Text Mode

I can confirm this also happens to me, with a similar setup (intel + KMS). When I turn the computer off the theme comes all right (and I must admit it is impressive wink), but at boot time only text mode appears. I didn't give it much thought, however, because of the various warnings about plymouth still being under development etc. and changed to splashy. But I would like to get it working to impress visitors big_smile

Last edited by davvil (2010-04-16 13:42:37)

Offline

#6 2010-04-16 14:02:50

jerf
Member
Registered: 2009-06-03
Posts: 29

Re: Plymouth Boot Splash only Text Mode

I have the same issue. During boot there is only progress bar at the bottom and text at the center of the screen. And unlike the situation described in previous post, I have just black screen at power off.
The system is: netbook with Intel 945GME graphics, kernel 2.6.33.2, KMS is enabled, plymouth is in the hooks array

HOOKS="base udev autodetect plymouth pata scsi sata filesystems"

I've chosen the theme and rebuilt the kernel image as root:

plymouth-set-default-theme spinfinity
mkinitcpio -p kernel26

and in /boot/grub/menu.lst I've added to the kernel command line options "quiet" and "splash" and there are no "vga":

kernel /vmlinuz26 root=/dev/disk/by-uuid/69d2946e-450d-4ced-9556-b63ebd64dd79 ro quiet splash

Plymouth was installed as package plymouth-git from AUR.

Offline

#7 2010-04-17 10:39:01

mikioma
Member
From: Spain
Registered: 2009-03-26
Posts: 18

Re: Plymouth Boot Splash only Text Mode

Exactly the very same issue here!!!! Intel 945GME, latest kernel, plymouth-git. Plymouth defaults to text mode during boot but shows up graphical process during shutdown...

... any clue?

Thanks in advance!

Offline

#8 2010-04-19 19:46:51

Pyntux
Member
From: Serbia
Registered: 2008-12-21
Posts: 275

Re: Plymouth Boot Splash only Text Mode

Same issue here...Dell laptop, intel+kms...Does someone try plymouth from aur, no plymouth-git?

Last edited by Pyntux (2010-04-19 19:47:30)


I do not speak English, but I understand...

Offline

#9 2010-04-20 14:21:10

franzrogar
Member
From: Spain
Registered: 2010-03-26
Posts: 35

Re: Plymouth Boot Splash only Text Mode

I had same issues as you, jarryson fixed them today. Kudos for him smile

Reinstall plymouth-git


Franz Rogar
MOTM : "Quis custodiet ipsos custodes?"

Offline

#10 2010-04-26 21:43:42

mikioma
Member
From: Spain
Registered: 2009-03-26
Posts: 18

Re: Plymouth Boot Splash only Text Mode

I've rebuilt plymouth-git... rerun mkinitcpio -p kernel26... rerun plymouth-set-default-theme solar...

... still the same. Text mode progress bar during boot... but full graphical during shutdown.

Anyone else?

Thanks!

Offline

#11 2010-04-26 22:38:39

franzrogar
Member
From: Spain
Registered: 2010-03-26
Posts: 35

Re: Plymouth Boot Splash only Text Mode

mikioma wrote:

I've rebuilt plymouth-git... rerun mkinitcpio -p kernel26... rerun plymouth-set-default-theme solar...

Hum... the order is not correct: first, set the theme, then mkinitcpio.


Franz Rogar
MOTM : "Quis custodiet ipsos custodes?"

Offline

#12 2010-04-27 14:40:42

scio
Member
From: Buffalo, NY
Registered: 2008-08-05
Posts: 366

Re: Plymouth Boot Splash only Text Mode

franzrogar wrote:
mikioma wrote:

I've rebuilt plymouth-git... rerun mkinitcpio -p kernel26... rerun plymouth-set-default-theme solar...

Hum... the order is not correct: first, set the theme, then mkinitcpio.

or do it in one shot with:

sudo plymouth-set-default-theme solar --rebuild-initrd

That sets the theme and then runs mkinitcpio for you (assuming default kernel).

Offline

#13 2010-04-30 05:59:06

mikioma
Member
From: Spain
Registered: 2009-03-26
Posts: 18

Re: Plymouth Boot Splash only Text Mode

Ok... tried in the order you say... but still the same. I've updated plymouth-git... updated kernel (pacman -Syu did tongue), reinstalled plymouth-git... still the same.

Thanks for your answers! smile

Offline

#14 2010-04-30 18:59:39

adee
Member
From: The Moon
Registered: 2009-11-10
Posts: 107

Re: Plymouth Boot Splash only Text Mode

Do you use KMS early start? My GeForce 8600GT + nouveau + plymouth works only with early start, late start gives me the text boot progress bar

Offline

#15 2010-05-05 05:48:22

mikioma
Member
From: Spain
Registered: 2009-03-26
Posts: 18

Re: Plymouth Boot Splash only Text Mode

Sorry for the delay.

Ok, I tried it out and... indeed early KMS made things a bit better because now screen resolution gets fixed immediately, while previouly the progress bar appeared on a smaller resolution and later KMS changed it to standard 1024x600.

Yet, I'm still to the progress bar... No solar theme appears during boot.

Thanks so much for your answers!

Offline

#16 2010-10-29 16:58:32

Berseker
Member
From: Near Lecco, Italy
Registered: 2008-04-24
Posts: 255

Re: Plymouth Boot Splash only Text Mode

same problem with my htpc box..
integrated ati 4250 (asus m4a88-t-i deluxe), xf86-video-ati-git, radeon module correctly loaded, driver, mkinitcpio.conf edited by adding radeon to modules and plymouth after base, udev and autodetect in hooks, theme selected and build on initrd succeded, grub.cfg edited by adding modeset=1 and quiet splash on kernel line.

During boot no splash, during shutdown works flawlessly.. if anyone have some suggestions they're welcome wink

sorry for my bad english

Offline

#17 2010-11-13 11:07:51

Berseker
Member
From: Near Lecco, Italy
Registered: 2008-04-24
Posts: 255

Re: Plymouth Boot Splash only Text Mode

no one can help?

Offline

#18 2010-12-16 15:35:48

Diaz
Member
From: Lisbon, Portugal
Registered: 2008-04-16
Posts: 361
Website

Re: Plymouth Boot Splash only Text Mode

I was having the same issue. Not sure if this is the cause, but i changed the order in the HOOKS and worked...weird stuff.

Was: HOOKS="base udev keymap autodetect sata resume filesystems pymouth"
IS: HOOKS="base udev plymouth keymap autodetect sata resume filesystems"


Owner of Asus 1215B :: User of Xfce :: Vasco Dias @blog

Offline

#19 2010-12-18 18:22:27

molecula21
Member
Registered: 2010-10-20
Posts: 33

Re: Plymouth Boot Splash only Text Mode

Same problem here... tried all the suggestions above, non of them worked. Any news?

Offline

#20 2011-05-19 12:04:32

twilight0
Member
From: Greece
Registered: 2011-05-01
Posts: 227
Website

Re: Plymouth Boot Splash only Text Mode

Sorry to dig this thread up but it may be useful to those who are after plymouth. After trying all options and configurations, I managed to get plymouth working by doing an early KMS start:

For Radeon users:

https://wiki.archlinux.org/index.php/Ra … _KMS_start

For Intel users:

https://wiki.archlinux.org/index.php/In … Setting.29


Proud Arch Linux user since 2007.

Offline

Board footer

Powered by FluxBB