You are not logged in.

#1 2011-05-05 11:24:36

lgolebio
Member
From: Poland / Wroclaw
Registered: 2008-07-28
Posts: 101

Xfce mousepad text editor takes a lot of time to exit.

Hi
As I am a happy user of XFCE, I have a strange problem with great mousepad.

1. Open text file with mousepad.
2. Copy the text.
3. Try to shut down mousepad, and it takes 5-10 seconds before it shuts down. hmm

What may be the problem ?

Offline

#2 2011-05-05 11:44:27

Cdh
Member
Registered: 2009-02-03
Posts: 1,098

Re: Xfce mousepad text editor takes a lot of time to exit.

Leafpad has the same problem. I have never found out that copying text is the problem. Interesting.

Last edited by Cdh (2011-05-05 11:45:14)


฿ 18PRsqbZCrwPUrVnJe1BZvza7bwSDbpxZz

Offline

#3 2011-05-05 11:58:30

vinayv
Member
From: Bangalore, India
Registered: 2008-08-11
Posts: 89

Re: Xfce mousepad text editor takes a lot of time to exit.

Till last week, I was using LXDE in Arch and plain old openbox in debian (for about 3-4 years).. I use Leafpad (and have used mousepad also for a brief period)
I have to say I have never seen this problem. I am sure I have encountered this copying and closing use case many a times..

One thing is that I always used run parcelite clipboard manager..

Offline

#4 2011-05-05 12:02:22

disastrophe
Member
From: pdx
Registered: 2010-10-08
Posts: 91

Re: Xfce mousepad text editor takes a lot of time to exit.

For me, removing the Clipman plugin solved the issue for mousepad & xfce.

Last edited by disastrophe (2011-05-05 12:03:28)


"If we believe absurdities, we shall commit atrocities." ~ Voltaire

Offline

#5 2011-05-05 12:16:17

lgolebio
Member
From: Poland / Wroclaw
Registered: 2008-07-28
Posts: 101

Re: Xfce mousepad text editor takes a lot of time to exit.

Nope, removing clipman doesn't help. Any other ideas ?

Offline

#6 2011-05-05 12:56:26

disastrophe
Member
From: pdx
Registered: 2010-10-08
Posts: 91

Re: Xfce mousepad text editor takes a lot of time to exit.

Another thing I noticed after a fresh xfce install was that the permissions were messed up in ~/.config/mousepad and ownership was set to root.(it was generating an error on shutdown using dbus-launch) So I took ownership and set permissions to 755. That was the only other thing I did. Anyway, it's working perfectly for me.

Last edited by disastrophe (2011-05-05 12:58:52)


"If we believe absurdities, we shall commit atrocities." ~ Voltaire

Offline

#7 2011-05-05 13:16:23

Murray_B
Member
From: Germany
Registered: 2008-07-29
Posts: 112

Re: Xfce mousepad text editor takes a lot of time to exit.

Same problem with mousepad here, too. I got the advice to switch over to leafpad, but I now use gvim or gedit.gedit is maybe the easier one ;-) I was told that there isn't really a developer working on mousepad and that there are many unfixed bugs in it. I really like Xfce but it seems, they need some more devs, there are many unmaintained Xfce-programs. Maybe Gnome 3 is bringing some new developer to Xfce.

Offline

#8 2011-05-05 13:19:15

tpfkanep
Member
From: South Africa
Registered: 2009-12-15
Posts: 60

Re: Xfce mousepad text editor takes a lot of time to exit.

also on xfce, and i can confirm that this also appens with:
- geany
- gnumeric

Sometimes the delay is only noticed when I above run from cmdline.

Last edited by tpfkanep (2011-05-05 13:20:42)

Offline

#9 2011-05-05 13:35:42

vinayv
Member
From: Bangalore, India
Registered: 2008-08-11
Posts: 89

Re: Xfce mousepad text editor takes a lot of time to exit.

tpfkanep wrote:

also on xfce, and i can confirm that this also appens with:
- geany
- gnumeric

Sometimes the delay is only noticed when I above run from cmdline.

Does the delay happen only in xfce environment? How about other environments like lxde or fluxbox, openbox or even gnome? Do same applications (geany, leafpad, mousepad, gnumeric) behave the same way there too?

I just want to understand if this is a problem with xfce or individual apps..

Offline

#10 2011-05-05 14:18:33

stqn
Member
Registered: 2010-03-19
Posts: 1,189
Website

Re: Xfce mousepad text editor takes a lot of time to exit.

Hey, I've had this problem with Mousepad forever, but had never noticed it happened after copying some text! That's a good find smile.

If I copy text in another app before closing Mousepad, there is no delay.

I'm not using Clipman (because it crashes as soon as I copy something in Code::Blocks.)

It also happens with geany; even though it closes its window immediately, it doesn't return control to the shell until a few seconds later.

Running Xfce.

Offline

#11 2011-05-05 14:19:37

tpfkanep
Member
From: South Africa
Registered: 2009-12-15
Posts: 60

Re: Xfce mousepad text editor takes a lot of time to exit.

installed lxde - behaviour of geany and gnumeric perfect...

Offline

#12 2011-05-05 17:10:04

vinayv
Member
From: Bangalore, India
Registered: 2008-08-11
Posts: 89

Re: Xfce mousepad text editor takes a lot of time to exit.

tpfkanep wrote:

installed lxde - behaviour of geany and gnumeric perfect...

Maybe you should file this as a bug in xfce as the behaviour is limited to xfce alone

Offline

#13 2011-05-08 06:36:38

tpfkanep
Member
From: South Africa
Registered: 2009-12-15
Posts: 60

Re: Xfce mousepad text editor takes a lot of time to exit.

https://bugzilla.xfce.org/show_bug.cgi?id=7588 looks like it is clipboard manager related.

Offline

#14 2011-05-31 02:31:54

TurkBits
Member
Registered: 2010-11-01
Posts: 4

Re: Xfce mousepad text editor takes a lot of time to exit.

lgolebio wrote:

Hi
As I am a happy user of XFCE, I have a strange problem with great mousepad.

1. Open text file with mousepad.
2. Copy the text.
3. Try to shut down mousepad, and it takes 5-10 seconds before it shuts down. hmm

What may be the problem ?

May be, you are install xclip and xfce4-clipman-plugin.
I removed xclip in my computer, problem solved for me.

Last edited by TurkBits (2011-05-31 02:34:48)

Offline

#15 2011-05-31 05:56:33

lgolebio
Member
From: Poland / Wroclaw
Registered: 2008-07-28
Posts: 101

Re: Xfce mousepad text editor takes a lot of time to exit.

Nope, I have clipman installed and the problem was solved some time ago. One of the updates fixed the bug, but i don't know which one. smile

Offline

Board footer

Powered by FluxBB