You are not logged in.

#1 2011-06-02 11:43:18

markhadman
Member
Registered: 2010-10-09
Posts: 38

jackd - failed to open alsa seq

I did an update last night, and on reboot this morning jackd complains that it cannot open /dev/snd/seq due to Permission denied. I have already downgraded jackd to 0.118 to no avail - other noteworthy updates last night include the kernel & udev.

Here's the full output of jackd, followed by last night's additions to /var/log/pacman.log - any informed ideas would be appreciated.

12:17:41.391 Patchbay activated.
12:17:41.474 Statistics reset.
12:17:41.519 Could not open ALSA sequencer as a client. ALSA MIDI patchbay will be not available.
12:17:43.867 Startup script...
12:17:43.868 artsshell -q terminate
ALSA lib seq_hw.c:457:(snd_seq_hw_open) open /dev/snd/seq failed: Permission denied
sh: artsshell: command not found
12:17:44.277 Startup script terminated with exit status=32512.
12:17:44.278 JACK is starting...
12:17:44.278 /usr/bin/jackd -P89 -dalsa -r44100 -p1024 -n2 -Xseq -D -Chw:1,0 -Phw:1,0
jackd 0.118.0
Copyright 2001-2009 Paul Davis, Stephane Letz, Jack O'Quinn, Torben Hohn and others.
jackd comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
Memory locking is unlimited - this is dangerous. You should probably alter the line:
     @audio   -  memlock    unlimited
in your /etc/limits.conf to read:
     @audio   -  memlock    965454
12:17:44.302 JACK was started with PID=2221.
could not open driver .so '/usr/lib/jack/jack_firewire.so': libffado.so.2: cannot open shared object file: No such file or directory
JACK compiled with System V SHM support.
loading driver ..
apparent rate = 44100
creating alsa driver ... hw:1,0|hw:1,0|1024|2|44100|0|0|nomon|swmeter|-|32bit
control device hw:1
configuring for 44100Hz, period = 1024 frames (23.2 ms), buffer = 2 periods
ALSA: final selected sample format for capture: 32bit integer little-endian
ALSA: use 2 periods for capture
ALSA: final selected sample format for playback: 32bit integer little-endian
ALSA: use 2 periods for playback
ALSA lib seq_hw.c:457:(snd_seq_hw_open) open /dev/snd/seq failed: Permission denied
failed to open alsa seq
ALSA: cannot attach midi: -13
12:17:46.508 JACK connection change.
12:17:46.510 Server configuration saved to "/home/mark/.jackdrc".
12:17:46.512 Statistics reset.
12:17:48.311 Client activated.
12:17:48.311 Post-startup script...
12:17:48.312 jack_connect system:capture_11 system:playback_3; jack_connect system:capture_12 system:playback_4
12:17:48.750 Post-startup script terminated successfully.
12:17:48.751 JACK active patchbay scan...
12:17:48.753 patch: system:capture_11 -> system:playback_3 checked.
12:17:48.754 patch: system:capture_12 -> system:playback_4 checked.
[2011-06-02 01:04] Running 'pacman -Sy'
[2011-06-02 01:04] synchronizing package lists
[2011-06-02 01:05] starting full system upgrade
[2011-06-02 01:07] Running 'pacman -S -u'
[2011-06-02 01:07] starting full system upgrade
[2011-06-02 01:24] upgraded acpid (2.0.10-1 -> 2.0.10-2)
[2011-06-02 01:24] upgraded jack (0.120.1-1 -> 0.120.2-1)
[2011-06-02 01:24] upgraded allegro (4.4.1.1-2 -> 4.4.2-1)
[2011-06-02 01:24] upgraded apr (1.4.4-1 -> 1.4.5-1)
[2011-06-02 01:24] upgraded apr-util (1.3.11-1 -> 1.3.12-1)
[2011-06-02 01:24] upgraded bluez (4.93-1 -> 4.93-2)
[2011-06-02 01:24] upgraded boost-libs (1.46.0-4 -> 1.46.1-1)
[2011-06-02 01:24] upgraded boost (1.46.0-4 -> 1.46.1-1)
[2011-06-02 01:24] upgraded nspr (4.8.7-1 -> 4.8.8-1)
[2011-06-02 01:24] upgraded nss (3.12.9-1 -> 3.12.10-1)
[2011-06-02 01:24] upgraded chromium (11.0.696.68-1 -> 11.0.696.71-1)
[2011-06-02 01:24] upgraded startup-notification (0.10-2 -> 0.12-1)
[2011-06-02 01:25] upgraded claws-mail (3.7.9-2 -> 3.7.9-3)
[2011-06-02 01:25] upgraded consolekit (0.4.4-1 -> 0.4.5-1)
[2011-06-02 01:25] upgraded deadbeef (0.5.0-2 -> 0.5.1-1)
[2011-06-02 01:25] upgraded glib2 (2.28.6-1 -> 2.28.7-1)
[2011-06-02 01:25] upgraded pango (1.28.4-2 -> 1.28.4-3)
[2011-06-02 01:25] upgraded gtk3 (3.0.9-2 -> 3.0.10-2)
[2011-06-02 01:25] upgraded libgnome-keyring (3.0.1-1 -> 3.0.3-1)
[2011-06-02 01:25] upgraded evince (3.0.0-4 -> 3.0.2-1)
[2011-06-02 01:25] upgraded flowcanvas (0.7.1-1 -> 0.7.1-2)
[2011-06-02 01:25] upgraded glew (1.5.8-1 -> 1.6.0-1)
[2011-06-02 01:25] upgraded glib-networking (2.28.6.1-2 -> 2.28.7-1)
[2011-06-02 01:25] upgraded gnome-keyring (3.0.2-1 -> 3.0.3-1)
[2011-06-02 01:25] upgraded gnome-mplayer (1.0.3-2 -> 1.0.3-3)
[2011-06-02 01:25] upgraded goffice (0.8.14-1 -> 0.8.15-1)
[2011-06-02 01:25] upgraded gnumeric (1.10.14-1 -> 1.10.15-1)
[2011-06-02 01:25] upgraded parted (2.3-1 -> 2.4-1)
[2011-06-02 01:25] upgraded gparted (0.8.0-2 -> 0.8.1-1)
[2011-06-02 01:25] upgraded gperf (3.0.4-2 -> 3.0.4-3)
[2011-06-02 01:25] upgraded gtksourceview3 (3.0.1-1 -> 3.0.3-1)
[2011-06-02 01:25] upgraded libsoup (2.34.1-1 -> 2.34.2-1)
[2011-06-02 01:25] upgraded libsoup-gnome (2.34.1-1 -> 2.34.2-1)
[2011-06-02 01:25] upgraded gvfs (1.8.1-1 -> 1.8.2-1)
[2011-06-02 01:25] ATTENTION UDEV:
[2011-06-02 01:25] ---------------
[2011-06-02 01:25] Kernel 2.6.32 or newer is now required.
[2011-06-02 01:25] OSS emulation modules are not loaded by default, add to rc.conf if needed.
[2011-06-02 01:25] Arch specific cd symlinks are now no longer created.
[2011-06-02 01:25] cd and net persistent rules will no longer be autogenerated,
[2011-06-02 01:25] see <https://wiki.archlinux.org/index.php/Udev> for details.
[2011-06-02 01:25] Errors are now logged (possibly to the console) by default.
[2011-06-02 01:25] ---------------
[2011-06-02 01:25] upgraded udev (168-2 -> 171-1)
[2011-06-02 01:25] upgraded upower (0.9.10-1 -> 0.9.11-1)
[2011-06-02 01:25] upgraded udisks (1.0.3-2 -> 1.0.3-3)
[2011-06-02 01:25] upgraded kdelibs (4.6.3-2 -> 4.6.3-3)
[2011-06-02 01:26] >>> Updating module dependencies. Please wait ...
[2011-06-02 01:26] >>> MKINITCPIO SETUP
[2011-06-02 01:26] >>> ----------------
[2011-06-02 01:26] >>> If you use LVM2, Encrypted root or software RAID,
[2011-06-02 01:26] >>> Ensure you enable support in /etc/mkinitcpio.conf .
[2011-06-02 01:26] >>> More information about mkinitcpio setup can be found here:
[2011-06-02 01:26] >>> http://wiki.archlinux.org/index.php/Mkinitcpio
[2011-06-02 01:26] 
[2011-06-02 01:26] >>> Generating initial ramdisk, using mkinitcpio.  Please wait...
[2011-06-02 01:26] ==> Building image "default"
[2011-06-02 01:26] ==> Running command: /sbin/mkinitcpio -k 2.6.38-ARCH -c /etc/mkinitcpio.conf -g /boot/kernel26.img
[2011-06-02 01:26] :: Begin build
[2011-06-02 01:26] :: Parsing hook [base]
[2011-06-02 01:26] :: Parsing hook [udev]
[2011-06-02 01:26] :: Parsing hook [autodetect]
[2011-06-02 01:26] :: Parsing hook [pata]
[2011-06-02 01:26] :: Parsing hook [scsi]
[2011-06-02 01:26] :: Parsing hook [sata]
[2011-06-02 01:26] :: Parsing hook [filesystems]
[2011-06-02 01:26] :: Generating module dependencies
[2011-06-02 01:26] :: Generating image '/boot/kernel26.img'...SUCCESS
[2011-06-02 01:26] ==> SUCCESS
[2011-06-02 01:26] ==> Building image "fallback"
[2011-06-02 01:26] ==> Running command: /sbin/mkinitcpio -k 2.6.38-ARCH -c /etc/mkinitcpio.conf -g /boot/kernel26-fallback.img -S autodetect
[2011-06-02 01:26] :: Begin build
[2011-06-02 01:26] :: Parsing hook [base]
[2011-06-02 01:26] :: Parsing hook [udev]
[2011-06-02 01:26] :: Parsing hook [pata]
[2011-06-02 01:26] :: Parsing hook [scsi]
[2011-06-02 01:27] :: Parsing hook [sata]
[2011-06-02 01:27] :: Parsing hook [filesystems]
[2011-06-02 01:27] :: Generating module dependencies
[2011-06-02 01:27] :: Generating image '/boot/kernel26-fallback.img'...SUCCESS
[2011-06-02 01:27] ==> SUCCESS
[2011-06-02 01:27] upgraded kernel26 (2.6.38.6-2 -> 2.6.38.7-1)
[2011-06-02 01:27] upgraded less (443-1 -> 443-2)
[2011-06-02 01:27] upgraded libass (0.9.11-1 -> 0.9.12-1)
[2011-06-02 01:27] upgraded libftdi (0.18-2 -> 0.19-1)
[2011-06-02 01:27] upgraded libjpeg-turbo (1.1.0-1 -> 1.1.1-1)
[2011-06-02 01:27] upgraded libmysqlclient (5.5.12-1 -> 5.5.13-1)
[2011-06-02 01:27] upgraded libpurple (2.7.11-3 -> 2.7.11-5)
[2011-06-02 01:27] upgraded libssh (0.4.8-1 -> 0.5.0-1)
[2011-06-02 01:27] upgraded libtorrent-rasterbar (0.15.6-1 -> 0.15.6-2)
[2011-06-02 01:27] upgraded mkinitcpio-busybox (1.18.2-1 -> 1.18.4-1)
[2011-06-02 01:27] upgraded neon (0.29.3-3 -> 0.29.6-1)
[2011-06-02 01:27] upgraded ntrack (1:13-1 -> 1:13-2)
[2011-06-02 01:27] upgraded pidgin (2.7.11-3 -> 2.7.11-5)
[2011-06-02 01:27] upgraded pkg-config (0.25-3 -> 0.26-1)
[2011-06-02 01:27] upgraded ruby (1.9.2_p180-1 -> 1.9.2_p180-2)
[2011-06-02 01:27] upgraded sox (14.3.2-2 -> 14.3.2-3)
[2011-06-02 01:27] upgraded spring (0.82.7.1-2 -> 0.82.7.1-4)
[2011-06-02 01:27] upgraded springlobby (0.131-1 -> 0.131-2)
[2011-06-02 01:27] upgraded sudo (1.8.1.p1-1 -> 1.8.1.p2-1)
[2011-06-02 01:27] upgraded thunar (1.2.1-2 -> 1.2.2-1)
[2011-06-02 01:27] upgraded totem-plparser (2.32.4-1 -> 2.32.5-1)
[2011-06-02 01:27] upgraded v4l-utils (0.8.3-1 -> 0.8.3-2)
[2011-06-02 01:27] upgraded vala (0.12.0-1 -> 0.12.1-1)
[2011-06-02 01:28] upgraded vlc (1.1.9-1 -> 1.1.9-3)
[2011-06-02 01:28] upgraded xfdesktop (4.8.2-1 -> 4.8.2-2)
[2011-06-02 01:28] upgraded xorg-iceauth (1.0.4-2 -> 1.0.5-1)
[2011-06-02 01:28] upgraded xorg-server-common (1.10.1-1 -> 1.10.2-1)
[2011-06-02 01:28] upgraded xorg-server (1.10.1-1 -> 1.10.2-1)
[2011-06-02 01:28] upgraded xorg-xauth (1.0.5-2 -> 1.0.6-1)
[2011-06-02 01:28] upgraded xscreensaver (5.13-1 -> 5.14-1)
[2011-06-02 12:09] Running 'pacman -Sy'
[2011-06-02 12:09] synchronizing package lists
[2011-06-02 12:09] starting full system upgrade
[2011-06-02 12:12] Running 'pacman -U /home/mark/Packages/jack-0.118.0-4-i686.pkg.tar.xz'
[2011-06-02 12:12] upgraded jack (0.120.2-1 -> 0.118.0-4)

Offline

#2 2011-06-02 12:01:54

karol
Archivist
Registered: 2009-05-06
Posts: 25,433

Re: jackd - failed to open alsa seq

Are you in the right group?

[karol@black ~]$ ls -al /dev/snd/seq 
crw------- 1 root audio 116, 1 06-02 13:18 /dev/snd/seq

Edit: There's a bugreport https://bugs.archlinux.org/task/24362 and a thread https://bbs.archlinux.org/viewtopic.php?pid=937274 already.

Last edited by karol (2011-06-02 12:05:36)

Offline

#3 2011-06-02 12:28:59

markhadman
Member
Registered: 2010-10-09
Posts: 38

Re: jackd - failed to open alsa seq

OK, so it's a udev bug. Reloading the snd_seq module manually creates the node with the correct permissions, and jackd can now access it.

[mark@squid ~]$ ls -al /dev/snd/seq
crw------- 1 root audio 116, 1 Jun  2 12:17 /dev/snd/seq
[mark@squid ~]$ sudo modprobe snd_seq
Password: 
[mark@squid ~]$ ls -al /dev/snd/seq
crw-rw---- 1 root audio 116, 1 Jun  2 13:26 /dev/snd/seq

A more permanent workaround seem to be to add snd_seq to the modules array in /etc/rc.conf , which I will try later.

EDIT: tried it, works. Thanks for the pointers, Karol

Last edited by markhadman (2011-06-03 12:17:17)

Offline

Board footer

Powered by FluxBB