You are not logged in.

#1 2011-06-30 19:24:16

gsg
Member
Registered: 2008-02-08
Posts: 14

[SOLVED] After fresh install (Netinstall) can't login in text mode.

After fresh install (Netinstall image) can't login in text mode.
After boot everiting goes fine (I see text scroling) but at some point monitor changes resolution and shows distorted blue image. I have tryed option vga=773, vga=769 in GRUB menu but it only changes the resolution before the point at witch again something happens and screen changes to distorted image.

Last edited by gsg (2011-06-30 20:52:10)

Offline

#2 2011-06-30 19:46:24

karol
Archivist
Registered: 2009-05-06
Posts: 25,433

Re: [SOLVED] After fresh install (Netinstall) can't login in text mode.

Just to make sure, you're not booting straight to X, right?
Does Alt-F2 etc. switching work?
Can you boot into single mode or use a liveCD to look at some logs?

Offline

#3 2011-06-30 20:00:03

gsg
Member
Registered: 2008-02-08
Posts: 14

Re: [SOLVED] After fresh install (Netinstall) can't login in text mode.

I havn't installed X at all. Alt-F2 doesn't work. I can see the logs. For hhat to look in the logs?

Offline

#4 2011-06-30 20:30:40

gsg
Member
Registered: 2008-02-08
Posts: 14

Re: [SOLVED] After fresh install (Netinstall) can't login in text mode.

I suposse the problem is in nouveaufb from dmesg.log i see these errors:

[    5.591472] nouveau 0000:00:05.0: PCI INT A -> Link[APC7] -> GSI 16 (level, low) -> IRQ 16
[    5.591477] nouveau 0000:00:05.0: setting latency timer to 64
[    5.592788] [drm] nouveau 0000:00:05.0: Detected an NV40 generation card (0x04e000a2)
[    5.594152] [drm] nouveau 0000:00:05.0: Attempting to load BIOS image from PRAMIN
[    5.672641] [drm] nouveau 0000:00:05.0: ... appears to be valid
[    5.672647] [drm] nouveau 0000:00:05.0: BIT BIOS found
[    5.672651] [drm] nouveau 0000:00:05.0: Bios version 05.51.28.39
[    5.672655] [drm] nouveau 0000:00:05.0: TMDS table version 1.1
[    5.672657] [drm] nouveau 0000:00:05.0: TMDS table script pointers not stubbed
[    5.672660] [drm] nouveau 0000:00:05.0: BIT table 'd' not found
[    5.672662] [drm] nouveau 0000:00:05.0: Found Display Configuration Block version 3.0
[    5.672666] [drm] nouveau 0000:00:05.0: Raw DCB entry 0: 02000300 00000023
[    5.672670] [drm] nouveau 0000:00:05.0: DCB connector table: VHER 0x30 5 10 2
[    5.672674] [drm] nouveau 0000:00:05.0:   0: 0x00000000: type 0x00 idx 0 tag 0xff
[    5.672684] [drm] nouveau 0000:00:05.0: Parsing VBIOS init table 0 at offset 0xCE85
[    5.672753] [drm] nouveau 0000:00:05.0: Parsing VBIOS init table 1 at offset 0xCFDC
[    5.672756] [drm] nouveau 0000:00:05.0: Parsing VBIOS init table 2 at offset 0xCFDD
[    5.673100] [drm] nouveau 0000:00:05.0: Parsing VBIOS init table 3 at offset 0xD15F
[    5.673106] [drm] nouveau 0000:00:05.0: Parsing VBIOS init table 4 at offset 0xD1A8

[    6.094466] [drm] nouveau 0000:00:05.0: 3 available performance level(s)
[    6.094472] [drm] nouveau 0000:00:05.0: 0: memory 0MHz core 100MHz fanspeed 100%
[    6.094477] [drm] nouveau 0000:00:05.0: 1: memory 800MHz core 350MHz fanspeed 100%
[    6.094481] [drm] nouveau 0000:00:05.0: 2: memory 1000MHz core 425MHz fanspeed 100%
[    6.094489] [drm] nouveau 0000:00:05.0: c: memory 0MHz
[    6.096980] [TTM] Zone  kernel: Available graphics memory: 1514152 kiB.
[    6.096984] [TTM] Initializing pool allocator.
[    6.097010] [drm] nouveau 0000:00:05.0: Detected 64MiB VRAM
[    6.105481] [drm] nouveau 0000:00:05.0: 64 MiB GART (aperture)
[    6.105883] [drm] nouveau 0000:00:05.0: Saving VGA fonts

[    6.201841] [drm] Supports vblank timestamp caching Rev 1 (10.10.2010).
[    6.201860] [drm] No driver support for vblank timestamp query.

[    6.207596] [drm] nouveau 0000:00:05.0: Setting dpms mode 3 on vga encoder (output 0)

[    6.383127] [drm] nouveau 0000:00:05.0: allocated 1600x1200 fb: 0x49000, bo ffff8800b316d400
[    6.383297] fbcon: nouveaufb (fb0) is primary device
[    6.451438] [drm] nouveau 0000:00:05.0: Setting dpms mode 0 on vga encoder (output 0)
[    6.451443] [drm] nouveau 0000:00:05.0: Output VGA-1 is running on CRTC 0 using output B
[    6.453288] [drm] nouveau 0000:00:05.0: PFIFO_DMA_PUSHER - Ch 0 Get 0x1000e814 Put 0x0000124c State 0xc0020000 (err: MEM_FAULT) Push 0x00000000
[    6.453997] [drm] nouveau 0000:00:05.0: PFIFO_DMA_PUSHER - Ch 0 Get 0x1000e814 Put 0x000013cc State 0xc0020000 (err: MEM_FAULT) Push 0x00000000
[    6.454187] [drm] nouveau 0000:00:05.0: PFIFO_DMA_PUSHER - Ch 0 Get 0x1000e814 Put 0x000013cc State 0xc0020000 (err: MEM_FAULT) Push 0x00000000
[    6.454321] Console: switching to colour frame buffer device 200x75
[    6.455934] [drm] nouveau 0000:00:05.0: PFIFO_DMA_PUSHER - Ch 0 Get 0x1000e814 Put 0x000013cc State 0xc0020000 (err: MEM_FAULT) Push 0x00000000
[    6.456138] [drm] nouveau 0000:00:05.0: PFIFO_DMA_PUSHER - Ch 0 Get 0x1000e814 Put 0x00000af0 State 0xc0020000 (err: MEM_FAULT) Push 0x00000000
[    6.456336] [drm] nouveau 0000:00:05.0: PFIFO_DMA_PUSHER - Ch 0 Get 0x1000e814 Put 0x000017d4 State 0xc0020000 (err: MEM_FAULT) Push 0x00000000
[    6.456526] [drm] nouveau 0000:00:05.0: PFIFO_DMA_PUSHER - Ch 0 Get 0x1000e814 Put 0x000017d4 State 0xc0020000 (err: MEM_FAULT) Push 0x00000000
[    6.456616] fb0: nouveaufb frame buffer device
[    6.456618] drm: registered panic notifier
[    6.456626] [drm] Initialized nouveau 0.0.16 20090420 for 0000:00:05.0 on minor 0

[   12.362320] [drm] nouveau 0000:00:05.0: PFIFO_DMA_PUSHER - Ch 0 Get 0x1000e814 Put 0x00000130 State 0xc0020000 (err: MEM_FAULT) Push 0x00000000

How to disable nouveau?

Last edited by gsg (2011-06-30 20:34:07)

Offline

#5 2011-06-30 20:32:05

Inxsible
Forum Fellow
From: Chicago
Registered: 2008-06-09
Posts: 9,079

Re: [SOLVED] After fresh install (Netinstall) can't login in text mode.

please use code tags instead of quote tags.


Forum Rules

There's no such thing as a stupid question, but there sure are a lot of inquisitive idiots !

Offline

#6 2011-06-30 20:35:22

karol
Archivist
Registered: 2009-05-06
Posts: 25,433

Re: [SOLVED] After fresh install (Netinstall) can't login in text mode.

Please use [ code ] tags instead of [ quote ] tags when pasting code https://bbs.archlinux.org/help.php#bbcode

Try adding 'nomodeset' to the kernel bootline. You may want to drop all the vga= for now.

Offline

#7 2011-06-30 20:50:34

gsg
Member
Registered: 2008-02-08
Posts: 14

Re: [SOLVED] After fresh install (Netinstall) can't login in text mode.

Thanks karol 'nomodeset' solved the problem.

Offline

Board footer

Powered by FluxBB