You are not logged in.

#1 2011-08-22 19:24:51

Registered: 2008-06-27
Posts: 3

[SOLVED]: Permanently change keyboard layout in XFCE?

Hi all! It's been a while since I've tried Arch, and it's good to be back. I am, however, having a bit of trouble with changing the keyboard layout. I have

Section "InputClass"
        Identifier "evdev pointer catchall"
        MatchIsPointer "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
        Option "XkbLayout" "us"
        Option "XkbVariant" "dvorak"

in my 10-evdev.conf, but XFCE still opens in QWERTY whenever I log in. I'm using gdm, so I tried putting

setxkbmap dvorak

in my ~/.xprofile, but no such luck. I've also tried Settings -> Keyboard -> Layout within XFCE, but that only changes the keyboard layout if I go in to that settings pane and actually change the layout (it says it's switched to dvorak but doesn't actually change the layout on boot) -- I'm guessing whenever there's a change, it executes

setxkbmap $NEWLAYOUT

. . .anyhow. Any suggestions?

Edit: In Settings -> Keyboard -> Layout, I switched from US/Dvorak to 'Use System Defaults' and everything was fine on reboot. Apparently it's a bug in the XFCE Applet.

Last edited by AndrewW (2011-08-22 19:29:43)


Board footer

Powered by FluxBB