You are not logged in.

#1 2011-09-22 08:10:15

xzakox
Member
Registered: 2011-09-01
Posts: 10

[SOLVED] Problem with MPD and ALSA

Hello, I'm having problems with mpd using alsa output.
My alsa system works, I can play mp3 using mplayer -ao alsa, and flash plugin plays sound, my user (and also mpd user)is in the audio group.
But then mpd can't open the alsa device.
If I tell mpd to autodetect audio, it can't find anything:

(Running as root to see output, if using /etc/rc.d/mpd start, it just fails)

output: No "audio_output" defined in config file
output: Attempt to detect audio output device
output: Attempting to detect a alsa audio device
ALSA lib confmisc.c:768:(parse_card) cannot find card '0'
ALSA lib conf.c:4184:(_snd_config_evaluate) function snd_func_card_driver returned error: No such file or directory
ALSA lib confmisc.c:392:(snd_func_concat) error evaluating strings
ALSA lib conf.c:4184:(_snd_config_evaluate) function snd_func_concat returned error: No such file or directory
ALSA lib confmisc.c:1251:(snd_func_refer) error evaluating name
ALSA lib conf.c:4184:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
ALSA lib conf.c:4663:(snd_config_expand) Evaluate error: No such file or directory
ALSA lib pcm.c:2212:(snd_pcm_open_noupdate) Unknown PCM default
alsa: Error opening default ALSA device: No such file or directory
output: Attempting to detect a oss audio device
oss: Error opening OSS device "/dev/dsp": No such file or directory
oss: Error opening OSS device "/dev/sound/dsp": No such file or directory
output: Attempting to detect a pulse audio device
mpd: src/output/pulse_output_plugin.c:400: pulse_output_wait_connection: Assertion `po->mainloop != ((void *)0)' failed.

and if I set up a basic alsa config...

audio_output {
        type            "alsa"
        name            "HDA-Intel"
}

It starts, but then playing anything:

% mpc play
Caspian - La Cerva
[paused]  #2/10   0:00/4:59 (0%)
volume: n/a   repeat: off   random: off   single: off   consume: off
ERROR: problems opening audio device

mpc.log output:

ALSA lib confmisc.c:768:(parse_card) cannot find card '0'
ALSA lib conf.c:4184:(_snd_config_evaluate) function snd_func_card_driver returned error: No such file or directory
ALSA lib confmisc.c:392:(snd_func_concat) error evaluating strings
ALSA lib conf.c:4184:(_snd_config_evaluate) function snd_func_concat returned error: No such file or directory
ALSA lib confmisc.c:1251:(snd_func_refer) error evaluating name
ALSA lib conf.c:4184:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
ALSA lib conf.c:4663:(snd_config_expand) Evaluate error: No such file or directory
ALSA lib pcm.c:2212:(snd_pcm_open_noupdate) Unknown PCM default
Sep 22 10:08 : output: Failed to open "HDA-Intel" [alsa]: Failed to open ALSA device "default": No such file or directory

I tried with different device and mixer settings and the error is always the same. It can't open alsa device.

Any Ideas?
Thank you.

Last edited by xzakox (2011-09-22 20:04:33)

Offline

#2 2011-09-22 11:39:56

Mr.Elendig
#archlinux@freenode channel op
From: The intertubes
Registered: 2004-11-07
Posts: 3,768

Re: [SOLVED] Problem with MPD and ALSA

Check that mpd is really being run as the mpd user, and that id lists audio for the mpd user. Also post your whole mpd.conf and the output from amixer when running as the user you run mpd as.

Last edited by Mr.Elendig (2011-09-22 11:43:35)


Evil #archlinux@freenode channel op and general support dude.
. files on github, Screenshots, Random pics and the rest

Offline

#3 2011-09-22 20:04:15

xzakox
Member
Registered: 2011-09-01
Posts: 10

Re: [SOLVED] Problem with MPD and ALSA

Solved, just running mpd as group audio did the trick.

mpd.conf:

user "mpd"
group                           "audio"

Thanks.

Offline

Board footer

Powered by FluxBB