You are not logged in.

#51 2011-08-19 14:30:45

julian516
Member
Registered: 2011-06-04
Posts: 20

Re: Arch reboots instead of shutting down.

As I said above "Thith doth driveth me nutth."

Before I left three weeks ago shutdown was working.  So I come back and read pubby's post.  I next upgraded so my system would be current.

Sure enough the bad penny returns.  If I select "shutdown" on the Xfce GUI menu, my system appears to shutdown but the power never turns off.  In effect what I get is a reboot.

One difference between pubby's situation, apparently, and mine; if I open a terminal and do "halt -fihp" as root the system will shutdown as it should.

In my experience software bugs are consistent; recreate the circumstance that provokes it and the bad code will do what it does.  Two points:

1.  I have never seen anything like this problem with any other Linux distro I have run and I have run a fair number of them.

2.  I have never experienced a problem that is this inconsistent.

uname -a returns:
Linux Home03 3.0-ARCH #1 SMP PREEMPT Wed Aug 17 21:55:57 CEST 2011 x86_64 Intel(R) Core(TM)2 Duo CPU T6400 @ 2.00GHz GenuineIntel GNU/Linux

My video driver is the current nouveau.

pubby, if "halt -fihp" does not work for you can we compare configurations and get anywhere?

Offline

#52 2011-08-19 20:27:49

pubby
Member
Registered: 2011-08-12
Posts: 8

Re: Arch reboots instead of shutting down.

halt -fihp still is rebooting.  The only way I can shutdown is by rebooting, going into BIOS/boot menu and holding power button.

uname -a
Linux pbpc 3.0-ARCH #1 SMP PREEMPT Wed Aug 17 21:55:57 CEST 2011 x86_64 Intel(R) Core(TM) i5-2500K CPU @ 3.30GHz GenuineIntel GNU/Linux

Video driver is nvidia proprietary

Wireless driver is rt2860sta

If you want to know anything else, just ask for what you're interested in.

Offline

#53 2011-08-19 21:02:17

julian516
Member
Registered: 2011-06-04
Posts: 20

Re: Arch reboots instead of shutting down.

Thanks pubby.

Looks like we differ with regard to wireless and video hardware/drivers.  How that bears on this problem I am not sure, to be honest.

One other thing I nearly forgot:  I am running wicd rather than network manager to handle my Ethernet and wireless connections.  wicd requires removal of nm-applet in order to work properly.

Do a search using Google on "xfce shutdown bug" and you will see quickly that this is an Xfce 4 problem across a wide range of distributions.  At this point some number of Arch/Xfce users may be experiencing it but I am not convinced it is actually an Arch bug, although there is a related bug filed as:  https://bugs.archlinux.org/task/23855.

I have gone to the Arch wiki at https://wiki.archlinux.org/index.php/Al … o_Shutdown

I then followed the instructions under that first section, "using sudo."

The suggested line "/sbin/shutdown -h now" did NOT work for me.  It results in the reboot we have been seeing.  If I substituted "halt -fhip" that DID work.  I simply open a terminal and do "sudo halt-fhip" and my system shuts down quickly.

Why "halt -fhip" works for me (whether with su or sudo) and does not work for you is mystifying.  Take a look at man halt, perhaps you will see something there, I did not but you ought to look.

One other thing seems clear, my ordinary user cannot shut down Xfce.  Shutting down requires root privileges.

You have answered one curiosity, which was whether or not installing an nVidia driver might help this situation.  Apparently it does not.

My wireless is an Intel and it requires iwlwifi-5000  My Ethernet, which I have been on throughout these tests is an RTL 8111/8168B.

Right about now we need a really smart Arch/Xfce person who says "lookie here kids ...."

Last edited by julian516 (2011-08-19 21:22:49)

Offline

#54 2011-08-19 21:59:54

pubby
Member
Registered: 2011-08-12
Posts: 8

Re: Arch reboots instead of shutting down.

Xfce lets me shutdown under my user. Any method of shutting down will reboot - using user, superuser, xfce or not.

Does it fix yours to remove wicd + network daemons and reboot (and then try shutting down) ? I am almost certain that is a bug with arch's wireless code.

Offline

#55 2011-08-20 11:45:38

julian516
Member
Registered: 2011-06-04
Posts: 20

Re: Arch reboots instead of shutting down.

You might be right pubby, but it is going to take me a while to test this.  Afraid I have a really busy week coming up.  Perhaps one of the earlier readers might return and give this a go?

Offline

#56 2011-09-01 13:16:28

hutch
Member
From: Lusiana - Italy
Registered: 2008-10-16
Posts: 13

Re: Arch reboots instead of shutting down.

Just to say that I had the same halt/reboot problem and I discovered that there was a "wake on lan" turned on on bios.
Turning it off solved the problem for me

Offline

#57 2011-09-24 10:05:37

Schwefelsaeure
Member
Registered: 2010-02-16
Posts: 17

Re: Arch reboots instead of shutting down.

Hi,

after updating Arch Linux via pacman -Syu on the 14th of August 2011 I've also run into the problem that Arch reboots instead of shutting down.

You can find pacman's update log at pastebin.com from this update.

I haven't used my PC very much in the last weeks, so the problem does not bothered me, but now it's time to solve it.
I upgraded the packages regularly in the meantime. Last update is from 23rd of September. But the problem wasn't solved by any package upgrade.

Pay attention: the problem didn't exist before the update on the 14th of August.
Amongst others, this upgrade introduced the linux kernel 3.0 package.

Here is the problem in more detail because in my case the behavior is a lot more deterministic in comparison to [user=julian516]julian516's[/user] experiences:

julian516 wrote:

I have never experienced a problem that is this inconsistent.

Everytime I make a fresh boot of Arch (= after Arch Linux was shutdown correctly) a shutdown leads to a reboot. But it seems not to be a normal reboot. The PC is powered off for about five seconds and then it is rebooted. A 'normal' reboot powers off the hardware for only one second and then it is powered on again. But in that case it looks like that the power on is triggered from anything 'outside'. I disabled all 'Power On Events' (e.g. via LAN) in the BIOS.

After this - unexpected - reboot I can shutdown Arch Linux normally, without any problems.

I've used different shutdown commands:

  • shutdown -h now

  • init 0

  • halt (-fihp)

  • poweroff

Every command shows the same behavior after a fresh boot, namely a reboot.

I also tried out not to log in via a login manager (KDE Display Manager in my case) and shutdown Arch via a virtual terminal. But this also produces a reboot. So, it's not a problem of KDE.

I assume it is either a problem with Arch's shutdown script /etc/rc.shutdown or an interference, introduced with kernel version 3.0.

I did not modify the shutdown script. You can find it also at pastebin.com.

The 'shutdown problem' does not exist on Microsoft Windows or other Linux distributions (includes Linux Live Systems; I tried out Arch's live CD). So, it's definitely an Arch problem.

Maybe anyone has a clue how to solve this problem.

Thanks.


Update: I've forgot to mention a warning, which is displayed on boot-up after the udev daemon is started. Here are the relevant lines from dmesg output:

[    5.271837] udevd[174]: starting version 173
[    5.653006] pci 0000:00:11.0: enabling device (0000 -> 0001)
[    5.653133] ALi_M1535: initialized. timeout=60 sec (nowayout=0)
[    5.659187] alim7101_wdt: Steve Hill <steve@navaho.co.uk>.
[    5.659208] alim7101_wdt: Detected old alim7101 revision 'a1d'.  If this is a cobalt board, set the 'use_gpio' module parameter.
[    5.744426] pci_hotplug: PCI Hot Plug PCI Core version: 0.5
[    5.754174] input: Power Button as /devices/LNXSYSTM:00/device:00/PNP0C0C:00/input/input1
[    5.754189] ACPI: Power Button [PWRB]
[    5.754290] input: Power Button as /devices/LNXSYSTM:00/LNXPWRBN:00/input/input2
[    5.754296] ACPI: Power Button [PWRF]
[    5.757884] Linux agpgart interface v0.103
[    5.979935] ACPI: acpi_idle registered with cpuidle
[    5.980002] ACPI: Invalid PBLK length [5]

I assume this is connected to the 'reboot problem'.

Last edited by Schwefelsaeure (2011-09-25 10:10:37)

Offline

#58 2011-09-28 05:32:25

thehodapp
Member
Registered: 2010-11-08
Posts: 30

Re: Arch reboots instead of shutting down.

Have been having the same issues for quite some time (at least a month). Everything is updated. Tried most of the suggestions- stopped all the daemons but that didn't help either. I would love to help figure this out, but I don't know how to go about it.

Offline

#59 2011-09-28 16:48:22

tpfkanep
Member
From: South Africa
Registered: 2009-12-15
Posts: 66

Re: Arch reboots instead of shutting down.

My PC [Foxconn MB] started to also reboot instead of shutting down... but only after I added USB and SATA expansion cards. I had to go into the BIOS under the [Power Management] options and disabled [Resume by Ring/LAN/PCI/etc.] settings to solve this.

Offline

#60 2011-09-28 22:50:43

thehodapp
Member
Registered: 2010-11-08
Posts: 30

Re: Arch reboots instead of shutting down.

Ok I figured out a fix...that sucks. If I disable "Integrated NIC" in the BIOS, Arch shuts down correctly (I don't have the ability to turn off "wake on LAN" in the BIOS like others on this forum). However this is at the cost of not using the ethernet. I suppose that narrows it down to a bug in the networking software especially because this problem doesn't occur on Windows or Ubuntu for me.

Has anyone filed a bug on this? It seems there isn't anyone here that knows enough about Arch to diagnose the problem.

Offline

#61 2011-09-28 23:24:30

thehodapp
Member
Registered: 2010-11-08
Posts: 30

Re: Arch reboots instead of shutting down.

Filed a bug on this at https://bugs.archlinux.org/task/26139?project=5

Update: Should have looked at the other bug branches (is that the word?). It's already been reported.

Last edited by thehodapp (2011-09-29 01:05:08)

Offline

#62 2011-09-30 00:24:32

Schwefelsaeure
Member
Registered: 2010-02-16
Posts: 17

Re: Arch reboots instead of shutting down.

@[user=tpfkanep]tpfkanep[/user]
Disabling the power on event 'Resume by Ring/LAN/PCI/etc.' (how it is called in your BIOS) didn't solve the problem for me.

@[user=thehodapp]thehodapp[/user]
Thank you for comitting a bug report.

Since I was not able to narrow the 'reboot problem' to a specific package/hardware component, I thought a bug report would be useless. But indeed it's a good idea. Thank you. I will follow the progress on this bug report - and hopefully the problem will be solved in near future.

thehodapp wrote:

Ok I figured out a fix...that sucks. If I disable "Integrated NIC" in the BIOS, Arch shuts down correctly

I don't use an integrated NIC, I have an external network card.
Output from lspci:

00:09.0 Ethernet controller: Intel Corporation 82557/8/9/0/1 Ethernet Pro 100 (rev 08)

Kernel module e100 is used for this NIC.
Output from dmesg:

[    5.997836] e100: Intel(R) PRO/100 Network Driver, 3.5.24-k2-NAPI
[    5.997842] e100: Copyright(c) 1999-2006 Intel Corporation

Tomorrow, I will try to disable the card completely (like you) and I'll check if this 'solves' the problem.

So, thanks for your efforts.

Offline

#63 2011-09-30 04:30:42

tpfkanep
Member
From: South Africa
Registered: 2009-12-15
Posts: 66

Re: Arch reboots instead of shutting down.

Here are my exact settings under [Power Management] on the Foxconn G41MXE mobo:

ACPI Suspend Type = [S3 (STR)]
Power on after Powerfail = [Poweroff]
HPET = [Enabled]
Resume by Ring = [Disabled]
Resume by LAN = [Disabled]
Resume by PCIE ME = [Disabled]
Resume by PCI Card = [Disabled]
Resume by USB Device = [Disabled]
Resume by PS2 Keyboard = [Enabled]
Resume by PS2 Mouse = [Enabled]
Resume by RTC = [Disabled]

My onboard LAN is enabled...

Before I installed my two cards, most of the above setting were enabled. Also, XP shutdowns normally with the two cards installed and the Power settings that were on the default settings.

Offline

#64 2011-10-05 19:29:27

meganox
Member
Registered: 2009-12-04
Posts: 4

Re: Arch reboots instead of shutting down.

@[user=Schwefelsaeure]Schwefelsaeure[/user], your description is very close to my experience, I will try to shed some light on it this weekend.

Offline

#65 2011-10-21 10:54:54

act28
Member
Registered: 2011-07-11
Posts: 10

Re: Arch reboots instead of shutting down.

CPUnltd wrote:

First and foremost, act28... try all the things that worked for the rest of us and eliminate those as solutions.... if none work, let us know... we can go from there.  If any DO work, let us know too... so we don't wonder what happened.

1. shutdown -hP now shutdowns, says power down, and then the laptop restarts again.
2. echo shutdown > /sys/power/disk does nothing -- shutdown -hP now does exactly the same thing.
3. Makes no difference if on battery or AC
4. halt just halts the machine (can still see stuff on screen), but doesn't actually shutdown.

I've noticed that on shutdown it isn't switching to runlevel 0 first and then initiating the shutdown sequence - which it usually does.

Offline

#66 2011-10-21 15:36:08

CPUnltd
Member
From: Milwaukee, WI
Registered: 2009-12-05
Posts: 470
Website

Re: Arch reboots instead of shutting down.

hmm... check the settings in /etc/rc.local.shutdown and /etc/rc.shutdown and see if you notice anything suspicious... if you could pastebin the contents, we all may be able to offer a bit of help if there is something not quite right in those files...


Help grow the dev population... have your tech trained and certified!

Offline

#67 2011-10-21 23:31:53

act28
Member
Registered: 2011-07-11
Posts: 10

Re: Arch reboots instead of shutting down.

/etc/rc.local.shutdown is empty (apart from default comments)
/etc/rc.shutdown is here http://pastebin.com/fMhT2uwN

These files AFAIK are from default install and haven't been changed.

Offline

#68 2011-10-21 23:38:49

CPUnltd
Member
From: Milwaukee, WI
Registered: 2009-12-05
Posts: 470
Website

Re: Arch reboots instead of shutting down.

is yours similar to this?

my rc.local.shutdown

#!/bin/bash
#
# /etc/rc.local.shutdown: Local shutdown script.
#

mpc pause
echo "Saving contents of ramdisk to harddrive"
rm /var/abs
rm /var/cache/pacman
rm /var/lib/pacman
mv /mnt/ramdisk/var/abs /var
mv /mnt/ramdisk/var/cache/pacman /var/cache
mv /mnt/ramdisk/var/lib/pacman /var/lib

Help grow the dev population... have your tech trained and certified!

Offline

#69 2011-10-21 23:42:19

act28
Member
Registered: 2011-07-11
Posts: 10

Re: Arch reboots instead of shutting down.

Nope. Nothing like it. Just the comment lines:
#!/bin/bash
#
# /etc/rc.local.shutdown: Local shutdown script.
#

Last edited by act28 (2011-10-21 23:42:53)

Offline

#70 2011-10-22 00:08:59

act28
Member
Registered: 2011-07-11
Posts: 10

Re: Arch reboots instead of shutting down.

Grrr... the problem seems to have gone away now after a package update this morning. Now running Linux 3.0.7-1 and I can confirm that shutdown -hP now does exactly that, shutdown, power off and power down. It also appears to be correctly switching to runlevel 0 first prior to initiating the shutdown sequence.

Shutdown from KDE also works.

Offline

#71 2011-10-22 00:38:58

CPUnltd
Member
From: Milwaukee, WI
Registered: 2009-12-05
Posts: 470
Website

Re: Arch reboots instead of shutting down.

maybe you had a kernel error... something corrupted in the kernel itself...  I've known Arch to fix itself like that for me in the past, so I am not surprised in the slightest...


Help grow the dev population... have your tech trained and certified!

Offline

#72 2011-10-27 04:08:17

thehodapp
Member
Registered: 2010-11-08
Posts: 30

Re: Arch reboots instead of shutting down.

Keep having this problem. I've narrowed it down...disabling the Wicd daemon (my network connection manager) in rc.conf allows me to shut down correctly (although I can't access the Internet).

I then tried starting the wicd daemon with rc.d start wicd and then:
1. immediately shut it back off with rc.d stop wicd without connecting --> shutdown correctly
2. connected to the wired ethernet, then disconnected, and shut back off with rc.d stop wicd --> computer restarted

I thought this meant that wicd was loading modules which somehow interfered with shutting down so I wrote a script to test this:

#!/bin/zsh
# Check stupid wifi

prev="/tmp/prev"
now="/tmp/now"
stats="/tmp/stats"

trap "rm -f $prev $now; exit 2" 1 2 3 15

lsmod > $prev
echo "Timelapse" > $stats
tail -f $stats &
rc.d start wicd >> $stats

i=0
while [ "$i" -lt 40 ]
do
    echo "$i" >> $stats
    lsmod > $now
    diff $prev $now >> $stats
    cat $now > $prev
    sleep 1
    i=`expr $i + 1`
done

rm $prev
rm $now
rm $stats
kill %1

exit 0

and I ran and got output:

Timelapse
:: Starting wicd Daemon    [BUSY]    [DONE] 
0
1
1a2,7
> appletalk              26298  0 
> ipx                    20395  0 
> p8022                   1171  1 ipx
> psnap                   1973  2 appletalk,ipx
> llc                     3761  2 p8022,psnap
> p8023                   1068  1 ipx
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39

That particular output shows the modules loaded after I connected with Ethernet and then disconnected and ran rc.d stop wicd.

Next I unloaded all the modules that were loaded when the ethernet connected.

rmmod appletalk ipx p8022 psnap llc p8023

I then shutdown but to my disappointment, my laptop still restarted.

So far, I think I've determined that wicd (for my laptop) is somehow causing my computer to not shut down correctly. I don't think the modules being loaded are causing the problem. More to come....hopefully.

And please, anyone who might have an idea how to troubleshoot this please let me know. I would be immensely grateful smile

Last edited by thehodapp (2011-10-27 04:09:21)

Offline

#73 2011-11-02 22:37:53

kichawa
Member
Registered: 2008-07-15
Posts: 32

Re: Arch reboots instead of shutting down.

On my machine there is the same issue. After some updates of the kernel the system shutdown properly but now i can't shutdown.

Offline

#74 2011-12-02 18:33:44

dennymallow
Member
Registered: 2011-07-08
Posts: 10

Re: Arch reboots instead of shutting down.

As this is a very populated post, I'd like to keep it alive, notifying the community that I have the same problem.
It was introduced by some recent (I mean two, three or four weeks ago) upgrade.
I'll try to search more and more, because this is quite annoying! hmm

Last edited by dennymallow (2011-12-02 18:35:10)


A good Arch can hold any weight!

Offline

#75 2011-12-13 21:38:36

albLinux
Member
Registered: 2007-04-24
Posts: 56

Re: Arch reboots instead of shutting down.

Anyone have a solution for this problem.
I have the same problem, when I shutdown the Pc from Gnome 3, its shutdown and after few sec maybe 10 sec it stats againe.

Offline

Board footer

Powered by FluxBB