You are not logged in.

#76 2011-12-14 00:36:08

PUE
Member
From: Earth/Europe/Austria
Registered: 2009-05-09
Posts: 34

Re: Arch reboots instead of shutting down.

I take my place in the row. I guess it started about a month ago and happens maybe 1 out of 5 times. I'm not using any DE or login manager, so they can be ruled out. So far my laptop was on LAN whenever this happened, but I can't rule out that it happens without LAN as well. Networking is done using a combination of net-auto-wireless, ifplugd, acpid, dhcpcd and so on, no high-level tools like networkmanager or wicd. Usually when this happened I used 'sudo shutdown -h <minutes>'.

Offline

#77 2011-12-15 11:36:35

pety80
Member
Registered: 2009-04-28
Posts: 2

Re: Arch reboots instead of shutting down.

albLinux wrote:

Anyone have a solution for this problem.
I have the same problem, when I shutdown the Pc from Gnome 3, its shutdown and after few sec maybe 10 sec it stats againe.

I had the same problem last week. I found the below link :
http://forums.fedoraforum.org/showthread.php?t=266387

After I unmounted all extended partitions before shutdown the computer, the problem has gone.

In addition I disabled the Fripery Shutdown menu extension and use the default ALT+ option.

Offline

#78 2011-12-15 23:23:15

David Batson
Member
Registered: 2011-10-13
Posts: 640

Re: Arch reboots instead of shutting down.

One workaround was posted in this thread today: https://bbs.archlinux.org/viewtopic.php … 7#p1028777

Offline

#79 2011-12-17 13:11:11

PUE
Member
From: Earth/Europe/Austria
Registered: 2009-05-09
Posts: 34

Re: Arch reboots instead of shutting down.

Thanks pety80, this seems to be the right track. I have a usb hub with two external disks connected to it (ext3, ntfs). The last three times I shutdown I made sure that the hub is unplugged and the laptop powered off immediately each time. I have a USB soundcard as well, it was plugged in each time. This tells me that it's not a general USB issue but somewhat USB-HDD related. I'll continue to narrow it down. Thanks for the hint.

Offline

#80 2011-12-28 21:39:32

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,661

Re: Arch reboots instead of shutting down.

I have one version of this problem, too:
- shutdown works fine on AC power at run level 5 (and presumably others);
- shutdown reboots on battery power at run level 3 or 5;
- shutdown seems to work OK on battery power at run level 1. (I only tested this once.)

In my case, the behaviour looks consistent - I get a reboot every time on battery power.

The reboot is immediate or almost immediate. There's no pause as described in some cases.

The failure occurs with nothing plugged into the laptop whatsoever, USB or otherwise. (I use a USB mouse but I tried removing it first. That's the only consistent attachment I use.)

The system _is_ correctly switching to run level 0 - at least, it says it is. It also reports "Power Off" as expected. There is nothing output suggesting that the process goes any differently on battery than AC power.

This is a thinkpad (x121e) and fairly new so I don't know how long the problem has existed for. I _thought_ that I powered off successfully while on battery at the beginning of December (around 9th or so) but I might have simply put it to sleep.

I'm using wicd with an Intel Centrino wifi. I've got Intel's integrated graphics. My rc.shutdown and rc.shutdown.local are default. I'm running laptop-mode-tools and pm-utils with most of the pm-utils power-management stuff disabled - basically leaving suspend/hibernate for pm-utils.

Wake on LAN etc. etc. is all disabled in BIOS.

I do not have any extended partitions mounted if that means logical as opposed to primary partitions as I'm using GPT. In case it is relevant, I'm booting in EFI mode.

Filesystem
rootfs
udev
/run
/dev/sda5
shm
tmpfs
/dev/sda1
/dev/sda3
/dev/sda6
/dev/sda7
/dev/sda8  
/dev/sda9
/dev/sda10 
/dev/sda11

I'd be very pleased to help troubleshoot this in any way that I can. I've read this thread and several others but I don't have much sense of the best strategy to pursue (or even if there is a "the" best strategy). I'm very new to Arch and pretty green where Linux generally is concerned.


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#81 2011-12-29 11:08:23

PUE
Member
From: Earth/Europe/Austria
Registered: 2009-05-09
Posts: 34

Re: Arch reboots instead of shutting down.

I think the best thing to do right now is to provide information and look for common things.
I use laptop mode tools as well, will disbale it and see whether this changes anything.

Weird observation:
1) unmounting USB HDDs before shutdown allows shutdown (have only tried both the ext3 and NTFS drive together so far)
2) Having the USB HDDs powered off but hub plugged in doesn't allow shutdown the first time.
3) As reported above already, the laptop shuts down fine if the USB hub is not connected.

Offline

#82 2011-12-29 16:15:09

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,661

Re: Arch reboots instead of shutting down.

So either I have a different version of the problem or internal USB connections can also be problematic? Obviously that would be much harder to test since I can't very well pull the laptop apart before shutting down!

Excluding mouse:

lsusb   
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 003: ID 0a5c:217f Broadcom Corp. Bluetooth Controller
Bus 002 Device 003: ID 064e:e285 Suyin Corp. 

If it is USB related what I don't understand is why it should not occur when I'm on AC...


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#83 2011-12-29 16:57:37

PUE
Member
From: Earth/Europe/Austria
Registered: 2009-05-09
Posts: 34

Re: Arch reboots instead of shutting down.

It's weird, I did shutdown about 6 times now, 3 times without laptop mode tolls, 3 times with, and it worked properly each time. It was always with hub plugged in and HDDs powered. Seems like my problem is magically gone for now.

One possible difference between AC and battery is that the laptop might provide different voltage levels for USB. However, I don't see how that could matter in your case.

Offline

#84 2011-12-29 21:57:33

tobsen
Member
Registered: 2011-10-13
Posts: 36

Re: Arch reboots instead of shutting down.

Problem is solved for me too. Don't even know if an update solved this issue but it's gone since yesterday.

Offline

#85 2011-12-29 23:30:59

PUE
Member
From: Earth/Europe/Austria
Registered: 2009-05-09
Posts: 34

Re: Arch reboots instead of shutting down.

Maybe we can figure out what it was. It may return. Can you post the pacman log or similar so we can see which packages have been updated?

Offline

#86 2012-01-01 21:51:00

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,661

Re: Arch reboots instead of shutting down.

Whatever fixed it for other people hasn't fixed it for me. I still reboot when I try to shutdown on battery power. Are other people running testing? I'm not, so maybe I don't have whatever fixed it yet?

I'm pretty sure it is not related to X in my case as the same problem occurs if I boot to run level 3.


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#87 2012-01-06 04:52:51

Yurlungur
Member
From: USA
Registered: 2012-01-06
Posts: 116

Re: Arch reboots instead of shutting down.

You're not the only one, cfr. This problem just appeared for me after an upgrade to kernel 3.1.7-1. Shutdown works fine with on AC power for all runlevels. The computer lags a bit in shutdown if the computer is on battery power. Then the computer immediately restarts. The behavior is totally consistent. This occurs for me even for runlevel 1. I have disabled acpid and laptop-mode-tools and the problem continues.

This is the extent of the testing I've done so far... Unfortunately, I can't unmount all extended partitions since Arch itself is on an extended partition.

David Batson wrote:

One workaround was posted in this thread today: https://bbs.archlinux.org/viewtopic.php … 7#p1028777

This workaround does not work for me. Inspired by it, however, I'm going to try playing around with the BIOS. It's possible there's some funny interaction there.



EDIT: There's no problem in the BIOS. Dumb question.  How badly could I damage my computer if I modified /etc/rc.shutdown so that the runlevel does not have to be zero for a shutdown? In other words, would anything bad happen if I removed the

if [[ $RUNLEVEL = 0 ]]; then

line at the end?


EDIT: I need to correct myself. Turning off laptop-mode-tools before shutting down the laptop does not prevent the restarting problem. However, disabling it on boot (removing the laptop-mode daemon) does prevent the strange rebooting problem. I suspect this is because of a poor interaction between laptop mode tools and pm-utils... but blacklisting the laptop-mode script in pm-utils doesn't solve the problem. It could also be a weird interaction between laptop mode tools and the kernel?

Last edited by Yurlungur (2012-01-06 06:50:00)


Lenovo Thinkpad T420; Intel sandy bridge i7 2.7GHz; integrated graphics card; 4GB RAM; wifi; Arch; Xmonad WM

Offline

#88 2012-01-06 21:02:20

Yurlungur
Member
From: USA
Registered: 2012-01-06
Posts: 116

Re: Arch reboots instead of shutting down.

I solved the problem, but I think it's a separate one from what everone here has experienced, so I've made a new thread. Sorry for gunking up this one.


Lenovo Thinkpad T420; Intel sandy bridge i7 2.7GHz; integrated graphics card; 4GB RAM; wifi; Arch; Xmonad WM

Offline

#89 2012-02-15 18:57:52

.:B:.
Forum Fellow
Registered: 2006-11-26
Posts: 5,819

Re: Arch reboots instead of shutting down.

I'll tag along. Since a few days, I have this problem as well. Even using -P with shutdown doesn't help; the f**ker just reboots (I had a nice cronjob that should shut down my server at a certain time).

I thought it was a problem caused by the initscripts update, but I rolled back, and no dice. Just upgraded the kernel (3.0.20-lts to 3.0.21-lts), and after one (intended) reboot and several unintended ones the problem persists.


Got Leenucks? :: Arch: Power in simplicity :: Get Counted! Registered Linux User #392717 :: Blog thingy

Offline

#90 2012-02-15 19:03:16

karol
Archivist
Registered: 2009-05-06
Posts: 25,423

Re: Arch reboots instead of shutting down.

Offline

#91 2012-02-16 08:22:17

.:B:.
Forum Fellow
Registered: 2006-11-26
Posts: 5,819

Re: Arch reboots instead of shutting down.

Thanks, added a comment.


Got Leenucks? :: Arch: Power in simplicity :: Get Counted! Registered Linux User #392717 :: Blog thingy

Offline

#92 2012-04-26 01:29:48

Tae
Member
From: Santiago, Chile
Registered: 2010-08-31
Posts: 32
Website

Re: Arch reboots instead of shutting down.

Same problem here. Linux 3.3.3-1-ARCH (but the problem began some weeks ago, with an older kernel).

What I tried:

  • # echo shutdown > /sys/power/disk
  • # export RUNLEVEL=0 && halt
  • # sudo shutdown -hP 0
  • Stop the network daemon before shutdown

All my partitions are logical, and my computer is a desktop one. I want to cry sad

Offline

#93 2012-04-26 04:22:06

Yurlungur
Member
From: USA
Registered: 2012-01-06
Posts: 116

Re: Arch reboots instead of shutting down.

Hi Tae,

there are several other threads on similar problems. They have to do with laptops, but perhaps something weird happened and they will help you?
https://bbs.archlinux.org/viewtopic.php … 7#p1028777
https://bbs.archlinux.org/viewtopic.php … 0#p1037290


Lenovo Thinkpad T420; Intel sandy bridge i7 2.7GHz; integrated graphics card; 4GB RAM; wifi; Arch; Xmonad WM

Offline

#94 2014-12-28 20:35:51

nicolito
Member
Registered: 2014-02-25
Posts: 7

Re: Arch reboots instead of shutting down.

For what it's worth.

I've had this very annoying problem since I reinstalled arch linux last week on a new hdd from scratch. I tried everything mentioned everywhere but symptoms persisted:
systemctl poweroff  inevitably rebooted the system, systemctl hibernate however failed to hibernate and actually powered off the system, but not correctly. The journal from that session was lost and dirty bits set.

After recalling reading that SLIM login manager was no longer supported I decided to try another option. I installed lightdm and voila..... Problem solved !

Seems SLIM was creating my misery all along. Too bad it was abandoned. I really liked it sad

But I like to be able to turn of my computer smile

Maybe someone reading this actually have the same issue caused by SLIM as well. Do try to change login manager if you have SLIM installed.

Offline

#95 2015-09-23 15:10:08

LoLei
Member
Registered: 2015-08-02
Posts: 14

Re: Arch reboots instead of shutting down.

I have also found a solution to this problem.

If you're using a laptop like me, try disabling the USB charger port in the BIOS
settings. That's what worked for me, although I don't understand why.

Source:
http://ubuntuforums.org/showthread.php? … st13089183

Offline

#96 2015-09-23 15:51:41

WorMzy
Forum Moderator
From: England
Registered: 2010-06-16
Posts: 5,057

Re: Arch reboots instead of shutting down.

And with that, I think this recurring zombie can be laid to rest.

https://wiki.archlinux.org/index.php/Fo … bumping.22

Closing.


Sakura:-
Mobo: ASUS P8Z77-V PRO // Processor: Intel Core i7-3770K 3.4GHz // GFX: nVidia GeForce GTX 970 Ti // RAM: 32GB (4x 8GB) Corsair DDR3 (@ 2133MHz) // Storage: 1x 3TB Seagate SATAII 5x 1TB Samsung SATAII, 2x 120GB Corsair SSD

Offline

Board footer

Powered by FluxBB