You are not logged in.

#3426 2019-01-04 09:38:17

glitsj16
Member
Registered: 2015-04-26
Posts: 28

Re: unofficial linux-ck repo with cpu optimized packages is ONLINE

@snack: In the mean time I also asked about the issue on ck's blog and got a clear response from him. Apparently PSI is a debugging feature and according to ck there's not much point in enabling it. You can disable PSI by adding 'psi=0' kernel parameter and get rid of the message at boot.

@graysky: Maybe you could change the default here by setting CONFIG_PSI_DEFAULT_DISABLED, so linux-ck users won't have to set any specific kernel parameter to fix this. Just a suggestion, I do realize this would be extra work for you.

Offline

#3427 2019-01-04 10:12:02

graysky
Wiki Maintainer
From: :wq
Registered: 2008-12-01
Posts: 9,775
Website

Re: unofficial linux-ck repo with cpu optimized packages is ONLINE

Let me see where that got enabled and fix.


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#3428 2019-01-04 19:03:07

graysky
Wiki Maintainer
From: :wq
Registered: 2008-12-01
Posts: 9,775
Website

Re: unofficial linux-ck repo with cpu optimized packages is ONLINE

The CONFIG_PSI=y option is set in the default Arch config that I mirror for linux-ck.  It can be disabled easily enough... I am wondering what in the CK patchset is triggering it and is it a false positive?  4.20.0-2-ck1 has this setting disabled, but it seems cosmetic unless the warning has a functional implication.

Last edited by graysky (2019-01-04 19:06:56)


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#3429 2019-01-04 20:14:41

glitsj16
Member
Registered: 2015-04-26
Posts: 28

Re: unofficial linux-ck repo with cpu optimized packages is ONLINE

@graysky: IMHO it would be easier to leave CONFIG_PSY=y as is and change # CONFIG_PSI_DEFAULT_DISABLED is not set instead. Setting that as CONFIG_PSI_DEFAULT_DISABLED=y will save users who want to disable the PSI feature from making any changes. Only users who want to keep the PSI feature would have to use kernel parameter 'psi=1' to override.

Offline

#3430 2019-01-04 20:43:13

graysky
Wiki Maintainer
From: :wq
Registered: 2008-12-01
Posts: 9,775
Website

Re: unofficial linux-ck repo with cpu optimized packages is ONLINE

@glitsj16 - Good idea.  See 4.20.0-3-ck1

https://wiki.archlinux.org/index.php?ti … did=561757

Last edited by graysky (2019-01-04 20:58:13)


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#3431 2019-01-06 21:23:27

fsyyy
Member
Registered: 2019-01-06
Posts: 3

Re: unofficial linux-ck repo with cpu optimized packages is ONLINE

-deleted-

Last edited by fsyyy (2019-06-01 19:18:25)

Offline

#3432 2019-01-10 10:49:30

bigfreak
Member
Registered: 2019-01-04
Posts: 3

Re: unofficial linux-ck repo with cpu optimized packages is ONLINE

Docker seems to have a Problem with 4.20.1-1-ck-skylake #1 SMP PREEMPT Wed Jan 9 18:00:42 EST 2019 x86_64 GNU/Linux

Jan 10 11:38:06 xps15 dockerd[7896]: time="2019-01-10T11:38:06.126220330+01:00" level=warning msg="Your kernel does not support cgroup cpu shares"
Jan 10 11:38:06 xps15 dockerd[7896]: time="2019-01-10T11:38:06.126231724+01:00" level=warning msg="Your kernel does not support cgroup cfs period"
Jan 10 11:38:06 xps15 dockerd[7896]: time="2019-01-10T11:38:06.126237747+01:00" level=warning msg="Your kernel does not support cgroup cfs quotas"
Jan 10 11:38:06 xps15 dockerd[7896]: time="2019-01-10T11:38:06.126242981+01:00" level=warning msg="Your kernel does not support cgroup rt period"
Jan 10 11:38:06 xps15 dockerd[7896]: time="2019-01-10T11:38:06.126248545+01:00" level=warning msg="Your kernel does not support cgroup rt runtime"
Jan 10 11:38:06 xps15 dockerd[7896]: time="2019-01-10T11:38:06.126698932+01:00" level=info msg="Loading containers: start."
Jan 10 11:38:06 xps15 dockerd[7896]: time="2019-01-10T11:38:06.357216135+01:00" level=info msg="Default bridge (docker0) is assigned with an IP address 172.18.0.0/16. Daemon option --bip can be used to set a preferred IP address"
Jan 10 11:38:06 xps15 dockerd[7896]: time="2019-01-10T11:38:06.447599031+01:00" level=info msg="Loading containers: done."
Jan 10 11:38:06 xps15 dockerd[7896]: time="2019-01-10T11:38:06.535639159+01:00" level=warning msg="Not using native diff for overlay2, this may cause degraded performance for building images: kernel has CONFIG_OVERLAY_FS_REDIRECT_DIR enabled" storage-driver=overlay2
Jan 10 11:38:06 xps15 dockerd[7896]: time="2019-01-10T11:38:06.535789616+01:00" level=info msg="Docker daemon" commit=4c52b901c6 graphdriver(s)=overlay2 version=18.09.1-ce
Jan 10 11:38:06 xps15 dockerd[7896]: time="2019-01-10T11:38:06.535944419+01:00" level=info msg="Daemon has completed initialization"
Jan 10 11:38:06 xps15 dockerd[7896]: time="2019-01-10T11:38:06.543938472+01:00" level=info msg="API listen on /var/run/docker.sock"
Jan 10 11:38:06 xps15 systemd[1]: Started Docker Application Container Engine.

this means that a start of my Containers failed with:

Jan 10 11:39:41 xps15 dockerd[7896]: time="2019-01-10T11:39:41.476848997+01:00" level=info msg="shim containerd-shim started" address="/containerd-shim/moby/5bc3c88bd9c7dd50fe669dc7b81d680f4f96cda7e8e980c1d919ac96717d9cb1/shim.sock" debug=false pid=13866
Jan 10 11:39:41 xps15 dockerd[7896]: time="2019-01-10T11:39:41.815105370+01:00" level=info msg="shim reaped" id=5bc3c88bd9c7dd50fe669dc7b81d680f4f96cda7e8e980c1d919ac96717d9cb1
Jan 10 11:39:42 xps15 dockerd[7896]: time="2019-01-10T11:39:42.247848503+01:00" level=error msg="5bc3c88bd9c7dd50fe669dc7b81d680f4f96cda7e8e980c1d919ac96717d9cb1 cleanup: failed to delete container from containerd: no such container"
Jan 10 11:39:42 xps15 dockerd[7896]: time="2019-01-10T11:39:42.247874941+01:00" level=error msg="Handler for POST /v1.39/containers/wikisql/start returned error: unable to find \"cpuacct\" in controller set: unknown"

with standard archlinux kernel the problem doesn't exist.

Offline

#3433 2019-01-10 20:25:24

graysky
Wiki Maintainer
From: :wq
Registered: 2008-12-01
Posts: 9,775
Website

Re: unofficial linux-ck repo with cpu optimized packages is ONLINE

@bigfreak - It would appear the ck1 patchset does this, see here for a diff of the Arch config before and after simply patching with CK1: https://github.com/graysky2/4.20.1_temp … 6faa187273

Recommend you post to CK's blog referencing that diff and your problem.  Might be that he did not mean to do that if I am correct.

Last edited by graysky (2019-01-10 20:28:03)


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#3434 2019-01-10 23:17:55

loqs
Member
Registered: 2014-03-06
Posts: 7,895

Re: unofficial linux-ck repo with cpu optimized packages is ONLINE

graysky wrote:

Recommend you post to CK's blog referencing that diff and your problem.  Might be that he did not mean to do that if I am correct.

https://github.com/ckolivas/linux/commi … ebd1cR1148
The change has been in every release of MUQSS.

Offline

#3435 2019-01-11 10:46:42

graysky
Wiki Maintainer
From: :wq
Registered: 2008-12-01
Posts: 9,775
Website

Re: unofficial linux-ck repo with cpu optimized packages is ONLINE

Yes, but someone can still ask CK if it is intentional and needed particularly if it affects functionality of docker.


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#3436 2019-01-11 10:56:19

bigfreak
Member
Registered: 2019-01-04
Posts: 3

Re: unofficial linux-ck repo with cpu optimized packages is ONLINE

graysky wrote:

@bigfreak - It would appear the ck1 patchset does this, see here for a diff of the Arch config before and after simply patching with CK1: https://github.com/graysky2/4.20.1_temp … 6faa187273

Recommend you post to CK's blog referencing that diff and your problem.  Might be that he did not mean to do that if I am correct.


done and the response from ck

No, docker and containers that use CPU scheduler cgroups in general do not work at all with MuQSS. There is no 'containment' as such, and the cgroups are only there to allow systems to run that mandate their existence. from https://ck-hack.blogspot.com/2018/12/li … 7335602087

Last edited by bigfreak (2019-01-11 10:59:12)

Offline

#3437 2019-01-11 12:55:18

vltr
Member
Registered: 2015-01-27
Posts: 18

Re: unofficial linux-ck repo with cpu optimized packages is ONLINE

Yeah, I can confirm that, unfortunately. I think it'll be wise to drop a line in the wiki (linux-ck and docker, perhaps?) in case someone gets stuck in docker wondering what may have happened ... It's a pity, though hmm


"For a successful technology, reality must take precedence over public relations, for Nature cannot be fooled." -- Richard P. Feynman

Offline

#3438 2019-01-11 15:25:05

graysky
Wiki Maintainer
From: :wq
Registered: 2008-12-01
Posts: 9,775
Website

Re: unofficial linux-ck repo with cpu optimized packages is ONLINE

@vltr - good idea, go for it...  it is a wiki after all wink


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#3439 2019-01-11 15:57:54

vltr
Member
Registered: 2015-01-27
Posts: 18

Re: unofficial linux-ck repo with cpu optimized packages is ONLINE

I will, since I had to change the output of pacman -V to match a prior version so I can pass on the wiki registration riddle big_smile


"For a successful technology, reality must take precedence over public relations, for Nature cannot be fooled." -- Richard P. Feynman

Offline

#3440 2019-01-11 16:49:34

vltr
Member
Registered: 2015-01-27
Posts: 18

Re: unofficial linux-ck repo with cpu optimized packages is ONLINE

Done. Added troubleshooting entries for Linux-ck and docker. Thanks!


"For a successful technology, reality must take precedence over public relations, for Nature cannot be fooled." -- Richard P. Feynman

Offline

#3441 2019-02-13 20:41:48

foudfou
Member
Registered: 2011-08-25
Posts: 4

Re: unofficial linux-ck repo with cpu optimized packages is ONLINE

Not sure to follow: is there a fix or workaround for using both `docker build` and linux-ck ?

Offline

#3442 2019-02-13 21:18:40

vltr
Member
Registered: 2015-01-27
Posts: 18

Re: unofficial linux-ck repo with cpu optimized packages is ONLINE

foudfou wrote:

Not sure to follow: is there a fix or workaround for using both `docker build` and linux-ck ?

I saw some reports where people were able to run docker with newest linux-ck kernel versions (4.20.x), but had to downgrade systemd (to 239 I think?) in order to achieve that. I'm not sure about if this is a workaround or fix since I've not tested myself nor want to pin my systemd version.


"For a successful technology, reality must take precedence over public relations, for Nature cannot be fooled." -- Richard P. Feynman

Offline

#3443 2019-02-23 04:58:10

john29
Member
Registered: 2014-11-27
Posts: 27

Re: unofficial linux-ck repo with cpu optimized packages is ONLINE

update to nvidia-utils again

installing nvidia-utils (418.43-1) breaks dependency 'nvidia-utils=415.27' required by nvidia-ck-zen

Offline

#3444 2019-02-23 10:34:46

graysky
Wiki Maintainer
From: :wq
Registered: 2008-12-01
Posts: 9,775
Website

Re: unofficial linux-ck repo with cpu optimized packages is ONLINE

Building now, thanks.  In the future, just flag the affected package out-of-date in the AUR.


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#3445 2019-02-23 12:56:33

bugsmanagement
Member
Registered: 2017-04-21
Posts: 201

Re: unofficial linux-ck repo with cpu optimized packages is ONLINE

Hello there,

error: failed retrieving file 'linux-ck-zen-4.20.11-2-x86_64.pkg.tar.xz' from repo-ck.com : The requested URL returned error: 404

Just dropping a line to let you know there's a problem. Seems the package is missing from the repo?

Regards

Offline

#3446 2019-02-23 21:26:08

john29
Member
Registered: 2014-11-27
Posts: 27

Re: unofficial linux-ck repo with cpu optimized packages is ONLINE

Thank all good

Offline

#3447 2019-02-28 22:11:10

fenix76
Member
Registered: 2019-02-28
Posts: 2

Re: unofficial linux-ck repo with cpu optimized packages is ONLINE

unable to satisfy dependency 'nvidia-utils=418.43' required by nvidia-ck-haswell

Offline

#3448 2019-02-28 23:08:18

graysky
Wiki Maintainer
From: :wq
Registered: 2008-12-01
Posts: 9,775
Website

Re: unofficial linux-ck repo with cpu optimized packages is ONLINE

fenix76 wrote:

unable to satisfy dependency 'nvidia-utils=418.43' required by nvidia-ck-haswell

Works for me...

# pacman -S nvidia-ck                          
resolving dependencies...
looking for conflicting packages...
warning: dependency cycle detected:
warning: xorg-server will be installed before its nvidia-utils dependency

Packages (14) egl-wayland-1.1.2-1  eglexternalplatform-1.0+3+g7c8f8e2-1  libepoxy-1.5.3-1  libevdev-1.6.0-1  libgudev-232-1
              libinput-1.12.6-1  libwacom-0.32-1  mtdev-1.1.5-2  nvidia-utils-418.43-2  xf86-input-libinput-0.28.2-1
              xorg-server-1.20.4-1  xorg-server-common-1.20.4-1  xorg-setxkbmap-1.3.1-2  nvidia-ck-2:418.43-4

Total Download Size:    50.97 MiB
Total Installed Size:  216.81 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
 nvidia-utils-418.43-2-x86_64                        39.4 MiB  15.7M/s 00:03 [############################################] 100%
 nvidia-ck-2:418.43-4-x86_64                         11.6 MiB  4.54M/s 00:03 [############################################] 100%
(14/14) checking keys in keyring                                             [############################################] 100%
(14/14) checking package integrity                                           [############################################] 100%
(14/14) loading package files                                                [############################################] 100%
(14/14) checking for file conflicts                                          [############################################] 100%
:: Processing package changes...
( 1/14) installing libepoxy                                                  [############################################] 100%
( 2/14) installing xorg-setxkbmap                                            [############################################] 100%
( 3/14) installing xorg-server-common                                        [############################################] 100%
( 4/14) installing mtdev                                                     [############################################] 100%
( 5/14) installing libevdev                                                  [############################################] 100%
( 6/14) installing libgudev                                                  [############################################] 100%
( 7/14) installing libwacom                                                  [############################################] 100%
( 8/14) installing libinput                                                  [############################################] 100%
Optional dependencies for libinput
    gtk3: libinput debug-gui
    python-pyudev: libinput measure
    python-evdev: libinput measure
( 9/14) installing xf86-input-libinput                                       [############################################] 100%
(10/14) installing xorg-server                                               [############################################] 100%
>>> xorg-server has now the ability to run without root rights with
    the help of systemd-logind. xserver will fail to run if not launched
    from the same virtual terminal as was used to log in.
    Without root rights, log files will be in ~/.local/share/xorg/ directory.

    Old behavior can be restored through Xorg.wrap config file.
    See Xorg.wrap man page (man xorg.wrap).
(11/14) installing eglexternalplatform                                       [############################################] 100%
(12/14) installing egl-wayland                                               [############################################] 100%
(13/14) installing nvidia-utils                                              [############################################] 100%
If you run into trouble with CUDA not being available, run nvidia-modprobe first.
Optional dependencies for nvidia-utils
    nvidia-settings: configuration tool
    xorg-server-devel: nvidia-xconfig
    opencl-nvidia: OpenCL support
(14/14) installing nvidia-ck                                                 [############################################] 100%
:: Running post-transaction hooks...
(1/5) Updating linux-ck module dependencies...
(2/5) Reloading system manager configuration...
(3/5) Creating system user accounts...
(4/5) Reloading device manager configuration...
(5/5) Arming ConditionNeedsUpdate...

Last edited by graysky (2019-02-28 23:08:27)


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#3449 2019-03-01 01:11:41

fenix76
Member
Registered: 2019-02-28
Posts: 2

Re: unofficial linux-ck repo with cpu optimized packages is ONLINE

sudo pacman -S nvidia-ck-haswell
resolving dependencies...
warning: cannot resolve "nvidia-utils=418.43", a dependency of "nvidia-ck-haswell"
:: The following package cannot be upgraded due to unresolvable dependencies:
      nvidia-ck-haswell

:: Do you want to skip the above package for this upgrade? [y/N]

Offline

#3450 2019-03-01 09:02:19

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 6,908

Re: unofficial linux-ck repo with cpu optimized packages is ONLINE

Offline

Board footer

Powered by FluxBB