You are not logged in.

#3651 2020-08-31 20:03:17

graysky
Wiki Maintainer
From: :wq
Registered: 2008-12-01
Posts: 10,073
Website

Re: unofficial linux-ck repo with cpu optimized packages is ONLINE

jooch wrote:
error: failed retrieving file 'linux-ck-k10-headers-5.7.16-1-x86_64.pkg.tar.zst' from repo-ck.com : The requested URL returned error: 404

I'm getting 404 errors on various kernels, is this correct?

I see one of my build nodes failed to build.  Missing several packages including k10.  Will fix and push.  Thank you for the report.


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#3652 2020-08-31 23:11:30

graysky
Wiki Maintainer
From: :wq
Registered: 2008-12-01
Posts: 10,073
Website

Re: unofficial linux-ck repo with cpu optimized packages is ONLINE

OK, all packages are online, enjoy.


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#3653 2020-09-03 17:06:34

ToLo
Member
From: Flensburg/Germany
Registered: 2006-02-12
Posts: 36

Re: unofficial linux-ck repo with cpu optimized packages is ONLINE

Hi graysky
I'm missing updates for linux-ck-core2 package. Please checkup your repository.
Thanks in advance.
ToLo

Offline

#3654 2020-09-03 20:41:44

graysky
Wiki Maintainer
From: :wq
Registered: 2008-12-01
Posts: 10,073
Website

Re: unofficial linux-ck repo with cpu optimized packages is ONLINE

Thanks for letting me know.  Should be built and online soon.


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#3655 2020-09-04 11:24:42

ToLo
Member
From: Flensburg/Germany
Registered: 2006-02-12
Posts: 36

Re: unofficial linux-ck repo with cpu optimized packages is ONLINE

I can confirm. I've updated to the newest release. Thanks!!

Offline

#3656 2020-09-18 05:48:15

vinnom
Member
Registered: 2013-11-24
Posts: 50

Re: unofficial linux-ck repo with cpu optimized packages is ONLINE

things are kinda odd

I've tried to build linux-ck using linux 5.7.19 but I had the same error pointed on this commit (btw @graysky, according to ooo on this comment, fix_ck1_for_5.7.17.patch is missing the below diff too)

--- patch-5.7-ck1	2020-09-18 00:39:36.211093747 -0300
+++ patch-5.7-ck1	2020-09-18 00:48:01.971127357 -0300
@@ -11903,6 +11903,11 @@
 +	return util;
 +}
 +
++static inline bool uclamp_is_used(void)
++{
++	return false;
++}
++
 +#ifndef arch_scale_freq_tick
 +static __always_inline
 +void arch_scale_freq_tick(void)

Trying to fix my issue, I've patched it myself, but then the build process threw a lot of errors regarding MuQSS.c (not only, but mostly). Trying to build as-is in PKGBUILD goes fine (which seems odd as the commit pointed by ooo isn't applied) and I have 5.7.19-ck right now here.

PS: I use the git repo to improve build time with ccache. For some reason, I can't improve it using the provided package.

Offline

Board footer

Powered by FluxBB