You are not logged in.

#276 2024-03-25 07:09:46

Awebb
Member
Registered: 2010-05-06
Posts: 6,321

Re: pacserve - easily share Pacman packages between computers

There is a laptop with a very slow wifi connection in my swarm. Is there a way to make a machine only download from others but not contribute? Is this somehow addressed or addressable?

Offline

#277 2024-03-25 09:28:20

deadite66
Member
Registered: 2015-06-13
Posts: 32

Re: pacserve - easily share Pacman packages between computers

Now CacheServer support has been added to pacman 6.1.0 i've moved over to using that, its very easy to setup and works consistently.

pacserve did work too but was a bit flaky, fresh booted machines i had to restart the service before it would work, some machines not being seen.

Last edited by deadite66 (2024-03-25 09:28:38)

Offline

#278 2024-05-07 13:45:50

kecef
Member
Registered: 2014-06-05
Posts: 6

Re: pacserve - easily share Pacman packages between computers

pacserve and quickserve stopped working probably after yesterday's system update.

pacserve          
/usr/bin/python3: Error while finding module specification for 'ThreadedServers.Pacserve' (ModuleNotFoundError: No module named 'ThreadedServers')

I haven't uninstalled python3-threaded_servers

Offline

#279 2024-05-07 13:51:14

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 21,892

Re: pacserve - easily share Pacman packages between computers

You need to rebuild both python3-threaded-servers and pacserve against the new python version. As all AUR packages that depend on python

Offline

#280 2024-05-07 14:56:12

kecef
Member
Registered: 2014-06-05
Posts: 6

Re: pacserve - easily share Pacman packages between computers

Weird. After several python updates I didn't need to do that. Both packages have been working for years ... but that thing helped. Only python3-threaded-servers rebuild was required. Thanks V1del

Offline

#281 2024-05-07 15:12:34

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 21,892

Re: pacserve - easily share Pacman packages between computers

You generally need to do that every time the "major" python version changes, in this case the bump from 3.11 -> 3.12 (minor versions, e.g. 3.12.1 are exempt from this)

Offline

Board footer

Powered by FluxBB