You are not logged in.

#1 2011-05-21 02:17:16

Tux the penguin
Member
From: Tomorrow
Registered: 2010-05-25
Posts: 196

[SOLVED]Stop joystick controlling mouse

I have a usb Logitech Extreme 3D Pro joystick it has been working fine. I installed xf86-input-joystick and it worked. That was yesterday, when I first tried it. When I booted up today, it was controlling the mouse which is irritating in games where mouse scrolling and stuff does things. It also messes up normally using mouse whenever it is plugged it. As soon as I plug it in, the cursor moves to the top right corner of my screen and stays there until i move it using the joystick. It wont accept mouse input then, until I first move the joystick. I added

Section "InputClass"
    Identifier "controller"
    MatchIsJoystick "on"
    MatchDevicePath "/dev/input/js0"
    Driver "joystick"
EndSection

to /etc/X11/xorg.conf.d/10-evdev.conf . I may have done that wrong, I just guessed using the other stuff in there. I created /etc/X11/xorg.conf.d/10-joystick.conf and put

Section "InputDevice"
    Identifier "controller"
    Driver "joystick"
    Option "Device" "/dev/input/js0"
    Option "DebugLevel" "0" 
    Option "StartKeysEnabled" "false" 
    Option "StartMouseEnabled" "false" 
EndSection

in it. I rebooted to make sure it would take effect, but that didn't help. I googled this and those things seemed to help other people, but not me... I also tried loading the joydev kernel module with

modprobe joydev

but that didn't make a difference either. Thanks. I'm using E17 btw, I don't know if that affects anything or not...

Last edited by Tux the penguin (2011-05-21 17:51:36)


I don't suffer from insanity. I enjoy every minute of it.
MSI CR600 / 3GB Memory / 320GB HDD / Intel Pentium Dual-Core CPU T4200 @ 2.00 GHz | Archlinux x86_64

Offline

#2 2011-05-21 13:22:15

Tux the penguin
Member
From: Tomorrow
Registered: 2010-05-25
Posts: 196

Re: [SOLVED]Stop joystick controlling mouse

Also, if there is a way to disable joystick scrolling at least, that would be almost as good. Because if I twist it just a bit, it scrolls, which is extremely annoying in E17 menus and even when I let it go back to normal, it keeps scrolling and using the mouse wont make it stop. I have to unplug it. Scrolling also effects stuff in games, and twisting the joystick has other functions, not scrolling, but it gets interpreted as a mouse wheels scroll. Also with it controlling the mouse, the cursor gets moved out of the game window frequently and I accidentally roll up the window and stuff alot because of that.


I don't suffer from insanity. I enjoy every minute of it.
MSI CR600 / 3GB Memory / 320GB HDD / Intel Pentium Dual-Core CPU T4200 @ 2.00 GHz | Archlinux x86_64

Offline

#3 2011-05-21 14:43:34

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 7,200

Re: [SOLVED]Stop joystick controlling mouse

I had the same problems as you, and found 2 solutions

1. remove xf86-input-joystick.
All of my applications that required joysticks could detect them, unfortunately they lacked deadzone settings so joystick control was not as good as i wanted.

2.
the correct place for the startkeysenabled / startmouseenabled settings appears to be 50-joystick.conf, which comes with the xf86-input-joystick package.

this is my edited version of 50-joystick.conf :

Section "InputClass"
    Identifier "joystick catchall"
    MatchIsJoystick "on"
    MatchDevicePath "/dev/input/event*"
    Driver "joystick"
    Option "StartKeysEnabled" "False"
    Option "StartMouseEnabled" "False"
EndSection

Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#4 2011-05-21 17:50:43

Tux the penguin
Member
From: Tomorrow
Registered: 2010-05-25
Posts: 196

Re: [SOLVED]Stop joystick controlling mouse

Lone_Wolf wrote:

I had the same problems as you, and found 2 solutions

1. remove xf86-input-joystick.
All of my applications that required joysticks could detect them, unfortunately they lacked deadzone settings so joystick control was not as good as i wanted.

2.
the correct place for the startkeysenabled / startmouseenabled settings appears to be 50-joystick.conf, which comes with the xf86-input-joystick package.

this is my edited version of 50-joystick.conf :

Section "InputClass"
    Identifier "joystick catchall"
    MatchIsJoystick "on"
    MatchDevicePath "/dev/input/event*"
    Driver "joystick"
    Option "StartKeysEnabled" "False"
    Option "StartMouseEnabled" "False"
EndSection

Thanks. My joystick didn't work until I installed xf86-input-joystick. When I googled it, the solutions that I saw both used 10-joystick.conf lol so that's why it didn't help. I tried putting that in 50-joystick.conf, but that didn't help. I had to add it to 10-evdev.conf for some reason. In evdev I think I had the device path and identifier wrong at first. Thanks for your help.


I don't suffer from insanity. I enjoy every minute of it.
MSI CR600 / 3GB Memory / 320GB HDD / Intel Pentium Dual-Core CPU T4200 @ 2.00 GHz | Archlinux x86_64

Offline

#5 2017-07-13 16:28:03

laszlolo
Member
Registered: 2017-07-13
Posts: 1

Re: [SOLVED]Stop joystick controlling mouse

I've had the same problem and after much trial and error I would like to add some piece of info, maybe it will be useful for someone else who has tried:

In my case, the order of appearance in the numbered .conf files didn't matter. The solution for me was just to replace "/dev/input/js0" to "/dev/input/eventX". It seems that the "jsX" device is not responsive to the "StartMouseEnabled" tag.

Cheers,
Laszlo

Offline

#6 2017-07-13 16:44:21

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 7,321

Re: [SOLVED]Stop joystick controlling mouse

Please pay attention to the dates. And to the solution which already came to the same conclusion you just repeated.

Do not necro bump: https://wiki.archlinux.org/index.php/Co … bumping.22

Closing.

Offline

Board footer

Powered by FluxBB