You are not logged in.

#126 2011-09-13 14:40:53

SanskritFritz
Member
From: Budapest, Hungary
Registered: 2009-01-08
Posts: 1,619
Website

Re: pacaur - an AUR helper that minimizes user interaction

This is where the error is issued:

su root -c "$(echo $@)"

Maybe this was the first time I tried to use pacaur over ssh.
If I find a solution, I'll tell you.


zʇıɹɟʇıɹʞsuɐs AUR || Cycling in Budapest with a helmet camera || Revised log levels proposal: "FYI" "WTF" and "OMG" (John Barnette)

Offline

#127 2011-09-14 12:08:20

SanskritFritz
Member
From: Budapest, Hungary
Registered: 2009-01-08
Posts: 1,619
Website

Re: pacaur - an AUR helper that minimizes user interaction

My favorite aur helper was bauerbill by far. It used a different approach: it had to be started by root, and it dropped privileges when it was necessary with a simple

su -c "makepkg" user

command
You could set the username in the config file.
pacaur cannot be called as root now, which is strange for me actually, because pacman needs root privileges anyway.
And no, some of us dont want to install sudo.
Maybe you could consider this alternative solution, if you like it.


zʇıɹɟʇıɹʞsuɐs AUR || Cycling in Budapest with a helmet camera || Revised log levels proposal: "FYI" "WTF" and "OMG" (John Barnette)

Offline

#128 2011-09-14 14:56:53

Spyhawk
Member
Registered: 2006-07-07
Posts: 411

Re: pacaur - an AUR helper that minimizes user interaction

SanskritFritz wrote:

My favorite aur helper was bauerbill by far. It used a different approach: it had to be started by root, and it dropped privileges when it was necessary with a simple

su -c "makepkg" user

command
You could set the username in the config file.
pacaur cannot be called as root now, which is strange for me actually, because pacman needs root privileges anyway.
And no, some of us dont want to install sudo.
Maybe you could consider this alternative solution, if you like it.

I suppose you're talking about the SSH issue, as pacaur can indeed be used as root on a local machine, right? Does packer works as intended through SSH, or does it have the same behavior as pacaur?

Also, I'm more interested in making the script working as intended rather than adding extra code to "bypass" some bugs. If you call pacaur as user Y, then it should operate as user Y. If you call pacaur as root, then it should operate as root.

Offline

#129 2011-09-14 19:41:12

SanskritFritz
Member
From: Budapest, Hungary
Registered: 2009-01-08
Posts: 1,619
Website

Re: pacaur - an AUR helper that minimizes user interaction

Understood, and accepted.


zʇıɹɟʇıɹʞsuɐs AUR || Cycling in Budapest with a helmet camera || Revised log levels proposal: "FYI" "WTF" and "OMG" (John Barnette)

Offline

#130 2011-09-14 21:34:23

Spyhawk
Member
Registered: 2006-07-07
Posts: 411

Re: pacaur - an AUR helper that minimizes user interaction

SanskritFritz wrote:

Understood, and accepted.

To expand a bit on what I wrote above, I'm still interested in fixing any ssh bug if there is one, I'm just thinking about the best way to do it. Also, it would be great if you could test packer with ssh, as pacaur share (or actually "borrow") the root/sudo code from packer. I've no access to any remote machine yet (so I cannot test it myself), and I'm a bit surprised that nobody encountered that bug with packer until now.

Offline

#131 2011-09-14 23:43:04

Ronis_BR
Member
Registered: 2010-05-16
Posts: 9

Re: pacaur - an AUR helper that minimizes user interaction

Hi, I'm having locales problem also!
If I use pt_BR.UTF8 than pacaur can't install packages, it just exit from
Proseguir com a instalação [S/n]?
It seems that pacaur is "typing" Y when it should type S with my locale.
If I execute LANG="en_US" pacaur ... then everything goes fine.

Btw, I also have to create a pacman-color alias to execute LANG="en_US" pacman-color instead.

Thanks,
Ronan

Offline

#132 2011-09-15 06:56:37

Spyhawk
Member
Registered: 2006-07-07
Posts: 411

Re: pacaur - an AUR helper that minimizes user interaction

Ronis_BR wrote:

It seems that pacaur is "typing" Y when it should type S with my locale.
If I execute LANG="en_US" pacaur ... then everything goes fine.

Btw, I also have to create a pacman-color alias to execute LANG="en_US" pacman-color instead.

Thanks,
Ronan

Thanks for the report. Now I know why some of you have problem with the last updates: pacaur uses the "yes" utility to confirm prompts instead of the --noconfirm option (have to do that to bypass the default "No" answer when a conflict arise). I'll try to fix that in the next release. In the meantime, either use 2.3.3 (link above) or use an alias in ~.bashrc

pacaur='LANG="en_US.UTF-8" pacaur'

Last edited by Spyhawk (2011-09-15 07:18:08)

Offline

#133 2011-09-15 09:07:41

SanskritFritz
Member
From: Budapest, Hungary
Registered: 2009-01-08
Posts: 1,619
Website

Re: pacaur - an AUR helper that minimizes user interaction

Spyhawk wrote:

I suppose you're talking about the SSH issue, as pacaur can indeed be used as root on a local machine, right? Does packer works as intended through SSH, or does it have the same behavior as pacaur?

I've tested packer over ssh, getting root rights with (I guess) su works without any problem:

~> packer -S udiskie
Aur Targets    (1): udiskie
Proceed with installation? [Y/n]

... snip ...

==> Finished making: udiskie 0.3.10-1 (2011. szept. 15., csütörtök, 10.55.34 CEST)
root Password:
resolving dependencies...
looking for inter-conflicts...
Targets (1): udiskie-0.3.10-1
Total Download Size:    0,00 MB
Total Installed Size:   0,08 MB
Proceed with installation? [Y/n]
(1/1) checking package integrity                                     [######################################] 100%
(1/1) checking for file conflicts                                    [######################################] 100%
(1/1) checking available disk space                                  [######################################] 100%
(1/1) installing udiskie                                             [######################################] 100%

UPDATE:

I checked the source of packer, and the only difference I could find is that you are using pacman-color. So I changed pacmanBin in the /etc/pacaur.conf to pacman, and found that pacaur does not honor this setting when color=true. Changing color=false did set pacaur to use pacman, however the error is the same:

==> Installing package udiskie with pacman -U...
standard in must be a tty
==> WARNING: Failed to install built package(s).

UPDATE2:
Just a small correction in the conf:

color=true                          # color support - default: true

should be

color=true                          # color support - default: false

Last edited by SanskritFritz (2011-09-15 09:27:50)


zʇıɹɟʇıɹʞsuɐs AUR || Cycling in Budapest with a helmet camera || Revised log levels proposal: "FYI" "WTF" and "OMG" (John Barnette)

Offline

#134 2011-09-15 10:28:15

Spyhawk
Member
Registered: 2006-07-07
Posts: 411

Re: pacaur - an AUR helper that minimizes user interaction

SanskritFritz wrote:

I checked the source of packer, and the only difference I could find is that you are using pacman-color. So I changed pacmanBin in the /etc/pacaur.conf to pacman, and found that pacaur does not honor this setting when color=true. Changing color=false did set pacaur to use pacman, however the error is the same:

==> Installing package udiskie with pacman -U...
standard in must be a tty
==> WARNING: Failed to install built package(s).

It seems you're using an old pacaur.conf file. pacmanBin option has been deprecated a long time ago (v.2.2.0) as it doesn't make sense to have two options to enable color. You probably have a /etc/pacaur.conf.pacnew file that should be used instead.

But well, if you got the same error with or withour pacman-color, and that the sudo/su code is the same in packer and pacaur, I guess the bug is hiding somewhere else...
I might have found some explanation here (look at the bottom).

Last edited by Spyhawk (2011-09-15 10:30:06)

Offline

#135 2011-09-16 07:17:29

SanskritFritz
Member
From: Budapest, Hungary
Registered: 2009-01-08
Posts: 1,619
Website

Re: pacaur - an AUR helper that minimizes user interaction

And now comes the punchline: the same error occurs at home on console, on xterm, in bash, in fish, so it has nothing to do with ssh. So, there is something wrong with my setup, thanks for trying to help me, but I don't think you should dig into that any further, just relax and enjoy your coffee smile


zʇıɹɟʇıɹʞsuɐs AUR || Cycling in Budapest with a helmet camera || Revised log levels proposal: "FYI" "WTF" and "OMG" (John Barnette)

Offline

#136 2011-09-29 04:42:58

anonymous_user
Member
Registered: 2009-08-28
Posts: 3,058

Re: pacaur - an AUR helper that minimizes user interaction

Something broke in 2.3.7. The -m and -y flags do not work.

~ $ pacaur -d freetype2-infinality
:: freetype2-infinality downloaded to /tmp/pacaurtmp-kevin
~ $ pacaur -m freetype2-infinality
error: no targets specified (use -h for help)
~ $ pacaur -y freetype2-infinality
error: no targets specified (use -h for help)
~ $ 

Also even though -d does give output, my /tmp/pacaurtmp-kevin is empty.

Last edited by anonymous_user (2011-09-29 14:30:39)

Offline

#137 2011-09-29 09:44:51

Spyhawk
Member
Registered: 2006-07-07
Posts: 411

Re: pacaur - an AUR helper that minimizes user interaction

anonymous_user > Thanks for the report, I'll try to fix that as soon as possible. In the meantime, you can use the other set of command (-Sw, -S) or use 2.3.6.

I hate it when bugfixes break something in the opposite part of the code sad

Edit: -m, -y, -u commands should now be fixed. I haven't found anything strange with the -d command. If you still have problem with it, please ensure your $buildDir is user writable.

Last edited by Spyhawk (2011-09-29 12:57:12)

Offline

#138 2011-09-29 10:14:19

SanskritFritz
Member
From: Budapest, Hungary
Registered: 2009-01-08
Posts: 1,619
Website

Re: pacaur - an AUR helper that minimizes user interaction

Spyhawk wrote:

I hate it when bugfixes break something in the opposite part of the code sad

http://www.youtube.com/watch?v=4XpnKHJAok8&t=23m26s wink


zʇıɹɟʇıɹʞsuɐs AUR || Cycling in Budapest with a helmet camera || Revised log levels proposal: "FYI" "WTF" and "OMG" (John Barnette)

Offline

#139 2011-09-29 14:33:26

anonymous_user
Member
Registered: 2009-08-28
Posts: 3,058

Re: pacaur - an AUR helper that minimizes user interaction

@Spyhawk - Its working fine now. Thanks.

Offline

#140 2011-10-10 12:17:15

anon27
Member
Registered: 2010-11-10
Posts: 18

Re: pacaur - an AUR helper that minimizes user interaction

Hi, thanks for this great program.

Is there a way to make confirmation prompts only require that I press "y" or "n" to continue the process, instead of "y enter" and "n enter"?

Offline

#141 2011-10-10 12:31:57

Spyhawk
Member
Registered: 2006-07-07
Posts: 411

Re: pacaur - an AUR helper that minimizes user interaction

anon27 wrote:

Hi, thanks for this great program.

Is there a way to make confirmation prompts only require that I press "y" or "n" to continue the process, instead of "y enter" and "n enter"?

pacaur does that where it is possible to do it - only confirmation prompt that are handled by pacman itself requires an additional "enter".
I'm not aware of a simple way of enabling that behavior when using pacman - if somebody knows, please speak up :]

Offline

#142 2011-10-14 15:30:11

Spyhawk
Member
Registered: 2006-07-07
Posts: 411

Re: pacaur - an AUR helper that minimizes user interaction

Please note that newly released cower 3.0.8 is only compatible with pacman 4 that is now in [testing]. Until pacman 4 reach [core], pacaur PKGBUILD has been updated to restrict it to cower <3.0.8 and expac<0.07.

If you want to use pacman 4 that is now in [testing], you'll need to upgrade pacman and expac [community-testing] first, then install cower 3.0.8 the old way with makepkg (or with any other aur helper). Also, pacman-color-testing is actually out of date, so no color in pacaur at the moment.

Last edited by Spyhawk (2011-10-14 15:40:44)

Offline

#143 2011-10-20 22:04:09

SanskritFritz
Member
From: Budapest, Hungary
Registered: 2009-01-08
Posts: 1,619
Website

Re: pacaur - an AUR helper that minimizes user interaction

Dear Spyhawk, this problem with su giving the "standard in must be a tty" error message really starts to bug me. The odd thing is that packer works in the same session, and I compared pacaur with packer, but cannot find the cause for this behaviour to be different. Is noone else having this problem?


zʇıɹɟʇıɹʞsuɐs AUR || Cycling in Budapest with a helmet camera || Revised log levels proposal: "FYI" "WTF" and "OMG" (John Barnette)

Offline

#144 2011-10-21 08:14:47

Spyhawk
Member
Registered: 2006-07-07
Posts: 411

Re: pacaur - an AUR helper that minimizes user interaction

SanskritFritz> Still having that issue? :]

Could you explain your issue in more details? What exact ssh command do you use prior to using pacaur?
Have you tried to double "-t" command as explained in the link I posted above?
Have you tried pacaur 2.3.3, and does it have the same issue?

Offline

#145 2011-10-21 09:44:06

SanskritFritz
Member
From: Budapest, Hungary
Registered: 2009-01-08
Posts: 1,619
Website

Re: pacaur - an AUR helper that minimizes user interaction

Spyhawk wrote:

SanskritFritz> Still having that issue? :]

Yes, and I still use pacaur even if I have to install the package manually after smile I use it because it fits my manual package maintenace well.

Spyhawk wrote:

Could you explain your issue in more details? What exact ssh command do you use prior to using pacaur?
Have you tried to double "-t" command as explained in the link I posted above?

Strangely enough, this problem is not tied to any ssh. The error comes when I'm in the Alt-F1 console, on xterm, konsole, ssh, whatever. The odd thing is that packer works well, even over ssh. Packer uses practically identical coding in runasroot(), I even bothered to paste the function from packer into pacaur, still the same error. I probably have some setting in my system, which is triggered by pacaur, but not by packer.

Spyhawk wrote:

Have you tried pacaur 2.3.3, and does it have the same issue?

No, because I first have to wait for pacman 4 if I understood correctly. I'm not using [testing].


zʇıɹɟʇıɹʞsuɐs AUR || Cycling in Budapest with a helmet camera || Revised log levels proposal: "FYI" "WTF" and "OMG" (John Barnette)

Offline

#146 2011-10-21 09:49:58

Spyhawk
Member
Registered: 2006-07-07
Posts: 411

Re: pacaur - an AUR helper that minimizes user interaction

SanskritFritz wrote:
Spyhawk wrote:

Have you tried pacaur 2.3.3, and does it have the same issue?

No, because I first have to wait for pacman 4 if I understood correctly. I'm not using [testing].

Pacaur works with any pacman version. You just have to ensure to use cower 3.0.8 with pacman 4.0.0, or cower 3.0.5 with pacman 3.5.
Please try 2.3.3 as I have an idea of which part of the code might be troublesome for you.

Offline

#147 2011-10-21 14:58:32

SanskritFritz
Member
From: Budapest, Hungary
Registered: 2009-01-08
Posts: 1,619
Website

Re: pacaur - an AUR helper that minimizes user interaction

Spyhawk wrote:

Please try 2.3.3

Umm, I didnt check the version previously assuming you mean the newest version, but I have now 2.3.8, should I downgrade?

UPDATE: I tried with 2.3.8-3, same problem.

Last edited by SanskritFritz (2011-10-21 15:03:08)


zʇıɹɟʇıɹʞsuɐs AUR || Cycling in Budapest with a helmet camera || Revised log levels proposal: "FYI" "WTF" and "OMG" (John Barnette)

Offline

#148 2011-10-21 15:33:14

Spyhawk
Member
Registered: 2006-07-07
Posts: 411

Re: pacaur - an AUR helper that minimizes user interaction

SanskritFritz wrote:

should I downgrade?

Please do. Pacaur 2.3.4 introduced package conflict support, and that is the part of the code I suspect to be problematic.

Last edited by Spyhawk (2011-10-21 15:33:31)

Offline

#149 2011-10-21 17:28:17

SanskritFritz
Member
From: Budapest, Hungary
Registered: 2009-01-08
Posts: 1,619
Website

Re: pacaur - an AUR helper that minimizes user interaction

Tadaaa! You were right, pacaur 2.3.3 works great. Now what?


zʇıɹɟʇıɹʞsuɐs AUR || Cycling in Budapest with a helmet camera || Revised log levels proposal: "FYI" "WTF" and "OMG" (John Barnette)

Offline

#150 2011-10-21 17:52:24

Spyhawk
Member
Registered: 2006-07-07
Posts: 411

Re: pacaur - an AUR helper that minimizes user interaction

JFYI, the code that works (but that automatically answer "No" when a conflict arise):

makepkg -sfi ${makeopts[@]} --noconfirm

And here's the code that doesn't work (answer "Yes" each and every time):

yes | makepkg -sfi ${makeopts[@]}

Although we know now what part of the code is problematic for you, I still don't know the reason. I'd check your /etc/sudoers, .bashrc, /etc/bash.bashrc and /etc/bash.bashrc.local first. Could you paste the content of those files (if existing) somewhere, so I could have a look?

Edit: Generating a report with "bash -x pacaur -S <package>" might also be useful.
Edit2: Having a look at http://superuser.com/questions/119376/b … t-be-a-tty might also help you.

Last edited by Spyhawk (2011-10-22 09:37:56)

Offline

Board footer

Powered by FluxBB