You are not logged in.

#51 2012-01-12 16:39:07

mjohnson
Member
Registered: 2009-08-14
Posts: 22

Re: Not resuming after suspend

@jwhendy: Yeah, it does sound like there's more than one issue. Oddly, though, I seem to be in a third group: hpet=disable does work for me, but 3.1.8 didn't change things (hpet=disable still works and is still necessary). Or rather, 3.1.8 did change things: whatever kernel version I was running before I did a system upgrade worked fine. smile (I don't suppose there's an easy way to see what the kernel version I used to have was, is there?)

So for now, fortunately, I can suspend, but I don't know if hpet=disable will degrade system performance, so I still hope for a real fix.

Offline

#52 2012-01-12 16:42:30

jwhendy
Member
Registered: 2010-04-01
Posts: 558

Re: Not resuming after suspend

@mjohnson: You can check the pacman logs. One could do better than this, but I just used grep...

$ grep linux /var/log/pacman.log

[2012-01-05 14:18] upgraded linux (3.1.6-1 -> 3.1.7-1)
[2012-01-05 14:19] upgraded linux-headers (3.1.6-1 -> 3.1.7-1)
[2012-01-09 09:20]   -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
[2012-01-09 09:20] ==> Creating gzip initcpio image: /boot/initramfs-linux.img
[2012-01-09 09:20]   -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
[2012-01-09 09:20] ==> Creating gzip initcpio image: /boot/initramfs-linux-fallback.img
[2012-01-09 09:20] upgraded linux (3.1.7-1 -> 3.1.8-1)
[2012-01-09 09:20] upgraded linux-headers (3.1.7-1 -> 3.1.8-1)
[2012-01-11 18:05] upgraded util-linux (2.20.1-1 -> 2.20.1-2)

You can look for the dates of all the "upgraded linux (3.1.x -> 3.1.y)" lines.

Good luck. At least hpet=disable is a workaround for you. Not being able to suspend at all was bad news.

Offline

#53 2012-01-12 17:46:32

mjohnson
Member
Registered: 2009-08-14
Posts: 22

Re: Not resuming after suspend

I started investigating this, but decided to try reproducing the issue first. So I took the hpet=disable line out of /boot/grub/menu.lst and rebooted; then I suspended. When I woke the machine back up, however, it woke back up just fine! I've tried a couple of times now, and can't seem to get the original issue to come back. I'm sorry for muddying the waters here with an issue unrelated to the original one. smile I have no idea why the screen wouldn't come back before, but I hope it stays working like this! And good luck to the people here who are still without suspend...that stinks!

Offline

#54 2012-01-14 23:21:43

amsri
Member
Registered: 2011-06-17
Posts: 48

Re: Not resuming after suspend

I have an HP laptop (HP Pavillion DV3142-ea) and I have the black screen (no backlight at all) problem. The always had black screen upon resume problem in this laptop and it never worked. I posted in other relevant posts but unfortunately issue never resolved.

The system resumes without any quirk but the screen doesnt come back. My video card specs are :

 lspci | grep VGA
01:05.0 VGA compatible controller: ATI Technologies Inc M880G [Mobility Radeon HD 4200]
02:00.0 VGA compatible controller: ATI Technologies Inc Manhattan [Mobility Radeon HD 5400 Series]

I am running driver xf86-video-ati and kernel version 3.1.8-1.

EDIT:
I have not tried hpet=disable

Last edited by amsri (2012-01-14 23:22:23)

Offline

#55 2012-01-14 23:43:48

amsri
Member
Registered: 2011-06-17
Posts: 48

Re: Not resuming after suspend

hpet=disable does not work. I tried disabling KMS by adding nomodeset to kernel line in /boot/grub/menu.lst and resume works with screen coming back (however I lost all my resolution etc.). Does the problem have to do anything with KMS?

Anyways, disbaling KMS is not an option for me so I have enabled it back and hoping for another solution.

Offline

#56 2012-01-15 14:03:27

toni
Member
Registered: 2011-10-15
Posts: 395

Re: Not resuming after suspend

Hi All,

Sorry to be late, I was investigating a lot and lastly I have solved it by adding acpid daemon to /etc/rc.conf file in DAEMONS line.

I have installed the following packages:

extra/acpid 2.0.14-1
    A daemon for delivering ACPI power management events with netlink support

extra/acpi 1.5-1
    Linux ACPI client providing battery, AC power, and thermal readings

extra/pm-quirks 0.20100619-2
    Quirks data for pm-utils

extra/pm-utils 1.4.1-3
    Utilities and scripts for suspend and hibernate power management

I still have linux kernel 3.1.4-1-ARCH and hpet=disable as kernel parameter in my /boot/syslinux/syslinux.cfg or /boot/grub/menu.lst if you use grub instead.

That worked for me.

Thanks all

Last edited by toni (2012-01-15 14:16:18)

Offline

#57 2012-01-15 14:09:54

toni
Member
Registered: 2011-10-15
Posts: 395

Re: Not resuming after suspend

snufkin wrote:

I've got the same problem, although none of the solutions posted in this thread helps.

Asus F5R laptop
uname -r: 3.1.6-1-ARCH
radeon driver

When using pm-suspend, the computer suspends as it's supposed to do. However, when I try to resume it again, the screen is blank. HDD and fans are spinning and all the lights turn back on, but the screen is blank.

pm-suspend.log:

Initial commandline parameters: 
Thu Jan  5 00:06:39 CET 2012: Running hooks for suspend.
Running hook /usr/lib/pm-utils/sleep.d/00logging suspend suspend:
Linux localhost 3.1.6-1-ARCH #1 SMP PREEMPT Thu Dec 22 08:52:33 UTC 2011 i686 Intel(R) Core(TM) Duo CPU T2450 @ 2.00GHz GenuineIntel GNU/Linux
Module                  Size  Used by
cryptd                  6925  0 
aes_i586                6940  1 
aes_generic            25702  1 aes_i586
ipv6                  247457  10 
joydev                  7439  0 
arc4                    1086  2 
b43                   301586  0 
mac80211              196411  1 b43
snd_hda_codec_si3054     2866  1 
uas                     6440  0 
usb_storage            35343  0 
snd_hda_codec_realtek   211044  1 
cfg80211              142604  2 b43,mac80211
bcma                   14319  1 b43
radeon                913985  2 
ttm                    45685  1 radeon
psmouse                56772  0 
ssb                    41907  1 b43
snd_hda_intel          19293  0 
snd_hda_codec          69829  3 snd_hda_codec_si3054,snd_hda_codec_realtek,snd_hda_intel
snd_hwdep               4942  1 snd_hda_codec
snd_pcm                60207  3 snd_hda_codec_si3054,snd_hda_intel,snd_hda_codec
drm_kms_helper         22237  1 radeon
ati_agp                 4545  0 
drm                   149266  4 radeon,ttm,drm_kms_helper
agpgart                22287  3 ttm,ati_agp,drm
serio_raw               3390  0 
snd_timer              15438  1 snd_pcm
mmc_core               66997  2 b43,ssb
snd                    43817  7 snd_hda_codec_si3054,snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_timer
pcmcia                 31534  2 b43,ssb
pcmcia_core            10114  1 pcmcia
atl2                   20345  0 
soundcore               5018  1 snd
i2c_piix4               7084  0 
snd_page_alloc          5869  2 snd_hda_intel,snd_pcm
videodev               77028  0 
media                   8609  1 videodev
asus_laptop            11994  0 
i2c_algo_bit            4423  1 radeon
sp5100_tco              3760  0 
sparse_keymap           2660  1 asus_laptop
evdev                   7278  7 
shpchp                 22497  0 
pci_hotplug            22072  1 shpchp
processor              21844  2 
i2c_core               16816  6 radeon,drm_kms_helper,drm,i2c_piix4,videodev,i2c_algo_bit
rfkill                 12470  2 cfg80211,asus_laptop
thermal                 6531  0 
pcspkr                  1375  0 
button                  3614  0 
battery                 5053  0 
ac                      1796  0 
video                   9716  0 
ext4                  341420  1 
mbcache                 4281  1 ext4
jbd2                   59633  1 ext4
crc16                   1091  1 ext4
sr_mod                 13244  0 
cdrom                  31405  1 sr_mod
sd_mod                 26147  3 
pata_acpi               2388  0 
ahci                   17497  2 
libahci                16783  1 ahci
pata_atiixp             2920  0 
libata                146596  4 pata_acpi,ahci,libahci,pata_atiixp
ohci_hcd               19226  0 
ehci_hcd               36074  0 
scsi_mod              112473  5 uas,usb_storage,sr_mod,sd_mod,libata
usbcore               120796  5 uas,usb_storage,ohci_hcd,ehci_hcd
             total       used       free     shared    buffers     cached
Mem:       1935344     628024    1307320          0      46344     285940
-/+ buffers/cache:     295740    1639604
Swap:      1048508          0    1048508

/usr/lib/pm-utils/sleep.d/00logging suspend suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/00powersave suspend suspend:

/usr/lib/pm-utils/sleep.d/00powersave suspend suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/01grub suspend suspend:

/usr/lib/pm-utils/sleep.d/01grub suspend suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/11netcfg suspend suspend:

/usr/lib/pm-utils/sleep.d/11netcfg suspend suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/49bluetooth suspend suspend:

/usr/lib/pm-utils/sleep.d/49bluetooth suspend suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/75modules suspend suspend:

/usr/lib/pm-utils/sleep.d/75modules suspend suspend: success.
Running hook /etc/pm/sleep.d/90alsa suspend suspend:

/etc/pm/sleep.d/90alsa suspend suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/90clock suspend suspend:

/usr/lib/pm-utils/sleep.d/90clock suspend suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/91wicd suspend suspend:

/usr/lib/pm-utils/sleep.d/91wicd suspend suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/94cpufreq suspend suspend:

/usr/lib/pm-utils/sleep.d/94cpufreq suspend suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/95led suspend suspend:

/usr/lib/pm-utils/sleep.d/95led suspend suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/98video-quirk-db-handler suspend suspend:
Kernel modesetting video driver detected, not using quirks.

/usr/lib/pm-utils/sleep.d/98video-quirk-db-handler suspend suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/99video suspend suspend:
kernel.acpi_video_flags = 0

/usr/lib/pm-utils/sleep.d/99video suspend suspend: success.
Thu Jan  5 00:06:47 CET 2012: performing suspend

If you need any more info for helping me, please let me know.

Have you installed acpi? and added acpid daemon to /etc/rc.conf? that worked for me. See my post #56 (I have added this to first post).
I have 3.1.4 kernel.

Hope it helps

Last edited by toni (2012-01-15 14:15:40)

Offline

#58 2012-01-15 16:59:39

jwhendy
Member
Registered: 2010-04-01
Posts: 558

Re: Not resuming after suspend

@toni: I'm interested in this, but am surprised that acpid would be related. From my skim, it seems like this is for handling events that should <i>trigger</i> something else. In other words, acpid lets you connect a button press or lid close with pm-suspend. I'm not at the moment sure why manually executing pm-suspend would require acpid.

Then again, if it's working for you, it's working! Keep us posted.

Offline

#59 2012-01-17 16:04:56

amsri
Member
Registered: 2011-06-17
Posts: 48

Re: Not resuming after suspend

I already have acpi installed and acpid in the daemons array of rc.conf. So I don't think this has relation to acpid

Offline

#60 2012-01-17 17:34:12

travmon
Member
From: Canada
Registered: 2010-09-17
Posts: 8

Re: Not resuming after suspend

I think by default acpi_osi is set to Windows NT.  Try adding  GRUB_CMDLINE_LINUX="acpi_osi=Linux"  to  /etc/default/grub to tell bios you are running linux  then update grub.


The dam fish won't bite

Offline

#61 2012-01-17 20:26:54

toni
Member
Registered: 2011-10-15
Posts: 395

Re: Not resuming after suspend

amsri wrote:

I already have acpi installed and acpid in the daemons array of rc.conf. So I don't think this has relation to acpid

Have a look at the links below. Maybe it could help you:

Acpid
Suspend to RAM

Have you checked pm-suspend.log file to see if there are errors? Can you post its content?

Offline

#62 2012-01-18 23:40:40

amsri
Member
Registered: 2011-06-17
Posts: 48

Re: Not resuming after suspend

toni wrote:

Have a look at the links below. Maybe it could help you:

Acpid
Suspend to RAM

I am running LXDE and have installed pm-utils and I have tried to follow the guide as far as applicable to my laptop(like resume Hook etc). Hibernate works fine. In suspend it successfully suspends but does not resume video (hardisk, keyboard etc all come back).

toni wrote:

Have you checked pm-suspend.log file to see if there are errors? Can you post its content?

I have posted the log of most recent suspend activity from /var/log/pm-suspend.log

 Initial commandline parameters: 
Sat Jan 14 23:57:03 GMT 2012: Running hooks for suspend.
Running hook /usr/lib/pm-utils/sleep.d/00logging suspend suspend:
Linux hplaptop 3.1.8-1-ARCH #1 SMP PREEMPT Sat Jan 7 08:59:43 CET 2012 x86_64 AMD Phenom(tm) II N930 Quad-Core Processor AuthenticAMD GNU/Linux
Module                  Size  Used by
fuse                   66858  2 
rfcomm                 34229  8 
bnep                    9149  2 
ext2                   63283  1 
uvcvideo               64995  0 
videodev               85100  1 uvcvideo
media                  10565  2 uvcvideo,videodev
v4l2_compat_ioctl32     8644  1 videodev
bcma                   17115  0 
arc4                    1410  2 
joydev                  9895  0 
snd_hda_codec_hdmi     22821  1 
brcmsmac              569864  0 
mac80211              221981  1 brcmsmac
snd_hda_codec_idt      56733  1 
brcmutil                6912  1 brcmsmac
snd_hda_intel          22442  1 
cfg80211              165796  2 brcmsmac,mac80211
cryptd                  8309  0 
aes_x86_64              7508  3 
radeon                996072  2 
snd_hda_codec          81242  3 snd_hda_codec_hdmi,snd_hda_codec_idt,snd_hda_intel
aes_generic            26138  1 aes_x86_64
hp_accel               13864  0 
edac_core              37552  0 
lis3lv02d              10604  1 hp_accel
ecb                     2073  1 
btusb                  11385  2 
snd_hwdep               6357  1 snd_hda_codec
snd_pcm                74368  3 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
serio_raw               4294  0 
psmouse                55501  0 
sp5100_tco              4568  0 
i2c_piix4               8224  0 
shpchp                 26249  0 
ttm                    54872  1 radeon
pci_hotplug            25454  1 shpchp
drm_kms_helper         25721  1 radeon
drm                   185768  4 radeon,ttm,drm_kms_helper
hp_wmi                  7738  0 
sparse_keymap           3120  1 hp_wmi
snd_timer              19544  1 snd_pcm
bluetooth             150884  23 rfcomm,bnep,btusb
snd                    58362  9 snd_hda_codec_hdmi,snd_hda_codec_idt,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_timer
soundcore               6210  1 snd
rfkill                 15498  5 cfg80211,hp_wmi,bluetooth
snd_page_alloc          7153  2 snd_hda_intel,snd_pcm
i2c_algo_bit            5199  1 radeon
wmi                     8475  1 hp_wmi
k10temp                 2883  0 
r8169                  45411  0 
mii                     4059  1 r8169
i2c_core               20460  6 videodev,radeon,i2c_piix4,drm_kms_helper,drm,i2c_algo_bit
thermal                 7799  0 
video                  11164  0 
evdev                   9530  16 
input_polldev           2914  1 lis3lv02d
pcspkr                  1819  0 
edac_mce_amd           13215  0 
ac                      2344  0 
battery                 6453  0 
button                  4470  0 
powernow_k8            13347  0 
freq_table              2515  1 powernow_k8
processor              24224  1 powernow_k8
mperf                   1275  1 powernow_k8
ext4                  375829  2 
mbcache                 5881  2 ext2,ext4
jbd2                   70763  1 ext4
crc16                   1359  2 bluetooth,ext4
sr_mod                 14951  0 
cdrom                  36553  1 sr_mod
sd_mod                 28275  5 
ohci_hcd               21714  0 
ahci                   20005  4 
libahci                19559  1 ahci
libata                166692  2 ahci,libahci
ehci_hcd               40762  0 
scsi_mod              132826  3 sr_mod,sd_mod,libata
usbcore               144240  5 uvcvideo,btusb,ohci_hcd,ehci_hcd
             total       used       free     shared    buffers     cached
Mem:       5855344     315732    5539612          0      20008      92460
-/+ buffers/cache:     203264    5652080
Swap:      2008696          0    2008696

/usr/lib/pm-utils/sleep.d/00logging suspend suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/00powersave suspend suspend:

/usr/lib/pm-utils/sleep.d/00powersave suspend suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/01grub suspend suspend:

/usr/lib/pm-utils/sleep.d/01grub suspend suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/11netcfg suspend suspend:
:: life down    [BUSY]    [DONE] 

/usr/lib/pm-utils/sleep.d/11netcfg suspend suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/49bluetooth suspend suspend:

/usr/lib/pm-utils/sleep.d/49bluetooth suspend suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/75modules suspend suspend:
Unloading kernel module hp_accel...Done.
Unloading kernel module lis3lv02d...Done.

/usr/lib/pm-utils/sleep.d/75modules suspend suspend: success.
Running hook /etc/pm/sleep.d/90alsa suspend suspend:

/etc/pm/sleep.d/90alsa suspend suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/90clock suspend suspend:

/usr/lib/pm-utils/sleep.d/90clock suspend suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/94cpufreq suspend suspend:

/usr/lib/pm-utils/sleep.d/94cpufreq suspend suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/95led suspend suspend:

/usr/lib/pm-utils/sleep.d/95led suspend suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/98video-quirk-db-handler suspend suspend:
Kernel modesetting video driver detected, not using quirks.

/usr/lib/pm-utils/sleep.d/98video-quirk-db-handler suspend suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/99video suspend suspend:
kernel.acpi_video_flags = 0

/usr/lib/pm-utils/sleep.d/99video suspend suspend: success.
Sat Jan 14 23:57:05 GMT 2012: performing suspend
Sat Jan 14 23:57:31 GMT 2012: Awake.
Sat Jan 14 23:57:31 GMT 2012: Running hooks for resume
Running hook /usr/lib/pm-utils/sleep.d/99video resume suspend:

/usr/lib/pm-utils/sleep.d/99video resume suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/98video-quirk-db-handler resume suspend:

/usr/lib/pm-utils/sleep.d/98video-quirk-db-handler resume suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/95led resume suspend:

/usr/lib/pm-utils/sleep.d/95led resume suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/94cpufreq resume suspend:

/usr/lib/pm-utils/sleep.d/94cpufreq resume suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/90clock resume suspend:

/usr/lib/pm-utils/sleep.d/90clock resume suspend: success.
Running hook /etc/pm/sleep.d/90alsa resume suspend:
Playing raw data '/dev/zero' : Unsigned 8 bit, Rate 8000 Hz, Mono

/etc/pm/sleep.d/90alsa resume suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/75modules resume suspend:
Reloaded unloaded modules.

/usr/lib/pm-utils/sleep.d/75modules resume suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/49bluetooth resume suspend:

/usr/lib/pm-utils/sleep.d/49bluetooth resume suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/11netcfg resume suspend:
:: life up    [BUSY]    [DONE] 

/usr/lib/pm-utils/sleep.d/11netcfg resume suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/01grub resume suspend:

/usr/lib/pm-utils/sleep.d/01grub resume suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/00powersave resume suspend:

/usr/lib/pm-utils/sleep.d/00powersave resume suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/00logging resume suspend:

/usr/lib/pm-utils/sleep.d/00logging resume suspend: success.
Sat Jan 14 23:57:42 GMT 2012: Finished.
 

Offline

#63 2012-01-18 23:45:48

jwhendy
Member
Registered: 2010-04-01
Posts: 558

Re: Not resuming after suspend

Hmmm... I just had this come back on a custom 3.1.7 kernel without hpet=disable. I've been fine for a couple weeks on this kernel and thought it was fixed and just had it happen to me today.

Offline

#64 2012-01-21 13:59:48

toni
Member
Registered: 2011-10-15
Posts: 395

Re: Not resuming after suspend

amsri wrote:
toni wrote:

Have a look at the links below. Maybe it could help you:

Acpid
Suspend to RAM

I am running LXDE and have installed pm-utils and I have tried to follow the guide as far as applicable to my laptop(like resume Hook etc). Hibernate works fine. In suspend it successfully suspends but does not resume video (hardisk, keyboard etc all come back).

toni wrote:

Have you checked pm-suspend.log file to see if there are errors? Can you post its content?

I have posted the log of most recent suspend activity from /var/log/pm-suspend.log

 Initial commandline parameters: 
Sat Jan 14 23:57:03 GMT 2012: Running hooks for suspend.
Running hook /usr/lib/pm-utils/sleep.d/00logging suspend suspend:
Linux hplaptop 3.1.8-1-ARCH #1 SMP PREEMPT Sat Jan 7 08:59:43 CET 2012 x86_64 AMD Phenom(tm) II N930 Quad-Core Processor AuthenticAMD GNU/Linux
Module                  Size  Used by
fuse                   66858  2 
rfcomm                 34229  8 
bnep                    9149  2 
ext2                   63283  1 
uvcvideo               64995  0 
videodev               85100  1 uvcvideo
media                  10565  2 uvcvideo,videodev
v4l2_compat_ioctl32     8644  1 videodev
bcma                   17115  0 
arc4                    1410  2 
joydev                  9895  0 
snd_hda_codec_hdmi     22821  1 
brcmsmac              569864  0 
mac80211              221981  1 brcmsmac
snd_hda_codec_idt      56733  1 
brcmutil                6912  1 brcmsmac
snd_hda_intel          22442  1 
cfg80211              165796  2 brcmsmac,mac80211
cryptd                  8309  0 
aes_x86_64              7508  3 
radeon                996072  2 
snd_hda_codec          81242  3 snd_hda_codec_hdmi,snd_hda_codec_idt,snd_hda_intel
aes_generic            26138  1 aes_x86_64
hp_accel               13864  0 
edac_core              37552  0 
lis3lv02d              10604  1 hp_accel
ecb                     2073  1 
btusb                  11385  2 
snd_hwdep               6357  1 snd_hda_codec
snd_pcm                74368  3 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
serio_raw               4294  0 
psmouse                55501  0 
sp5100_tco              4568  0 
i2c_piix4               8224  0 
shpchp                 26249  0 
ttm                    54872  1 radeon
pci_hotplug            25454  1 shpchp
drm_kms_helper         25721  1 radeon
drm                   185768  4 radeon,ttm,drm_kms_helper
hp_wmi                  7738  0 
sparse_keymap           3120  1 hp_wmi
snd_timer              19544  1 snd_pcm
bluetooth             150884  23 rfcomm,bnep,btusb
snd                    58362  9 snd_hda_codec_hdmi,snd_hda_codec_idt,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_timer
soundcore               6210  1 snd
rfkill                 15498  5 cfg80211,hp_wmi,bluetooth
snd_page_alloc          7153  2 snd_hda_intel,snd_pcm
i2c_algo_bit            5199  1 radeon
wmi                     8475  1 hp_wmi
k10temp                 2883  0 
r8169                  45411  0 
mii                     4059  1 r8169
i2c_core               20460  6 videodev,radeon,i2c_piix4,drm_kms_helper,drm,i2c_algo_bit
thermal                 7799  0 
video                  11164  0 
evdev                   9530  16 
input_polldev           2914  1 lis3lv02d
pcspkr                  1819  0 
edac_mce_amd           13215  0 
ac                      2344  0 
battery                 6453  0 
button                  4470  0 
powernow_k8            13347  0 
freq_table              2515  1 powernow_k8
processor              24224  1 powernow_k8
mperf                   1275  1 powernow_k8
ext4                  375829  2 
mbcache                 5881  2 ext2,ext4
jbd2                   70763  1 ext4
crc16                   1359  2 bluetooth,ext4
sr_mod                 14951  0 
cdrom                  36553  1 sr_mod
sd_mod                 28275  5 
ohci_hcd               21714  0 
ahci                   20005  4 
libahci                19559  1 ahci
libata                166692  2 ahci,libahci
ehci_hcd               40762  0 
scsi_mod              132826  3 sr_mod,sd_mod,libata
usbcore               144240  5 uvcvideo,btusb,ohci_hcd,ehci_hcd
             total       used       free     shared    buffers     cached
Mem:       5855344     315732    5539612          0      20008      92460
-/+ buffers/cache:     203264    5652080
Swap:      2008696          0    2008696

/usr/lib/pm-utils/sleep.d/00logging suspend suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/00powersave suspend suspend:

/usr/lib/pm-utils/sleep.d/00powersave suspend suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/01grub suspend suspend:

/usr/lib/pm-utils/sleep.d/01grub suspend suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/11netcfg suspend suspend:
:: life down    [BUSY]    [DONE] 

/usr/lib/pm-utils/sleep.d/11netcfg suspend suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/49bluetooth suspend suspend:

/usr/lib/pm-utils/sleep.d/49bluetooth suspend suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/75modules suspend suspend:
Unloading kernel module hp_accel...Done.
Unloading kernel module lis3lv02d...Done.

/usr/lib/pm-utils/sleep.d/75modules suspend suspend: success.
Running hook /etc/pm/sleep.d/90alsa suspend suspend:

/etc/pm/sleep.d/90alsa suspend suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/90clock suspend suspend:

/usr/lib/pm-utils/sleep.d/90clock suspend suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/94cpufreq suspend suspend:

/usr/lib/pm-utils/sleep.d/94cpufreq suspend suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/95led suspend suspend:

/usr/lib/pm-utils/sleep.d/95led suspend suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/98video-quirk-db-handler suspend suspend:
Kernel modesetting video driver detected, not using quirks.

/usr/lib/pm-utils/sleep.d/98video-quirk-db-handler suspend suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/99video suspend suspend:
kernel.acpi_video_flags = 0

/usr/lib/pm-utils/sleep.d/99video suspend suspend: success.
Sat Jan 14 23:57:05 GMT 2012: performing suspend
Sat Jan 14 23:57:31 GMT 2012: Awake.
Sat Jan 14 23:57:31 GMT 2012: Running hooks for resume
Running hook /usr/lib/pm-utils/sleep.d/99video resume suspend:

/usr/lib/pm-utils/sleep.d/99video resume suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/98video-quirk-db-handler resume suspend:

/usr/lib/pm-utils/sleep.d/98video-quirk-db-handler resume suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/95led resume suspend:

/usr/lib/pm-utils/sleep.d/95led resume suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/94cpufreq resume suspend:

/usr/lib/pm-utils/sleep.d/94cpufreq resume suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/90clock resume suspend:

/usr/lib/pm-utils/sleep.d/90clock resume suspend: success.
Running hook /etc/pm/sleep.d/90alsa resume suspend:
Playing raw data '/dev/zero' : Unsigned 8 bit, Rate 8000 Hz, Mono

/etc/pm/sleep.d/90alsa resume suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/75modules resume suspend:
Reloaded unloaded modules.

/usr/lib/pm-utils/sleep.d/75modules resume suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/49bluetooth resume suspend:

/usr/lib/pm-utils/sleep.d/49bluetooth resume suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/11netcfg resume suspend:
:: life up    [BUSY]    [DONE] 

/usr/lib/pm-utils/sleep.d/11netcfg resume suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/01grub resume suspend:

/usr/lib/pm-utils/sleep.d/01grub resume suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/00powersave resume suspend:

/usr/lib/pm-utils/sleep.d/00powersave resume suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/00logging resume suspend:

/usr/lib/pm-utils/sleep.d/00logging resume suspend: success.
Sat Jan 14 23:57:42 GMT 2012: Finished.
 

Hi amsri,

Have you checked /etc/mkinitcpio.conf file? how is your hooks array? mine is the following:

HOOKS="base udev pata scsi sata resume filesystems usbinput"

Note that I have removed autodetect from it and add resume instead. Take into account that resume must be placed after ide, scsi, sata and/or lvm2, but before filesystems. Have you tried this?

after modifying this file you must rebuild the initrd image for these changes to take effect using:

# mkinitcpio -p linux

If you use a custom kernel, then you might have to change the value of the '-p' option.

Have you seen following troubleshootings? Please, see below:

Sections "Resume Hook" and "Blank screen when waking from suspend" from "Troubleshooting" chapter at the bottom of the following link:

Some troubleshootings and Tips and Tricks

and section "Blank Screen Issue" from "Tips and Tricks / FAQ".

Hope it helps.

Offline

#65 2012-01-21 16:05:25

jwhendy
Member
Registered: 2010-04-01
Posts: 558

Re: Not resuming after suspend

@toni: that should only be an issue if the appropriate error message is located in the log, correct? I've never seen any error messages like mentioned in the wiki and thus don't think the resume hook applies to me. I don't see "Image not present or could not be loaded" in amsri's log either.

Offline

#66 2012-01-23 21:27:31

konstantin.p
Member
Registered: 2012-01-04
Posts: 7

Re: Not resuming after suspend

Hello, I had the same "blank screen" problem on resume with my AMD A6 APU (CPU+GPU). After upgrade to linux 3.2 the problem grown up to "blank screen every boot" (always).
I solved all this by applying patches from comment 13 of bug https://bugs.freedesktop.org/show_bug.cgi?id=41569 to kernel 3.2.1

Offline

#67 2012-01-24 16:28:20

gururise
Member
Registered: 2011-11-03
Posts: 18

Re: Not resuming after suspend

My suspend/resume has been working fine on my Desktop since Kernel 3.1.6; however, with the recent switch to KMOD from module-init-tools, suddenly my Desktop won't wake up anymore.  I'm not sure if its KMOD that did it or the upgrade to Kernel 3.2.x, as they happened around the same time.  I haven't tried with hpet=disable yet.  I've always had the 'resume' hook, as that was required for my desktop to wake up.

I'm thinking KMOD has something to do with the recent troubles.

Edit: Turns out it wasn't KMOD, as I was able to suspend/resume again under 3.2.1; however, I am now using 3.2.5, and resume is broken once again, even after downgrading to 3.2.1.  So it must be some other packages that are the cause.

Last edited by gururise (2012-02-10 18:42:43)

Offline

#68 2012-01-25 13:27:51

amsri
Member
Registered: 2011-06-17
Posts: 48

Re: Not resuming after suspend

@toni I also have the same hooks array in /etc/mkinitcpio.conf file as yours. I tried both resume and usresume hooks. uresume was used with uswusp sleep backend. I have also tried all the tips and tricks in the link mentioned by you. However, I would try removing the autodetect issue again (though I have tried it previously).

Offline

#69 2012-01-31 21:40:45

jwhendy
Member
Registered: 2010-04-01
Posts: 558

Re: Not resuming after suspend

Just happened to me again on a custom 3.2.1 kernel with hpet=disable in the menu.lst options. Very frustrated. Any more thoughts as to the cause of this?

Offline

#70 2012-03-14 13:42:49

CyrIng
Member
From: France
Registered: 2010-07-17
Posts: 76
Website

Re: Not resuming after suspend

Same issue here with kernel 3.2.9-2
Try everything such as hpet=disable ; any hooks whatever the runlevel is single, multi w/o X and from kde : no success
Suspend to ram goes ... computer stops ... power button blinks ... resume with button ... screen stays black with a cursor .
No keyboard & my acpi power button shell script does not run the shutdown I have programmed
What I noticed is that the fan goes high meaning that CPU may be locked.
S3 used to work with previous releases, at least 2.6 while I used to have Grub rather than SysLinux
I suspect last Linux kernels are buggy

Last edited by CyrIng (2012-03-14 13:50:38)

Offline

#71 2012-03-30 07:02:01

caasi
Member
Registered: 2012-03-21
Posts: 44
Website

Re: Not resuming after suspend

I can resume but after that... CPU usage is REALLY HIGH. I have to reboot ever time I suspend and resume.
the pm-suspend.log is all "success"
any idea ?

Offline

#72 2012-04-01 08:17:12

toni
Member
Registered: 2011-10-15
Posts: 395

Re: Not resuming after suspend

amsri wrote:

@toni I also have the same hooks array in /etc/mkinitcpio.conf file as yours. I tried both resume and usresume hooks. uresume was used with uswusp sleep backend. I have also tried all the tips and tricks in the link mentioned by you. However, I would try removing the autodetect issue again (though I have tried it previously).

The cause of the problem for me was mainly that I had not installed acpid so after installing it all works ok for me, even upgrading kernel is working for me as well. A few time ago I upgraded to kernel 3.2.6-1-ARCH and it continues working without problems.

My daemons are the following in the order specified /etc/rc.conf:

DAEMONS=(hwclock syslog-ng dbus hal networkmanager netfs cups oss crond acpid gdm)

Offline

#73 2012-04-22 18:26:29

Kpunkt
Member
Registered: 2009-06-08
Posts: 142

Re: Not resuming after suspend

I'm having similar issues, but I'm not sure if my problem is related:

Resuming after suspend works, except that the system suspends again two seconds after having resumed. If I resume from that, everything works fine.
If I try to suspend & resume using rtcwake, things get even stranger: Executing something as

sudo rtcwake -m mem -s 2

resumes fine in most of the cases, except sometimes when resuming behaves as stated above.
Adding hpet=disable to the kernel line doesn't help with any of this.

I'm using a Lenovo ThinkPad x201 with intel drivers and the latest kernel (3.3.2-1-ARCH). Problem exist since 3.1.X

Last edited by Kpunkt (2012-04-22 18:27:31)

Offline

#74 2012-05-21 17:56:13

akoustiq
Member
Registered: 2012-05-21
Posts: 1

Re: Not resuming after suspend

Hi, sorry to bring back a potentially dead thread, but I'm sure a lot of people are still experiencing this problem. I run Arch on a Macbook5,1 and have been unable to resume after a suspend to RAM. My log indicated that the suspend operation was fine, but on resume, X would fail to restart.

I was able to solve this problem in my situation by replacing the Nvidia Nouveau drivers with the proprietary "nvidia" package provided by Arch. This solution worked without any further configuration. Hope this helps. Please message me or reply here if you would like more information.

Offline

#75 2012-06-14 15:57:39

podosinovik
Member
Registered: 2010-02-27
Posts: 16

Re: Not resuming after suspend

Thanx for nice summary in top post. It helped me.

Here is my story, may be it will help others.

My archlinux started to refuse to suspend after motherboard battery replacement. I saw black screen and cursor.
I tweaked BIOS settings relying on common sense so that system went to suspend mode but can not resume thoroughly. Again black screen(no cursor this time) but this time I could blindly type commands at least to reboot my computer cleanly.
All this tyme pm-suspend logs are OK, even modules with poor behaviour(ehci etc) were unloaded.
Futher tweaks on BIOS didn't help.
I gave acpid a try and everething just works now.

Tip:
You can try it without rebooting:
rc.d start acpid
And if it works - go add it to the DAEMONS in rc.conf

By the way i'm on custom nettop, not laptop.

Offline

Board footer

Powered by FluxBB