You are not logged in.

#26 2012-01-29 16:31:21

mangus
Member
From: Bologna, Italy
Registered: 2007-04-07
Posts: 289

Re: Makepkg errors everwhere after pacman 4.x update

Some more stuff to debug this...
- I just got this compiling googlecl from AUR with yaourt , as root.
- Compiling as user through simple makepkg doesn't show the issue..
- Compiling as root through simple makepkg  shows the issue

Probably people having this issue with packer here are using it as root I suppose

edit: I've setup sudo in my system just to try  (never used before) , and the error shows up using yaourt through sudo , too

Last edited by mangus (2012-01-29 16:49:36)

Offline

#27 2012-01-29 16:56:17

hadrons123
Member
From: chennai
Registered: 2011-10-07
Posts: 1,249

Re: Makepkg errors everwhere after pacman 4.x update

Did you happen to update your yaourt and its dependencies?


LENOVO Y 580 IVYBRIDGE 660M NVIDIA
Unix is user-friendly. It just isn't promiscuous about which users it's friendly with. - Steven King

Offline

#28 2012-01-29 17:13:24

mangus
Member
From: Bologna, Italy
Registered: 2007-04-07
Posts: 289

Re: Makepkg errors everwhere after pacman 4.x update

hadrons123 wrote:

Did you happen to update your yaourt and its dependencies?

package-query  1.0.1-1
yaourt         1.0.1-1                                   
Pacman v4.0.1 - libalpm v7.0.1

Offline

#29 2012-01-29 17:54:27

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,095
Website

Re: Makepkg errors everwhere after pacman 4.x update

The real question is, why are you running makepkg as root... Better yet, why the hell does yaourt facilitate this?

(( ! UID )) && program_arg $A_M "--asroot"

Awful.

Offline

#30 2012-01-29 21:54:02

stefanwilkens
Member
From: Enschede, the Netherlands
Registered: 2008-12-10
Posts: 624

Re: Makepkg errors everwhere after pacman 4.x update

Quite a few users seem to have gotten it into their heads that the first thing to do when something doesn't work is to do that same thing again, under root rights. This is bad. It breaks things.

Only the actual installation requires root rights, makepkg does not and this section of Yaourt certainly shouldn't either.


Arch i686 on Phenom X4 | GTX760

Offline

#31 2012-02-01 20:15:30

*nixer
Member
Registered: 2011-11-11
Posts: 56

Re: Makepkg errors everwhere after pacman 4.x update

stefanwilkens wrote:

Quite a few users seem to have gotten it into their heads that the first thing to do when something doesn't work is to do that same thing again, under root rights. This is bad. It breaks things.

Only the actual installation requires root rights, makepkg does not and this section of Yaourt certainly shouldn't either.

I've only done it under root, because I run everything as root. I've been doing so for over a year, and haven't had any issues (outside of user error) present themselves because of this.

I may have deleted system files in the past necessitating a reinstall, but I understood the risks involved.

As to the thread issue... I don't think it's related to running as root. Anyone figure out what is causing it at the very least, pacman update or not? This started for me after doing some updates.

Last edited by *nixer (2012-02-01 20:18:02)

Offline

Board footer

Powered by FluxBB