You are not logged in.

#326 2012-07-25 07:26:11

I am Gianluca
Member
From: London, UK
Registered: 2011-05-22
Posts: 195

Re: glibc update refusing to proceed. File ownership problem

nomorewindows wrote:

Hmm...2.16.0-1 is the one that's installed...and it is waiting for 2.16.0-2, and 2.16.0-2's files seem to be in place, but if you made the symlink yourself, it will just remove 2.16.0-1 if that's actually what's there. 
I think the commandline is pacman -Rdd glibc
Once you do that ??? I'm not sure which one you'll have to use.  If you have everything else installed you might be able to go right back with 2.16.0-2.

# pacman -Rdd glibc
warning: glibc is designated as a HoldPkg.
HoldPkg was found in target list. Do you want to continue? [y/N]

I don't know if it can be useful now, but I want to remind you that previously I've also done:

rm var/cache/pacman/pkg/glibc-2.16.0-1-i686.pkg.tar.xz

I don't think it's related but not being an expert I can wrong.

Last edited by I am Gianluca (2012-07-25 07:39:04)


Laptop: Acer Aspire S3 | Linux Mint Cinnamon 64-bit

Offline

#327 2012-07-25 21:38:46

Strike0
Member
From: Germany
Registered: 2011-09-05
Posts: 1,277

Re: glibc update refusing to proceed. File ownership problem

Using pacman -Rdd on it should work (I'm not sure it will work either, never had to use it).

Apart from deleting the glibc.tar you also wrote earlier that you manually moved the glibc-2.16.0.-1 linker files from /lib to /usr/lib and created the symlink manually. That's what messing things now maybe more.

Another way might be to remove the symlink and move the files back to /lib and trying a regular pacman -Su (since glibc-2.16.0-2 seems to be in your pacman cache already - double check that first) again then.

Offline

#328 2012-07-25 22:14:59

Terminator
Member
From: Belgium
Registered: 2012-05-07
Posts: 265

Re: glibc update refusing to proceed. File ownership problem

I am Gianluca wrote:
# pacman -Rdd glibc
warning: glibc is designated as a HoldPkg.
HoldPkg was found in target list. Do you want to continue? [y/N]

That's because of the following line in /etc/pacman.conf:

HoldPkg     = pacman glibc

Which means: never uninstall pacman or glibc.

I have read through your posts in this topic but I can't help you. I would probably just make a backup and reinstall.

Last edited by Terminator (2012-07-25 22:16:19)

Offline

#329 2012-07-25 22:47:21

nomorewindows
Member
Registered: 2010-04-03
Posts: 3,010

Re: glibc update refusing to proceed. File ownership problem

I am Gianluca wrote:
nomorewindows wrote:

Hmm...2.16.0-1 is the one that's installed...and it is waiting for 2.16.0-2, and 2.16.0-2's files seem to be in place, but if you made the symlink yourself, it will just remove 2.16.0-1 if that's actually what's there. 
I think the commandline is pacman -Rdd glibc
Once you do that ??? I'm not sure which one you'll have to use.  If you have everything else installed you might be able to go right back with 2.16.0-2.

# pacman -Rdd glibc
warning: glibc is designated as a HoldPkg.
HoldPkg was found in target list. Do you want to continue? [y/N]

I don't know if it can be useful now, but I want to remind you that previously I've also done:

rm var/cache/pacman/pkg/glibc-2.16.0-1-i686.pkg.tar.xz

I don't think it's related but not being an expert I can wrong.

If you answer yes to the HoldPkg question does it continue?
The file you deleted is still held back at http://pkgbuild.com/~allan/


I may have to CONSOLE you about your usage of ridiculously easy graphical interfaces...
Look ma, no mouse.

Offline

#330 2012-07-26 00:52:34

I am Gianluca
Member
From: London, UK
Registered: 2011-05-22
Posts: 195

Re: glibc update refusing to proceed. File ownership problem

# pacman -Rdd glibc
warning: glibc is designated as a HoldPkg.
HoldPkg was found in target list. Do you want to continue? [y/N] y

Target (1): glibc-2.16.0-1

Total Removed Size: 33.95 MiB

Do you want to remove these packages? [y/N] y
(1/1) removing glibc
warning: /etc/locale.gen saved as /etc/locale.gen.pacsave 

As I've imagined now I can use both pacman and tar commands. So, I don't know how to re-install glibc.


Laptop: Acer Aspire S3 | Linux Mint Cinnamon 64-bit

Offline

#331 2012-07-26 11:28:27

nomorewindows
Member
Registered: 2010-04-03
Posts: 3,010

Re: glibc update refusing to proceed. File ownership problem

Just where did you run pacman?
I don't see a pacman -r pointing to an installation, which means you are probably uninstalling it from the LiveCD.
pacman and tar are working off of the LiveCD.

pacman -Rdd glibc -r /mnt/arch
pacman -S glibc -r /mnt/arch


I may have to CONSOLE you about your usage of ridiculously easy graphical interfaces...
Look ma, no mouse.

Offline

#332 2012-07-26 11:40:33

I am Gianluca
Member
From: London, UK
Registered: 2011-05-22
Posts: 195

Re: glibc update refusing to proceed. File ownership problem

Yes, I was chrooting.
If I umount everything with a 'Ctrl+D' and run your latter command (I don't need to uninstall glibc anymore) I have this error:

error: failed retrieving file 'glibc-2.16.0-2-i686.pkg.tar.xz' from mirrors.st.uz : No address record
warning: failed to retrieve some files from core
error: failed to commit transaction (No address record)
Errors occurred, no packages were upgrade.

Obviously the list of servers is much longer, but writing all the list on a BlackBerry is a pain.
Hope you could understand. At the end of the day the main error I think is clear.


Laptop: Acer Aspire S3 | Linux Mint Cinnamon 64-bit

Offline

#333 2012-07-26 11:47:18

nomorewindows
Member
Registered: 2010-04-03
Posts: 3,010

Re: glibc update refusing to proceed. File ownership problem

You may just need to change the entry in /etc/pacman.d/mirrorlist to point to a different server.  But I thought you had already downloaded this file, which would remain in your chroot.


I may have to CONSOLE you about your usage of ridiculously easy graphical interfaces...
Look ma, no mouse.

Offline

#334 2012-07-26 13:17:06

Barrucadu
Member
From: York, England
Registered: 2008-03-30
Posts: 1,158
Website

Re: glibc update refusing to proceed. File ownership problem

Are you connected to the Internet? Do you have DNS working?

Offline

#335 2012-07-27 16:22:56

LB06
Member
From: The Netherlands
Registered: 2003-10-29
Posts: 435

Re: glibc update refusing to proceed. File ownership problem

I don't get it. When doing pacman -Su I still get the conflicting files error. When I execute the greps from the wiki however, it shows that all files are owned by glibc: http://pastebin.com/mFJpiJZu

Offline

#336 2012-07-27 16:32:33

Strike0
Member
From: Germany
Registered: 2011-09-05
Posts: 1,277

Re: glibc update refusing to proceed. File ownership problem

LB06 wrote:

I don't get it. When doing pacman -Su I still get the conflicting files error. When I execute the greps from the wiki however, it shows that all files are owned by glibc: http://pastebin.com/mFJpiJZu

No, the empty directory /lib/modules is left over. You have to delete that manually.

Offline

#337 2012-07-28 11:33:09

danielpublic
Member
Registered: 2011-01-03
Posts: 6

Re: glibc update refusing to proceed. File ownership problem

Hi. So I made something obviously really stupid. Contrary to what it said on the DeveloperWiki:usrlib-page. Instead I did:

sudo mv /lib/* /home/daniel/tmp/OLDlib/

Which results in, e.g: "command not found: ls"

Please, advice me so that I can better myself.
Thanks.

Offline

#338 2012-07-28 12:07:26

nomorewindows
Member
Registered: 2010-04-03
Posts: 3,010

Re: glibc update refusing to proceed. File ownership problem

danielpublic wrote:

Hi. So I made something obviously really stupid. Contrary to what it said on the DeveloperWiki:usrlib-page. Instead I did:

sudo mv /lib/* /home/daniel/tmp/OLDlib/

Which results in, e.g: "command not found: ls"

Please, advice me so that I can better myself.
Thanks.

You moved the working libraries much the same as deleting everything in /lib (you made a backup).

Now just get the LiveCD out (reboot), and update your glibc.


I may have to CONSOLE you about your usage of ridiculously easy graphical interfaces...
Look ma, no mouse.

Offline

#339 2012-07-28 12:40:51

japenagosc
Member
Registered: 2012-01-19
Posts: 78

Re: glibc update refusing to proceed. File ownership problem

dhave wrote:
japenagosc wrote:

Hello everybody.

I updated my system a few days ago, and it appeared to have a problem regarding glibc (mentioned in the news http://www.archlinux.org/news/the-lib-d … a-symlink/ ). I didn't read these news at that time, and i used the --force option with pacman. Now the system is broke. What should i do?

Thanks for your help.

Check the info in the pink box on this page:

https://wiki.archlinux.org/index.php/De … iki:usrlib

It worked! Thank you so much for your help. I really love Arch, but i didn't want to reinstall it from scratch. Thanks!!!

Offline

#340 2012-07-28 14:11:11

I am Gianluca
Member
From: London, UK
Registered: 2011-05-22
Posts: 195

Re: glibc update refusing to proceed. File ownership problem

nomorewindows wrote:

You may just need to change the entry in /etc/pacman.d/mirrorlist to point to a different server.  But I thought you had already downloaded this file, which would remain in your chroot.

Mm.. I've checked and using the LiveUSB* mode the mirrorlist that I was using was an old one. So probably it could have caused the errors messages.
So I've created a new mirrorlist file and used this two servers that should be updated:

Server = ftp://mirror.bytemark.co.uk/archlinux/$repo/os/$arch
Server = http://mirror.bytemark.co.uk/archlinux/$repo/os/$arch

I've tried to run a 'pacman -Syy -r /mnt/arch' but I recurred in the same errors:

error: failed to retrieving file 'core.db' from mirror.bytenmark.co.uk : No address record
error: failed to update core (No address record)
...
error: failed to syncronize any databases

* = using the LiveUSB to me means boot by the LiveUSB, create a /mnt/arch directory, mount in it the /dev/sda3 partition. Nothing more. Perhaps I've done something wrong. As I've said you, I'm a newbie user in this kind of stuffs.


Laptop: Acer Aspire S3 | Linux Mint Cinnamon 64-bit

Offline

#341 2012-07-28 14:16:03

Strike0
Member
From: Germany
Registered: 2011-09-05
Posts: 1,277

Re: glibc update refusing to proceed. File ownership problem

@Gianluca: Is network working before you chroot? Did you take care of resolv.conf as described in the chroot wiki?
If network is not working tell which steps you try to activate it _before_ the chroot and also which liveISO (date of the ISO or link) you use.

Offline

#342 2012-07-28 16:45:05

I am Gianluca
Member
From: London, UK
Registered: 2011-05-22
Posts: 195

Re: glibc update refusing to proceed. File ownership problem

Strike0 wrote:

@Gianluca: Is network working before you chroot? Did you take care of resolv.conf as described in the chroot wiki?
If network is not working tell which steps you try to activate it _before_ the chroot and also which liveISO (date of the ISO or link) you use.

These are the commands that I use to chroot:

mkdir /mnt/arch
mount /dev/sda3 /mnt/arch

cd /mnt/arch
mount -t proc proc proc/
mount -t sysfs sys sys/
mount -o bind /dev dev/
mount -t devpts pts dev/pts/

mount /dev/sda1 boot/

cp -L /etc/resolv.conf etc/resolv.conf

chroot . /bin/bash

Since after having eliminated glibc from my system I obtain this error after running 'chroot . /bin/bash':

chroot: failed to run command '/bin/bash': No such file or directory

Before chrooting, if I run 'ping www.google.com' i obtain:

ping: unknown host www.google.com

So, I suppose to not being correctly connected to the network.

Anyway, I've used the LiveISO founded with LinuxLiveUSB software. Unfortunately I don't known the exact version of the ISO. I only selected the OS (archlinux) and perhaps architecture (both i686 and x86) and waited until the automatic process ended the creation of the LiveUSB.


Laptop: Acer Aspire S3 | Linux Mint Cinnamon 64-bit

Offline

#343 2012-07-28 17:51:56

Strike0
Member
From: Germany
Registered: 2011-09-05
Posts: 1,277

Re: glibc update refusing to proceed. File ownership problem

@Gianluca -Just try this after the LiveUSB has booted:

dhcpcd eth0
ping mirror.bytemark.co.uk

and if works, go on like in your post #340:

mkdir /mnt/arch
mount /dev/sda3 /mnt/arch
pacman -S glibc -r /mnt/arch

Offline

#344 2012-07-28 18:20:08

I am Gianluca
Member
From: London, UK
Registered: 2011-05-22
Posts: 195

Re: glibc update refusing to proceed. File ownership problem

Ok, the network connection works now.
Unfortunately I still have an error when trying to install glibc:

# pacman -S glibc -r /mnt/arch
resolving dependencies

...

(1/1) checking package integrity
(1/1) checking for file conflicts
error: failed to commit transaction (conflict files)
Glibc: /mnt/arch/lib exists in filesystem
Errors occurred, no packages were upgraded.

Laptop: Acer Aspire S3 | Linux Mint Cinnamon 64-bit

Offline

#345 2012-07-28 18:22:12

nomorewindows
Member
Registered: 2010-04-03
Posts: 3,010

Re: glibc update refusing to proceed. File ownership problem

I am Gianluca wrote:

Ok, the network connection works now.
Unfortunately I still have an error when trying to install glibc:

# pacman -S glibc -r /mnt/arch
resolving dependencies

...

(1/1) checking package integrity
(1/1) checking for file conflicts
error: failed to commit transaction (conflict files)
Glibc: /mnt/arch/lib exists in filesystem
Errors occurred, no packages were upgraded.

Ok, so what's in it?  Anything?
If it's the symlink you created to /usr/lib you would just need to delete just the symlink, since the upgrade will recreate it.

Last edited by nomorewindows (2012-07-28 18:30:17)


I may have to CONSOLE you about your usage of ridiculously easy graphical interfaces...
Look ma, no mouse.

Offline

#346 2012-07-28 18:36:17

I am Gianluca
Member
From: London, UK
Registered: 2011-05-22
Posts: 195

Re: glibc update refusing to proceed. File ownership problem

If I run 'ls /mnt/arch/lib' there are lots of stuffs inside. Lots of file starting with lib and other files like yaourt, vlc, vmware, udev, etc.
They seems to be the same files that I have in /mnt/arch/lib too.


Laptop: Acer Aspire S3 | Linux Mint Cinnamon 64-bit

Offline

#347 2012-07-28 19:01:25

nomorewindows
Member
Registered: 2010-04-03
Posts: 3,010

Re: glibc update refusing to proceed. File ownership problem

I am Gianluca wrote:

If I run 'ls /mnt/arch/lib' there are lots of stuffs inside. Lots of file starting with lib and other files like yaourt, vlc, vmware, udev, etc.
They seems to be the same files that I have in /mnt/arch/lib too.

Just rm /mnt/arch/lib and re-try pacman.
If you ls -al /mnt/arch, lib will probably show ->/usr/lib.


I may have to CONSOLE you about your usage of ridiculously easy graphical interfaces...
Look ma, no mouse.

Offline

#348 2012-07-28 20:23:04

I am Gianluca
Member
From: London, UK
Registered: 2011-05-22
Posts: 195

Re: glibc update refusing to proceed. File ownership problem

First of all thank you to all of you that have helped me during the last few days. Finally I've been able to update glibc smile
Unfortunately, even if now I can boot I encounter a problem after the login. Basically, after having inserted username and password, selected to boot the XFCE DesktopEnvironment in CMD (login manager) I receive an error which tells me:

Check to see if you are wrapping your session with ck-launch-session or increase the timeout.

So, I've tried to boot manually typing:

# xinit
# startxfce4
# startxfce4 with-ck-launch

but every time it returns me this error:

X.Org X Server 1.12.3
Release Date: 2012-07-09
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.4.4-3-ARCH i686
Current Operating System: Linux gianluca-laptop 3.4.5-1-ck #1 SMP PREEMPT Mon Jul 16 19:56:55 EDT 2012 i686
Kernel command line: root=/dev/disk/by-uuid/2bef0cce-027d-44fa-a086-056c390cd847 ro quiet vga=773 init=/bin/systemd elevator=bfq pcie_aspm=force i915.i915_enable_rc6=1
Build Date: 9 July 2012 04:03:16 PM

Current version of pixman: 0.26.2
Before reporting problems, check http://wiki.x.org to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting, (++) from command line, (!!) notice, (II) informational, (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time Sat Jul 28 21:16:14 2012
(==) using config directory: "/etc/X11/xorg.conf.d"

Fatal server error:
no screens found

Please consult the The X.Org Foundation support at http://wiki.x.org for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

Server terminated with error (1). Closing log file.
xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error

Is this related to glibc? I think so.


Laptop: Acer Aspire S3 | Linux Mint Cinnamon 64-bit

Offline

#349 2012-07-28 20:41:20

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 13,117

Re: glibc update refusing to proceed. File ownership problem

Well, there's your problem:

Fatal server error:
no screens found

Did X work before?  Have you installed the xf86-video-xxxx driver for your video card?
If you still have problems:
<ModeratorMode> then go ahead and mark this thread solved, and please open a new thread pertaining to the Xorg issue.  In that thread, I suggest you post your /var/log/Xorg.0.log file (inside code tags, of course) and, if you think it is relevant, a link back to this thread.  Thanks </ModeratorMode>


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
You assume people are rational and influenced by evidence.  You must not work with the public much. -- Trilby
----
How to Ask Questions the Smart Way

Offline

#350 2012-07-28 21:55:37

nomorewindows
Member
Registered: 2010-04-03
Posts: 3,010

Re: glibc update refusing to proceed. File ownership problem

ewaller wrote:

If you still have problems:
<ModeratorMode> then go ahead and mark this thread solved, and please open a new thread pertaining to the Xorg issue.  In that thread, I suggest you post your /var/log/Xorg.0.log file (inside code tags, of course) and, if you think it is relevant, a link back to this thread.  Thanks </ModeratorMode>

He's not OP!


I may have to CONSOLE you about your usage of ridiculously easy graphical interfaces...
Look ma, no mouse.

Offline

Board footer

Powered by FluxBB