You are not logged in.

#26 2012-08-23 13:07:46

c0de
Member
From: Montevideo, Uruguay
Registered: 2012-07-01
Posts: 4

Re: Virtualbox + GNOME + mouse = phantom clicks

WhiteShadow wrote:

@c0de: you say it works if you use Openbox but not with Gnome or KDE?

Indeed


Mess with the best , die like the rest

Offline

#27 2012-08-23 16:17:11

WhiteShadow
Member
Registered: 2012-07-31
Posts: 9

Re: Virtualbox + GNOME + mouse = phantom clicks

I tried OpenBox - it kind of works. If I start "dolphin" or "konsole" and move them around - it "jumps" - less often than under KDE but still - it is possible to find "jumpmarks".

Offline

#28 2012-08-23 17:05:35

olfhrmgcyh
Member
Registered: 2012-08-23
Posts: 1

Re: Virtualbox + GNOME + mouse = phantom clicks

It's not Arch specific. I run Debian on Windows 7 and also ran into the same issue (but this post is one of the first results on Google). As a workaround, instead of disabling the guest additions, just disable mouse integration (VirtualBox GUI -> menu -> machine -> disable mouse integration, or right click the mouse icon at the bottom right), and everything works normally except you have to tap Ctrl (or whatever your host key is) each time you tab into/out of VB.

Someone else already filed a ticket upstream: https://www.virtualbox.org/ticket/10853

Last edited by olfhrmgcyh (2012-08-23 17:07:32)

Offline

#29 2012-08-23 17:11:05

Gnarl
Member
Registered: 2010-11-18
Posts: 63

Re: Virtualbox + GNOME + mouse = phantom clicks

I have the same issue but no one answered my post. The problem goes away if you revert to xorg-server and xorg-server-common 1.12.2

Offline

#30 2012-08-23 18:58:58

vaskodd
Member
Registered: 2012-08-23
Posts: 1

Re: Virtualbox + GNOME + mouse = phantom clicks

Definitely it's not Arch specific. Same issue with Fedora 17. Host is 3.5.2-3.fc17.x86_64, guest is the same 3.5.2-3.fc17.x86_64. Gnome DE. Upgrade from Virtualbox 4.1.18 to 4.1.20 didn,t make a difference.

droosa wrote:

One other factor that may be involved is the host system graphics/driver versions.  I'm on NVIDIA Geforce GTS 250 with the 295.73 driver.  Going to update this to see if it makes a difference.  If you are on different graphics cards and/or driver versions, we can rule this as (un)related.

I'm on ATI Radeon HD 5730, so gues graphics/driver versions is unrelated.

Offline

#31 2012-08-25 06:35:20

th0r12
Member
Registered: 2012-08-19
Posts: 5

Re: Virtualbox + GNOME + mouse = phantom clicks

Found something, that might help to fix this bug.
Since I needed ArchLinux as virtual machine and it didn't work well in VirtualBox, I decided to install it under VMWare. I did it and it worked well - there was no sight of this bug. But there was one small problem - the back/forward buttons didn't work on my mouse. So i googled how to fix them: i put "usb.generic.allowHID = "TRUE" and "mouse.vusb.enable = "TRUE" to the VM's .vmx config file...and this bug appeared again! So, as Gnarl said, it's not VirtualBox problem...

Offline

#32 2012-08-26 00:08:48

littlegecko
Member
Registered: 2012-08-25
Posts: 1

Re: Virtualbox + GNOME + mouse = phantom clicks

Gnarl wrote:

I have the same issue but no one answered my post. The problem goes away if you revert to xorg-server and xorg-server-common 1.12.2

Reverting to 1.12.2 also solved the problem for me. Gentoo ~amd64 guest, Windows 7 X64 + VirtualBox 4.1.20 host.

I git-bisected it down to xorg/xserver commit 889ce06946b8c1a246130a899e2702a3d7340fd2. That patch supposedly fixes a similar issue on tablets, so I'm not sure how it caused breakage instead. It'd be nice if someone who understood a bit about X internals went through the X.Org bug reporting procedure.

For any Gentoo users that happen to be coming in from Google, here's a revert patch for use in combination with 1.12.3. Easiest way to get it in is by using the epatch_user feature (mkdir -p /etc/portage/patches/x11-base/xorg-server and put it in there with a .patch extension, rebuild xorg-server). You may have to install x11-misc/util-macros to prevent an eautoreconf failure. I'm not sure if reverting this breaks anything else, use at your own risk.

Offline

#33 2012-08-27 06:36:34

WhiteShadow
Member
Registered: 2012-07-31
Posts: 9

Re: Virtualbox + GNOME + mouse = phantom clicks

I can confirm that xorg-server 1.12.2 works.

Here you can find how to downgrade: https://wiki.archlinux.org/index.php/Do … g_Packages (ARM has the old version)


I only downgraded xorg-server, not xorg-server-common. That narrows the problem down to just one package/program: xorg-server

Offline

#34 2012-08-29 17:15:44

abiss
Member
From: Las Vegas
Registered: 2012-08-29
Posts: 3

Re: Virtualbox + GNOME + mouse = phantom clicks

I was able to resolve this by setting my mouse acceleration/threshold to the following: 

xset m 1/3 0

Hopefully this helps someone else out there...

Offline

#35 2012-08-29 17:30:39

abiss
Member
From: Las Vegas
Registered: 2012-08-29
Posts: 3

Re: Virtualbox + GNOME + mouse = phantom clicks

...

Last edited by abiss (2012-08-30 00:29:17)

Offline

#36 2012-08-29 17:47:17

c0de
Member
From: Montevideo, Uruguay
Registered: 2012-07-01
Posts: 4

Re: Virtualbox + GNOME + mouse = phantom clicks

Earlier in this topic i said that i wasn't suffering this problem with openbox.
Let me tell you that , in fact,  i was .

just that

Regards


Mess with the best , die like the rest

Offline

#37 2012-08-30 00:29:38

abiss
Member
From: Las Vegas
Registered: 2012-08-29
Posts: 3

Re: Virtualbox + GNOME + mouse = phantom clicks

...

Offline

#38 2012-09-05 19:29:27

yug
Member
From: Northern California
Registered: 2012-09-05
Posts: 5

Re: Virtualbox + GNOME + mouse = phantom clicks

Virtualbox forums https://forums.virtualbox.org/viewtopic.php?f=3&t=51125 seem to point to the problem being xorg. I have the same symptoms in Fedora 17 and Arch VMs, both x86_64.
It was reported that downgrading xorg server fixed the problem. I haven't yet figured out how to downgrade X with Arch Linux.
Is there an old package archive?

Offline

#39 2012-09-05 20:14:10

th0r12
Member
Registered: 2012-08-19
Posts: 5

Re: Virtualbox + GNOME + mouse = phantom clicks

yug wrote:

Virtualbox forums https://forums.virtualbox.org/viewtopic.php?f=3&t=51125 seem to point to the problem being xorg. I have the same symptoms in Fedora 17 and Arch VMs, both x86_64.
It was reported that downgrading xorg server fixed the problem. I haven't yet figured out how to downgrade X with Arch Linux.
Is there an old package archive?

https://bbs.archlinux.org/viewtopic.php … 8#p1151978

Offline

#40 2012-09-05 20:18:43

yug
Member
From: Northern California
Registered: 2012-09-05
Posts: 5

Re: Virtualbox + GNOME + mouse = phantom clicks

I didn't see that there were 2 pages of posts on this topic -- I followed the downgrading link posted by "whiteshadow" and downgraded xorg-server to 1.12.2-1 and so far it seems to be all good.

Offline

#41 2012-10-15 20:05:17

Gnarl
Member
Registered: 2010-11-18
Posts: 63

Re: Virtualbox + GNOME + mouse = phantom clicks

Still not fixed in 1.13.0-2

Offline

#42 2012-10-16 03:19:10

t0ken
Member
Registered: 2012-06-29
Posts: 28

Re: Virtualbox + GNOME + mouse = phantom clicks

abiss wrote:

I was able to resolve this by setting my mouse acceleration/threshold to the following: 

xset m 1/3 0

Hopefully this helps someone else out there...


At first look, this appears to be a valid workaround (at least on my end).

Thanks!

Offline

#43 2012-10-16 13:52:00

Gnarl
Member
Registered: 2010-11-18
Posts: 63

Re: Virtualbox + GNOME + mouse = phantom clicks

t0ken wrote:
abiss wrote:

I was able to resolve this by setting my mouse acceleration/threshold to the following: 

xset m 1/3 0

Hopefully this helps someone else out there...


At first look, this appears to be a valid workaround (at least on my end).

Thanks!

This one didn't work for me.

Offline

#44 2012-10-16 13:53:39

Gnarl
Member
Registered: 2010-11-18
Posts: 63

Re: Virtualbox + GNOME + mouse = phantom clicks

littlegecko wrote:
Gnarl wrote:

I have the same issue but no one answered my post. The problem goes away if you revert to xorg-server and xorg-server-common 1.12.2

Reverting to 1.12.2 also solved the problem for me. Gentoo ~amd64 guest, Windows 7 X64 + VirtualBox 4.1.20 host.

I git-bisected it down to xorg/xserver commit 889ce06946b8c1a246130a899e2702a3d7340fd2. That patch supposedly fixes a similar issue on tablets, so I'm not sure how it caused breakage instead. It'd be nice if someone who understood a bit about X internals went through the X.Org bug reporting procedure.

For any Gentoo users that happen to be coming in from Google, here's a revert patch for use in combination with 1.12.3. Easiest way to get it in is by using the epatch_user feature (mkdir -p /etc/portage/patches/x11-base/xorg-server and put it in there with a .patch extension, rebuild xorg-server). You may have to install x11-misc/util-macros to prevent an eautoreconf failure. I'm not sure if reverting this breaks anything else, use at your own risk.


This patch worked for me when applied to 1.13.0 abs/xorg-server

Offline

#45 2012-10-16 15:04:35

t0ken
Member
Registered: 2012-06-29
Posts: 28

Re: Virtualbox + GNOME + mouse = phantom clicks

Gnarl wrote:
t0ken wrote:
abiss wrote:

I was able to resolve this by setting my mouse acceleration/threshold to the following: 

xset m 1/3 0

Hopefully this helps someone else out there...


At first look, this appears to be a valid workaround (at least on my end).

Thanks!

This one didn't work for me.


Yeah I actually spoke too soon yesterday.  The behavior was curtailed a bit, but it still occurred.  I'll try out the patch when I get home, hopefully will have better luck.

Offline

#46 2012-10-21 14:04:18

bkcoffma
Member
Registered: 2012-09-06
Posts: 2

Re: Virtualbox + GNOME + mouse = phantom clicks

olfhrmgcyh wrote:

Someone else already filed a ticket upstream: https://www.virtualbox.org/ticket/10853

From the above, I found this bug report with the following workaround:

xinput set-prop "VirtualBox mouse integration" "Coordinate Transformation Matrix" 0.5 0 0 0 0.5 0 0 0 1.0
xinput set-prop "VirtualBox mouse integration" "Coordinate Transformation Matrix" 1.0 0 0 0 1.0 0 0 0 1.0

EDIT: After some research, I created a package that fixes this. I used this patch (instigated by this bug) to create it. The patch is already merged into upstream. It's just not released yet.

Last edited by bkcoffma (2012-10-22 15:33:41)

Offline

#47 2012-10-27 06:24:12

niriven
Member
Registered: 2012-04-11
Posts: 17

Re: Virtualbox + GNOME + mouse = phantom clicks

I have posted a arch package bug here:
https://bugs.archlinux.org/task/32243

This is something that was introduced with an xorg patch, but it's acutally an underlying bug on a transform function. XOrg maintainers have fixed this in master but there is no new version of xorg-server to get this change. I opened a bug to get the XOrg patch into the 1.13.0 package.

Please vote if you think it should be fixed smile

Last edited by niriven (2012-10-27 06:41:23)

Offline

#48 2012-11-09 06:27:29

WhiteShadow
Member
Registered: 2012-07-31
Posts: 9

Re: Virtualbox + GNOME + mouse = phantom clicks

fixed xorg-server got uploaded to testing - haven't tried it by now.

edit:
it's moved from testing to stable. For me it seems, that the error is fixed now. Thanks to all who helped.


Maybe the thread starter wants to set it to [solved]

Last edited by WhiteShadow (2012-11-12 09:31:48)

Offline

#49 2012-11-21 17:58:11

mlitke
Member
Registered: 2011-04-25
Posts: 4

Re: Virtualbox + GNOME + mouse = phantom clicks

It looks like this has been solved, but I thought I would add a bit of information. Earlier in the thread WhiteShadow asked if the same problem existed in 32-bit Arch. I was experiencing the issue in a 64-bit Arch install, so I did a fresh 32-bit install to test. After a day or so of testing and not experiencing the bug, I migrated my files over to the 32-bit system. I have been running the 32-bit Arch install for few weeks now, and I never experienced the bug (it was quite noticeable in the 64-bit install). I find it interesting the bug was traced to the xorg-server package, I would assume the code causing the issue was 64-bit specific?

Offline

#50 2013-01-21 22:39:59

xstaticxgpx
Member
Registered: 2008-10-22
Posts: 48

Re: Virtualbox + GNOME + mouse = phantom clicks

bkcoffma wrote:
olfhrmgcyh wrote:

Someone else already filed a ticket upstream: https://www.virtualbox.org/ticket/10853

From the above, I found this bug report with the following workaround:

xinput set-prop "VirtualBox mouse integration" "Coordinate Transformation Matrix" 0.5 0 0 0 0.5 0 0 0 1.0
xinput set-prop "VirtualBox mouse integration" "Coordinate Transformation Matrix" 1.0 0 0 0 1.0 0 0 0 1.0

EDIT: After some research, I created a package that fixes this. I used this patch (instigated by this bug) to create it. The patch is already merged into upstream. It's just not released yet.

I'm not using arch in the VM that was having this problem... but I'm so glad I ended up looking at this forum, this fixed the problem for me. thank you so much

Offline

Board footer

Powered by FluxBB