You are not logged in.

#26 2012-11-10 16:20:37

endived
Member
Registered: 2011-06-14
Posts: 8

Re: [Solved] Yaourt 301

h54 wrote:

I'm not sure how you could even test if your system is talking to the AUR if everything is being blocked.  Connection by proxy perhaps?

Nope, I'm not using a proxy. 
I can connect to https://aur.archlinux.org in a browser but no AUR helper (and I've also tried packer, aurget, cower/meat so far) allows me to interact with the AUR.   yaourt returns packages from core/extra/community/multilib but not from the AUR.

Offline

#27 2012-11-14 23:49:41

0mark
Member
From: earth
Registered: 2010-06-09
Posts: 139
Website

Re: [Solved] Yaourt 301

I had the same problem, but only on one machine. On all other, yaourt worked well. When ich tried

curl https://aur.archlinux.org/

it said that the certificate is not valid yet. Turned out that the system date was 1970. Setting the current date helped.


Ceterum autem censeo Systemdinem esse delendam

Offline

#28 2012-11-15 08:21:27

endived
Member
Registered: 2011-06-14
Posts: 8

Re: [Solved] Yaourt 301

As it turned out, Arch or yaourt had nothing to do with it.   For some reason my ISP (HKBN in Hong Kong) blocked connections to https://aur.archlinux.org.   
I could download tarballs in the AUR site using the chromium browser but not pull them in using curl, wget or, well, yaourt or any AUR helper for that matter.   
Not quite sure how they achieved that and why.   Or in other words: whether it was by design or by mistake.   I've informed them of the situation and got the proverbial shrug. 

Luckily, I still have a cable from another ISP and everything runs perfectly.

Last edited by endived (2012-11-15 08:21:43)

Offline

#29 2012-11-21 01:21:31

rnarch
Member
Registered: 2012-03-17
Posts: 292

Re: [Solved] Yaourt 301

I had same problem (on 2 computers) and following (as suggested above) fixed it:

echo "AURURL='https://aur.archlinux.org'" >> ~/.yaourtrc

Last edited by rnarch (2012-11-22 03:49:07)

Offline

Board footer

Powered by FluxBB