You are not logged in.

#26 2013-03-28 10:27:17

dontbugme
Banned
Registered: 2011-11-04
Posts: 166
Website

Re: ASUS PCE-N53 Kernel Panic

https://bbs.archlinux.org/viewtopic.php?id=159947 . Done 3 days ago. I made a PKGBUILD for this driver. It's not perfect(don't exactly know the dependencies and such stuff, but it works and installs the driver). I included the 3.8 patch floating around here in this thread.

Offline

#27 2013-05-04 18:09:48

Amnesthesia
Member
Registered: 2013-05-04
Posts: 1

Re: ASUS PCE-N53 Kernel Panic

I just got myself a PCE-N53 as well, and kept getting build errors like so: http://pastie.org/7801054

I would just like to add that these were also solved by the patch posted earlier in this thread, in case anybody is experiencing the same issue.

Offline

#28 2013-05-22 14:50:26

johnny_boy
Member
Registered: 2013-02-22
Posts: 9

Re: ASUS PCE-N53 Kernel Panic

jcrews wrote:

I've updated the driver to compile on 3.8:

http://gridlox.net/diff/rt5592sta_fix_64bit_3.8.patch

Note: this applies cleanly to the 2.6.00 distribution. patch -R if you've applied the previous modification to fix panicking, or simply delete and re-extract the original package.

Thank you again! I had just tried the first patch and wondered why it failed to build. Your latest patch put everything right on my 3.8 kernel. Cheers!

Offline

#29 2013-06-21 23:15:29

frankysev
Member
Registered: 2013-06-21
Posts: 2

Re: ASUS PCE-N53 Kernel Panic

jcrews wrote:

I've updated the driver to compile on 3.8:
http://gridlox.net/diff/rt5592sta_fix_64bit_3.8.patch
Note: this applies cleanly to the 2.6.00 distribution. patch -R if you've applied the previous modification to fix panicking, or simply delete and re-extract the original package.

Hello.
I have an Asus Pce-N53 wireless in Linux Mint 15, but I am not able to do it works, despite I have tried it.
I'm not an English speaker nor an expert with computers, so I need a "guide for dummies" to install your patch, if it's possible.
Thank you.

Offline

#30 2013-06-21 23:58:22

jasonwryan
Forum & Wiki Admin
From: .nz
Registered: 2009-05-09
Posts: 19,061
Website

Re: ASUS PCE-N53 Kernel Panic

Please ask for help on the Mint boards; only Arch is supported here:
https://wiki.archlinux.org/index.php/Fo … pport_ONLY


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#31 2013-06-22 11:21:44

frankysev
Member
Registered: 2013-06-21
Posts: 2

Re: ASUS PCE-N53 Kernel Panic

jasonwryan wrote:

Please ask for help on the Mint boards; only Arch is supported here:
https://wiki.archlinux.org/index.php/Fo … pport_ONLY

I'm sorry I bothered to your forum sad
I can not find help anywhere else, so I thought that the user jcrews could help me.

Offline

#32 2013-07-16 21:52:09

Vermind
Member
Registered: 2013-07-16
Posts: 1

Re: ASUS PCE-N53 Kernel Panic

Thanks jcrews for the patch! works great on Debian Testing, kernel 3.9.1 too.
I also added these lines on line 42 of pci_main_dev.c to keep it from complaining about missing __dev* stuff:

/*FIX:  __dev* was removed in kernel 3.8 */
#if LINUX_VERSION_CODE >= KERNEL_VERSION(3,8,0)
#define __devinit
#define __devinitdata
#define __devexit
#define __devexit_p(x) x
#endif

Offline

#33 2013-08-02 17:31:47

johnny_boy
Member
Registered: 2013-02-22
Posts: 9

Re: ASUS PCE-N53 Kernel Panic

Will this patch work if running kernel 3.10 (or higher)? If not, would replacing in the patch all occurrences of "3,8,0" with "3,10,0" make it work?

Cheers!

Offline

#34 2013-09-14 17:02:04

jcrews
Member
Registered: 2013-01-27
Posts: 11

Re: ASUS PCE-N53 Kernel Panic

johnny_boy wrote:

Will this patch work if running kernel 3.10 (or higher)? If not, would replacing in the patch all occurrences of "3,8,0" with "3,10,0" make it work?

Cheers!


Yes. 3.8 was a special case where deprecated coded was deleted. No further changes should be needed for the forseeable future. I've also updated the patch so you can export a KERN_VER variable. If you don't define it, the current running kernel will be used as the build target, as before.

Example. You upgrade your kernel and you want build this driver for it before you reboot. This is convenient if your machine is headless or managed over the wifi link.

Just export KERN_VER=<new name> where <new name> is replaced with the next version. It must be as listed in /lib/modules. E.g., 3.10.10-1-ARCH.

Offline

#35 2013-10-07 09:59:00

benjkaiser
Member
Registered: 2013-08-13
Posts: 7

Re: ASUS PCE-N53 Kernel Panic

Hey @jcrews,

Since the Linux kernel updates frequently, is there a way for the driver to reinstall / rebuild every time the kernel upgrades?

Cheers.

Offline

#36 2013-12-11 18:24:09

Darksurf
Member
Registered: 2013-12-11
Posts: 1

Re: ASUS PCE-N53 Kernel Panic

Is anyone else having trouble getting this patch to work with the 3.12.3 kernel?


In file included from /home/darksurf/Linux/Linux/DPO_GPL_RT5592STA_LinuxSTA_v2.6.0.0_20120326/include/os/rt_linux.h:53:0,
                 from /home/darksurf/Linux/Linux/DPO_GPL_RT5592STA_LinuxSTA_v2.6.0.0_20120326/include/rtmp_os.h:44,
                 from /home/darksurf/Linux/Linux/DPO_GPL_RT5592STA_LinuxSTA_v2.6.0.0_20120326/include/rtmp_comm.h:69,
                 from /home/darksurf/Linux/Linux/DPO_GPL_RT5592STA_LinuxSTA_v2.6.0.0_20120326/os/linux/../../os/linux/sta_ioctl.c:30:
/home/darksurf/Linux/Linux/DPO_GPL_RT5592STA_LinuxSTA_v2.6.0.0_20120326/os/linux/../../os/linux/sta_ioctl.c: In function ‘rt_ioctl_giwscan’:
include/net/iw_handler.h:554:9: warning: array subscript is below array bounds [-Warray-bounds]
  CC [M]  /home/darksurf/Linux/Linux/DPO_GPL_RT5592STA_LinuxSTA_v2.6.0.0_20120326/os/linux/../../os/linux/rt_linux.o
/home/darksurf/Linux/Linux/DPO_GPL_RT5592STA_LinuxSTA_v2.6.0.0_20120326/os/linux/../../os/linux/rt_linux.c: In function ‘__RtmpOSFSInfoChange’:
/home/darksurf/Linux/Linux/DPO_GPL_RT5592STA_LinuxSTA_v2.6.0.0_20120326/os/linux/../../os/linux/rt_linux.c:1133:20: error: incompatible types when assigning to type ‘int’ from type ‘kuid_t’
/home/darksurf/Linux/Linux/DPO_GPL_RT5592STA_LinuxSTA_v2.6.0.0_20120326/os/linux/../../os/linux/rt_linux.c:1134:20: error: incompatible types when assigning to type ‘int’ from type ‘kgid_t’
make[2]: *** [/home/darksurf/Linux/Linux/DPO_GPL_RT5592STA_LinuxSTA_v2.6.0.0_20120326/os/linux/../../os/linux/rt_linux.o] Error 1
make[1]: *** [_module_/home/darksurf/Linux/Linux/DPO_GPL_RT5592STA_LinuxSTA_v2.6.0.0_20120326/os/linux] Error 2
make[1]: Leaving directory `/usr/src/linux-3.12.0-sabayon'
make: *** [LINUX] Error 2

Offline

#37 2013-12-15 00:25:57

Webbeh
Member
Registered: 2012-07-08
Posts: 33

Re: ASUS PCE-N53 Kernel Panic

Hi.

I have troubles with the 3.12.4 kernel for this package... Downgraded to 3.12.3 to have a working build again...


It gave me the error "no rule to make target for 'LINUX'", for the file dfs.o, required by rt5592sta.o.


Darksurf -> I uploaded my working package for 3.12.3 on http://up.levert.ch/a30614-rt5592sta_li … 4pkgtar.xz . You will need to rename it ".tar.xz" for the installation with pacman -U. Keep in mind that it will only work with stock "3.12.3-1 ARCH" kernel. After installing the package, "sudo depmod" and "sudo modprobe rt5592sta", as usual. And don't update to 3.12.4 ! I think I will download the latest LTS linux kernel for once...

Offline

#38 2013-12-23 12:48:36

Webbeh
Member
Registered: 2012-07-08
Posts: 33

Re: ASUS PCE-N53 Kernel Panic

Got it compiling again for 3.12.5-1-ARCH, and working flawlessy for three hours now. I think last time was just a problem with GCC.

The annoying dmesg rt_ioctl errors are still present, but it works good 100/100Mbps.

Offline

#39 2013-12-27 17:52:41

eklvya
Member
Registered: 2013-12-27
Posts: 1

Re: ASUS PCE-N53 Kernel Panic

Webbeh can you share your newly compiled driver? TIA

Offline

#40 2013-12-27 17:59:46

Webbeh
Member
Registered: 2012-07-08
Posts: 33

Re: ASUS PCE-N53 Kernel Panic

http://up.levert.ch/821f88-rt5592sta_li … 4pkgtar.xz

Package for 3.12.5-1-ARCH ONLY

- Rename the package .tar.xz
- sudo pacman -U <package>
- sudo depmod
- sudo modprobe rt5592sta

Offline

#41 2014-02-17 10:59:13

johnny_boy
Member
Registered: 2013-02-22
Posts: 9

Re: ASUS PCE-N53 Kernel Panic

This used to work on (K)Ubuntu 13.10 but not since I've updated the kernel to 3.13. Now all I get is the following error:

install -d /lib/modules/3.13.0-031300-generic/kernel/drivers/net/wireless/
install -m 644 -c rt5592sta.ko /lib/modules/3.13.0-031300-generic/kernel/drivers/net/wireless/
install: cannot stat ‘rt5592sta.ko’: No such file or directory
make[1]: *** [install] Error 1
make[1]: Leaving directory `/media/Hitachi/Downloads/Linux/DPO_GPL_RT5592STA_LinuxSTA_v2.6.0.0_20120326/os/linux'
make: *** [install] Error 2

Can anyone help with this? (Sorry, I'm not on Arch but this is the only thread with people that appear to know what they're doing.)

Last edited by johnny_boy (2014-02-17 11:00:08)

Offline

#42 2014-02-17 16:11:13

Webbeh
Member
Registered: 2012-07-08
Posts: 33

Re: ASUS PCE-N53 Kernel Panic

Hi.

Where does the package come from ? What is you actual kernel version ? Are the sources still installed ? What distro are you on ?

Offline

#43 2014-02-19 15:10:46

johnny_boy
Member
Registered: 2013-02-22
Posts: 9

Re: ASUS PCE-N53 Kernel Panic

I downloaded the drivers from Asus's website. The patch is from a comment in this thread, namely #17.  The kernel version is 3.13.0-031300-generic from Ubuntu's mainline kernel "ppa" (http://kernel.ubuntu.com/~kernel-ppa/ma … 13-trusty/). The sources (linux-headers) are still installed along with other prerequisites. The distro is Kubuntu 13.10.

Offline

#44 2014-04-23 16:54:05

Webbeh
Member
Registered: 2012-07-08
Posts: 33

Re: ASUS PCE-N53 Kernel Panic

Sorry for the laaaaaaate answer.

It just seems that your module is not found in the folder. I was not able to build for that specific version either, nor for the three next kernel versions.

I'm giving up on making this PCI device work and bought an atheros-based on thinkpenguin[dot]com that I'll receive in a few days. I also flagged the AUR package out of date.

I'm sorry not to be able to answer your question...

Offline

#45 2014-04-29 13:44:33

benjkaiser
Member
Registered: 2013-08-13
Posts: 7

Re: ASUS PCE-N53 Kernel Panic

Anyone else manage to get the driver building on 3.14 (specifically 3.14.1-1)?

It seems to be 3.12.4 all over again (failing to build)

Offline

#46 2014-04-29 14:18:30

Webbeh
Member
Registered: 2012-07-08
Posts: 33

Re: ASUS PCE-N53 Kernel Panic

A patch was uploaded by hallou89 on the AUR page, it fixes the "incompatible types when assigning to type ‘int’ from type ‘kuid_t`" error.


Patch only : http://up.levert.ch/d7ba21-patch314.patch (rename patch314.patch and put in the main aur package folder, next to the PKGBUILD given right below)
...and the new PKGBUILD : http://up.levert.ch/5360b2-PKGBUILD


If you're not sure about what to do, you should download this archive, containing the full folder.
http://up.levert.ch/2dc4b1-rt5592hallou89.tgz

Untar it (tar xzvf 2dc4b1-rt5592hallou89.tgz), move to the rt5592sta_linux_hollow89 folder, and makepkg as usual.

Last edited by Webbeh (2014-04-29 15:17:36)

Offline

#47 2014-04-29 14:35:20

Webbeh
Member
Registered: 2012-07-08
Posts: 33

Re: ASUS PCE-N53 Kernel Panic

It you can't make it work, there is the package file. http://up.levert.ch/fa4e20-rt5592sta_li … pkg.tar.xz

There are a LOOOT of "IOCTL errors" on the dmesg, but they seem inoffensive at first sigh, no real issue after ~1 week of running.

Last edited by Webbeh (2014-04-29 14:38:09)

Offline

#48 2014-04-29 15:08:28

benjkaiser
Member
Registered: 2013-08-13
Posts: 7

Re: ASUS PCE-N53 Kernel Panic

Thanks Webbeh,

I didn't notice the AUR page (I tend to just check this thread when building the driver after a kernel upgrade doesn't work).

Thanks for the simple instructions and uploading those files. I looked at the patch and since I had all the files up I just modified the file myself, but thanks for putting it all together.

Offline

#49 2014-04-29 15:18:31

Webbeh
Member
Registered: 2012-07-08
Posts: 33

Re: ASUS PCE-N53 Kernel Panic

You're welcome.

If anybody has an idea for the annoying  "IOCTL::unknown IOCTL's cmd = 0x00008947" spamming my dmesg, I would love to hear it..

Offline

#50 2014-05-05 10:43:15

benjkaiser
Member
Registered: 2013-08-13
Posts: 7

Re: ASUS PCE-N53 Kernel Panic

I just upgraded to Linux 3.14.2-1 and hit a new snag when compiling:

/opt/rt5592sta/os/linux/../../sta/sta_cfg.c:4896:85: error: macro "__DATE__" might prevent reproducible builds [-Werror=date-time]
             snprintf(extra, size, "Driver version-%s, %s %s\n", STA_DRIVER_VERSION, __DATE__, __TIME__ );

I was able to fix this however by commenting out the line in the error (hopefully this has no adverse effects, but it makes the compilation succeed and my card work).

Change sta/sta_cfg.c line 4896 from:

snprintf(extra, size, "Driver version-%s, %s %s\n", STA_DRIVER_VERSION, __DATE__, __TIME__ );

to

//snprintf(extra, size, "Driver version-%s, %s %s\n", STA_DRIVER_VERSION, __DATE__, __TIME__ );

Offline

Board footer

Powered by FluxBB