You are not logged in.

#26 2012-11-19 01:39:03

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,662

Re: Dhcpcd does not start automatically on boot

I think you should disable dhcpcd@eth0.service. It is disabled here and wicd works fine for me. That may not solve the problem but it will at least remove a complication.

However, I really think you should start a new thread. Use the "Report" button and ask a mod to move your posts (and mind) to your new thread so that we do not hijack this one smile.

Last edited by cfr (2012-11-19 01:39:43)


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#27 2012-11-19 02:12:55

phil
Member
Registered: 2012-09-22
Posts: 72

Re: Dhcpcd does not start automatically on boot

Ok, I did that.
My workaround is:
Install dhclient and make wicd use this. It works.

Offline

#28 2012-11-20 21:59:42

na12
Member
From: /home/serbia
Registered: 2008-12-23
Posts: 749

Re: Dhcpcd does not start automatically on boot

I have the same problem,and it started a few days ago. First time I thought it was problem with my router,but it repeats every day. Definitely it is some kind of bug.

┌╸dany╺─╸~╺
└─╍ sudo systemctl status dhcpcd@eth0.service
dhcpcd@eth0.service - dhcpcd on eth0
	  Loaded: loaded (/usr/lib/systemd/system/dhcpcd@.service; enabled)
	  Active: failed (Result: exit-code) since Wed, 2012-11-21 10:03:01 CET; 3min 32s ago
	 Process: 368 ExecStart=/sbin/dhcpcd -A -q -w %I (code=exited, status=1/FAILURE)
	  CGroup: name=systemd:/system/dhcpcd@.service/eth0

Nov 21 10:02:23 localhost dhcpcd[368]: version 5.6.2 starting
Nov 21 10:03:01 localhost systemd[1]: Failed to start dhcpcd on eth0.
Nov 21 10:03:01 localhost systemd[1]: Unit dhcpcd@eth0.service entered failed state
┌╸dany╺─╸~╺
└─╍ sudo dhcpcd
dhcpcd[1247]: version 5.6.2 starting
dhcpcd[1247]: eth0: sending IPv6 Router Solicitation
dhcpcd[1247]: eth0: broadcasting for a lease
dhcpcd[1247]: eth0: offered 192.168.100.100 from 192.168.100.252
dhcpcd[1247]: eth0: acknowledged 192.168.100.100 from 192.168.100.252
dhcpcd[1247]: eth0: checking for 192.168.100.100
dhcpcd[1247]: eth0: sending IPv6 Router Solicitation
dhcpcd[1247]: eth0: leased 192.168.100.100 for 86400 seconds
dhcpcd[1247]: forked to background, child pid 1273
┌╸dany╺─╸~╺
└─╍ sudo systemctl status dhcpcd@eth0.service
dhcpcd@eth0.service - dhcpcd on eth0
	  Loaded: loaded (/usr/lib/systemd/system/dhcpcd@.service; enabled)
	  Active: failed (Result: exit-code) since Wed, 2012-11-21 10:03:01 CET; 5min ago
	 Process: 368 ExecStart=/sbin/dhcpcd -A -q -w %I (code=exited, status=1/FAILURE)
	  CGroup: name=systemd:/system/dhcpcd@.service/eth0

Nov 21 10:02:23 localhost dhcpcd[368]: version 5.6.2 starting
Nov 21 10:03:01 localhost systemd[1]: Failed to start dhcpcd on eth0.
Nov 21 10:03:01 localhost systemd[1]: Unit dhcpcd@eth0.service entered failed state
┌╸dany╺─╸~╺
└─╍ sudo systemctl restart dhcpcd@eth0.service
Job for dhcpcd@eth0.service failed. See 'systemctl status dhcpcd@eth0.service' and 'journalctl -n' for details.
┌╸dany╺─╸~╺
└─╍ sudo killall dhcpcd
┌╸dany╺─╸~╺
└─╍ sudo systemctl status dhcpcd@eth0.service
dhcpcd@eth0.service - dhcpcd on eth0
	  Loaded: loaded (/usr/lib/systemd/system/dhcpcd@.service; enabled)
	  Active: failed (Result: resources) since Wed, 2012-11-21 10:09:13 CET; 26s ago
	 Process: 1376 ExecStart=/sbin/dhcpcd -A -q -w %I (code=exited, status=0/SUCCESS)
	  CGroup: name=systemd:/system/dhcpcd@.service/eth0

Nov 21 10:09:13 localhost systemd[1]: Starting dhcpcd on eth0...
Nov 21 10:09:13 localhost systemd[1]: Failed to start dhcpcd on eth0.
Nov 21 10:09:13 localhost systemd[1]: Unit dhcpcd@eth0.service entered failed state
┌╸dany╺─╸~╺
└─╍ sudo systemctl restart dhcpcd@eth0.service
┌╸dany╺─╸~╺
└─╍ sudo systemctl status dhcpcd@eth0.service
dhcpcd@eth0.service - dhcpcd on eth0
	  Loaded: loaded (/usr/lib/systemd/system/dhcpcd@.service; enabled)
	  Active: active (running) since Wed, 2012-11-21 10:09:42 CET; 7s ago
	 Process: 1409 ExecStart=/sbin/dhcpcd -A -q -w %I (code=exited, status=0/SUCCESS)
	Main PID: 1435 (dhcpcd)
	  CGroup: name=systemd:/system/dhcpcd@.service/eth0
		  └ 1435 /sbin/dhcpcd -A -q -w eth0

Nov 21 10:09:42 localhost systemd[1]: Starting dhcpcd on eth0...
Nov 21 10:09:42 localhost systemd[1]: Started dhcpcd on eth0.
Nov 21 10:09:46 localhost dhcpcd[1435]: eth0: sending IPv6 Router Solicitation

Last edited by na12 (2012-11-21 08:10:42)

Offline

#29 2012-11-23 21:51:35

Ipozya
Member
Registered: 2011-01-20
Posts: 52

Re: Dhcpcd does not start automatically on boot

Any updates on this bug?

Offline

#30 2012-11-23 22:11:19

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,094
Website

Re: Dhcpcd does not start automatically on boot

Ipozya wrote:

Any updates on this bug?

This isn't a bug tracker. Someone who actually cared filed FS#30235 some time ago, and it was since resolved.

Offline

#31 2012-11-26 09:44:03

na12
Member
From: /home/serbia
Registered: 2008-12-23
Posts: 749

Re: Dhcpcd does not start automatically on boot

falconindy wrote:

and it was since resolved.

Not for me,same problem with dhcpcd 5.6.3-2.

Offline

#32 2012-11-27 00:28:04

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,662

Re: Dhcpcd does not start automatically on boot

Have you reported it? Have you figured out if it has been reported? If it is the same bug or a different one?


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#33 2012-11-27 02:35:26

ismaelvc
Member
From: México, D.F.
Registered: 2012-02-26
Posts: 136

Re: Dhcpcd does not start automatically on boot

It's fixed for me:

ismaelvc@toybox ~ $ packer -Qs dhcpcd
local/dhcpcd 5.6.3-2 (base)
    RFC2131 compliant DHCP client daemon

ismaelvc@toybox ~ $ sudo systemctl status dhcpcd@eth0.service
[sudo] password for ismaelvc: 
dhcpcd@eth0.service - dhcpcd on eth0
	  Loaded: loaded (/usr/lib/systemd/system/dhcpcd@.service; enabled)
	  Active: active (running) since Mon, 2012-11-26 19:36:55 CST; 58min ago
	 Process: 238 ExecStart=/usr/sbin/dhcpcd -q -w %I (code=exited, status=0/SUCCESS)
	Main PID: 963 (dhcpcd)
	  CGroup: name=systemd:/system/dhcpcd@.service/eth0
		  └ 963 /usr/sbin/dhcpcd -q -w eth0

Nov 26 19:36:53 toybox dhcpcd[238]: eth0: sending IPv6 Router Solicitation
Nov 26 19:36:55 toybox dhcpcd[238]: eth0: leased 192.168.0.2 for 3600 seconds
Nov 26 19:36:55 toybox dhcpcd[238]: forked to background, child pid 963
Nov 26 19:36:55 toybox systemd[1]: Started dhcpcd on eth0.
Nov 26 19:36:57 toybox dhcpcd[963]: eth0: sending IPv6 Router Solicitation
Nov 26 19:37:01 toybox dhcpcd[963]: eth0: sending IPv6 Router Solicitation
Nov 26 19:37:01 toybox dhcpcd[963]: eth0: no IPv6 Routers available
Nov 26 20:06:55 toybox dhcpcd[963]: eth0: renewing lease of 192.168.0.2
Nov 26 20:06:56 toybox dhcpcd[963]: eth0: acknowledged 192.168.0.2 from 192.168.0.1
Nov 26 20:06:56 toybox dhcpcd[963]: eth0: leased 192.168.0.2 for 3600 seconds

Last edited by ismaelvc (2012-11-27 02:41:47)


Laptop: LG LM70 Express                                                  Kernel: 3.14.2-1-ARCH   
CPU: Intel Pentium M processor @1.86GHz                  Hard Drive: 80G
Video: Mobility Radeon X600                                            X Driver: xf86-video-ati
Memory Size: 1.5G + zramswap: 384M + swap: 3G

Offline

#34 2012-11-27 08:28:44

na12
Member
From: /home/serbia
Registered: 2008-12-23
Posts: 749

Re: Dhcpcd does not start automatically on boot

cfr wrote:

Have you reported it? Have you figured out if it has been reported? If it is the same bug or a different one?

I am not sure anymore is it a bug or I am doing something wrong. That's why I am posting this problem here. Where can I see more info, systemctl status don't show to much,you can see in my earlier post.

Offline

#35 2012-11-27 10:50:08

swordfish
Member
Registered: 2012-01-14
Posts: 160

Re: Dhcpcd does not start automatically on boot

na12 wrote:

Where can I see more info, systemctl status don't show to much,you can see in my earlier post.

You could try this: Reboot with enabled dhcpcd@eth0.service, then run

$ sudo journalctl -b

There you may find additional information.

Last edited by swordfish (2012-11-27 10:50:42)


Arch_x64 on Thinkpad Edge E520 (Intel Core i5, 4 GB RAM, 128 GB Crucial M4 SSD) + ITX-Desktop (Asrock H77M-ITX, Intel Core i3-2120T, 8GB RAM, 64 GB Samsung 830 SSD)

Offline

#36 2013-01-30 18:26:07

stringchopper
Member
Registered: 2009-02-19
Posts: 38

Re: Dhcpcd does not start automatically on boot

I'm a newbie, so this may or may not be helpful info (i ran arch a few years ago for a brief time, but still a newbie)

doing "sudo journalctl -b" shows that udev changes the name eth0 to enp3s0, and afterwards dhcpcd can't find eth0 and systemd exits the control process.


Regards,
Brian

Offline

#37 2013-01-31 00:26:50

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,662

Re: Dhcpcd does not start automatically on boot

Please search. There are a number of threads about this by now.


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#38 2013-01-31 00:44:47

stringchopper
Member
Registered: 2009-02-19
Posts: 38

Re: Dhcpcd does not start automatically on boot

cfr wrote:

Please search. There are a number of threads about this by now.

That's definitely true, but the solution of adding a /etc/modules-load.d/realtek.conf file with "r8169" in it didn't work for me.  Other threads that I found seemed only to be work-arounds, and as a new user, I'm concerned about breaking things.


Regards,
Brian

Offline

#39 2013-01-31 00:48:57

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,662

Re: Dhcpcd does not start automatically on boot

I meant about the interface name change - that you don't get eth0 etc. by default on a new install.


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#40 2013-01-31 01:43:37

the sad clown
Member
From: 192.168.0.X
Registered: 2011-03-20
Posts: 833

Re: Dhcpcd does not start automatically on boot

stringchopper wrote:

I'm a newbie, so this may or may not be helpful info (i ran arch a few years ago for a brief time, but still a newbie)

doing "sudo journalctl -b" shows that udev changes the name eth0 to enp3s0, and afterwards dhcpcd can't find eth0 and systemd exits the control process.

You have your own solution.  Wherever you were using "eth0" previously, replace that with "enp3s0".  It is your new network interface name for ethernet.


I laugh, yet the joke is on me

Offline

#41 2013-01-31 09:07:31

Mr.Elendig
#archlinux@freenode channel op
From: The intertubes
Registered: 2004-11-07
Posts: 3,727

Re: Dhcpcd does not start automatically on boot

stringchopper wrote:

I'm a newbie, so this may or may not be helpful info (i ran arch a few years ago for a brief time, but still a newbie)

doing "sudo journalctl -b" shows that udev changes the name eth0 to enp3s0, and afterwards dhcpcd can't find eth0 and systemd exits the control process.

https://bugs.archlinux.org/task/31093

Just symlink the .service file yourself.


Evil #archlinux@freenode channel op and general support dude.
. files on github, Screenshots, Random pics and the rest

Offline

Board footer

Powered by FluxBB