You are not logged in.

#26 2012-12-27 22:50:55

dodo3773
Member
Registered: 2011-03-17
Posts: 798

Re: [SOLVED] Thunar Trash Stopped Working - always asks to permanently del

Nope that wasn't it. Mine is just working now for some reason though. The only thing I changed in my setup was removing "thunar --daemon" from my autostart file. No clue other than that.

Offline

#27 2012-12-27 22:55:43

TeoBigusDickus
Member
From: /Greece/Kastoria
Registered: 2010-05-29
Posts: 122

Re: [SOLVED] Thunar Trash Stopped Working - always asks to permanently del

Hah! dbus-launch thunar launches thunar WITHOUT trash and thunar launches - surprise - thunar WITH trash.
Nevermind mate, thanks for the help; I really appreciate it.


Please make Autocad Civil 3d and Archicad work on Linux! Please make Autocad Civil 3d and Archicad work on Linux! Please make Autocad Civil 3d and Archicad work on Linux! Please make Autocad Civil 3d and Archicad work on Linux! Please make Autocad Civil 3d and Archicad work on Linux! Please make Autocad Civil 3d and Archicad work on Linux! Please make Autocad Civil 3d and Archicad work on Linux!

Offline

#28 2012-12-28 02:18:51

es92
Member
Registered: 2012-12-08
Posts: 18

Re: [SOLVED] Thunar Trash Stopped Working - always asks to permanently del

yep, dbus-launch worked, thanks!

Offline

#29 2012-12-28 04:38:39

drcouzelis
Member
From: Connecticut, USA
Registered: 2009-11-09
Posts: 3,497
Website

Re: [SOLVED] Thunar Trash Stopped Working - always asks to permanently del

TeoBigusDickus wrote:

dbus-launch thunar launches thunar WITHOUT trash and thunar launches - surprise - thunar WITH trash.

es92 wrote:

yep, dbus-launch worked, thanks!

Wait... so, which is it? yikes

Offline

#30 2012-12-28 04:44:50

es92
Member
Registered: 2012-12-08
Posts: 18

Re: [SOLVED] Thunar Trash Stopped Working - always asks to permanently del

running dbus-launch thunar launches thunar with functional trash for me.

Offline

#31 2012-12-28 07:13:56

TeoBigusDickus
Member
From: /Greece/Kastoria
Registered: 2010-05-29
Posts: 122

Re: [SOLVED] Thunar Trash Stopped Working - always asks to permanently del

es92 wrote:

running dbus-launch thunar launches thunar with functional trash for me.

The opposite for me sad
Calling dbus-launch has no effect for me, ie. thunar starts without trash after boot and regains trash after calling it for a second time, with dbus-launch or not.
Video thumbnails are still missing all the time.

Last edited by TeoBigusDickus (2012-12-28 08:15:00)


Please make Autocad Civil 3d and Archicad work on Linux! Please make Autocad Civil 3d and Archicad work on Linux! Please make Autocad Civil 3d and Archicad work on Linux! Please make Autocad Civil 3d and Archicad work on Linux! Please make Autocad Civil 3d and Archicad work on Linux! Please make Autocad Civil 3d and Archicad work on Linux! Please make Autocad Civil 3d and Archicad work on Linux!

Offline

#32 2012-12-29 00:03:53

dodo3773
Member
Registered: 2011-03-17
Posts: 798

Re: [SOLVED] Thunar Trash Stopped Working - always asks to permanently del

Okay update. The solution was not a solution at all for me (removing --daemon) same behavior again today. For now a second launch is going to have to be good enough for me (rather do that then switch file managers). I still think this is somehow dbus related though. That is my official unofficial guess tongue

Offline

#33 2012-12-29 02:59:35

dodo3773
Member
Registered: 2011-03-17
Posts: 798

Re: [SOLVED] Thunar Trash Stopped Working - always asks to permanently del

Okay so I came up with something. I do not know if it is working correctly or not as my system has been working correctly on and off so someone please test (looking at you TeoBigusDickus tongue). Here is what I did:

Create this file

/etc/systemd/system/thunar.service

[Unit]
Description=Thunar Daemon

[Service]
Type=dbus
BusName=org.xfce.Thunar
ExecStart=/usr/bin/Thunar --daemon

[Install]
WantedBy=multi-user.target

After that enable it of course:

# systemctl enable thunar.service

Then reboot. Let me know if it is working or not. Got this idea from the file that is now installed with thunar (/usr/share/dbus-1/services/org.xfce.Thunar.service/usr/share/dbus-1/services/org.xfce.Thunar.service  ). Let me know guys.

Edit: The last line you may need to change "multi-user.target" to whatever runlevel that you use to boot your system. I'm not entirely sure as I am very new to systemd. You can always check if it is enabled / running after though with  "systemctl list-unit-files --no-pager | grep thunar".


Edit: Nope. Doesn't work.

Last edited by dodo3773 (2012-12-30 04:20:11)

Offline

#34 2012-12-30 09:07:01

TeoBigusDickus
Member
From: /Greece/Kastoria
Registered: 2010-05-29
Posts: 122

Re: [SOLVED] Thunar Trash Stopped Working - always asks to permanently del

dodo3773 wrote:

Edit: Nope. Doesn't work.

Indeed it doesn't (sorry for the late response).

Never mind mate. I'm starting to like pcmanfm, it even recognizes and opens my sister's nikon coolpix camera.
Thanks for the help.


Please make Autocad Civil 3d and Archicad work on Linux! Please make Autocad Civil 3d and Archicad work on Linux! Please make Autocad Civil 3d and Archicad work on Linux! Please make Autocad Civil 3d and Archicad work on Linux! Please make Autocad Civil 3d and Archicad work on Linux! Please make Autocad Civil 3d and Archicad work on Linux! Please make Autocad Civil 3d and Archicad work on Linux!

Offline

#35 2013-02-07 17:48:24

lenzenmi
Member
Registered: 2013-02-07
Posts: 1

Re: [SOLVED] Thunar Trash Stopped Working - always asks to permanently del

I had the same problem, and now it's fixed. Here's what I did.

replaced my .xinitrc with the version from /etc/skel/
for reference here is my working .xinitrc file (notice the absence of dbus-launch and ck-launch-session)

#!/bin/sh
#
# ~/.xinitrc
#
# Executed by startx (run your window manager from here)

if [ -d /etc/X11/xinit/xinitrc.d ]; then
  for f in /etc/X11/xinit/xinitrc.d/*; do
    [ -x "$f" ] && . "$f"
  done
  unset f
fi

# exec gnome-session
# exec startkde
# exec startxfce4
# ...or the Window Manager of your choice
eval $(gpg-agent --daemon) &
exec startfluxbox

In my .fluxbox/startup file I have the following line

thunar --daemon &

That's it.

Last edited by lenzenmi (2013-02-07 17:50:21)

Offline

#36 2013-02-07 18:11:47

TeoBigusDickus
Member
From: /Greece/Kastoria
Registered: 2010-05-29
Posts: 122

Re: [SOLVED] Thunar Trash Stopped Working - always asks to permanently del

No big deal; pcmanfm is perfect for me.
I've even found a replacement for thunar's killer feature - Bulk Rename: GPRename.


Please make Autocad Civil 3d and Archicad work on Linux! Please make Autocad Civil 3d and Archicad work on Linux! Please make Autocad Civil 3d and Archicad work on Linux! Please make Autocad Civil 3d and Archicad work on Linux! Please make Autocad Civil 3d and Archicad work on Linux! Please make Autocad Civil 3d and Archicad work on Linux! Please make Autocad Civil 3d and Archicad work on Linux!

Offline

#37 2013-02-08 03:31:35

drcouzelis
Member
From: Connecticut, USA
Registered: 2009-11-09
Posts: 3,497
Website

Re: [SOLVED] Thunar Trash Stopped Working - always asks to permanently del

lenzenmi wrote:

I had the same problem, and now it's fixed. Here's what I did.

I'm sorry, I don't think it's fixed, unless you think my configuration is somehow different from yours in a way that makes a difference:

.xinitrc:

#!/bin/sh
#
# ~/.xinitrc
#
# Executed by startx (run your window manager from here)

# Run the X startup scripts
if [ -d /etc/X11/xinit/xinitrc.d ]; then
  for f in /etc/X11/xinit/xinitrc.d/*; do
    [ -x "$f" ] && . "$f"
  done
  unset f
fi

# Disable the TV output
~/Library/bin/tv-disable

# If you use xscreensaver, it will override these values
xset s off # Disable the X screen saver (blanking)
xset dpms 0 0 1800 # Turn off the monitor after 30 minutes

# Allow Ctrl + Alt + Backspace
setxkbmap -option terminate:ctrl_alt_bksp

# Set the default keyboard layout to Dvorak
setxkbmap dvorak

# Set the default mouse cursor
xsetroot -cursor_name left_ptr

# Setup SCIM for Japanese input
export XMODIFIERS=@im=SCIM
export GTK_IM_MODULE="scim"
export QT_IM_MODULE="scim"
scim -f x11 -c simple -d

exec openbox-session

.config/openbox/autostart:

#
# These things are run when an Openbox X Session is started.
# You may place a similar script in $HOME/.config/openbox/autostart
# to run user-specific things.
#

# Wallpaper
sh ${HOME}/.fehbg

# Info
conky &

# System tray
stalonetray &

# Preload
urxvtd &
thunar --daemon &

After a fresh boot, I still have no trash can in Thunar until I log out and log back in to X. sad

Offline

#38 2013-02-23 01:44:11

calegria
Member
Registered: 2013-02-23
Posts: 6

Re: [SOLVED] Thunar Trash Stopped Working - always asks to permanently del

drcouzelis wrote:

Ok, I think I have a fix. Deleting my Thunar config files helped. But here's the tricky part:

You know the "~/.config/Thunar" directory? That apparently is not the Thunar config file location. tongue

Instead, I removed "~/.config/xfce4/xfconf/xfce-perchannel-xml/thunar*". After restarting Thunar, my Trash can worked correctly. smile

This worked for me too.

Offline

Board footer

Powered by FluxBB