You are not logged in.

#276 2014-05-19 06:17:45

orschiro
Member
Registered: 2009-06-04
Posts: 2,136
Website

Re: Aura - 1.3.5 *Please update to fix breakage*

@ewaller

Fair enough to raise that question. I switched my installation from Antergos to vanilla Arch a while ago. Thereby I noticed that Antergos only adds very minor modifications, such as wallpapers and themes.

Regarding the issue here, I suspect that I have not enough space to build on root (although still being 1GB free).

When I build it manually in my home directory, then it succeeds.

Offline

#277 2014-05-19 15:28:26

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 12,936

Re: Aura - 1.3.5 *Please update to fix breakage*

Makes sense,  I think you are on the right track


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Like you, I have no idea what you are doing, but I am pretty sure it is wrong...Jasonwryan
----
How to Ask Questions the Smart Way

Offline

#278 2014-05-19 16:22:51

bstaletic
Member
Registered: 2014-02-02
Posts: 601

Re: Aura - 1.3.5 *Please update to fix breakage*

@orschiro
How can you be lacking space if the package is about the same as firefox (in size)?

Last edited by bstaletic (2014-05-19 16:23:39)

Offline

#279 2014-05-30 07:00:28

orschiro
Member
Registered: 2009-06-04
Posts: 2,136
Website

Re: Aura - 1.3.5 *Please update to fix breakage*

@bstaletic

I think building atom-edtior also requires significant space. I made some large amount of free space available and now it successfully builds. smile

Thanks for your comments!

Offline

#280 2014-06-18 10:32:10

orschiro
Member
Registered: 2009-06-04
Posts: 2,136
Website

Re: Aura - 1.3.5 *Please update to fix breakage*

Hi guys,

I would like to use Aura to display the number of available AUR/repo updates in conky.

I know I can use /usr/bin/checkupdates for the repo if Aura can only handle the AUR.

I looked into the manual but could not find a command to retrieve available updates.

Did I overlook something?

Thanks!

Offline

#281 2014-07-21 18:42:30

fosskers
Member
Registered: 2012-02-21
Posts: 142
Website

Re: Aura - 1.3.5 *Please update to fix breakage*

1.3.0.0
-------
- Last major version of Aura 1! We have entered the design phase for Aura 2,
  the implementation of which will transform Aura into a multi-distro
  package management platform.
- Aura 1 itself has entered "legacy" mode. The only releases to be made
  on Aura 1 after this will be of `1.3.0.x`. You'll likely never see
  `1.3.1.x`.
- Befitting a major release, we have:
  - New AUR interaction layer via the `aur` package. This fixes nasty
    "AUR lookup failed" errors.
  - `http-conduit` dropped for `wreq`, which is much easier to use.
  - Better version number parsing/comparison on installation/upgrading.
  - Package state backups have had their format changed. This BREAKS _all_
    previously saved states. Please delete your old ones!
  - Implemented extended `--needed` functionality for the AUR side of Aura.
    AUR packages won't build if they're already installed.
  - Indonesian translations!
  - Other updated translations.


Author of Aura

Offline

#282 2014-08-02 19:23:59

fosskers
Member
Registered: 2012-02-21
Posts: 142
Website

Re: Aura - 1.3.5 *Please update to fix breakage*

Hey guys, Aura has an IRC channel now.

Come for usage help or dev discussion!

irc.freenode.net
Channel: #aurapm


Author of Aura

Offline

#283 2014-08-15 19:19:55

stef_204
Member
Registered: 2014-08-15
Posts: 16

Re: Aura - 1.3.5 *Please update to fix breakage*

The error in my post below seems to be related to one of the AUR packages aura is trying to update while executing command below; so not an aura issue, sorry.
Issue is solved.

@mod: feel free to remove post.

===================

Hi,

Just started to use aura.
One problem I get is:

% sudo aura -Akuax                               
aura >>= Fetching package information...
aura >>= Comparing package versions...
aura >>= AUR Packages to upgrade:
conkywx : 0.7.9-2 => 2.0.0-1
[clip]
aura >>= `conkywx` has no stored PKGBUILD yet. # this is normal so not an error (my 2 cents)
[clip]
# This below is the problem.
aura >>= Determining dependencies...
aura >>= Dependency checking failed for these reasons:
The dependency `python` demands version `<3.4.0`, but the most recent version is `3.4.1-1`.

*So nothing updates.*

Anyone with same issue? How to best resolve?

I am using aura-bin from AUR, version 1.3.0.0-1
(I couldn't build using aura PKGBUILD due to haskell issues so went with the binary.)

Thanks for feedback.

Last edited by stef_204 (2014-08-22 15:37:39)

Offline

#284 2014-08-20 13:36:41

evujumenuk
Member
Registered: 2013-07-02
Posts: 14

Re: Aura - 1.3.5 *Please update to fix breakage*

I think aura should let the user decide which package to install, when multiple packages provide a dependency. Right now, it is impossible to install e.g. minecraft with jre8-openjdk, aura installs jre7-openjdk right away…

Offline

#285 2014-10-03 13:23:11

MultiForce
Member
Registered: 2014-03-26
Posts: 4

Re: Aura - 1.3.5 *Please update to fix breakage*

Is it possible to have it build all the dependencies (also if there's a mix between AUR/ABS stuff)?

I'm an arch/linux noob so it might be something obvious I'm missing wink

Think I got it figured out. The last part is having it reinstall already installed packages (build them).

Last edited by MultiForce (2014-10-04 19:14:31)

Offline

#286 2014-10-06 01:50:55

fosskers
Member
Registered: 2012-02-21
Posts: 142
Website

Re: Aura - 1.3.5 *Please update to fix breakage*

@MultiForce: Try the `--absdeps` option.


Author of Aura

Offline

#287 2014-10-14 14:22:09

bstaletic
Member
Registered: 2014-02-02
Posts: 601

Re: Aura - 1.3.5 *Please update to fix breakage*

I'm unable to build teamviewer using aura. It seems to be the problem with multilib repo. It is enabled and aura still can not find teamviewer's dependancies from [multilib]. I had manually installed the dependancies and tried running "aura -A teamviewer" but it failed. makepkg -s works perfectly. I ma unsure if aura has a problem with [multilib] or with 32bit packages on 64bit systems (it may as well be a problem on my side, but I don't have another pc to check).

Can anyone verify this?

Offline

#288 2014-10-14 18:04:04

Spyhawk
Member
Registered: 2006-07-07
Posts: 402

Re: Aura - 1.3.5 *Please update to fix breakage*

@bstaletic> I haven't tried, but this is most probably related to the PKGBUILD parser's limitations. Will be fixed in Aura 2 (and makepkg 4.2 to some extent).

Offline

#289 2014-10-14 19:37:45

bstaletic
Member
Registered: 2014-02-02
Posts: 601

Re: Aura - 1.3.5 *Please update to fix breakage*

I just tried another package called "lib32-dbus-glib" and aura does it's job like it should. So it is not general problem with aura and lib32. Thatt is actually a relief, I thought I would have to find my self another AUR helper.

Offline

#290 2014-10-16 16:16:44

chaonaut
Member
From: Kyiv, Ukraine
Registered: 2014-02-05
Posts: 317

Re: Aura - 1.3.5 *Please update to fix breakage*

excuse me for a dumb question, but how exactly ABS support works?
i spent half an hour reading manpage and fiddling with different options, but could not manage to build a single ABS package from source.
is it possible at all?


— love is the law, love under wheel, — said aleister crowley and typed in his terminal:
usermod -a -G wheel love

Offline

#291 2014-10-20 02:06:38

Kaliwal
Member
Registered: 2011-12-05
Posts: 24

Re: Aura - 1.3.5 *Please update to fix breakage*

chaonaut wrote:

excuse me for a dumb question, but how exactly ABS support works?
i spent half an hour reading manpage and fiddling with different options, but could not manage to build a single ABS package from source.
is it possible at all?

Try
sudo aura -Ma --absdeps <packagename>

Worked for me. Hope it works for you, too.
I found this info in the man page for Aura.

Seniors: Correct me if I am wrong, please.

EDIT:

sudo -My will refresh the local abs packages you have but fon't fetch the latest abs tree. So i suggest you instead rely on "sudo abs" for refreshing the local abs tree. you can then try the above command to build a package with all its dependencies.

Last edited by Kaliwal (2014-10-20 02:10:14)

Offline

#292 2014-12-07 23:29:51

fosskers
Member
Registered: 2012-02-21
Posts: 142
Website

Re: Aura - 1.3.5 *Please update to fix breakage*

Or if you only want to sync one particular package to your local tree, use `-Mt`.

Also, 1.3.0.2 has been released! I fixed a bug related to ignored packages.


Author of Aura

Offline

#293 2014-12-26 04:14:11

hcra
Member
From: Oregon
Registered: 2013-04-20
Posts: 56

Re: Aura - 1.3.5 *Please update to fix breakage*

I'm seeking guidance to remove haskell and the haskell-core repo used to build aura.

I'm tremendously enjoying aura-bin and would like to remove haskel-core from pacman.conf and all of the haskell packages added to compile aura. I'm thinking:

1) remove haskel-core from pacman.conf
2) uninstall all haskell packages detailed in the Wiki
3) cross my fingers and hope for the best!

What bugs me is my last step, cross my fingers and hope for the best. Surely there is a wiser approach.

Can someone please help my thinking!? Thanks so much --

Offline

#294 2014-12-26 12:30:41

Spyhawk
Member
Registered: 2006-07-07
Posts: 402

Re: Aura - 1.3.5 *Please update to fix breakage*

@hcra> Check the PKGBUILD instead.

I'd proceed this way: remove the haskell repo, remove the haskell deps listed above with -Rsn, check -Qm (any package not in enabled repositories) for any possible haskell leftover.

Offline

#295 2014-12-26 16:29:12

hcra
Member
From: Oregon
Registered: 2013-04-20
Posts: 56

Re: Aura - 1.3.5 *Please update to fix breakage*

[EDIT] @Spyhawk Thanks for the wise advice. I successfully removed all of the packages in the haskell repository and checked for stray packages with -Qm. So far, so good. Thanks for the help!!

Last edited by hcra (2014-12-26 17:49:58)

Offline

#296 2015-01-11 20:24:13

fosskers
Member
Registered: 2012-02-21
Posts: 142
Website

Re: Aura - 1.3.5 *Please update to fix breakage*

Hey guys, new package in the AUR: aura1-git

All users of aura-git should switch to this if they want aura1 functionality. The aura-git package will be following Aura2 development.


Author of Aura

Offline

#297 2015-02-25 18:00:04

Asta666
Member
From: Argentina
Registered: 2014-12-08
Posts: 20

Re: Aura - 1.3.5 *Please update to fix breakage*

Lately after executing sudo aura -Au I'm getting the  following:
aura >>= Fetching package information...
aura >>= Comparing package versions...
aura >>= No AUR package upgrades necessary.
aura >>= No valid packages specified. <--- any ideas why I started getting this message? (I use aura-bin 1.3.0.4-1)

Last edited by Asta666 (2015-02-25 18:01:23)

Offline

#298 2015-03-05 11:52:37

stef_204
Member
Registered: 2014-08-15
Posts: 16

Re: Aura - 1.3.5 *Please update to fix breakage*

@asta666
I believe this is normal behavior.  I show the same message when AUR packages are up to date.
And when an AUR package does need to be upgraded, Aura picks it up and presents it for upgrade.

Last edited by stef_204 (2015-03-05 11:52:58)

Offline

#299 2015-03-06 01:17:12

Asta666
Member
From: Argentina
Registered: 2014-12-08
Posts: 20

Re: Aura - 1.3.5 *Please update to fix breakage*

I hope so, seems to be working fine but I just wanted to make sure since I found it a bit strange that I didn't see it before.

Offline

#300 2015-07-22 14:56:33

fosskers
Member
Registered: 2012-02-21
Posts: 142
Website

Re: Aura - 1.3.5 *Please update to fix breakage*

Hey guys, Aura has been updated to point to AUR4. Enjoy!


Author of Aura

Offline

Board footer

Powered by FluxBB