You are not logged in.

#26 2013-04-05 07:06:48

kinleyd
Member
From: Thimphu, Bhutan
Registered: 2012-09-21
Posts: 113

Re: [SOLVED] xfce-session-logout does not work as expected

Thanks for this solution - worked for my slim/i3-wm and slim/herbstluftwm lash ups.

My system doesn't hard lock anymore on the second logout, as it did before. I'm really happy about that! However, I still can't switch to tty using Ctrl+Alt+Fx.

I read on another thread about pango having something to do with a problem similar to this. Anyone have an update on that?

Last edited by kinleyd (2013-04-05 07:11:35)

Offline

#27 2013-04-06 04:22:30

kinleyd
Member
From: Thimphu, Bhutan
Registered: 2012-09-21
Posts: 113

Re: [SOLVED] xfce-session-logout does not work as expected

Good news, the latest release of the 304.88 driver fixed the problem. smile

Edit: Ctrl-Alt-F1-F6 now launches tty 1-6, etc. However, logging out to slim still crashes on the second attempt. Still need the hack (killall --user $USER -TERM etc) in slim.conf to avoid this.

Last edited by kinleyd (2013-04-06 09:04:25)

Offline

#28 2013-04-26 18:56:53

f1tzl4nd
Member
From: Corsicana, TX ~ US
Registered: 2012-07-26
Posts: 4

Re: [SOLVED] xfce-session-logout does not work as expected

Thanks for help with this issue. I'm using LXDM (same happened with Slim) along with Openbox and Enlightenment. Adding the following to /etc/lxdm/PostLogout

# this makes sure lxdm is restarted if it crashes
if [ ! -z "$(pgrep lxdm)" ]
  then
	systemctl restart lxdm
fi

# this forces users to logout 
loginctl terminate-user user1 user2

Worked for me.

Offline

#29 2013-06-17 21:45:13

colinkeenan
Member
From: Kansas City, MO USA
Registered: 2013-06-13
Posts: 175
Website

Re: [SOLVED] xfce-session-logout does not work as expected

Here's a method that would work with any display manager and so works with SDDM: https://bbs.archlinux.org/viewtopic.php … 9#p1289209

It took me a while to find this thread since it doesn't mention SDDM at all so that I ended up starting a new thread which nobody responded to. Eventually I found this thread and used the information to come up with my own solution that I posted above. If anyone can improve on what I did there, please post comments on that thread. Thanks.

Offline

#30 2013-06-25 22:23:47

colinkeenan
Member
From: Kansas City, MO USA
Registered: 2013-06-13
Posts: 175
Website

Re: [SOLVED] xfce-session-logout does not work as expected

I finally found a general solution THAT DIRECTLY SOLVES THE REAL PROBLEM. All you have to do is add a single line to the end of a pam conf file. Add it to the one for your display manager. For sddm:

/etc/pam.d/sddm

...
session 	required 	pam_systemd.so

For lxdm, you would add that line to the end of /etc/pam.d/lxdm, and I'm sure it would work similarly for other display managers.

I have updated the Display Manager wiki with this information.

Last edited by colinkeenan (2013-06-25 22:37:32)

Offline

#31 2013-06-26 12:00:13

Eishorn
Member
From: somewhere
Registered: 2011-04-18
Posts: 36

Re: [SOLVED] xfce-session-logout does not work as expected

No luck with lxdm. pam_systemd.so is already listed as optional, changing it to required brings back the crashes.

Offline

#32 2013-06-26 12:07:35

colinkeenan
Member
From: Kansas City, MO USA
Registered: 2013-06-13
Posts: 175
Website

Re: [SOLVED] xfce-session-logout does not work as expected

Eishorn wrote:

No luck with lxdm. pam_systemd.so is already listed as optional, changing it to required brings back the crashes.

See this post from cb474: http://forum.manjaro.org/index.php?topi … 8#msg45338

For him, it only works with a dash in front of that line. You might want to try that.

Also, if you previously made changes that causes lxdm to restart whenever you log out, you would obviously need to undo those changes.

Last edited by colinkeenan (2013-06-26 12:13:25)

Offline

#33 2013-06-26 18:58:17

archtom
Member
Registered: 2011-05-04
Posts: 42

Re: [SOLVED] xfce-session-logout does not work as expected

f1tzl4nd wrote:

Thanks for help with this issue. I'm using LXDM (same happened with Slim) along with Openbox and Enlightenment. Adding the following to /etc/lxdm/PostLogout

# this makes sure lxdm is restarted if it crashes
if [ ! -z "$(pgrep lxdm)" ]
  then
	systemctl restart lxdm
fi

# this forces users to logout 
loginctl terminate-user user1 user2

Worked for me.

thanks, but if you autologin on the first start, this leads to automatic relogin and you cannot choose another desktop or user

Offline

#34 2013-06-26 18:59:13

archtom
Member
Registered: 2011-05-04
Posts: 42

Re: [SOLVED] xfce-session-logout does not work as expected

colinkeenan wrote:
Eishorn wrote:

No luck with lxdm. pam_systemd.so is already listed as optional, changing it to required brings back the crashes.

See this post from cb474: http://forum.manjaro.org/index.php?topi … 8#msg45338

For him, it only works with a dash in front of that line. You might want to try that.

Also, if you previously made changes that causes lxdm to restart whenever you log out, you would obviously need to undo those changes.

sorry also no luck for me, tried with and without hyphen

Offline

#35 2013-06-26 19:36:42

colinkeenan
Member
From: Kansas City, MO USA
Registered: 2013-06-13
Posts: 175
Website

Re: [SOLVED] xfce-session-logout does not work as expected

archtom wrote:
f1tzl4nd wrote:

Thanks for help with this issue. I'm using LXDM (same happened with Slim) along with Openbox and Enlightenment. Adding the following to /etc/lxdm/PostLogout

# this makes sure lxdm is restarted if it crashes
if [ ! -z "$(pgrep lxdm)" ]
  then
	systemctl restart lxdm
fi

# this forces users to logout 
loginctl terminate-user user1 user2

Worked for me.

thanks, but if you autologin on the first start, this leads to automatic relogin and you cannot choose another desktop or user

It's amazing to me that the Arch developers don't solve this issue. If I were you and really wanted to be able to log off and then log in as another user while maintaining automatic log in, I would write a bash script that: first, pops up a zenity dialogue listing users to choose from; second, uses python or perl to replace the current users name with the new one in /etc/lxdm.conf; third, restarts lxdm. In order to avoid having to provide the sudo password, you would also have to run visudo to make your script runable without a password. Or, you could just disable automatic login?

If you do want to write the script, the following links will help you:

To make a drop-down zenity list, see http://askubuntu.com/questions/50988/wh … ith-zenity

To use perl to find and replace a string in a text file, see http://stackoverflow.com/questions/5255 … sh-command

Last edited by colinkeenan (2013-06-26 19:40:17)

Offline

#36 2013-06-26 20:43:40

archtom
Member
Registered: 2011-05-04
Posts: 42

Re: [SOLVED] xfce-session-logout does not work as expected

colinkeenan wrote:
archtom wrote:
f1tzl4nd wrote:

Thanks for help with this issue. I'm using LXDM (same happened with Slim) along with Openbox and Enlightenment. Adding the following to /etc/lxdm/PostLogout

# this makes sure lxdm is restarted if it crashes
if [ ! -z "$(pgrep lxdm)" ]
  then
	systemctl restart lxdm
fi

# this forces users to logout 
loginctl terminate-user user1 user2

Worked for me.

thanks, but if you autologin on the first start, this leads to automatic relogin and you cannot choose another desktop or user

It's amazing to me that the Arch developers don't solve this issue. If I were you and really wanted to be able to log off and then log in as another user while maintaining automatic log in, I would write a bash script that: first, pops up a zenity dialogue listing users to choose from; second, uses python or perl to replace the current users name with the new one in /etc/lxdm.conf; third, restarts lxdm. In order to avoid having to provide the sudo password, you would also have to run visudo to make your script runable without a password. Or, you could just disable automatic login?

If you do want to write the script, the following links will help you:

To make a drop-down zenity list, see http://askubuntu.com/questions/50988/wh … ith-zenity

To use perl to find and replace a string in a text file, see http://stackoverflow.com/questions/5255 … sh-command


thanks, perhaps I´ll try around a bit when I have time but this can not be the "real" solution. thanks anyway, perhaps someone comes up with an easier workaround or perhaps someone can file a bug on the tracker. I´m not capable of providing the correct logs... otherwise I would do it. Did anyone file a bug for this?

Offline

#37 2013-06-26 21:36:58

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [SOLVED] xfce-session-logout does not work as expected

colinkeenan wrote:

It's amazing to me that the Arch developers don't solve this issue.

You have to remember that Arch Linux usually ships packages with as little patching as possible.  Usually patching is only done in order to ensure that something builds against our very new toolchain, or if there is some very significant fix pushed upstream that would make sense to backport immediately.  Typically these are security things, but in those cases an update is more likely the proper solution.  So you have to ask yourself if what you are seeing is a problem with Arch packaging or a problem that is coming directly from upstream.

The other thing is that even though there appear to be a number of people having this issue and participating in this thread, no one has mentioned, or thought to report it to the flyspray (bug tracker).  I also did a quick search and was unable to find anything relating to this either.  So you are then saying that you expect teh Arch developers to frequent the forums and seek out issues that they might be able to fix.  If you want help from the devlopers, go about it the right way and report it!

Offline

#38 2013-06-30 14:01:55

archtom
Member
Registered: 2011-05-04
Posts: 42

Re: [SOLVED] xfce-session-logout does not work as expected

o.k., I know this is seen as solved but I wanted to describe my solution for anyone who will read this in the future. thanks to anyone in this thread that pointed me to this. I´m using xfce4 and lxdm:

Please test if X is still running after two logouts, if X crashes, add new line to /etc/pam.d/lxdm (do not modify existing lines):

nano /etc/pam.d/lxdm
...
session		required 	pam_systemd.so

If you are using x11vnc test if x11vnc is still running after two logouts, if not, restart your x11vnc script after logout, for me it is:

nano /etc/lxdm/PostLogout
systemctl restart x11vnc_start.service

Perhaps someone can file a bug to the archlinux bugtracker with a link to this thread.

Offline

#39 2013-08-14 13:35:01

lesebas
Member
Registered: 2013-07-10
Posts: 15

Re: [SOLVED] xfce-session-logout does not work as expected

Hello,

I have a similar problem with xfce and lxdm. Loginctl show only the first logged user even if a second is connected... complete description here :

https://bbs.archlinux.org/viewtopic.php?id=167505

even if my /etc/pam.d/lxdm is :

#%PAM-1.0
auth            requisite       pam_nologin.so
auth            required        pam_env.so
auth            required        pam_unix.so
account         required        pam_unix.so
session         required        pam_limits.so
session         required        pam_unix.so
password        required        pam_unix.so
-session         optional        pam_loginuid.so
-session         optional        pam_systemd.so

Offline

#40 2013-09-06 11:42:57

lesebas
Member
Registered: 2013-07-10
Posts: 15

Re: [SOLVED] xfce-session-logout does not work as expected

Offline

#41 2013-09-12 21:15:44

lesebas
Member
Registered: 2013-07-10
Posts: 15

Re: [SOLVED] xfce-session-logout does not work as expected

Hello,

Bug fixed in the last version, you can try the git... maybe it solve the crash with the second user login.

Offline

Board footer

Powered by FluxBB