You are not logged in.

#626 2013-10-15 00:09:26

brenix
Member
From: California
Registered: 2008-03-05
Posts: 182

Re: infinality-bundle: good looking fonts made (even) easier

@bohoomil: I understand you had to recently updated the infinality-settings.sh file to have "hintfull". I was looking at 10-base-rendering.conf and it still has "hintslight"..  I thought I'd bring it up in case it was your intention to set it in both. Fonts are looking great though!

Offline

#627 2013-10-15 00:47:11

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,662

Re: infinality-bundle: good looking fonts made (even) easier

That's not necessary. A simple pacman -S <pkgname> will downgrade the package - no need to uninstall it first or download it manually.


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#628 2013-10-15 09:53:04

X-dark
Member
From: France
Registered: 2009-10-25
Posts: 135
Website

Re: infinality-bundle: good looking fonts made (even) easier

bohoomil wrote:

No problem. wink I am aware of the fact that this sort of upgrade/re-installation may be confusing, but in order to make the project functional a switch like this had to be performed. At first I wanted to add another post-upgrade hook to the *.install file, but then I decided to force re-installation of the package instead. I hope that once I manage to improve Makefiles properly, such issues should not be the case any more.

Maybe you could have advertized this in a post upgrade message as not all infinality-bundle users read this topic.
Anyway thanks for the great work.


Cedric Girard

Offline

#629 2013-10-15 12:03:30

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: infinality-bundle: good looking fonts made (even) easier

brenix wrote:

I was looking at 10-base-rendering.conf and it still has "hintslight".

This one has to be set to "slight": This is the default value and this is what non-TTF fonts need to render properly. Besides, if you install a new font in your system and won't apply special settings to it (e.g. append its name to the 90-tt-fonts.conf list), it will use the default 'base' configuration. All exceptions, special cases, etc., can be found in 90-*.conf and 92-*.conf files. smile


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#630 2013-10-15 13:18:13

logos88
Member
From: Valencia
Registered: 2013-04-02
Posts: 28

Re: infinality-bundle: good looking fonts made (even) easier

Thanks for the great work!! Arch wouldn't be the same without you big_smile

When you make "fc-presets set", which are the diferences between Custom and Free?

Offline

#631 2013-10-15 13:30:57

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: infinality-bundle: good looking fonts made (even) easier

Custom is currently a copy of ms. What it should be is up to a user. One day I'm going to make 'custom' a documented set of files with just a basic configuration for free fonts. This should be a nice option for users willing to break something and when the damage is done revert their systems to the working state. smile


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#632 2013-10-15 18:16:08

redDEADresolve
Member
From: Chicago
Registered: 2009-09-17
Posts: 19

Re: infinality-bundle: good looking fonts made (even) easier

redDEADresolve wrote:
redDEADresolve wrote:

I keep getting this error

error: failed retrieving file 'infinality-bundle.db' from ibn.net6I 3.net : Connection timed out after 10001 milliseconds
error: failed to update infinality-bundle (download library error)

what am I doing wrong? My desktop is working great.

Days later and I still cannot connect and update.

Any ideas on what I can do?


A month and a half later I keep getting:

error: failed retrieving file 'infinality-bundle.db' from ibn.net63.net : Connection timed out after 10001 milliseconds
error: failed to update infinality-bundle (download library error)

Any ideas on whats going on? I followed the directions on the first page.

Offline

#633 2013-10-15 18:27:32

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: infinality-bundle: good looking fonts made (even) easier

Connection timed out after 10001 milliseconds

The requested URL returned error: 504 Gateway Time-out

It has nothing to do with you: Just the usual pains we all know about. If things go well, there may be an additional mirror available soon which should prevent such issues from happening.


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#634 2013-10-15 18:31:53

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: infinality-bundle: good looking fonts made (even) easier

bohoomil wrote:

Connection timed out after 10001 milliseconds

The requested URL returned error: 504 Gateway Time-out

It has nothing to do with you: Just the usual pains we all know about. If things go well, there may be an additional mirror available soon which should prevent such issues from happening.

Edit: Roughly 5 minutes later everything is back and working again. Please, be patient despite all (frustrating) odds…


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#635 2013-10-15 23:15:16

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,662

Re: infinality-bundle: good looking fonts made (even) easier

I was just wondering if the latest updates changed your recommended settings for KDE.

Right now, I have not altered them. This means that I have:

anti-aliasing: enabled
   > configuration:
        exclude range is disabled (unchecked)
        sub-pixel rendering is checked and set to RGB
        hinting style is set to Full

force fonts DPI is checked and set at 96

Fonts are set as follows:

general: droid serif 9
fixed width: droid sans mono 9
small: droid serif 8
toolbar: droid serif 8
menu: droid serif 9
window title: droid serif 8
taskbar: droid serif 9
desktop: droid serif 9

[I think I'm using droid because I liked it better than whatever the default was and/or it was sufficiently legible in smaller sizes to allow me to make better use of limited screen space which I guard jealously!]

EDIT: Also, I would suggest linking to https://bbs.archlinux.org/viewtopic.php … 3#p1336233 and the "sister thread" from the first post in this thread so it is easy for people to find. Also note that the documentation you link to there is not currently up to date. (It still says for best results install MS fonts etc.) Right now it is not very easy to find the current information even if you know what you're looking for and it is going to be confusing to link to documentation you haven't yet had time to update. [Maybe even disable that link for now and just point to the relevant forum posts which I believe contain the most current information.]

Last edited by cfr (2013-10-15 23:54:06)


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#636 2013-10-16 06:12:59

orschiro
Member
Registered: 2009-06-04
Posts: 2,136
Website

Re: infinality-bundle: good looking fonts made (even) easier

Fonts are set as follows:
general: droid serif 9
fixed width: droid sans mono 9
small: droid serif 8
toolbar: droid serif 8
menu: droid serif 9
window title: droid serif 8
taskbar: droid serif 9
desktop: droid serif 9

I think you can achieve even better results if you take the default fonts from the 'sister thread':

Default sans-serif, serif, monospace, fantasy, cursive
serif => Heuristica
sans-serif => Noto Sans
monospace => Liberation Mono
fantasy => Signika
cursive => Tex Gyre Chorus

Offline

#637 2013-10-16 16:34:37

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: infinality-bundle: good looking fonts made (even) easier

@cfr, thank you for mentioning that. DE font settings will remain just the same, so you don't have to change anything. I'm going to include this bit in the Wiki article: I remember DE specific font configuration was found a bit problematic in the past and the conclusions have never been put in the relevant article.

User interface configuration is, in my opinion, on the extreme end of customization: whatever a user finds fine, is fine. Droid is a great family and so are many others that work perfectly well as UI fonts: at the moment I'm playing with Source Sans Pro (Type 1 packages of Adobe's both Source families are already available in the repository) and for various reasons it seems even better than my other favourite(s) (e.g. it behaves better at sizes < 9px).

Default sans, serif, etc., mentioned by orschiro, is a different cup of tea: I recommended type faces for general use (reading content on the Web for instance) that I like personally, but there are also more traditional ones available in the default collection which may be necessary when metric compatibility comes to terms (i.e. when you need to open a Word document in LibreOffice and want to preserve the original layout). These two aspects aren't usually treated separately, but they really should be since there is a clear distinction between target media used to reproduce the text (screen vs. paper).  Hence Heuristica was recommended as a default serif face, but TeX Gyre Termes is still better in a typical office context. The optimal solution would be to apply those two defaults automatically when necessary: when you launch LO, a substitution is loaded automatically whenever a particular type face is needed (in our example: the text body requires Times New Roman, so TeX Gyre Termes is used instead). By the way, improvements to office documents portability is one of the points on my TODO list (right below updated documentation & Wiki). smile

Last edited by bohoomil (2013-10-16 17:11:49)


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#638 2013-10-16 22:52:25

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,662

Re: infinality-bundle: good looking fonts made (even) easier

Thanks bohoomil, orschiro.

fc-match shows I am actually using most of the defaults orschiro listed at the fontconfig level:

$ for i in sans-serif serif monospace fantasy cursive; do echo $i; fc-match $i; done
sans-serif
NotoSans-Regular.ttf: "Noto Sans" "Regular"
serif
Heuristica-Regular.pfb: "Heuristica" "Regular"
monospace
LiberationMono-Regular.ttf: "Liberation Mono" "Regular"
fantasy
NotoSans-Regular.ttf: "Noto Sans" "Regular"
cursive
texgyrechorus-mediumitalic.otf: "TeX Gyre Chorus" "Regular"

I'm not sure why it is using Noto Sans for fantasy since I seem to have Signika installed:

infinality-bundle-fonts/otf-signika-family-ib 1.0001-1 (infinality-bundle-fonts) [installed]
    Signika is a sans-serif with a gentle character, developed for wayfinding, signage, and other media where clarity of information is
    required.

EDIT: I'm not mad about LiberationMono so I hesitate to change from Droid. I find Droid very economical in terms of the space it uses and very legible at small sizes. I'm interested in Noto but then I need to find complementary fonts for serif etc. Ah, too many choices!

Last edited by cfr (2013-10-16 22:54:38)


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#639 2013-10-18 10:33:31

jakobcreutzfeldt
Member
Registered: 2011-05-12
Posts: 1,033

Re: infinality-bundle: good looking fonts made (even) easier

I have both infinality-bundle and infinality-bundle-fonts installed. After the latest updates to infinality-bundle (I think, though I also installed the fonts just after the updates), I find that the section headings in the gtk Emacs info reader (C-h i) have been replaced with boxes (see screenshot below). Normally, those headings should be bold text. I had changed the default font in Emacs from DejaVu Sans Mono to Liberation Mono to match the rest of the system as set up by the bundle, however changing back to DejaVu does not fix the problem. Uninstalling fontconfig-infinality-ultimate and replacing it with vanilla fontconfig does resolve it, though, so I think the problem lies there.

Can anyone reproduce the problem? This is on my work computer (Arch) but I haven't checked if I also have the problem at home (same set-up except in Parabola, so I'm not allowed to get support at home).

infinality-emacs-boxes-thumb.png

Last edited by jakobcreutzfeldt (2013-10-18 10:56:08)

Offline

#640 2013-10-18 10:57:50

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: infinality-bundle: good looking fonts made (even) easier

Could you share your Emacs config file, please? I've just installed Emacs and with default settings (i.e. no custom config files) everything looks fine.


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#641 2013-10-18 11:07:53

jakobcreutzfeldt
Member
Registered: 2011-05-12
Posts: 1,033

Re: infinality-bundle: good looking fonts made (even) easier

bohoomil wrote:

Could you share your Emacs config file, please? I've just installed Emacs and with default settings (i.e. no custom config files) everything looks fine.

Here is my .emacs, but loading emacs without it does not resolve the problem (neither emacs -q nor emacs -Q).

I forgot to mention but I did the proper uninstall-reinstall of fontconfig-infinality-bundle.

edit: Also, just to verify, you checked the info reader in emacs ('control-h', followed by 'i'), right? I've checked in other modes now too: anytime the font should be bold, it is replaced with boxes.

Last edited by jakobcreutzfeldt (2013-10-18 11:26:53)

Offline

#642 2013-10-18 11:54:51

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: infinality-bundle: good looking fonts made (even) easier

This is what I see with the following settings (click 1 & click 2):

(unless (string= (getenv "DESKTOP_SESSION") 'gnome)
(load-theme 'tango-dark t)
  (set-default-font "DejaVu Sans Mono-8:antialias=true:rgba=rgb"))
(custom-set-faces
 '(bold ((t (:weight bold :foundry "bitstream" :family "DejaVu Sans Mono"))))
 '(variable-pitch ((t (:family "DejaVu Sans")))))

:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#643 2013-10-18 12:08:42

jakobcreutzfeldt
Member
Registered: 2011-05-12
Posts: 1,033

Re: infinality-bundle: good looking fonts made (even) easier

bohoomil wrote:
(custom-set-faces
 '(bold ((t (:weight bold :foundry "bitstream" :family "DejaVu Sans Mono"))))
 '(variable-pitch ((t (:family "DejaVu Sans")))))

Yep, this bit fixed it. I didn't have to specify this before so the culprit is definitely in the new fontconfig settings somewhere (but probably in conflict with something I did manually, since you don't have the same problem).

Edit: more specifically, it's the variable-pitch part; if I set that to Noto Sans, I get the boxes. Perhaps this post should be moved to the fonts bundle?

BTW is this interesting?:

$ pacman -Qo /etc/fonts/conf.d/*
/etc/fonts/conf.d/10-base-rendering.conf is owned by fontconfig-infinality-ultimate 2.11.0-4
/etc/fonts/conf.d/31-fix-cantarell.conf is owned by fontconfig-infinality-ultimate 2.11.0-4
error: No package owns /etc/fonts/conf.d/37-repl-global-free.conf
/etc/fonts/conf.d/38-repl-tt-traced-bitmap.conf is owned by fontconfig-infinality-ultimate 2.11.0-4
/etc/fonts/conf.d/40-non-latin.conf is owned by fontconfig-infinality-ultimate 2.11.0-4
/etc/fonts/conf.d/45-latin.conf is owned by fontconfig-infinality-ultimate 2.11.0-4
/etc/fonts/conf.d/49-sansserif.conf is owned by fontconfig-infinality-ultimate 2.11.0-4
/etc/fonts/conf.d/50-user.conf is owned by fontconfig-infinality-ultimate 2.11.0-4
/etc/fonts/conf.d/51-local.conf is owned by fontconfig-infinality-ultimate 2.11.0-4
error: No package owns /etc/fonts/conf.d/60-latin-free.conf
error: No package owns /etc/fonts/conf.d/65-non-latin-free.conf
error: No package owns /etc/fonts/conf.d/65-ttf-noto-sans-ui.conf
error: No package owns /etc/fonts/conf.d/65-ttf-noto-sans.conf
error: No package owns /etc/fonts/conf.d/65-ttf-noto-serif.conf
error: No package owns /etc/fonts/conf.d/66-aliases-wine-free.conf
/etc/fonts/conf.d/68-override.conf is owned by fontconfig-infinality-ultimate 2.11.0-4
/etc/fonts/conf.d/82-no-embedded-bitmaps.conf is owned by fontconfig-infinality-ultimate 2.11.0-4
/etc/fonts/conf.d/82-no-force-autohint.conf is owned by fontconfig-infinality-ultimate 2.11.0-4
/etc/fonts/conf.d/82-no-ttf-as-bitmap.conf is owned by fontconfig-infinality-ultimate 2.11.0-4
error: No package owns /etc/fonts/conf.d/83-no-bitmaps.conf
/etc/fonts/conf.d/83-yes-bitmaps.conf is owned by fontconfig-infinality-ultimate 2.11.0-4
/etc/fonts/conf.d/83-yes-postscript.conf is owned by fontconfig-infinality-ultimate 2.11.0-4
/etc/fonts/conf.d/88-forced-synthetic.conf is owned by fontconfig-infinality-ultimate 2.11.0-4
/etc/fonts/conf.d/90-non-tt-fonts.conf is owned by fontconfig-infinality-ultimate 2.11.0-4
/etc/fonts/conf.d/90-tt-fonts.conf is owned by fontconfig-infinality-ultimate 2.11.0-4
/etc/fonts/conf.d/92-selective-rendering.conf is owned by fontconfig-infinality-ultimate 2.11.0-4
error: No package owns /etc/fonts/conf.d/93-final-lang-spec-free.conf
/etc/fonts/conf.d/93-final-rendering.conf is owned by fontconfig-infinality-ultimate 2.11.0-4
/etc/fonts/conf.d/94-no-synthetic.conf is owned by fontconfig-infinality-ultimate 2.11.0-4
/etc/fonts/conf.d/95-reject.conf is owned by fontconfig-infinality-ultimate 2.11.0-4
/etc/fonts/conf.d/99pdftoopvp.conf is owned by cups-filters 1.0.40-1
/etc/fonts/conf.d/README is owned by fontconfig-infinality-ultimate 2.11.0-4

$ ls -l /etc/fonts/conf.d
total 20K
lrwxrwxrwx 1 root root 1K Oct 17 22:48 10-base-rendering.conf -> /etc/fonts/conf.avail.infinality/10-base-rendering.conf
lrwxrwxrwx 1 root root 1K Oct 17 22:48 31-fix-cantarell.conf -> /etc/fonts/conf.avail.infinality/31-fix-cantarell.conf
lrwxrwxrwx 1 root root 1K Oct 18 12:27 37-repl-global-free.conf -> ../conf.avail.infinality/free/37-repl-global-free.conf
lrwxrwxrwx 1 root root 1K Oct 17 22:48 38-repl-tt-traced-bitmap.conf -> /etc/fonts/conf.avail.infinality/38-repl-tt-traced-bitmap.conf
lrwxrwxrwx 1 root root 1K Oct 17 22:48 40-non-latin.conf -> /etc/fonts/conf.avail.infinality/40-non-latin.conf
lrwxrwxrwx 1 root root 1K Oct 17 22:48 45-latin.conf -> /etc/fonts/conf.avail.infinality/45-latin.conf
lrwxrwxrwx 1 root root 1K Oct 17 22:48 49-sansserif.conf -> /etc/fonts/conf.avail.infinality/49-sansserif.conf
lrwxrwxrwx 1 root root 1K Oct 17 22:48 50-user.conf -> /etc/fonts/conf.avail.infinality/50-user.conf
lrwxrwxrwx 1 root root 1K Oct 17 22:48 51-local.conf -> /etc/fonts/conf.avail.infinality/51-local.conf
lrwxrwxrwx 1 root root 1K Oct 18 12:27 60-latin-free.conf -> ../conf.avail.infinality/free/60-latin-free.conf
lrwxrwxrwx 1 root root 1K Oct 18 12:27 65-non-latin-free.conf -> ../conf.avail.infinality/free/65-non-latin-free.conf
lrwxrwxrwx 1 root root 1K Oct 17 18:18 65-ttf-noto-sans-ui.conf -> ../conf.avail/65-ttf-noto-sans-ui.conf
lrwxrwxrwx 1 root root 1K Oct 17 18:18 65-ttf-noto-sans.conf -> ../conf.avail/65-ttf-noto-sans.conf
lrwxrwxrwx 1 root root 1K Oct 17 18:18 65-ttf-noto-serif.conf -> ../conf.avail/65-ttf-noto-serif.conf
lrwxrwxrwx 1 root root 1K Oct 18 12:27 66-aliases-wine-free.conf -> ../conf.avail.infinality/free/66-aliases-wine-free.conf
lrwxrwxrwx 1 root root 1K Oct 17 22:48 68-override.conf -> /etc/fonts/conf.avail.infinality/68-override.conf
lrwxrwxrwx 1 root root 1K Oct 17 22:48 82-no-embedded-bitmaps.conf -> /etc/fonts/conf.avail.infinality/82-no-embedded-bitmaps.conf
lrwxrwxrwx 1 root root 1K Oct 17 22:48 82-no-force-autohint.conf -> /etc/fonts/conf.avail.infinality/82-no-force-autohint.conf
lrwxrwxrwx 1 root root 1K Oct 17 22:48 82-no-ttf-as-bitmap.conf -> /etc/fonts/conf.avail.infinality/82-no-ttf-as-bitmap.conf
lrwxrwxrwx 1 root root 1K Oct 17 22:48 83-yes-bitmaps.conf -> /etc/fonts/conf.avail.infinality/83-yes-bitmaps.conf
lrwxrwxrwx 1 root root 1K Oct 17 22:48 83-yes-postscript.conf -> /etc/fonts/conf.avail.infinality/83-yes-postscript.conf
lrwxrwxrwx 1 root root 1K Oct 17 22:48 88-forced-synthetic.conf -> /etc/fonts/conf.avail.infinality/88-forced-synthetic.conf
lrwxrwxrwx 1 root root 1K Oct 17 22:48 90-non-tt-fonts.conf -> /etc/fonts/conf.avail.infinality/90-non-tt-fonts.conf
lrwxrwxrwx 1 root root 1K Oct 17 22:48 90-tt-fonts.conf -> /etc/fonts/conf.avail.infinality/90-tt-fonts.conf
lrwxrwxrwx 1 root root 1K Oct 17 22:48 92-selective-rendering.conf -> /etc/fonts/conf.avail.infinality/92-selective-rendering.conf
lrwxrwxrwx 1 root root 1K Oct 18 12:27 93-final-lang-spec-free.conf -> ../conf.avail.infinality/free/93-final-lang-spec-free.conf
lrwxrwxrwx 1 root root 1K Oct 17 22:48 93-final-rendering.conf -> /etc/fonts/conf.avail.infinality/93-final-rendering.conf
lrwxrwxrwx 1 root root 1K Oct 17 22:48 94-no-synthetic.conf -> /etc/fonts/conf.avail.infinality/94-no-synthetic.conf
lrwxrwxrwx 1 root root 1K Oct 17 22:48 95-reject.conf -> /etc/fonts/conf.avail.infinality/95-reject.conf
-rw-r--r-- 1 root root 1K May 18 17:31 99pdftoopvp.conf
-rw-r--r-- 1 root root 2K Oct 17 22:48 README

The 83-no-bitmaps can be removed (I made that one, iirc) but the others weren't made by me and all have creation dates from yesterday, when I updated the bundle and installed the fonts. e.g. Noto Sans was installed via your bundle and those links were created on the same date. Shouldn't they be owned by ttf-noto-sans-ib or fontconfig-infinality-ultimate?

Anyway, I'll try digging into the settings to figure out why the above emacs code fixes the bold font problem.

Last edited by jakobcreutzfeldt (2013-10-18 12:39:15)

Offline

#644 2013-10-18 13:55:35

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: infinality-bundle: good looking fonts made (even) easier

Check this way instead:

[$] pacman -Qo /etc/fonts/conf.avail.infinality/free/60-latin-free.conf
/etc/fonts/conf.avail.infinality/free/60-latin-free.conf is owned by fontconfig-infinality-ultimate 2.11.0-4

Files in /etc/fonts/conf.d are symlinks created by post-install hook, hence their absence in the pacman db. 'pkgfile' returns the correct output:

[~] $ pkgfile 60-latin-free.conf
infinality-bundle/fontconfig-infinality-ultimate

By the way, with DejaVu Sans Mono it's enough to declare only the default typeface:

(set-default-font "DejaVu Sans Mono-8:antialias=true:rgba=rgb"))

Anything else can be safely removed from the config file.

Indeed, the problem is with Noto Sans only: I tested various sans faces for 'variable-pitch' and all of them worked fine but Noto Sans. I'll certainly look into it (I suppose there must be something fishy inside 65-ttf-noto-sans.conf).


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#645 2013-10-18 14:10:49

jakobcreutzfeldt
Member
Registered: 2011-05-12
Posts: 1,033

Re: infinality-bundle: good looking fonts made (even) easier

OK, everything looks fine then! I'm getting used to Liberation Mono, so it suffices to just replace Noto Sans with DejaVu Sans for the variable-pitch font.

Thanks again for all your work on this!

I just realized that I had a bunch of custom fonts set up in my browser and once I removed those, everything's looking even better than before. Nice...

Offline

#646 2013-10-20 17:25:08

karol
Archivist
Registered: 2009-05-06
Posts: 25,430

Re: infinality-bundle: good looking fonts made (even) easier

The link to the wiki in the introductory post https://bbs.archlinux.org/viewtopic.php … 3#p1263503

Note 1: repository info and quick installation notes are available in the Wiki.

and in https://github.com/bohoomil/fontconfig-ultimate

Font Configuration - Infinality: the easy way (quick install notes)

should be changed to https://wiki.archlinux.org/index.php/Fo … Infinality



$pkgver in the freetype2-infinality-ultimate PKGBUILD

provides=('freetype2=$pkgver' 'freetype2-infinality' 'freetype2-infinality-ultimate')

doesn't get expanded:

$ pacman -Qi freetype2-infinality-ultimate | grep Provides
Provides       : freetype2=$pkgver  freetype2-infinality  freetype2-infinality-ultimate

Offline

#647 2013-10-20 18:22:46

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: infinality-bundle: good looking fonts made (even) easier

Thanks for debugging -- much appreciated.

All the Wiki related stuff will be updated soon: I hope I'll manage to do this next week. There will be a dedicated page for the bundle and I'll leave only a brief info about it in the "Font configuration" article, which is already pretty long and complex.

freetype2-iu has been rebuilt with the correct "quote": now everything gets expanded properly.


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#648 2013-10-28 03:17:39

donniezazen
Member
From: Salt Lake City
Registered: 2011-06-24
Posts: 671
Website

Re: infinality-bundle: good looking fonts made (even) easier

Is it okay to remove XFT settings from .Xresources as there are globally provided by /etc/profile.d/infinality-settings.sh?

Offline

#649 2013-10-28 04:35:05

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: infinality-bundle: good looking fonts made (even) easier

I keep them, just in case. You can comment relevant entries see if nothing goes wrong (for instance, when you reload your local .Xresources: use -merge option with xrdb then). To monitor Xft status, issue 'xrdb -q | grep Xft'.


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#650 2013-10-28 11:51:39

donniezazen
Member
From: Salt Lake City
Registered: 2011-06-24
Posts: 671
Website

Re: infinality-bundle: good looking fonts made (even) easier

@jakobcreutzfeldt How exactly have you solved Emacs box problem?

I am learning Emacs, so, my ~/.emacs is empty. I set Emacs font to system fonts. Here what I currently have in my .emacs.

(custom-set-variables
 ;; custom-set-variables was added by Custom.
 ;; If you edit it by hand, you could mess it up, so be careful.
 ;; Your init file should contain only one such instance.
 ;; If there is more than one, they won't work right.
 '(font-use-system-font t))
(custom-set-faces
 ;; custom-set-faces was added by Custom.
 ;; If you edit it by hand, you could mess it up, so be careful.
 ;; Your init file should contain only one such instance.
 ;; If there is more than one, they won't work right.
 )

UPDATE:- I have removed infinality-bundle-fonts for now and Emacs seems to work fine with the above mentioned settings.

Last edited by donniezazen (2013-10-28 12:24:39)

Offline

Board footer

Powered by FluxBB